Subject: [mpls] Comments on MPLS-in-UDP

From: Xuxiaohu <[email-masked]>
Date: Mon, 30 Jul 2012 18:03:44 +0000

Hi Eric,

Thanks a lot for your comments during the WG session.

As for MPLS-in-GRE or MPLS-in-L2TPv3, it requires P routers to be capable of performing hash calculations on the specific "load-balancing field" contained in the encapsulating header (e.g., L2TPv3 session ID field or GRE key field). Such requirement can not be met by some P routers which could only perform hash calulations on the five tuple of TCP/UDP packets. MPLS-in-UDP is only proposed to be used in such specific cases.

Any further comments are welcome.

Best regards,

Xiaohu

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 30 Jul 2012 14:22:31 -0400

I agree with Eric's points made during the presentation. This seems to be a solution looking for a problem.

--Tom

From: Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 30, 2012 11:03 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] Comments on MPLS-in-UDP

Hi Eric,

Best regards,

Xiaohu