Subject: Re: [mpls] current state transition definiton cause returning Normal directly without WTR.

From: Yaacov Weingarten <[email-masked]>
Date: Tue, 24 Jul 2012 15:46:59 +0300

Hi,

I have a slight problem understanding your scenario.

Based on my reading of the state machine (as described in the Appendix, but
I am sure that the document description is the same) the folloeing should
be the scenario:

Both A & Z are in PF:W:L
If A receives the local SFc it will transition into WTR state and begin
transmitting a WTR message.
[branch point a] When A receives the SF-W message from Z it stops the WTR
timer and transitions to PF:W:R and transmits a NR message.
Meanwhile, Z received the local SFc and transitions into WTR state and
begins transmitting the WTR message.
As long as the WTR timer is running at Z, Z will ignore the NR message from
A
When A receives the WTR message from Z it transitions into WTR state
continuing to transmit the NR message.

Finally, when the WTR timer expires, Z transits into Normal state and
begins to transmit the NR message
When A receives the NR message it transits into Normal state and continues
to transmit the NR message.

If at [branch point a] A does not receive a SF-W message, because Z has
already transitioned into WTR state and instead A receives a remote WTR
message while in WTR state it will be ignored
Eventually, A's WTR timer will expire and begin transmitting the NR message
until it receives a NR from Z
The same will happen at Z and when both receive the NR message from the
other endpoint they transition into Normal state.

In any case the WTR state is entered in both scenarios.  Assuming of course
that the network is configured for revertive action.  If in non-revertive
configuration then a similar scenario will be played through the DNR state.

Can you explain where you are having difficulty?

Hope this helps,
yaacov weingarten

On Tue, Jul 24, 2012 at 4:45 AM, Feng, Ying (NSN - CN/Shanghai) <
[email-masked]> wrote:

> **
>
> Dear Yaacov Weingarten,
>
> We found an issue below during the implementation:
>
> According to the state transition definition in rfc6378,
>
> when both local working path signal fail and remote working path signal
> fail, APS state will be local protection failure state.
>
> then if local working path signal fail clear comes,
>
> it will enter remote protection failure state and send NR request.
>
> when in remote protection failure state, it will return to Normal when NR
> request is received.
>
> Thus if both ends have working path signal fail clear at same/very-close
> time, then both ends will return Normal directly. That is no WTR state
>
> In my opinion, this transition without WTR is not expected.
>
> Please have a double check.
>
> Look forward to your reply, thank you!
>
> Best Regards
> Feng Yingzhen
>
> Nokia Siemens Networks Transport Systems (Shanghai) Ltd.
>
> 诺基亚西门子通信技术（北京）有限公司上海分公司
>
> 9/F, Building 89, 1122 North Qin Zhou Road, Shanghai 200233, China
>
> 中国上海钦州北路1122号89号楼7楼 200233
>
> Office: +86-21-60855761
> Email: [email-masked]* <[email-masked]>
>
>

---

From: "Feng, Ying (NSN - CN/Shanghai)" <[email-masked]>
Date: Tue, 24 Jul 2012 09:45:53 +0800

Dear Yaacov Weingarten, 

According to the state transition definition in rfc6378, 
when both local working path signal fail and remote working path signal fail, APS state will be local protection failure state.
then if local working path signal fail clear comes, 
it will enter remote protection failure state and send NR request.
when in remote protection failure state, it will return to Normal when NR request is received.

Thus if both ends have working path signal fail clear at same/very-close time, then both ends will return Normal directly. That is no WTR state
In my opinion, this transition without WTR is not expected.

Best Regards 
Feng Yingzhen 
Email: [email-masked]

---

From: "Feng, Ying (NSN - CN/Shanghai)" <[email-masked]>
Date: Wed, 25 Jul 2012 12:45:24 +0800

Hi, Yaacov Weingarten,

I am sorry not to give the detailed description in previous mail, after all it was found several months ago. 

I add another transition case in addition to yours, I believe this case cause the problem. Please have a check  whether my understanding is in accordance with the document. Thank you!

Both A & Z are in PF:W:L

If A receives the local SFc it will transition into WTR state and begin transmitting a WTR message.

If Z receives the local SFc it will transition into WTR state and begin transmitting a WTR message.

[branch point a] 

When A receives the SF-W message from Z it stops the WTR timer and transitions to PF:W:R and transmits a NR message.

When Z receives the SF-W message from A it stops the WTR timer and transitions to PF:W:R and transmits a NR message.

(because it takes time for WTR message to arrive, previous SF-W works, if this, then transition above happens, that is both A and Z enter PF:W:R)

When A receives the WTR message from Z it transitions into WTR state continuing to transmit the NR message.

When Z receives the WTR message from A it transitions into WTR state continuing to transmit the NR message.

When A receives the NR message from Z it transitions into Normal State and continues to transmit the NR message.

When Z receives the NR message from A it transitions into Normal State and continues to transmit the NR message.

Best Regards 
Feng Yingzhen 

诺基亚西门子通信技术（北京）有限公司上海分公司

Office: +86-21-60855761 
Email: [email-masked] 

From: ext Yaacov Weingarten [mailto:[email-masked]] 
Sent: Tuesday, July 24, 2012 8:47 PM
To: Feng, Ying (NSN - CN/Shanghai)
Cc: Sprecher, Nurit (NSN - IL/Hod HaSharon); Zhao, Peng (NSN - CN/Shanghai); Ma, Kai 1. (NSN - CN/Shanghai); Doolan, Paul (NSN - US/Irving); [email-masked]
Subject: Re: current state transition definiton cause returning Normal directly without WTR.

Hi,

Based on my reading of the state machine (as described in the Appendix, but I am sure that the document description is the same) the folloeing should be the scenario:

Both A & Z are in PF:W:L

If A receives the local SFc it will transition into WTR state and begin transmitting a WTR message.

[branch point a] When A receives the SF-W message from Z it stops the WTR timer and transitions to PF:W:R and transmits a NR message.

Meanwhile, Z received the local SFc and transitions into WTR state and begins transmitting the WTR message.

As long as the WTR timer is running at Z, Z will ignore the NR message from A

When A receives the WTR message from Z it transitions into WTR state continuing to transmit the NR message.

Finally, when the WTR timer expires, Z transits into Normal state and begins to transmit the NR message

When A receives the NR message it transits into Normal state and continues to transmit the NR message.

If at [branch point a] A does not receive a SF-W message, because Z has already transitioned into WTR state and instead A receives a remote WTR message while in WTR state it will be ignored 

Eventually, A's WTR timer will expire and begin transmitting the NR message until it receives a NR from Z

The same will happen at Z and when both receive the NR message from the other endpoint they transition into Normal state.

In any case the WTR state is entered in both scenarios.  Assuming of course that the network is configured for revertive action.  If in non-revertive configuration then a similar scenario will be played through the DNR state.

Hope this helps,

yaacov weingarten

On Tue, Jul 24, 2012 at 4:45 AM, Feng, Ying (NSN - CN/Shanghai) <[email-masked]> wrote:

Dear Yaacov Weingarten, 

Best Regards
Feng Yingzhen 

诺基亚西门子通信技术（北京）有限公司上海分公司

Office: +86-21-60855761
Email: [email-masked] <mailto:[email-masked]>