Subject: [mpls] MPLS-RT review of draft-raza-mpls-ldp-applicability-label-adv

From: <[email-masked]>
Date: Wed, 11 Jul 2012 15:47:09 +0000

Hi,

I have reviewed the draft and agree with others reviewers: this document 
is straightforward, useful, well written, and ready for adoption.

Simple as it is, it might even be ready for a WGLC ;-).

I have however, one comment.  It was suggested that the document should 
make it MANDATORY for future LDP application to state the applicability 
of the negotiated mode.  I wonder if a simpler solution could be 
considered: say that by default, unless a new application says that the 
negotiated mode applies, then by default it the negotiated mode would 
not apply.  This would possibly reduce the overhead for authors of 
future specs, and avoid possible confusion raising forgetting to apply 
this MUST.  Of course, this approach is only valid if we believe that 
applications that need to rely on the negotiated mode are rare and 
easily identified.

-Thomas

2012-06-20, Ross Callon :
> You have been selected as an MPLS Review team reviewers for
> draft-raza-mpls-ldp-applicability-label-adv.
> Reviews should comment on whether the document is coherent, is it useful
> (ie, is it likely to be actually useful in operational networks), and is
> the document technically sound? We are interested in knowing whether the
> document is ready to be considered for WG adoption (ie, it doesn’t 
> have to
> be perfect at this point, but should be a good start).
> Reviews should be sent to the document authors, WG co-chairs and 
> secretary,
> and CC’d to the MPLS WG email list. If necessary, comments may be sent
> privately to only the WG chairs.
> Are you able to review this draft by July 11, 2012 (this is giving you an
> extra week due to the July 4th holiday)?
> Thanks, Ross
> (as MPLS WG chair)

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Mon, 16 Jul 2012 22:44:05 +0000

Hi Thomas,

Thanks for your review. Please see inline [skraza]:

On 12-07-11 11:47 AM, "[email-masked]" <[email-masked]>
wrote:

>this MUST.  

[skraza]: On the flip side, can this still not cause confusion if an
author 
of a future (mode-bound) application misses this (default)
statement/requirement;
and thinks/assumes (just based on RFC 5036) that its new application will
use the negotiated mode, whereas, in reality, the negotiated mode won't
apply 
unless stated explicitly.

For this revision of draft, I will take the comment (use of "MUST") from
other authors, 
and keep your suggestion open for WG discussion/consensus/closure in
subsequent Revs.

Rgds,
-- Kamran

>Of course, this approach is only valid if we believe that
>> document is ready to be considered for WG adoption (ie, it doesn¹t
>> have to
>> and CC¹d to the MPLS WG email list. If necessary, comments may be sent
>__________________________________________________________________________
>_______________________________________________
>
>Ce message et ses pieces jointes peuvent contenir des informations
>confidentielles ou privilegiees et ne doivent donc
>pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
>recu ce message par erreur, veuillez le signaler
>a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
>electroniques etant susceptibles d'alteration,
>This message and its attachments may contain confidential or privileged
>information that may be protected by law;
>As emails may be altered, France Telecom - Orange is not liable for
>messages that have been modified, changed or falsified.
>Thank you.
>
>_______________________________________________
>mpls mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mpls

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Fri, 20 Jul 2012 12:56:17 +0000

I have just read the draft as well, and I echo Thomas's comment that it's well written and clear.

One thing I think it needs is some language for future LDP applications.  You define mode-based and mode-independent, and you classify existing applications into one of two buckets.  It seems like a good idea to add some text that requires any future LDP application to assign itself to one of these two categories, so that future apps clearly fit into the existing architecture.

eric

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Wednesday, July 11, 2012 11:47 AM
> To: [email-masked]; mpls-
> [email-masked]; Martin Vigoureux
> Cc: [email-masked]
> Subject: [mpls] MPLS-RT review of draft-raza-mpls-ldp-applicability-label-adv
> 
> Hi,
> 
> __________________________________________________________
> __________________________________________________________
> _____
> 
> As emails may be altered, France Telecom - Orange is not liable for messages
> that have been modified, changed or falsified.
> Thank you.
>