Subject: [mpls] 答复: MPLS-RT review of draft-jin-jounay-mpls-mldp-hsmp

From: Mach Chen <[email-masked]>
Date: Thu, 26 Jul 2012 01:18:59 +0000

Hi Lizhong,

[snip]

> > I have reviewed the draft and here are my comments:
> >
> > 1.       First, I am not fully convinced by the use cases
> > a)       For the PTP case, since the requirements is to have co-
> > routed bidirectional path, and LDP-based solution may not be the
> > best choose, it cannot guarantee that the upstream and downstream
> > LSP are fully co-routed, because it’s path follow IP routing, two
> > directions may choose different interfaces(links) or tunnels as the
> > nexthop.
> [Lizhong] Do you mean ECMP link (e.g, LAG) between two LDP neighbors? If the
> logical link is ECMP, although physical interface is different from upstream to
> downstream and vice versa, we still consider it co-routed. One possible case for
> not co-routing is using static routing between LDP neighbors, if that happens,
> the LSR could generate an indication to operator. Another possible case to
> choose different interfaces will happen when physical link cost is assymmetric,
> which is a corner case in field deployment. When TE-Tunnels are used between
> LDP neighbors, yes, it is possible to be not co-routed for HSMP LSP. We will add
> these exceptions in the next version. The LSR/LER in HSMP LSP could detect if
> the path is co-routed or not, if not co-routed, an indication could be generated.

Not just the ECMP link, actually you have illustrated all the potential cases (e.g., asymmetric link, TE tunnel...).

> 
> > RSVP-TE-based solution maybe a better choice. In addition,
> > if the purpose is to save the bandwidth (compare to use unicast
> > bidirectional LSP), seems the benefit is limited.
> [Lizhong] The purpose is not saving the bandwidth, mLDP based HSMP would
> be used in the network where bandwidth is not an issue. And time
> synchronization is only one of the use case for HSMP LSP, the benefit would be
> more in other use case, e.g, IPTV scenario in section 2.2.

Got your point, so the HSMP LSP is not the better choice for PTP case.

Best regards,
Mach

---

From: Lizhong Jin<[email-masked]>
Date: Thu, 26 Jul 2012 14:16:53 +0800

Hi Mach,
Thank you for the reply and review. See inline.

Regards
Lizhong

Mach Chen <[email-masked]> wrote 2012/07/26 09:18:59:

> Not just the ECMP link, actually you have illustrated all the 
> potential cases (e.g., asymmetric link, TE tunnel...).
> 
> > 
[Lizhong] hmm, better or not, it is really depends on many network 
factors. At least, mLDP based HSMP LSP is an alternative for PTP case.