Subject: [mpls] Question on LDP Multi-topology draft

From: "Dutta, Pranjal K (Pranjal)" <[email-masked]>
Date: Thu, 23 Aug 2012 23:37:45 +0530

Hi Authors,
                     I apologize if this is already discussed; I have a few questions on the latest version of LDP MT draft
(http://tools.ietf.org/html/draft-ietf-mpls-ldp-multi-topology-04).

                    The draft introduces  two new address families - MT IP and MT IPV6. This fits well into existing Prefix
and mLdp FEC element types since the respective FEC elements has the Address Family field.

                     Could you please clarify how OAM tool sets (LSP Ping etc) are going to work for LDP-MT based prefix
FECs?

Following are encodings of LDP IPV4/V6 Targeted FEC sub-types as per RFC 4379.

       Sub-Type        Length            Value Field

      --------          ------           -----------

             1            5            LDP IPv4 prefix

             2           17            LDP IPv6 prefix

Sub-type 1 = LDP IPV4 FEC

       0                   1                   2                   3

       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

      |                          IPv4 prefix                          |

      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

      | Prefix Length |         Must Be Zero                          |

      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Sub-type 2 = LDP IPV6 FEC

           0                   1                   2                   3

       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

      |                          IPv6 prefix                          |

      |                          (16 octets)                          |

      |                                                               |

      |                                                               |

      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

      | Prefix Length |         Must Be Zero                          |

      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

I don't see how existing Targeted FEC stack types would work for LDP-MT based Prefix FEC elements since it's the
Targeted FEC  sub-types that seem to hardcode the address family.

The Multicast LDP FEC Stacks TLV (RFC 6425) bear Address Family field for Root address, so the LDP-MT extensions
would get aligned.

IMO, a section in the draft referring to OAM extensions (if required or not required) would help.
I think the following refers to section 9, as opposed to section 10.
3.4<http://tools.ietf.org/html/draft-ietf-mpls-ldp-multi-topology-04#section-3.4>.  IGP MT-ID Mapping and Translation

   The non-reserved non-special IGP MT-ID values can be used/carried in

   LDP as-is and need no translation.  However, there is a need for

   translating reserved/special IGP MT-ID values to corresponding LDP

   MT-IDs.  The corresponding special/reserved LDP MT-ID values are

   defined in later section 10<http://tools.ietf.org/html/draft-ietf-mpls-ldp-multi-topology-04#section-10>.

Thanks,
Pranjal

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Thu, 23 Aug 2012 18:32:37 +0000

Hi Pranjal,

I agree with your comment on adding a section / behavior for MPLS OAM extensions to support MT for Prefix FEC types.
We will discuss amongst us (author) and update accordingly.

Rgds,
--Kamran

From: <Dutta>, "Pranjal K (Pranjal)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 23, 2012 2:07 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] Question on LDP Multi-topology draft

Hi Authors,

                    The draft introduces  two new address families – MT IP and MT IPV6. This fits well into existing Prefix
and mLdp FEC element types since the respective FEC elements has the Address Family field.

             1            5            LDP IPv4 prefix

             2           17            LDP IPv6 prefix

       0                   1                   2                   3

      |                          IPv4 prefix                          |

           0                   1                   2                   3

      |                          IPv6 prefix                          |

      |                          (16 octets)                          |

      |                                                               |

      |                                                               |

I don’t see how existing Targeted FEC stack types would work for LDP-MT based Prefix FEC elements since it’s the
Targeted FEC  sub-types that seem to hardcode the address family.

Thanks,
Pranjal

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 23 Aug 2012 11:34:32 -0700

Pranjal,

I do not think one could use the existing FEC types identified in RFC4379. There should be new FEC types in order to perform OAM functions. Authors should add relevant section identifying the same. 

With many extensions (FEC types) being added via different drafts, in order to support OAM via RFC4379,  not sure it is a good idea to create a lap ping draft whenever new type is added. Again, I do not know if there is a better option than having a new draft for each extension. Thoughts?

-sam
On Aug 23, 2012, at 11:07 AM, "Dutta, Pranjal K (Pranjal)" <[email-masked]> wrote:

> 3.4.  IGP MT-ID Mapping and Translation
> 
>  
>    defined in later section 10.
>  
>  
> Thanks,
> Pranjal
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: "Dutta, Pranjal K (Pranjal)" <[email-masked]>
Date: Fri, 24 Aug 2012 00:07:47 +0530

Hi Kamran,
                    Thanks for the info.
Thanks,
Pranjal

________________________________
From: Kamran Raza (skraza) [mailto:[email-masked]]
Sent: Thursday, August 23, 2012 11:33 AM
To: Dutta, Pranjal K (Pranjal); [email-masked]
Subject: Re: [mpls] Question on LDP Multi-topology draft

Hi Pranjal,

Rgds,
--Kamran

Hi Authors,

             1            5            LDP IPv4 prefix

             2           17            LDP IPv6 prefix

       0                   1                   2                   3

      |                          IPv4 prefix                          |

           0                   1                   2                   3

      |                          IPv6 prefix                          |

      |                          (16 octets)                          |

      |                                                               |

      |                                                               |

Thanks,
Pranjal

---

From: "Dutta, Pranjal K (Pranjal)" <[email-masked]>
Date: Fri, 24 Aug 2012 00:15:09 +0530

Hi Sam,
               Yes, existing types can't be used for LDP-MT. It requires new types. I agree with you - probably it is fragile to keep adding new types to
RFC 4379 but at the same I don't see a cleaner seamless solution that would maintain backward compatibility with RFC 4379. Perhaps creating a
generic Target FEC stack for LDP that would embed any LDP FEC element types may be extendable solution, but need to explore pros and cons
on such approaches from LspPing/Trace point if view.

Thanks,
Pranjal

________________________________
From: Sam Aldrin [mailto:[email-masked]]
Sent: Thursday, August 23, 2012 11:35 AM
To: Dutta, Pranjal K (Pranjal)
Cc: [email-masked]
Subject: Re: [mpls] Question on LDP Multi-topology draft

Pranjal,

-sam
On Aug 23, 2012, at 11:07 AM, "Dutta, Pranjal K (Pranjal)" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Authors,

             1            5            LDP IPv4 prefix

             2           17            LDP IPv6 prefix

       0                   1                   2                   3

      |                          IPv4 prefix                          |

           0                   1                   2                   3

      |                          IPv6 prefix                          |

      |                          (16 octets)                          |

      |                                                               |

      |                                                               |

Thanks,
Pranjal
_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls