Subject: [mpls] R: Working group last call on draft-ietf-mpls-tp-ring-protection

From: D'Alessandro Alessandro Gerardo <[email-masked]>
Date: Wed, 3 Oct 2012 17:03:18 +0200

Dear authors of draft-ietf-mpls-tp-ring-protection-02,
Could you please clarify the following points

2.1.  Wrapping
   In this figure we have a ring with a LSP that enters the ring at    LSR-B and exits at LSR-E.  The normal working path follows through   B-A-F-E.  If a fault is detected on the link A<-->F, then the   wrapping mechanism decides that LSR-A would wrap the traffic around    the ring, on a wrapped data path A-B-C-D-E-F, to arrive at LSR-F (on    the far side of the failed link).  LSR-F would then wrap the data    packets back onto the working path F-->E to the egress node.  In this    protection scheme, the traffic will follow the path    B-A-B-C-D-E-F-E.
Figure 1 and the text above seems not to be aligned. What is the intended behavior?

2.1.  Wrapping
If a double-fault situation occurs in the ring, then wrapping will     not be able to deliver any packets except between the ingress and   the first fault location.
How is defined first/second  fault location in a ring? is "first" time or location related? Can you please elaborate a little bit this concept?

Best regards,
Alessandro
------------------------------------------------------------------
Telecom Italia
Alessandro Gerardo D'Alessandro
Transport Innovation
Via Reiss Romoli, 274 - 10148 Torino
phone:  +39 011 228 5887
mobile: +39 335 766 9607
fax: +39 06 418 639 07

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non ? necessario.

---

From: Yaacov Weingarten <[email-masked]>
Date: Sun, 28 Oct 2012 15:17:32 +0200

Alessandro, hi

Thank you for your detailed list of comments to the draft.  I will try to
address your concerns below while I attempt to publish an updated version
of the draft that would address your concerns.

I would like to reiterate a point that was made by several of the
respondents to this very interesting LC correspondence - the document in
question is merely an applicability statement intended to be an Informative
IETF document pointing out that it is possible to apply linear protection
to a "ring topology" in MPLS-TP.  This does not preclude the discussion of
any other mechanism that may be proposed based on existing MPLS constructs,
or by proposing new constructs - after these are fully defined in the MPLS
community.

My calrifications are provided inline below (prefixed by "yw>>").

Hope this helps,
yaacov weingarten

*Still looking for new opportunity.*

On Wed, Oct 3, 2012 at 5:03 PM, D'Alessandro Alessandro Gerardo <
[email-masked]> wrote:

>  Dear authors of draft-ietf-mpls-tp-ring-protection-02,****
>
> Could you please clarify the following points****
>
> ** **
>
> 2.1.  Wrapping****
>
>    In this figure we have a ring with a LSP that enters the ring at    LSR-B
> and exits at LSR-E.  The normal working path follows through   B-A-F-E.  If
> a fault is detected on the link A<-->F, then the   wrapping mechanism
> decides that LSR-A would wrap the traffic around    the ring, on a
> wrapped data path A-B-C-D-E-F, to arrive at LSR-F (on    the far side of
> the failed link).  LSR-F would then wrap the data    packets back onto
> the working path F-->E to the egress node.  In this    protection scheme,
> the traffic will follow the path    B-A-B-C-D-E-F-E.****
>
yw>> Figure 1 will be corrected to show the protection path connecting to
the proper node, this had been pointed out to the authors by other
commenters.

> ****
>
> ** **
>
> ** **
>
> 2.1.  Wrapping****
>
> If a double-fault situation occurs in the ring, then wrapping will     not
> be able to deliver any packets except between the ingress and   the first
> fault location.****
>
> How is defined first/second  fault location in a ring? is “first” time or
> location related? Can you please elaborate a little bit this concept?
>
yw>> Not sure that I understand the difficulty in understanding, nor am I
sure whether the "first" refers to the node that failed before the other or
the one that is encountered earlier along the path since the statement is
clearly stating that this would cause a complete disconnect situation.
 Could you please provide a suggestion for text that would help your
comprehension of the limitation?

> ****
> ** **
> Best regards,****
> Alessandro ****
> *Telecom Italia
> *Alessandro Gerardo D'Alessandro
> Transport Innovation
> Via Reiss Romoli, 274 - 10148 Torino*
> *phone:  +39 011 228 5887
> mobile: +39 335 766 9607
> fax: +39 06 418 639 07****
>
> ** **
>    Questo messaggio e i suoi allegati sono indirizzati esclusivamente
> alle persone indicate. La diffusione, copia o qualsiasi altra azione
> derivante dalla conoscenza di queste informazioni sono rigorosamente
> vietate. Qualora abbiate ricevuto questo documento per errore siete
> cortesemente pregati di darne immediata comunicazione al mittente e di
> provvedere alla sua distruzione, Grazie.
>
> *This e-mail and any attachments** is **confidential and may contain
> privileged information intended for the addressee(s) only. Dissemination,
> copying, printing or use by anybody else is unauthorised. If you are not
> the intended recipient, please delete this message and any attachments and
> advise the sender by return e-mail, Thanks.*
> *Rispetta l'ambiente. Non stampare questa
> mail se non è necessario.*
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

-- 
Thanx and BR,
yaacov

*Still looking for new opportunity*