Subject: [mpls] Fwd: New Version Notification for draft-villamizar-mpls-forwarding-00.txt

From: Kireeti Kompella <[email-masked]>
Date: Mon, 8 Oct 2012 17:30:37 -0700

Hi Folks,

I'd spoken on the issue of deep label stacks at the last IETF, and there was interest from chip suppliers, vendors and service providers.  Curtis just submitted the draft; it goes beyond just deep label stacks.  There are suggestions in the draft on aspects of implementing MPLS forwarding, as well as questions to ask regarding an implementation, and things to test.

Please read and comment to the list.  

If you (that includes MPLS WG chairs and ADs) could also  formulate your thoughts on what type of doc (Info, BCP, PS) this should be, that would be very helpful in moving this discussion forward.

Thanks,
Kireeti.

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-villamizar-mpls-forwarding-00.txt
> Date: October 8, 2012 16:49:08PDT
> To: [email-masked]
> Cc: [email-masked]
> 
> 
> A new version of I-D, draft-villamizar-mpls-forwarding-00.txt
> has been successfully submitted by Curtis Villamizar and posted to the
> IETF repository.
> 
> Filename:	 draft-villamizar-mpls-forwarding
> Revision:	 00
> Title:		 MPLS Forwarding Compliance and Performance Requirements
> Creation date:	 2012-10-08
> WG ID:		 Individual Submission
> Number of pages: 17
> URL:             http://www.ietf.org/internet-drafts/draft-villamizar-mpls-forwarding-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-villamizar-mpls-forwarding
> Htmlized:        http://tools.ietf.org/html/draft-villamizar-mpls-forwarding-00
> 
> 
> Abstract:
>   This document provides guidelines for implementors regarding MPLS
>   forwarding and a basis for evaluations of forwarding implementations.
>   Guidelines cover basic MPLS forwarding, forwarding when a deep MPLS
>   label stack is encountered, MPLS UHP operations which require one or
>   more label POP plus a PUSH, guidelines for hashing an MPLS stack and
>   payload for multipath, and conformance and performance requirements
>   for recent pseudowire and MPLS standards.
> 
> 
> 
> 
> The IETF Secretariat
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 9 Oct 2012 10:50:33 -0700

Kireeti and Curtis,

Thanks for an interesting and useful draft. Just with my PWE3 chair
hat on, while there's a good discussion of pseudowire labels with
respect to multipath in section 2.3, it would be good to also have a
short introduction to PW labels in section 2.1 as well, since they
certainly fit the category of "Early Uses of Multiple Label Stack
Entries".

Taking off my PWE3 hat, regarding your question on document type, this
certainly looks like a BCP to me, or if not that, then an MPLS WG
Informational RFC.

Cheers,
Andy

On Mon, Oct 8, 2012 at 5:30 PM, Kireeti Kompella
<[email-masked]> wrote:
> Hi Folks,
>
> I'd spoken on the issue of deep label stacks at the last IETF, and there was
> interest from chip suppliers, vendors and service providers.  Curtis just
> submitted the draft; it goes beyond just deep label stacks.  There are
> suggestions in the draft on aspects of implementing MPLS forwarding, as well
> as questions to ask regarding an implementation, and things to test.
>
> If you (that includes MPLS WG chairs and ADs) could also  formulate your
> thoughts on what type of doc (Info, BCP, PS) this should be, that would be
> very helpful in moving this discussion forward.
>
> Thanks,
> Kireeti.
>
> Begin forwarded message:
>
> URL:
> http://www.ietf.org/internet-drafts/draft-villamizar-mpls-forwarding-00.txt
> Status:
> http://datatracker.ietf.org/doc/draft-villamizar-mpls-forwarding
> Htmlized:
> http://tools.ietf.org/html/draft-villamizar-mpls-forwarding-00
>
>
> Abstract:
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 10 Oct 2012 06:52:17 -0700

Hi Andy,

> certainly fit the category of "Early Uses of Multiple Label Stack

Thanks -- good suggestion. Will do. Also perhaps a quick note on the control word. 

> certainly looks like a BCP to me, or if not that, then an MPLS WG

Our thinking as well, but let's see what others and the chairs say. 

Regards,
Kireeti

---

From: Curtis Villamizar <[email-masked]>
Date: Sat, 13 Oct 2012 15:48:51 -0400

In message <CAA=[email-masked]>
 
> certainly fit the category of "Early Uses of Multiple Label Stack

OK.  Will look at adding something on PW there.

> certainly looks like a BCP to me, or if not that, then an MPLS WG

Thanks.  BCP or informational seems to make sense.

BMWG might me interested in followup work.

Curtis