Subject: [mpls] Some question on draft-xu-mpls-in-udp-04

From: "Vivek Kumar" <[email-masked]>
Date: Wed, 5 Dec 2012 11:18:55 +0000

Hi  Authors,

I have some question.

1)      The  draft-xu-mpls-in-udp-04 main purpose seems to be for proving load balancing in IP network for MPLS packets.  Is that the only use case of this new encapsulation method or there can be some more ?

2)      The draft says that ingress PE router will calculate entropy and  encapsulate UDP header with src port containing entropy value . Does this mean that only PE routers can do UDP encap since PE router can look deep inside the packet to calculate entropy ?
                What if LSR's want to initiate UDP tunnel ?

Kindly provide your comments .

Regards,
Vivek

---

From: Lucy yong <[email-masked]>
Date: Wed, 5 Dec 2012 20:22:28 +0000

Hi Vivek,

I share my opinion. Please see below.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Vivek Kumar
Sent: Wednesday, December 05, 2012 5:19 AM
To: [email-masked]
Subject: [mpls] Some question on draft-xu-mpls-in-udp-04

Hi  Authors,

I have some question.

1)      The  draft-xu-mpls-in-udp-04 main purpose seems to be for proving load balancing in IP network for MPLS packets.  Is that the only use case of this new encapsulation method or there can be some more ?
[Lucy] This draft proposes mpls-in-udp format to enable better load balancing in IP network for MPLS payload. In fact, as section 4 states, the udp encapsulation can apply other applications beside MPLS, for example, IP. However, potential for other applications are outside scope of this draft. We plan to have another draft describe the udp encapsulation in general as mentioned in section 4.

2)      The draft says that ingress PE router will calculate entropy and  encapsulate UDP header with src port containing entropy value . Does this mean that only PE routers can do UDP encap since PE router can look deep inside the packet to calculate entropy ?
                What if LSR's want to initiate UDP tunnel ?
[Lucy] Yes, the solution requires PE to support UDP and proposes to reserve two UDP port number to indicate the payload type. PE understands the payload and can get some flow entropy from the payload and insert into UDP src port. Could you elaborate what is the UDP tunnel?

Lucy

Regards,
Vivek

---

From: "Vivek Kumar" <[email-masked]>
Date: Thu, 6 Dec 2012 04:07:14 +0000

Thanks Lucy for your comments.

For point 2 ) below I meant that since MPLS label could also have an entropy as one of their label , can the proposed approach of UDP encapsulation be applied to LSR also or it will be restricted for PE only ?

Regards,
Vivek

From: Lucy yong [mailto:[email-masked]]
Sent: Thursday, December 06, 2012 1:52 AM
To: Vivek Kumar; [email-masked]
Subject: RE: Some question on draft-xu-mpls-in-udp-04

Hi Vivek,

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Vivek Kumar
Sent: Wednesday, December 05, 2012 5:19 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [mpls] Some question on draft-xu-mpls-in-udp-04

Hi  Authors,

I have some question.

Lucy

Regards,
Vivek

---

From: Lucy yong <[email-masked]>
Date: Thu, 6 Dec 2012 15:19:50 +0000

Hi Vivek,

Thank you for the clarification. I think that my answer to your first question applies to the point 2.  In short, it can apply to LSR. But in the context of MPLS application, it means PE.

Lucy

From: Vivek Kumar [mailto:[email-masked]]
Sent: Wednesday, December 05, 2012 10:07 PM
To: Lucy yong; [email-masked]
Subject: RE: Some question on draft-xu-mpls-in-udp-04

Regards,
Vivek

Hi Vivek,

Hi  Authors,

I have some question.

Lucy

Regards,
Vivek

---

From: "Vivek Kumar" <[email-masked]>
Date: Fri, 7 Dec 2012 04:04:11 +0000

Hi Lucy,
  Thanks for clarification.  In Section 3 of draft, the figure says MPLS Packet. Wouldn't it be more consistent to change it to MPLS label stack same as mentioned in RFC 4023.

Regards,
Vivek

From: Lucy yong [mailto:[email-masked]]
Sent: Thursday, December 06, 2012 8:50 PM
To: Vivek Kumar; [email-masked]
Subject: RE: Some question on draft-xu-mpls-in-udp-04

Hi Vivek,

Lucy

From: Vivek Kumar [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Wednesday, December 05, 2012 10:07 PM
To: Lucy yong; [email-masked]<mailto:[email-masked]>
Subject: RE: Some question on draft-xu-mpls-in-udp-04

Regards,
Vivek

From: Lucy yong [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Thursday, December 06, 2012 1:52 AM
To: Vivek Kumar; [email-masked]<mailto:[email-masked]>
Subject: RE: Some question on draft-xu-mpls-in-udp-04

Hi Vivek,

Hi  Authors,

I have some question.

Lucy

Regards,
Vivek

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 7 Dec 2012 04:11:20 +0000

Will fix it in the next version.

Thanks.
Xiaohu

发件人: [email-masked] [mailto:[email-masked]] 代表 Vivek Kumar
发送时间: 2012年12月7日 12:04
收件人: Lucy yong; [email-masked]
主题: Re: [mpls] Some question on draft-xu-mpls-in-udp-04

Hi Lucy,
  Thanks for clarification.  In Section 3 of draft, the figure says MPLS Packet. Wouldn’t it be more consistent to change it to MPLS label stack same as mentioned in RFC 4023.

Regards,
Vivek

Hi Vivek,

Lucy

Regards,
Vivek

Hi Vivek,

Hi  Authors,

I have some question.

2)      The draft says that ingress PE router will calculate entropy and  encapsulate UDP header with src port containing entropy value . Does this mean that only PE routers can do UDP encap since PE router can look deep inside the packet to calculate entropy ?
                What if LSR’s want to initiate UDP tunnel ?
[Lucy] Yes, the solution requires PE to support UDP and proposes to reserve two UDP port number to indicate the payload type. PE understands the payload and can get some flow entropy from the payload and insert into UDP src port. Could you elaborate what is the UDP tunnel?

Lucy

Regards,
Vivek