Subject: [mpls] Jari Arkko's Discuss on draft-ietf-mpls-tp-temporal-hitless-psm-13: (with DISCUSS)

From: Jari Arkko <[email-masked]>
Date: Thu, 16 Mar 2017 07:08:33 -0700

Jari Arkko has entered the following ballot position for
draft-ietf-mpls-tp-temporal-hitless-psm-13: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-tp-temporal-hitless-psm/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Stewart Bryant's Gen-ART review comments deserve more discussion, in my
opinion. Perhaps that response is in the way of showing that Stewart is
wrong, or that the working group has knowingly chosen a particular path,
or that some clarification or changes are needed in the document. But
substantial comments need to be addressed in some fashion, and I don't
feel we're quite there yet. But I also didn't see much discussion on my
e-mail search, it is possible of course that discussion happened without
me seeing it (I'm not on the MPLS WG list).

All that being said, this Discuss position is a request for discussion,
but I do not plan to hold on to it beyond this telechat.

---

From: D'Alessandro Alessandro Gerardo <[email-masked]>
Date: Fri, 17 Mar 2017 08:34:31 +0000

Dear all,

We are extremely interested in the functionality described in this  RFC. We will start discussing with our vendors as soon as this document has been approved.

As far as Stewart Bryant's Gen-ART review comments, it seems that "The key question for the IESG is whether it is appropriate to publish this requirements text when  no one has any idea of the impact on the MPLS architecture or if there are any practical solutions to the problems raised."  To that question I can say that a potential solution that was conceived at the time the draft was written is based on combining TTL and node/interface ID.  I hope this can brighten up a little bit.

Again from Stewart Bryant's Gen-ART review comments "So that leaves the reader with a question: do the authors now have an insight into how a solution can now be designed to meet the requirement,  or do the authors intend to propose a change to the MPLS architecture, or is the intention to publish this to state the requirements in the hope that someone will eventually propose a solution?" I believe that what I said above provide an answer to this doubt. Personally I do not believe it is appropriate to either include comments about solutions nor to anticipate solutions in a requirement document but if you believe this is a way to improve the document I can add some details.

Finally, from Stewart Bryant's Gen-ART review comments "The text around Figure 8 explains the deficiency in TTL based section of an OAM monitoring point in MPLS. However the authors give no indication of a feasible alternative." That appears to be the concrete IESG concern and I do understand that.

Draft draft-ietf-mpls-tp-temporal-hitless-psm-13 says: "Assuming that OAM packet termination depends only on  the TTL value of the MPLS label header, the target node of the HPSM  changes from E to D .....<snipped>....  As a result requirement (M9) is not satisfied.” . Text is NOT saying that MPLS architecture is not adequate to satisfy requirement (M9). It simply says that using ONLY TTL is not adequate to satisfy requirement (M9). A possible solution has been described above.

I hope this clarifies and let the document to be finalized so starting a second phase where people can be committed to work on the solution.

Best regards,

Alessandro

------------------------------------------------------------------

Alessandro Gerardo D'Alessandro

Transport Innovation

Transport and IP Innovation

Via Reiss Romoli, 274 - 10148 Torino

phone:  +39 011 228 5887

mobile: +39 335 766 9607

fax: +39 06 418 639 07

Tim Official: Facebook - Twitter

www.tim.it

-----Messaggio originale-----
Da: Jari Arkko [mailto:[email-masked]]
Inviato: giovedì 16 marzo 2017 15:09
A: The IESG
Cc: [email-masked]; [email-masked]; David Sinicrope; [email-masked]; [email-masked]; [email-masked]
Oggetto: Jari Arkko's Discuss on draft-ietf-mpls-tp-temporal-hitless-psm-13: (with DISCUSS)

DISCUSS:

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

[rispetta l'ambiente]Rispetta l'ambiente. Non stampare questa mail se non è necessario.