Subject: [mpls] RMR updates

From: Kireeti Kompella <[email-masked]>
Date: Wed, 8 Nov 2017 13:13:39 -0800

Hi All,

We'd like to move to last call on the RMR document, but first there are a
couple of loose ends we'd like to tie up, specifically, the "Advanced
topics" in the -05 version of the draft.

a) how should the RMR document deal with "half-rings"?

Consider the following half-ring:

    A    B
    |    |
    C----D

Here are some options:
i) the RMR document shouldn't concern itself with this case
ii) create a PW from A to B to complete the ring
ii) instead of creating N LSPs (in this case 4), only create LSPs from A to
B and from B to A.

b) how should the RMR document deal with protecting hub nodes?
i) not deal with it.
ii) use technology akin to PIC edge

We feel that it is important to address both these issues. We are
soliciting your response, either among the options suggested, or
potentially other ideas.

Thanks,
-- 
Kireeti

---

From: Huub van Helvoort <[email-masked]>
Date: Tue, 14 Nov 2017 12:34:58 +0100

Hello Kireeti,

You wrote:

We'd like to move to last call on the RMR document,
but first there are a couple of loose ends we'd like to tie up,
specifically, the "Advanced topics" in the -05 version of the
draft.

A    B

|    |

C----D

To me this is the same as a linear
topology:

A--C--D--B

A ring topology is a closed loop.

Here are some options:

yes, because it is not a ring

no, closing the ring should be at lower layers

ii) instead of creating N LSPs (in this case 4), only
create LSPs from A to B and from B to A.

maybe, but with the requirement that these two LSPs shall not pass

through nodes C and D to avoid single points of failure

b) how should the RMR document deal with protecting hub
nodes?

they should be considered to be "normal" ring nodes and protected as
such

i) not deal with it.

no

I am not familiar with this.

We feel that it is important to address both these issues.
We are soliciting your response, either among the options
suggested, or potentially other ideas.

My 0.02€

Best regards, Huub.

--
================================================================
Always remember that you are unique...just like everyone else...

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 15 Nov 2017 14:47:07 +0800

Hi Kireeti, et. al,
I concur with Huub in regard to leaving half-ring (or arc) outside of scope
of RMR document.
I suspect that PIC stands for prefix-independent convergence (edge)
<https://www.juniper.net/documentation/en_US/junos/topics/example/bgp-pic-edge.html>.
I think a'la PIC approach may be mentioned in RMR docuemnt but I don't see
the benefit of making it part of the standard solution.

Regards,
Greg

On Tue, Nov 14, 2017 at 7:34 PM, Huub van Helvoort <[email-masked]>
wrote:

> To me this is the same as a linear topology:
> A--C--D--B
>
> ii) instead of creating N LSPs (in this case 4), only create LSPs from A
> to B and from B to A.
>
> they should be considered to be "normal" ring nodes and protected as such
>
> i) not deal with it.
>
> no
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 15 Nov 2017 18:06:38 +0800

Hi Kireeti,

Keep it out of scoop.

Thanks,

Jeff

From: mpls <[email-masked]> on behalf of Kireeti Kompella <[email-masked]>
Date: Thursday, November 9, 2017 at 05:13
To: "[email-masked]" <[email-masked]>
Subject: [mpls] RMR updates

Hi All,

We'd like to move to last call on the RMR document, but first there are a couple of loose ends we'd like to tie up, specifically, the "Advanced topics" in the -05 version of the draft.

    A    B

    |    |

    C----D

Here are some options:

ii) instead of creating N LSPs (in this case 4), only create LSPs from A to B and from B to A.

i) not deal with it.

We feel that it is important to address both these issues. We are soliciting your response, either among the options suggested, or potentially other ideas.

Thanks,
-- 

Kireeti

_______________________________________________ mpls mailing list [email-masked] https://www.ietf.org/mailman/listinfo/mpls

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 30 Nov 2017 03:27:59 +0000

Hi Kireeti,

Some comments from my side:

1.       If the “half-ring” is the physical network topology, then I’d agree with Huub that it is similar to a linear topology. Then RMR may not need to consider this scenario.

2.       As for hub nodes protection, IMO it is definitely needed. One possible solution maybe is to treat the two hub nodes as a virtual node, and allocate the same ring label. OAM can be used to detect the failure and trigger ring LSP switch over. This is described in the shared ring protection document.

Best regards,
Jie

From: mpls [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Thursday, November 09, 2017 5:14 AM
To: [email-masked]
Subject: [mpls] RMR updates

Hi All,

    A    B
    |    |
    C----D

Here are some options:

Thanks,
--
Kireeti