Subject: Re: [mpls] Mirja Kühlewind's No Objection on draft-ietf-mpls-ldp-mrt-06: (with COMMENT)

From: Chris Bowers <[email-masked]>
Date: Mon, 6 Nov 2017 16:14:56 +0000

Mirja,

Thanks for the feedback.  Responses are inline with [CB].

Thanks,
Chris

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
Sent: Monday, September 11, 2017 6:37 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] Mirja Kühlewind's No Objection on draft-ietf-mpls-ldp-mrt-06: (with COMMENT)

Mirja Kühlewind has entered the following ballot position for
draft-ietf-mpls-ldp-mrt-06: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-ldp-mrt/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

1) I was just wondering if it was considered to just use one flag of the reserved field of the multi-topology extension in RFC7307 to advertise MRT support, given that MT must always advertised as well...?

[CB]  I don't really understand the suggestion.  The document is requesting three values from the MPLS Multi-Topology Identifiers Registry (defined in RFC 7307). I think that we need all three, MRT-Red, MRT-Blue, and Rainbow MRT, for the protocol to work.  The registry has 64k possible values (with 4k being most useful), of which only 6 are currently used.

Or are you referring to the request for a value from the Label Distribution Protocol (LDP) Parameters registry "TLV Type Name Space"?

2) Why would a node withdraw the MRT capability/ when would it send a MRT advertisement with S=0?

[CB]  As an example, a configuration change on the node to no longer participate in label distribution for MRT would generally result in a withdrawal of the MRT capability, which is done by setting S=0.  The document currently has a  reference to RFC 5661 "LDP Capabilities" for more information on this.  Do you think more text is needed in the document to clarify this?

3) If you update the document, please also see the gen-art review: there are many small nits which will probably also be caught by the RFC editor but if you can fix them now, that's even better!

[CB]  Thanks.  I did that in a separate response.

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Thu, 9 Nov 2017 16:28:07 +0900

Hi Chris,

see below.

> Am 07.11.2017 um 01:14 schrieb Chris Bowers <[email-masked]>:
> 
> Mirja,
> 

I was thinking just about the MRT Capability Advertisement (use a flag instead of a new TLV Type, namely TBD-MRT-LDP-1). However this is not important...

> [CB]  As an example, a configuration change on the node to no longer participate in label distribution for MRT would generally result in a withdrawal of the MRT capability, which is done by setting…

Not necessarily. But it always helps to be rather explicit than implicit. It might be good to note that this is send based on things like config changes and not based on state changes that are happening during usual operation. However, maybe this is more obvious to people who are more expert than I am.

Mirja

---

From: Chris Bowers <[email-masked]>
Date: Mon, 13 Nov 2017 17:59:40 +0800

Mirja,

With respect to the second comment, since the behavior is defined in
RFC5661, in this case I think it is better to not be more explicit in this
document because it might confuse matters and be interpreted as specifying
behavior that is in some way different from RFC5661.

If it is OK with you, I will close out these two items without making
changes to the current text.

Thanks,
Chris

On Thu, Nov 9, 2017 at 3:28 PM, Mirja Kuehlewind (IETF) <[email-masked]
> wrote:

> > Subject: [mpls] Mirja Kühlewind's No Objection on
> draft-ietf-mpls-ldp-mrt-06: (with COMMENT)
> >
> > When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> >
> >
> > 1) I was just wondering if it was considered to just use one flag of the
> reserved field of the multi-topology extension in RFC7307 to advertise MRT
> support, given that MT must always advertised as well...?
> >
> > [CB]  I don't really understand the suggestion.  The document is
> requesting three values from the MPLS Multi-Topology Identifiers Registry
> (defined in RFC 7307). I think that we need all three, MRT-Red, MRT-Blue,
> and Rainbow MRT, for the protocol to work.  The registry has 64k possible
> values (with 4k being most useful), of which only 6 are currently used.
>
> I was thinking just about the MRT Capability Advertisement (use a flag
> instead of a new TLV Type, namely TBD-MRT-LDP-1). However this is not
> important...
>
> >
> > Or are you referring to the request for a value from the Label
> Distribution Protocol (LDP) Parameters registry "TLV Type Name Space"?
> >
> > [CB]  As an example, a configuration change on the node to no longer
> participate in label distribution for MRT would generally result in a
> withdrawal of the MRT capability, which is done by setting S=0.  The
> document currently has a  reference to RFC 5661 "LDP Capabilities" for more
> information on this.  Do you think more text is needed in the document to
> clarify this?
>
> Not necessarily. But it always helps to be rather explicit than implicit.
> It might be good to note that this is send based on things like config
> changes and not based on state changes that are happening during usual
> operation. However, maybe this is more obvious to people who are more
> expert than I am.
>
> Mirja
>
> >
> > 3) If you update the document, please also see the gen-art review: there
> are many small nits which will probably also be caught by the RFC editor
> but if you can fix them now, that's even better!
> >

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Tue, 14 Nov 2017 16:43:55 +0800

That was just a comment. Just do the right thing…

> Am 13.11.2017 um 17:59 schrieb Chris Bowers <[email-masked]>:
> 
> Mirja,
> 
> With respect to the second comment, since the behavior is defined in RFC5661, in this case I think it is better to not be more explicit in this document because it might confuse matters and be interpreted as specifying behavior that is in some way different from RFC5661.  
> 
> If it is OK with you, I will close out these two items without making changes to the current text.
> 
> Thanks,
> Chris
> 
> On Thu, Nov 9, 2017 at 3:28 PM, Mirja Kuehlewind (IETF) <[email-masked]> wrote:
> Hi Chris,
> 
> see below.
>