Subject: Re: [mpls] Eric Rescorla's No Objection on draft-ietf-mpls-ldp-mrt-06: (with COMMENT)

From: Chris Bowers <[email-masked]>
Date: Mon, 6 Nov 2017 16:37:45 +0000

Eric,

Thanks for the comments.  See inline below with [CB].  Changes addressing these comments can be found here:

https://github.com/cbowers/draft-ietf-mpls-ldp-mrt/commit/b930b3455453e6d50814955154fd1206f06b14c3

Thanks,
Chris

-----Original Message-----
From: Eric Rescorla [mailto:[email-masked]] 
Sent: Saturday, September 9, 2017 1:07 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Eric Rescorla's No Objection on draft-ietf-mpls-ldp-mrt-06: (with COMMENT)

Eric Rescorla has entered the following ballot position for
draft-ietf-mpls-ldp-mrt-06: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-ldp-mrt/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Line 106
   familiar with the architecture in [RFC7812] to understand how and why
   the LDP extensions for behavior are needed.

It would actually be helpful to explain this here.
=====
[CB]   I changed the first paragraph of the introduction to read.  

   This document describes the LDP signaling extensions and associated
   behavior necessary to support the architecture that defines how IP/
   LDP Fast-Reroute can use MRTs [RFC7812].  The current document
   provides a brief description of the MRT-FRR architecture, focusing on
   the aspects most directly related to LDP signaling.  The complete
   description and specification of the MRT-FRR architecture can be
   found in [RFC7812].

A basic description of the architecture already exists in the introduction.  This new text makes that clearer.

=======
Line 430
   However, should this situation occur, the expected behavior of an LSR
   receiving these conflicting advertisements is defined as foll If an
   LSR receives a label mapping advertisement for a rainbow FEC from an

Nit: as follows.

[CB] fixed in a previous commit.

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 6 Nov 2017 09:56:28 -0800

Thanks

On Mon, Nov 6, 2017 at 8:37 AM, Chris Bowers <[email-masked]> wrote:

> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; [email-masked]
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> A basic description of the architecture already exists in the
> introduction.  This new text makes that clearer.
>
> =======
> Line 430