Subject: [mpls] Entropy in MPLS-SR-over-UDP

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 14 Nov 2017 06:56:43 -0000

Hi Wim,
A couple of observations on the question you raised at the mic...

An entropy value can be preserved e2e, but it is by no means necessary to do so.

This shows at three points in a network...

1. UDP tunnel ends, new UDP tunnel starts
This the "normal" case. It is possible to conceive of storing the entropy value
and re-using it (but I don't think I would implement that). Each UDP tunnel is a
new tunnel and gets its own entropy value. Of course, if there is already an EL
in the stack, that can be extracted.

2. Previous hop is native MPLS-SR, next hop is UDP tunnel
This case is just like the tunnel between two islands (first use case). The UDP
entropy value can be pulled from an EL if one is in the stack or can be
generated locally. This is just 7510.

3. UDP tunnel ends, next hop is native MPLS-SR
This case is just like the tunnel between two islands (first use case). The
MPLS-SR entropy value might already be in an EL in the stack in which case,
nothing to do. Or an EL might need to be made in which case it could be stored
from the incoming UDP or freshly generated. This, too, is just as 7510.

The crunch is that if you are worried about making an entropy value at a transit
node (for example because it would involve too much processing or exceed the
RLD) then your head end should add an EL that will survive e2e because (as
noted) the SR stack persists just as normal for MPLS-SR.

Does that help?
I think we thought this was unnecessary to expose in the text, but if you think
adding this explanation would be useful, we can do it.

Thanks,
Adrian

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 14 Nov 2017 07:14:55 +0000

Adrian, good.
My point is we should specify the behaviour in the draft. 
Your take is the ingress node of the SR-TE LSP should insert an entropy label in the stack based on RLD capabilities even though SRoUDP is used.
Only when you use SRoUDP all the way we can avoid adding the entropy label.

On 14/11/2017, 14:56, "Adrian Farrel" <[email-masked]> wrote:

    Hi Wim,

    

    
    
    Does that help?
    
    Thanks,
    Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 14 Nov 2017 07:23:22 -0000

OK, we'll add text.

And I think the message is "more or less" (TM) unchanged from the behavior for native MPLS-SR.

A

> -----Original Message-----
> From: Henderickx, Wim (Nokia - BE/Antwerp)
> [mailto:[email-masked]]
> Sent: 14 November 2017 07:15
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; Jeff Tantsura
> Subject: Re: Entropy in MPLS-SR-over-UDP
> 
> Adrian, good.
> Your take is the ingress node of the SR-TE LSP should insert an entropy label in
> the stack based on RLD capabilities even though SRoUDP is used.

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 14 Nov 2017 07:31:20 +0000

I agree but the draft claims we can do src udp port for entropy label and hence people might forget this. Hence why I believe its important to define this behaviour explicitly.

On 14/11/2017, 15:23, "Adrian Farrel" <[email-masked]> wrote:

    OK, we'll add text.

    A

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 14 Nov 2017 08:16:37 -0000

Yeah, OK.
The point is we *do* use src port for entropy on the UDP tunnel, but we have to drag that value from somewhere or create it.

We'll throw some text together.

A

> Sent: 14 November 2017 07:31
> Cc: [email-masked]; [email-masked]; 'Jeff Tantsura'
> I agree but the draft claims we can do src udp port for entropy label and hence
> people might forget this. Hence why I believe its important to define this
> behaviour explicitly.
> 
>     >     An entropy value can be preserved e2e, but it is by no means necessary to
> do
>     > so.
>     >
> UDP

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 14 Nov 2017 08:38:39 +0000

thx

On 14/11/2017, 16:35, "Adrian Farrel" <[email-masked]> wrote:

    Yeah, OK.

    A