Subject: [MSEC] Question concerning MIKEY

From: "Peter Barany" <[email-masked]>
Date: Fri, 1 Mar 2002 11:17:56 -0600

Hi,

I have a quick question concerning the operation of MIKEY v00 with SRTP v02.

In section 3.3 of the SRTP I-D v02, it mentions that "Authentication MUST be
applied to RTCP as it is the control protocol ... "

Also, earlier in the same section of the SRTP I-D v02, it mentions that "
... SRTCP authentication is mandatory. The authentication transforms and
related parameters (e.g., key size) shall be the same selected for the
protection of the associated SRTP stream(s) (when SRTP is authenticated
too)."

I am unclear about what authentication algorithm will be used for SRTCP if
in the MIKEY SP payload the parameter "auth alg" is set to "NULL"
(indicating that the SRTP packets will not be authenticated).

Regards,

Pete

---

From: Mark Baugher <[email-masked]>
Date: Fri, 01 Mar 2002 09:58:05 -0800

At 11:17 AM 3/1/2002 -0600, Peter Barany wrote:

>In section 3.3 of the SRTP I-D v02, it mentions that "Authentication MUST 
>be applied to RTCP as it is the control protocol ... "
>
>protection of the associated SRTP stream(s) (when SRTP is authenticated too)."
>

SRTP defaults to HMAC-SHA1.

Mark

>Pete

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Fredrik Lindholm" <[email-masked]>
Date: Sat, 2 Mar 2002 11:50:11 +0100

Hi Peter,

this has been fixed in the -01 version of MIKEY (i.e. it is
possible to set the SRTCP parameters independent of
the SRTP). I submitted a new version of MIKEY this
Thursday. Until it is available in the archives you may
fetch it at:
http://standards.ericsson.net/fli/draft-ietf-msec-mikey-01.txt
(note also that a new SRTP version was also submitted
this week).

Except from normal editorial changes, the main changes
are due to the support of multiple TEKs and the support
of a Re-key SA (and KEK).

Some of the most notable changes from the -00 draft:
* Support for Re-key SA including KEK transport for all
  methods.
* PK: Envelope approach for encryption of keys (as the
  size may exceed the limit that can be encrypted with
  one public-key operation).
* Message processing updated
* SDP, SIP and RTSP considerations updated
* Group section updated
* The use of Rand (instead of require a large and random
   MCS ID)
* (SRTP) policies updated
* Payload update (to support the above changes)

Comments and questions on the new draft are very
welcome!

Cheers,
Fredrik

-----Original Message-----
From: Peter Barany <[email-masked]>
To: [email-masked]' <[email-masked]>;
[email-masked]' <[email-masked]>;
[email-masked]' <[email-masked]>
Cc: [email-masked]' <[email-masked]>
Date: den 1 mars 2002 18:16
Subject: Question concerning MIKEY

>In section 3.3 of the SRTP I-D v02, it mentions that "Authentication
>MUST be applied to RTCP as it is the control protocol ... "
>
>Also, earlier in the same section of the SRTP I-D v02, it mentions that
>" ... SRTCP authentication is mandatory. The authentication transforms
>and related parameters (e.g., key size) shall be the same selected for
>the protection of the associated SRTP stream(s) (when SRTP is
>authenticated too)."
>
>I am unclear about what authentication algorithm will be used for SRTCP
>if in the MIKEY SP payload the parameter "auth alg" is set to "NULL"