Subject: [MSEC] MIKEY - SRTP Interaction

From: "Steffen Fries" <[email-masked]>
Date: Wed, 06 Nov 2002 11:10:17 +0100

Hi,

I've got a question to the interworking of MIKEY and SRTP. 

In SRTP section 9.1 it is recommended that RTP senders on 
different hosts not use the same master key to send RTP data. 

From the MIKEY perspective this (the SRTP master key) relates 
to the TEK according to MIKEY Appendix A. 

This means, that from an initiators perspective for a voice 
connection between two entities two TEKs are necessary, one for 
sending RTP packets, one for receiving.

How is the signaling, which TEK is used for which direction 
being done? My assumption is, that the SSRC may be used for 
this, but I'm not quite sure how. MIKEY exchanges the TGK, from 
which the TEKs are derived loacally. There needs to be a 
mapping between the different TEKs generated and the streams to 
which they are applied. Could somebody please explain this 
mapping?

Regards
	Steffen

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Elisabetta Carrara (EAB)" <[email-masked]>
Date: Wed, 6 Nov 2002 14:03:27 +0100

correct

> -----Original Message-----
> From: Steffen Fries [mailto:[email-masked]]
> Sent: den 6 november 2002 13:38
> To: Elisabetta Carrara (EAB)
> Cc: [email-masked]
> Subject: RE: [MSEC] MIKEY - SRTP Interaction
> 
> 
> Hi Elisabetta,
> 
> > With one common TGK, the differentiation is done 
> > in the TEK derivation process. Section 4.1.4: you input 
> > cs_id, the crypto session id. Note that the cs_id is 
> > defined by the mapping in 6.1.1. for SRTP (where each 
> > policy, ssrc & roc are mapped to a specific cs_id).  
> 
> Just to sumarize it for myself, both sides calculate the TEKs, 
> where the CD ID is also an input parameter for the PRF. Each 
> entity is now able to associate the SSRC delivered in the CS ID 
> map info field to a dedicated CS ID. Since the i-th SSRC will 
> have the CS ID equeal to i one can associate the TEK to the 
> SSRC. Is this right?
> 
> Ciao
> 	Steffen
>