Subject: [MSEC] MIKEY key data transport

From: "Steffen Fries" <[email-masked]>
Date: Fri, 08 Nov 2002 11:47:38 +0100

Hi,

hope it is not a beancounter question ;-)

Section 6.2 of the MIKEY draft states the length of the 
encrypted data with 16 bit. The encrypted data itself is the 
key data sub payload (section 6.13), which also consists of two 
length information field. Both length fields have a size of 16 
bit too.
When someone tries to use the use these fields to the full 
extent, the payload will not fit into the KEMAC payload.
I'm not sure if this can really happen. The remark is more 
regarding consistency.

Regards
	Steffen

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Elisabetta Carrara (EAB)" <[email-masked]>
Date: Fri, 8 Nov 2002 17:11:18 +0100

Hi again

well, I see what you mean ;o)
however, as you say, it is really improbable that it happens.

thanks, cheers
/E 

> -----Original Message-----
> From: Steffen Fries [mailto:[email-masked]]
> Sent: den 8 november 2002 11:48
> To: [email-masked]
> Subject: [MSEC] MIKEY key data transport
> 
> 
> Hi,
>