Subject: Re: Proposal for the interactive message tracking protocol

From: Tomorrow SystemsInc <[email-masked]>
Date: Thu, 4 Nov 1999 07:00:15 -0800 (PST)

I think this idea is a good one. In order to trace the
complete path of a message, a "management station"
will go from MTA to MTA to MTA, piecing the
information together as it goes. This is a lot like
the model for classic network management, where each
"agent" is independent and aggregate staticstics about
the network must be deduced from information returned
from multiple agents.

As far as the following goes:

>There might be an issue
> with handing back
> response data like this in SMTP in that it would be
> somewhat larger than
> your average SMTP response.

At what point does this apply ? Do you mean during the
setup phase of an SMTP session  only ?  MTAs pass some
very large messages, so the overhead of the message
tracking response is probably about the same as a
message unless there is a protocol-specific state
where MTAs traditionally don't want to see a "larger
than average SMTP response" as you describe above.
Otherwise, what is the anticipated ratio of message
tracking requests versus normal message traffic ?  Is
there a class of user who will want to saturate and
MTA with message tracking requests ?

Gordon

=====
Gordon Jones
Tomorrow Systems Incorporated
Internet Consulting - Internet Software
http://www.tomorrowsys.com
(703) 309 - 8859
__________________________________________________
Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com

---

From: Tony Hansen <[email-masked]>
Date: Fri, 05 Nov 1999 00:35:26 -0500

Tomorrow SystemsInc wrote:
> ...

It's the opposite of the usual client-to-server ratio (large data
segments compared to small server responses), but the comparison is apt.
If the response to a tracking request were encapsulated in what
essentially looks like a delivery notification, then it will be the size
of a small mail message.

> tracking requests versus normal message traffic ?

I expect it to be rather low.

> Is there a class of user who will want to saturate and

Hmmm, good question.

	Tony Hansen
	[email-masked]