Subject: [Mud] Updated Manufactures supporting MUD

From: Daniel Cohen-Sason <[email-masked]>
Date: Wed, 8 Jul 2020 05:59:41 +0000

Hi
I am Daniel, leading the R&D for Check Point's IoT protection (https://www.checkpoint.com/solutions/iot-security/)
I am considering to include some level of support in MUD with our products.
I understand the technology, and as security vendor I understand what we need to do.
I'd like to validate that this is something that the manufactures adopted already, and the trend.
Can you share with me more information?

Regards,
Daniel
+972-53-5658548

---

From: Eliot Lear <[email-masked]>
Date: Wed, 8 Jul 2020 09:32:16 +0200

Hi Daniel,

There are a number of manufacturers that are in flight.  The code is supported by Microchip, and the capability is being introduced in Wifi Alliance’s DPP as well.  Molex supports.  If you don’t mind I will point your name to several companies under separate cover, and maybe one or two others who can add.

> On 8 Jul 2020, at 07:59, Daniel Cohen-Sason <[email-masked]> wrote:
> 
> Hi
> I am Daniel, leading the R&D for Check Point’s IoT protection (https://www.checkpoint.com/solutions/iot-security/ <https://www.checkpoint.com/solutions/iot-security/>)
> I’d like to validate that this is something that the manufactures adopted already, and the trend.
> -- 
> Mud mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mud <https://www.ietf.org/mailman/listinfo/mud>

---

From: Daniel Cohen-Sason <[email-masked]>
Date: Wed, 8 Jul 2020 08:35:25 +0000

OK. Thanks.

So this is the list, as of what you stated:

1.       https://www.microchip.com/

a.       All their products? Or some?

2.       Wifi Alliance’s DPP

a.       Is it a product? Or kind of OED? Can you point me to the relevant product?

3.       https://www.molex.com/molex/product-search/products.action

a.       Which of their product? I see a lot

Can we get their MUD files?

Daniel.

From: Eliot Lear <[email-masked]>
Sent: Wednesday, 8 July 2020 10:32
To: Daniel Cohen-Sason <[email-masked]>
Cc: [email-masked]
Subject: Re: [Mud] Updated Manufactures supporting MUD

Hi Daniel,

On 8 Jul 2020, at 07:59, Daniel Cohen-Sason <[email-masked]<mailto:[email-masked]>> wrote:

Hi
I am Daniel, leading the R&D for Check Point’s IoT protection (https://www.checkpoint.com/solutions/iot-security/)

Regards,
Daniel
+972-53-5658548

--
Mud mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mud<https://ct-url-protection.portal.checkpoint.com/v1/load/pK23o7XyujKAg9ANyWera5rh79Qd8yNpO5imbbbwhYQ9HUwfOX3AEtxXRnn47-yG8C-SIa7T_wGVkMPpDLyGV-bNnRyrDnRo5nig-EIrZjzNL0b3a_SSElg2mLvaYKCyXIFJQqnTfpF0XkEqfeRLQ79JxD62ZGWRtwWsVk4HCt1ReBkh5pIxdcPCIwm98dNR-SzXOui-POcV3j754sNqpUvJ5Y9SPSJzEOaJHGHc9MircuzoKgfMV8g9na7axI1W_VrCPBseqlrAHhxJ74qmIWxbzSkWE7NSWLZ-7KJ7viZaK4HQ_MJdu_vYO8FR8UBXg6N4RQhyrQRwRC97LsKdksB9_LZViFYaM0-XYEpyiA?original_url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmud>

Email secured by Check Point
Report Phishing<https://mta-cnf.iaas.checkpoint.com/mta_feedback?id=898048883003ed012f9c8330350484fd5128f8894e6baac3c2779059bcd2666f&ck=16CEDF0A967F;3D4CC6C8CB55;C5CEAA199888;&v=m>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 8 Jul 2020 10:44:10 +0200

> On 8 Jul 2020, at 10:35, Daniel Cohen-Sason <[email-masked]> wrote:
> 
> OK. Thanks.
>  
> 1.       https://www.microchip.com/ <https://www.microchip.com/>

Molex and others use their processors.  I can ask which models if you like.

> a.       Is it a product? Or kind of OED? Can you point me to the relevant product?

It’s a standard for onboarding IoT devices..

> 3.       https://www.molex.com/molex/product-search/products.action <https://www.molex.com/molex/product-search/products.action>

I can ping them, but it’s in their controllers.

Eliot

> From: Eliot Lear <[email-masked] <mailto:[email-masked]>> 
> To: Daniel Cohen-Sason <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> On 8 Jul 2020, at 07:59, Daniel Cohen-Sason <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi
> https://www.ietf.org/mailman/listinfo/mud <https://ct-url-protection.portal.checkpoint.com/v1/load/pK23o7XyujKAg9ANyWera5rh79Qd8yNpO5imbbbwhYQ9HUwfOX3AEtxXRnn47-yG8C-SIa7T_wGVkMPpDLyGV-bNnRyrDnRo5nig-EIrZjzNL0b3a_SSElg2mLvaYKCyXIFJQqnTfpF0XkEqfeRLQ79JxD62ZGWRtwWsVk4HCt1ReBkh5pIxdcPCIwm98dNR-SzXOui-POcV3j754sNqpUvJ5Y9SPSJzEOaJHGHc9MircuzoKgfMV8g9na7axI1W_VrCPBseqlrAHhxJ74qmIWxbzSkWE7NSWLZ-7KJ7viZaK4HQ_MJdu_vYO8FR8UBXg6N4RQhyrQRwRC97LsKdksB9_LZViFYaM0-XYEpyiA?original_url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmud>
>  
> 
> Report Phishing <https://mta-cnf.iaas.checkpoint.com/mta_feedback?id=898048883003ed012f9c8330350484fd5128f8894e6baac3c2779059bcd2666f&ck=16CEDF0A967F;3D4CC6C8CB55;C5CEAA199888;&v=m>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 08 Jul 2020 20:27:48 -0400

Daniel Cohen-Sason <[email-masked]> wrote:
    > I am Daniel, leading the R&D for Check Point's IoT protection
    > (https://www.checkpoint.com/solutions/iot-security/)

Hi, welcome to the list, we are very happy to have you here!
I'm pleased that you are considering 8520 support.
We are still in that hard spot where there are few products supporting MUD,
and few devices supplying MUD.
So there is going to be a bit of a leap of faith.

    > adopted already, and the trend.

I'd like to draw your attention to the concept of putting MUD URLs into QR
codes.  I described this in https://datatracker.ietf.org/doc/draft-richardson-opsawg-securehomegateway-mud/

{The WiFi Alliance's put RFC8520 into their spec, but not into their QR code!
https://www.wi-fi.org/download.php?file=/sites/default/files/private/DRAFT%20Device_Provisioning_Protocol_Specification_v_1.2_0.pdf
}

Rather than thinking that RFC8520 support means getting LLDP, DHCP (or BRSKI)
support into your product and struggling with how to get down to that
low-level of bits on the wire immediately, think of RFC8520 as a way to
package and distribute ACLs, signed by a manufacturer.
{of course, I'd like checkpoint to do LLDP, DHCP and BRSKI, but it doesn't
have to be critical path for a minimum viable product}

So a MUD URL can arrive by any method at all, and translating it into ACLs
can literally be done in your (G)UI only.   If you also allow your UI to
*export* a MUD file from a set of ACLs, then this can create a way to crowd
source much needed IoT rules.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-