Subject: Re: An idea: GxSE

From: [email-masked]
Date: Sun, 15 Jul 2001 22:43:50 -0400

>>>>> "Iljitsch" == Iljitsch van Beijnum <[email-masked]> writes:
    Iljitsch> The only systems that are hard to renumber are those that
    Iljitsch> others frequently connect to. Since you wouldn't want your web
    Iljitsch> server to magically get a new IP address and become unreachable
    Iljitsch> when it gets a new MAC address or someone else uses the same
    Iljitsch> MAC address these are configured manually. But how many web
    Iljitsch> servers do most organizations run?

  Every single Linux and Windows 2000 box that I've installed lately has
had a web server installed by default. They are used for system
maintenance and all sorts of other things.
  Please do not let yourself get trapped into client/server world. This
is peer to peer world.
  Deployment of VoIP will make that much more clear.

]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another NetBSD/notebook using, kernel hacking, security guy");  [

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 16 Jul 2001 10:09:56 +0200 (West-Europa (zomertijd))

>   Please do not let yourself get trapped into client/server world. This

But does this invalidate my point? I don't see boxes that provide actual 
services use autoconfiguration.

Iljitsch van Beijnum

---

From: "Tony Hain" <[email-masked]>
Date: Mon, 16 Jul 2001 10:32:55 -0700

Iljitsch van Beijnum wrote:

> I don't see boxes that provide actual services 
> use autoconfiguration.

Isn't this simply an artifact of the lack of secure DDNS? There are environments where sufficient trust exists for a 'service' node to autoconfigure itself and register that with DNS. The fact you don't see them says more about your local network / trust environment than it does about technical possibilities.

Tony

---

From: RJ Atkinson <[email-masked]>
Date: Mon, 16 Jul 2001 14:04:02 -0400

At 13:32 16/07/01, Tony Hain wrote:
>Isn't this simply an artifact of the lack of secure DDNS? 

        No.  

        Even ignoring security, which I don't advise, DDNS
requires more gorp (protocols, network transactions, 
services, etc.) than just running with a static network
configuration.

        Folks running high-availability {networking, computing}
services generally try hard to make their configurations 
very simple, because simple generally works best and most
reliably.

Ran

---

From: "Tony Hain" <[email-masked]>
Date: Mon, 16 Jul 2001 11:54:47 -0700

> services, etc.) than just running with a static network

This is a trade-off between the automation getting confused, or the operator misconfiguring it. I will agree that the current state of automation in products will lose this contest to a skilled operator, but I will also argue that in the end automation will always beat out the cheap low-skill operator. 

> very simple, because simple generally works best and most

I agree completely that simplicity is crucial, but there is a crossover between which is simpler based on the skill level of the operator. Generally the lower the skill level, the more automation is required to keep it simple.

Tony