Subject: Re: Fwd: Re: note from the iesg plenary

From: "Brian Haberman" <[email-masked]>
Date: Tue, 28 Aug 2001 13:11:23 -0400

Eliot,
     Yes, I am well aware that DNS is an ideal use of anycast.  That is
part of the reason why v6 anycast is of interest to people.  However,
my point has been to find out if anyone thinks that having 128-bit host
routes in the global routing table is going to scale.  Or, would you
think that anycast DNS deployed within a domain/site/admin scope
region is a better solution?

Brian

Eliot Lear wrote:
> 
> On Tue, 28 Aug 2001, Brian Haberman wrote:
> > Can you give me a definition of works boringly well?  Would that
> > entail no calls to the NOC as the measuring stick?
> 
> Because nearly all DNS requests are single packet exchanges AND
> connectionless, there are no adverse consequences for a routing shift, and
> thus DNS is ideal for anycast.  More robustness is needed for connection
> oriented anycast.

---

From: Eliot Lear <[email-masked]>
Date: Tue, 28 Aug 2001 11:12:13 -0700

Not clear you want to have host routes in the global routing system, but
that doesn't eliminate anycast use.  It means that the routing exchange on
those /128s has to be limited to IGPs.

--
Eliot Lear
[email-masked]

---

From: "Brian Haberman" <[email-masked]>
Date: Tue, 28 Aug 2001 15:14:09 -0400

Eliot,

> those /128s has to be limited to IGPs.

Exactly.  That means the anycast addresses being advertised have to
be allocated out of the "domain's" prefix, thus being aggregatable.
Users within an IGP would be able to use anycast to do (e.g.) DNS,
but the anycast route gets aggregated within BGP.

Users outside the domain COULD send to the anycast address and get
a response since the anycast address's prefix would be advertised
via BGP.

Brian

---

From: Randy Bush <[email-masked]>
Date: Wed, 29 Aug 2001 09:54:18 +0800

> routes in the global routing table is going to scale.

exactly as well as /32s for dns servers scale in the v4 internet

randy