Subject: RE: (multi6) requirements draft comments

From: "Michel Py" <[email-masked]>
Date: Tue, 18 Dec 2001 08:11:47 -0800

>> [Brian Carpenter]
>> Shame we don't have a PI solution that we actually know how to deploy
>> and route at large scale.
>
> [Randy Bush]
> like democracy, it sucks, but less than any other way we actually have.
>
>> [Brian Carpenter]
>> the illusory PI
>
> [Randy Bush]
> sadly, so far, it is the only non-illusory approach.  it is actually
> deployed and being widely used, as opposed to, for example, using per-host
> ping as a routing protocol.
> no, we don't like it.  but, though we have fears/worries, we don't have
> solid research/measurements about its actual scalability.  and far worse,
> we have no alternatives which are on any platform other then powerpoint.

>> [Brian Carpenter]
>> This requirement could lead to several other conclusions than PI:

I have to agree with Randy here. Granted, the PI approach has its own challenges, but it actually WORKS and is one of the building blocks of today's Internet.

This discussion reminds me of the electric car: Gas cars pollute, let's replace them with electric. Two problems: electric cars do pollute too, because the electricity they use is produced by a coal plant, and because the disposal of half a ton of lead-acid batteries after they're gone is not friendly to the environment either. Besides, plugging it to recharge is a terrible hassle.

I would love an electric car, and I will get one when I can get one that actually works. Today, the best I can think of is the hybrid; I might get one when my current car dies, but not before. The electric car failed because it was too many changes at the same time.

Same thing applies to v6 multihoming. I personally don't have a problem with tossing the current model away to replace it with something else entirely new, as long as that something else is better than what we currently have and has reasonable expectations in terms of success.

Given that the market will ultimately decide, it seems to me that the approach to v6 multihoming should be:
1. Provide v6 multihoming to EXISTING v4 multihoming sites/customers in a way that they would like, which probably requires PI.
2. By having these people moving to v6, it will then enable us to have a real environment to test  new solutions that we design against.

If there was a slam dunk solution for v6 multihoming, I would adopt it in a heartbeat. The reality check today is that nobody as invented it. This tells me that the road we need to pursue is an evolution of the current model as a headstart and continue to research other things as incremental changes.

To conclude, let me repeat a few ideas that I have read in other documents that some of you might be familiar with:
- The market does not like revolutions; the Internet has historically evolved with incremental changes.
- What we decide in this workgroup is one thing, what the market does is quite another.
- End-to-end connectivity is important.
- An imperfect solution is better than no solution.

Michel.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Dec 2001 17:55:25 +0100

We're miscommunicating a bit... see below

> > ping as a routing protocol.

Yes, it is what we do today in IPv4. But when I run the numbers for the future
Internet, it becomes illusory for the reasons in draft-iab-bgparch-02.txt
(which is supposed to be an RFC within 48 hours).

> > we have no alternatives which are on any platform other then powerpoint.

Fully agree. All I am suggesting right now is that we don't *assume* PI is
the answer for multi6.
> I have to agree with Randy here. Granted, the PI approach has its own challenges, but it actually WORKS and is one of the building blocks of today's Internet.

If I thought it would scale for tomorrow's Internet, we wouldn't be
having this conversation. 

...
> Same thing applies to v6 multihoming. I personally don't have a problem with tossing the current model away to replace it with something else entirely new, as long as that something else is better…

We agree. So don't build PI into the requirements of multi6.

> 2. By having these people moving to v6, it will then enable us to have a real environment to test  new solutions that we design against.

It may work out that way, but please don't build that into the requirements either.

> If there was a slam dunk solution for v6 multihoming, I would adopt it in a heartbeat. The reality check today is that nobody as invented it. This tells me that the road we need to pursue is an evo…

Please don't build that into the requirements either. Maybe somebody will invent the
slam dunk when they see the agreed requirements. (Unlikely, but we mustn't exclude
it by construction.)

   Brian