Subject: RE: (multi6) control / load balancing of ingress traffic.

From: "Michel Py" <[email-masked]>
Date: Thu, 10 Jan 2002 16:55:58 -0800

Masataka,

> Masataka Ohta wrote:
> Looking at your proposal, I feel we should add one more
> requirement that:
> A proposal must be for large scale policy rich Internet
> with highly assymmetric routing.
> Namely, routing information at a source gives no
> information or hint about how or whether the source can
> be reached from	destination.

I am not sure I completely understand what you mean above,
Could you please develop it a little bit?

Thanks
Michel.

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 12 Jan 2002 01:38:21 +0859 ()

Michel;

> Could you please develop it a little bit?

For example, your selection of addresses at a source may
randomly distribute return traffic but unlikely balance it.

The destination may know, from routing information, some return
path is temporaliry unavailable or some return path is five
times more favourable than others.

						Masataka Ohta

---

From: Pekka Savola <[email-masked]>
Date: Sat, 12 Jan 2002 15:39:34 +0200 (EET)

> times more favourable than others.

A problem with this 'destination address selection'...

When sending a packet, the source must pick _one_ source address; it
cannot store more of them.  When the destination replies, it might know
which path is best but this cannot be done unless the transport protocols
are changed (or something else rather radical is done) so all addresses 
are tagged in the packets.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 15 Jan 2002 12:45:34 +0859 ()

Pekka;

> are tagged in the packets.

That is not a problem at all.

					Masataka Ohta