Subject: RE: The state of IPv6 multihoming development

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 24 Oct 2002 16:08:20 +0200

> >   > Also note that
  > >   > current mobility will not support multihoming in any way,
  > >   > it would just
  > >   > be a starting point and we can borrow the header.
  > 
  > > => Current MIPv6 mechanisms _will_ support a multihomed/
  > > multiaddressed hosts. However, they will not give you a
  > > seamless switch from one path to another when one of the
  > > paths fail.
  > 
  > So what's the use then? We don't multihome because we like 
  > having many
  > addresses, but to survive failures.

=> That's why I asked: "How much interruption is acceptable?"
What do you mean by survive failure? Is it ok to lose 150 ms
of traffic? Or are you asking for a seamless survival failures
(i.e. zero interruption). Frankly I don't think that a 100 - 200 ms
interruption is a big deal, considering that this failure is not 
something that will happen once a minute.

  > 
  > > The host will somehow need to be explicitly
  > > notified that it should choose a new CoA. So this will
  > > interrupt (but need not break) ongoing connections.
  > 
  > How does a mobile host survive the home agent becoming unreachable?

=> I'm confused. Why would a home Agent become unreachable??
You seem to assume that the HA must be located in the 
upstream provider's network (that's the only interpretation
I can think of for your statement above). The HA can be located
in the mutlihomed enterprise. 

Hesham

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 24 Oct 2002 16:41:20 +0200 (CEST)

On Thu, 24 Oct 2002, Hesham Soliman (EAB) wrote:

>   > having many addresses, but to survive failures.

> something that will happen once a minute.

The shorter the better, but anything under 15 seconds is good enough,
IMO.

> in the mutlihomed enterprise.

Ah, I see now. I'm not sure where exactly I envisioned the home agent,
but I didn't consider moving it to a place that is multihomed through
separate means. Still, we'd need a good solution for all the home agents
(at least this will lessen the problem a good deal) and having a single
point of failure somewhere isn't optimal.