Subject: RE: The state of IPv6 multihoming development

From: "Tony Li" <[email-masked]>
Date: Tue, 22 Oct 2002 16:08:56 -0700

[ post by non-subscriber.  with the massive amount of spam, it is easy to
  miss and therefore delete mis-posts.  so fix subscription addresses! ]

It's vitally important in the sense that if we deploy
the wrong solution (or no solution), then we end up back
on the exponential curve and it will be that much harder
to change later because we would then have an installed
base.

In other words, the sequence should not be: ready, fire, 
aim.

;-)

Tony

|   -----Original Message-----
|   From: Tim Chown [mailto:[email-masked]]
|   Sent: Tuesday, October 22, 2002 4:04 PM
|   To: Peter Tattam
|   Cc: Multi6 Working Group
|   Subject: Re: The state of IPv6 multihoming development
|   
|   
|   On Wed, Oct 23, 2002 at 08:24:48AM +1100, Peter Tattam wrote:
|   > 
|   > One thing still remains clear though - multihoming is the 
|   thorn in the side for
|   > IPv6.  Until it is finalized, IPv6 will be going nowhere.
|   
|   Is it really that big a thorn?
|   
|   To play devil's advocate...
|   
|   What proportion of Internet sites are multihomed?  Academia 
|   generally isn't,
|   not to the universities, although the NRENs will have 
|   multiple peerings.
|   
|   What proportion of Internet enterprise sites are mission 
|   critical?  My home
|   or small business DSL/cable network certainly isn't 
|   multihomed, in the
|   access network at least.   Itojun is a rare example with 
|   four home /48's,
|   I think :)
|   
|   How frequently are multihomed sites calling on their 
|   resilient links?  Of
|   course ISPs like to sell additional connectivity.
|   
|   How much of the IPv4 DFZ clutter is due to multihomed sites?  
|   
|   Are 3GPP systems using IPv6 in Release 5 multihomed?
|    
|   I don't see lack of multihoming stopping deployment to 
|   academic networks
|   (many 10's of millions of users), or to broadband home 
|   networks.  There's
|   a potentially big IPv6 market in the latter.
|   
|   Multihoming is important, but is it that important?
|   
|   Tim
|   
|

---

From: Tim Chown <[email-masked]>
Date: Wed, 23 Oct 2002 00:27:02 +0100

> In other words, the sequence should not be: ready, fire, 

OK, containment (of the DFZ table size) is certainly a good goal.

But who is actually going to be multihoming with IPv6, and to what extent?
Perhaps there are now 50,000 large enterprises doing so with IPv4.  Is the
number of such enterprises going to rise?   What's the change in terms of
the types of sites multihoming that's pushing the DFZ size up so much?
Small ISPs?  Smaller enterprises?

I'm just curious as to who the multihomers are, and best guesstimates of
future growth.   Do we foresee home users multihoming to multiple ISPs?
I don't pay for resilience now with two telephone lines, or having DSL and
cable lines; paying double isn't economic for Joe User.   The same I assume 
would be true for mobile handsets.   Academia + home users + mobile (3G) users
is (or will be) a large chunk of the Internet;  all three can benefit from 
IPv6 now, or in the near future.

The crux seems to be projected top limits on who will demand multihoming,
and what clas of users those people/sites are?   Of course, predicting 10
years ahead is a tad tricky :)

Any pointers to research/stats on this would be interesting.

Tim

---

From: "Christian de Larrinaga" <[email-masked]>
Date: Wed, 23 Oct 2002 11:05:14 +0100

Tim

> Small ISPs?  Smaller enterprises?

this is a guess... ok;-)

the size of the ipv6 address space itself is likely to open up multihoming
demand.

for instance if we deploy trillions of embedded networked devices its a fair
assumption that a few hundred million will be considered sufficiently
mission critical as to warrant a redundant IP path even if they have a very
light data load.

now you say 50,000 in ip4 and on very expensive communications links and
limited business applications. What's the proportion of this number
multihoming to the address space in ip4 and would it be valid to apply that
proportion to ipv6? well it might give us something to think about at least.

Also consider that 64k line costs of $20,000 per annum and today dsl of $300
and FTTH potentially of $50 (perhaps without service) what impact then on
demand for multi homing?

We can only guess but my guess is that it would be a mistake to think multi
homing in ipv6 only applies to a few big boys because that's the lesson from
the history of big iron computing.

Christian
Christian de Larrinaga