Subject: RE: multihomed host

From: "Michel Py" <[email-masked]>
Date: Wed, 9 Oct 2002 15:55:55 -0700

> Bill Sommerfeld wrote:
> From the point of view of what applications need to do,
> it's safest to assume that all V6 hosts are multiaddressed.

Strongly agree. Although multiaddressed does not necessarily mean
multihomed, it is likely that part of the multihoming solution is
multiadressed hosts.

Michel.

---

From: "Ragib, Husain B (UMKC-Student)" <[email-masked]>
Date: Wed, 9 Oct 2002 21:39:44 -0500

[ post by non-subscriber.  with the massive amount of spam, it is easy to
  miss and therefore delete mis-posts.  so fix subscription addresses! ]

Multi-Homed Hosts: These are any machines which has more than one
interface to connect to multiple networks. There are lots of
complication involved when thinking in terms of Multi-homed hosts, such
as routing tables entrys and local hosts IP address translations to name
a few.

An interesting point to note in Multi-Homed hosts is that it can be
visaulised as a normal computer with two NIC and two IP address of two
diffrent networks. Here it could just be sitting and recieving traffic
from both network and rarely if anytime be involved in routing
functions.(Or else it would become a Router..Though there is a
distinction between those two..]

hope this helps..

Husain

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Bill Sommerfeld
Sent: Wednesday, October 09, 2002 3:31 PM
To: Margaret Wasserman
Cc: Yoshihiro Ohba; [email-masked]; [email-masked]
Subject: Re: multihomed host 

[ post by non-subscriber.  with the massive amount of spam, it is easy
to
  miss and therefore delete mis-posts.  so fix subscription addresses! ]

> I don't know if there is an official definition, but I
> have usually heard the term "multihomed host" used to
> refer to multi-interface systems that do not function
> as routers (i.e. they don't forward packets).

For what it's worth, I've occasionally heard the term used in an
application-layer context to refer to hosts having multiple IP
addresses rather than/in addition to multiple interfaces. 

						- Bill

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Fri, 11 Oct 2002 00:39:09 +0200

> >>> "Bill" == Bill Sommerfeld <[email-masked]> writes:
  > 
  >     Bill> For what  it's worth, I've occasionally heard  
  > the term used
  >     Bill> in  an application-layer  context to  refer to  
  > hosts having
  >     Bill> multiple  IP addresses rather  than/in addition  
  > to multiple
  >     Bill> interfaces.
  > 
  > This  just  looks like  the  degenerate  case  -- multiple  
  > addresses,
  > multiple  interfaces,  except that  each  of  the multiple  
  > interfaces
  > happen to  be the  same. It seems  to me  that the network  
  > layer code
  > should treat both cases identically. Does this make sense?

=> I don't think so. There is a difference in existing 
standards (2461) and implementations between the 2 cases. 
A multiaddressed node with a single interface assumes 
that any address can be used as a source address with any
default router. This is clearly not a good assumption 
for multi-interfaced (multihomed) nodes

Hesham