Subject: RE: The state of IPv6 multihoming development

From: "Tony Li" <[email-masked]>
Date: Tue, 22 Oct 2002 17:00:29 -0700

[ post by non-subscriber.  with the massive amount of spam, it is easy to
  miss and therefore delete mis-posts.  so fix subscription addresses! ]

Back when we were doing the CIDR work, we asked a bunch of
ISPs and they came back with about 10% of their customer
base being multihomed.  And typically, the second 
provider wasn't part of the sample, so that we felt that
about 10% of all enterprises were multihomed.

During the bubble, it looked like that number was increasing,
but post-bubble, I'd make the educated guess that it's 
back to 10%.  This may well increase as more enterprises
find that the net is mission critical to them.

A side point: another result that we got from CIDR is that
even at 10% of the enterprises being multihomed, that their
contribution to the DFZ tables would come to dominate the
size of the table and push us back into exponential growth
extremely quickly.  Or, another way of looking at it is
that when you have exponential growth, dividing the problem 
by 10 only gets you about one growth cycle of relief.  It
doesn't solve the issue entirely.

Will homes, academia and non-enterprises multihome?  Some
academic sites already are.  I know of some sick netgeeks
who are already multihomed.  All of it hangs in the balance
between the economic cost and the perception of mission 
critical importance.

Bottom line: we need a multihoming solution that allows
the DFZ table to scale reasonably even if everyone is multihomed.
Because that might happen and the net must continue to work.

Tony

p.s. In the past I have certainly been an opponent to IPv6.
However, my position has changed somewhat.  I can see the
pressure to go down the IPv6 path and I would like to see
some good come out of the exercise.  If v6 turns out to be
simply v4 with a bigger address space but it still collapses
due to the poor routing architecture, then we will have
failed miserably.  So I am pushing for scalability for the
routing layer and hoping that we don't make the same mistakes
again.  -- t

|   -----Original Message-----
|   From: Tim Chown [mailto:[email-masked]]
|   Sent: Tuesday, October 22, 2002 4:27 PM
|   To: Tony Li
|   Cc: Multi6 Working Group
|   Subject: Re: The state of IPv6 multihoming development
|   
|   
|   On Tue, Oct 22, 2002 at 04:08:56PM -0700, Tony Li wrote:
|   > 
|   > It's vitally important in the sense that if we deploy
|   > the wrong solution (or no solution), then we end up back
|   > on the exponential curve and it will be that much harder
|   > to change later because we would then have an installed
|   > base.
|   > 
|   > In other words, the sequence should not be: ready, fire, 
|   > aim.
|   > 
|   > ;-)
|   
|   OK, containment (of the DFZ table size) is certainly a good goal.
|   
|   But who is actually going to be multihoming with IPv6, and 
|   to what extent?
|   Perhaps there are now 50,000 large enterprises doing so 
|   with IPv4.  Is the
|   number of such enterprises going to rise?   What's the 
|   change in terms of
|   the types of sites multihoming that's pushing the DFZ size 
|   up so much?
|   Small ISPs?  Smaller enterprises?
|   
|   I'm just curious as to who the multihomers are, and best 
|   guesstimates of
|   future growth.   Do we foresee home users multihoming to 
|   multiple ISPs?
|   I don't pay for resilience now with two telephone lines, or 
|   having DSL and
|   cable lines; paying double isn't economic for Joe User.   
|   The same I assume 
|   would be true for mobile handsets.   Academia + home users 
|   + mobile (3G) users
|   is (or will be) a large chunk of the Internet;  all three 
|   can benefit from 
|   IPv6 now, or in the near future.
|   
|   The crux seems to be projected top limits on who will 
|   demand multihoming,
|   and what clas of users those people/sites are?   Of course, 
|   predicting 10
|   years ahead is a tad tricky :)
|   
|   Any pointers to research/stats on this would be interesting.
|   
|   Tim
|

---

From: "Craig A. Huegen" <[email-masked]>
Date: Tue, 22 Oct 2002 19:33:49 -0500 (Central Daylight Time)

> routing layer and hoping that we don't make the same mistakes

On the other hand, it can also be argued that we have failed miserably if
we don't end up with demand for this network because it cannot address
baseline requirements for business.  That's the path we head down with
multi-PA.

Noel asked if I could suggest any other mechanisms.  So far, all of the
multi-homing solutions I can think of that are implementable with current
code do not address the requirements that enterprises have:

* simple to implement and operate for the enterprise
* network infrastructure visibility into alternative paths such that
  policy decisions may be made on paths by the infrastructure, not the
  host
* unique, host-aware end-to-end addresses so poorly-written applications
  (in use in IPv4 today) will work

Given that, the only solutions I can think of require changes to code,
whether router or host, network or transport or application layer.  This
code change will require time.  This time delays adoption and makes IPv6
continue to stagnate.

I believe we need to come up with something now, with the current amount
of energy behind IPv6, in order to bring these large enterprises on board.
Otherwise, we will continue to build a great experimental network with
little business value to anyone except the academic community.

/cah

---
Craig A. Huegen, Chief Network Architect      C i s c o  S y s t e m s
IT Transport, Network Technology & Design           ||        ||
Cisco Systems, Inc., 400 East Tasman Drive          ||        ||
San Jose, CA  95134, (408) 526-8104                ||||      ||||
email: [email-masked]       CCIE #2100      ..:||||||:..:||||||:..

---

From: Randy Bush <[email-masked]>
Date: Tue, 22 Oct 2002 17:48:05 -0700

> little business value to anyone except the academic community.

this group is chartered to refine and explore solutions to the
problems of large-scale multihoming in ipv6.  it is not chartered
to do ipv6 marketing.  and, while it would be nice to use existing
code, that is not a constraint (and i suspect that, if it were,
this group would likely fail).

randy

---

From: Mark Smith <[email-masked]>
Date: 23 Oct 2002 12:14:23 +1000

> between the economic cost and the perception of mission 

I agree.

My house is already multi-homed for electricity supply - my conventional
phone has an independent power supply from my house.

I'm already multi-homed with my voice service itself - I have both a
sepearate fixed line and a mobile services.

While I'm not a netgeek yet with a multi-homed Internet connections,
when my Internet connection becomes as critical as my phone during
emergency situations, I'd all of a sudden become very interested in
multi-homing, likely via both land line and wireless.

As the critical infrastructure converges onto the Internet, I think
multi-homing is going to become far more common than what exists today,
to the point where the majority of connections may be multi-homed.

Mark.

---

From: "Christian de Larrinaga" <[email-masked]>
Date: Wed, 23 Oct 2002 11:05:10 +0100

> Behalf Of Craig A. Huegen

true for all users (not just *enterprises*)

Christian

---

From: Michael Richardson <[email-masked]>
Date: Wed, 23 Oct 2002 11:53:07 -0400

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Tony" == Tony Li <[email-masked]> writes:
    Tony> A side point: another result that we got from CIDR is that even at
    Tony> 10% of the enterprises being multihomed, that their contribution to
    Tony> the DFZ tables would come to dominate the size of the table and
    Tony> push us back into exponential growth extremely quickly.  Or,
    Tony> another way of looking at it is that when you have exponential
    Tony> growth, dividing the problem by 10 only gets you about one growth
    Tony> cycle of relief.  It doesn't solve the issue entirely.

  This is a useful thing to understand.

    Tony> Will homes, academia and non-enterprises multihome?  Some academic
    Tony> sites already are.  I know of some sick netgeeks who are already
    Tony> multihomed.  All of it hangs in the balance between the economic
    Tony> cost and the perception of mission critical importance.

  I know multiple homes and small business who have multiple network
connections because they don't want to be offline. They do not show up
as multihomed because they manage with a combination of NAT, source address
routing, use of explicit web proxies and educated guessing. 

  We have been down this road before. I though we were in agreement on 
two things:
    1) that multihoming would increase, 
    2) and that we can't do it like IPv4.
  
]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 25 Oct 2002 00:34:38 +0859 ()

Randy;

> this group would likely fail).

Just FYI, their is existing code running for end to end multihoming.

With 8+8 addressing, modification to TCP code was trivially easy.

							Masataka Ohta