Subject: RE: The state of IPv6 multihoming development

From: "Tony Li" <[email-masked]>
Date: Wed, 23 Oct 2002 12:49:26 -0700

|   I've still yet to see an idea here that provided complete 
|   multihoming
|   (i.e. ones that won't get filtered to uselessness) without 
|   either breaking
|   aggregation and exploding the DFZ or making transport level 
|   changes..

And you're not likely to see one soon either.  Look at the 
problem that we're trying to solve:

- Not exploding the DFZ requires hierarchical addressing.
- Being multihomed implies that there is a cycle in the
  graph, which implies that a node appears multiple 
  places in the hierarchy.
- No changes in the transport implies that once you start
  using an address, you MUST continue using it, thereby
  binding yourself to one path through the hierarchy.

Tunnelling tries to address this by maintaining the
hierarchy and virtualizing the topology.  Geographic
addressing declares the top of the graph to be 
hierarchical, but makes the lower layers non-hierarchical
and thereby pushes the explosion down, simply moving
the problem.

Something has to give, and IMHO, it had better be the
transport.

Tony

---

From: "Tony Hain" <[email-masked]>
Date: Wed, 23 Oct 2002 13:51:28 -0700

Tony Li wrote:
> ...  
> Geographic addressing declares the top of the graph to be 

The important missing point is that it not only moves the problem, it
segments it at the same time. This reduces the scaling issues at any
given point, but you are correct it does not eliminate them. 

Tony

---

From: Greg Maxwell <[email-masked]>
Date: Wed, 23 Oct 2002 16:58:05 -0400 (EDT)

> Something has to give, and IMHO, it had better be the

I believe that any tunnling purposal would be an incomplete solution  and
something of a hack. I really don't think that anyone is arguing that such
a solution is realistic due to it's inelegance. (anyone feel free
to correct me)

I condend that the requirements of no-transport-layer-mods and aggregation
are mutually exclusive and we need to drop one of them.. as soon as we
do: The answer becomes trivial.