Subject: RE: PI/metro/geo [Re: The state of IPv6 multihoming development]

From: "Michel Py" <[email-masked]>
Date: Mon, 28 Oct 2002 08:12:14 -0800

> J. Noel Chiappa wrote:
> Well, you usefully point out that all geographical proposals
> basically amount to the proposal to create exchanges! :-) 

Absolutely not.

Michel.

---

From: "Michel Py" <[email-masked]>
Date: Mon, 28 Oct 2002 08:22:09 -0800

> Brian E Carpenter
> The problem with this (and the reason I have serious
> doubts about Tony's PI proposal, and all geographical
> proposals going back at least to Bill Simpson's metro
> proposal years ago), is there is no economic reason to
> create such an exchange.

No disagreement here. We are talking about geo PI that does not require
exchanges.

Michel.

---

From: "Tony Li" <[email-masked]>
Date: Wed, 30 Oct 2002 23:49:57 -0800

|   > Are you suggesting that we disallow the globally visible route?
|   
|   In short: yes, that is what my provider-internal aggregation draft
|   suggests. However, since aggregation happens within individual ISP
|   networks they all get to choose whether they want to 
|   aggregate or not.
|   This uses regular BGP. A longer-term solution may be able 
|   to improve on
|   this, although I doubt having a few hundred million globally visible
|   routes will work well even with much smarter protocols.

Excellent, thank you this is the first step towards scalability.  Now
we only differ on the mechanisms.

Tony

---

From: "Tony Li" <[email-masked]>
Date: Thu, 31 Oct 2002 00:09:54 -0800

|   > But in many cases, there will be no
|   > such convenient boundary.  What do you do?  You cannot 
|   make an exception
|   > and flat route any enterprise that has such links, 
|   because then their
|   > overhead dominates the cost of all routing and you're not 
|   sufficiently
|   > scalable.
|   
|   If we require a solution (even a short-term one) to address 
|   this fully,
|   then yes, this is a problem. However, I think we can leave 
|   this problem
|   unsolved for now as there doesn't seem to be a good reason for an
|   organization to do this other than cost saving and we're not in the
|   business of making the internet a more expensive place for all to
|   accomodate savings for some.

News flash: we left this problem unsolved when we did CIDR for IPv4.
It's now an issue.  It needs to be addressed if IPv6 is to succceed.

Tony