Subject: RE: The state of IPv6 multihoming development

From: "Tony Li" <[email-masked]>
Date: Fri, 25 Oct 2002 00:07:12 -0700

|   > If an address of an end system is known, reverse and 
|   forward DNS look
|   > up gives all the addresses of the end system.
|   
|   As an enterprise network operator I do not have reasonable 
|   policy controls
|   when path selection is performed by the originating host's 
|   selection of
|   source and destination addresses from the system's set of 
|   source addresses
|   and the destination's set of DNS-registered addresses.
|   
|   DNS as a routing policy specification language seems 
|   inappropriate to me.

A fine way of architecting this would be to have the host request
routing preferences from the enterprise's border gateway.  Of
course, if the enterprise DNS server was colocated with the 
gateway, it could massage this as part of the response.

|   I can accept some interaction between the host and network 
|   infrastructure
|   in order to determine the best path to use to a 
|   multi-address destination
|   host; however, we still run into the support issues associated with
|   applying and maintaining several, multi-PA prefixes to tens 
|   of thousands
|   of subnets.

Would you feel this way if you could simply maintain the prefixes
in the border gateway?

Tony

---

From: "Craig A. Huegen" <[email-masked]>
Date: Fri, 25 Oct 2002 15:04:58 -0700 (PDT)

> Would you feel this way if you could simply maintain the prefixes

No.  The open concern then becomes that of applications that carry
addresses in the payload -- would border routers require a knowledge base
of applications to translate a la IPv4 NAT?

/cah

---
Craig A. Huegen, Chief Network Architect      C i s c o  S y s t e m s
IT Transport, Network Technology & Design           ||        ||
Cisco Systems, Inc., 400 East Tasman Drive          ||        ||
San Jose, CA  95134, (408) 526-8104                ||||      ||||
email: [email-masked]       CCIE #2100      ..:||||||:..:||||||:..