Subject: RE: questions about draft-wen-ipv6-rsra-opt-multihoming-00

From: Lawrence Zou <[email-masked]>
Date: Tue, 06 Jun 2006 15:08:53 +0800

sorry,I am confused by your draft.

in section 1 you mentioned the purpose of your idear is  "How to help
host implement 
   exit router selection and the associated prefix or address selection
"

in my understand ,
your prblem is the host have got several prefix or addresses from
different routers,when the host have some data to send to a destination,
it must choose a source address and a exit router. is that true?

for this purpose ,the host send RS with the multihome-option that carry
some information such as ISP name ,then  the corresponding exit router
response it  wiht  RA.

but  I think if the host have know which ISP it will got it's
service(explicit by ISP name),that also mean the host have already
selected one exit router and the corresponding source address.

maybe i have misunderstand the procedure.can you explain it more
explicit ? 

thanks 

Best regards

Lawrence

>-----Original Message-----
>From: CTO WEN Haibo [mailto:[email-masked]] 
>Sent: Tuesday, June 06, 2006 1:44 PM
>To: Lawrence Zou
>Cc: [email-masked]; [email-masked]
>Subject: RE: questions about draft-wen-ipv6-rsra-opt-multihoming-00
>
>
>hi Lawrence,
>
>I'm glad to receive your comments.
>
>I can explain to you one by one.
>
>1. The secnarios in the draft are using the ISP name 
>sub-option. It does not 
>mean that it's a "MUST" sub-option in the multi-homing 
>information option for 
>RS message (and other sub-option can be used if needed). Of 
>course, if we want to solve the problem described in the 
>charter of shim6 w.g., it is a "MUST" sub-option for RA 
>message. Without this information along with the Prefix 
>Information option, host doesn't know how to choose the 
>appropriate prefix and 
>the associated exit router. 
>I think multi-homing environment doesn't mean that some hosts 
>in a multi- home site just in the VLAN connected to a 
>specified ISP. All the hosts in the 
>multihome site have been connected to all the exit routers 
>that belongs to 
>different ISP. That is, the host can obtain all the periodical 
>RA messages from different routers. Our goal is to solve 
>prefix selection and exit router selection in this environment.
>
>2. First, that's just an example of how to use multi-homing 
>option in access network. It can also be used in LAN with 
>multiple exit routers. The layer2 access node I mean in this 
>example is not just a pure layer2 devices. It can snoop some 
>special layer3 packets, such as RS/RA messages, then it can 
>forward the RS to the correct router without flooding it to 
>other parts of 
>access netework. 
>If the access node doesn't have this ability, RS can be sent 
>to all routers, only the corresponding will respond this RS 
>message. This will not add any bad 
>impact.
>
>Thanks.
>
>Best regards,
>
>Haibo
>
>
>
>> -----Original Message-----
>> From: Lawrence Zou [mailto:[email-masked]]
>> Sent: 2006年6月6日 12:04
>> To: CTO WEN Haibo
>> Cc: [email-masked]
>> Subject: questions about draft-wen-ipv6-rsra-opt-multihoming-00
>> 
>> 
>> hi,wen:
>> 
>>      i have read you draft.  Although there are some strong 
>technical 
>> points in this document,  i still think there are some big problem:
>> 
>> 1. I noticed  that in all 3 Scenarios, the RS message must 
>include ISP 
>> name sub-option,so,is it a "MUST"  sub-optinon that be 
>include in the 
>> Multi-homing Information option? if it is true,what will it 
>happen if 
>> the host don't know the name of the ISP? I think in the Scenarios of 
>> stateless addres autoconfigue, it is not necessary for host to know 
>> the topology of the network and the name of the ISP.
>> in your draft ,all hosts know clearly which ISP they belong 
>> to ,I think
>> we can distinguish them using some kinds of  VLAN techonoly.
>> 
>> 2.In Scenario 3,you mention the equipment of "layer2 CPE 
>".so what the 
>> difference is that with "layer3 CPE "? In my understand ,the layer2 
>> CPE is a layer2 equipmnet ,so in the section 3.3
>>    Step (b) : Base on the information in Multi-homing 
>> Information option
>>               , layer 2 access node can forward this RS to 
>the correct
>>               edge router of the desired ISP without sending 
>> it to the 
>>               router that will not respond this RS.	
>> 
>>  can layer2 equipment do this kind of thing?	
>>   
>> 
>> 
>> 
>

---

From: Lawrence Zou <[email-masked]>
Date: Tue, 06 Jun 2006 17:32:58 +0800

>Sent: Tuesday, June 06, 2006 4:54 PM
>To: Lawrence Zou
>Lawrence,
>In current IPv6 multihoming site, each hosts in this site can 
>have multiple prefixes from different exit routers. It cannot 
>identify which ISP assignes 
>the exact prefix, because there is no extra information in 
>prefix information option.
>
>The multi-homing information defined in this draft is used 
>along with prefix information option. It will provide extra 
>information for host to do selection. Host only selects the 
>prefix from the desired ISP to form its IPv6 address, of 
>course, the corresponding exit router will be cached. Other 
>prefixes from other routers will not be used to form IP 
>address. For example, STB may only want services from IPTV 
>service provider. Other prefixes from other service providers 
>are useless for itself.

yes,i think you point out the most important thing:the host only form IP
adress it will use it .
so i guess that:
1)ISP1 and ISP2 send RA with prefix information and multi-homing
information.
2)if host can decide whitch ISP it will select,for example ,it select
ISP1,the host will form address with
 the prefix in the RA of ISP1 and ignore  the RA of ISP2.

>
>Host knows which ISP it will got its service, and it also 
>knows its exit router is the edge router of the desired ISP. 
>But it doesn't know the network topology, it doesn't know the 
>exact exit router either, unless multi-homing informaiton 
>option is used along the prefix information option.

i do not agree with this point of "Host knows which ISP it will got its
service" in the scenario 
of  stateless address auto-configure,in the SAAC,we should assume that
No manual configuration 
of individual machines  before connecting them to the network, but if
you do not do some manual configuration,
how can you know which ISP the host will got its service?One available
method the host can do this is it ask "who
can provide the service of......?" and if someone  anwer it "i can do it
",then the host select this ISP.
>> Sent: 2006年6月6日 15:09
>> different routers,when the host have some data to send to a 
>> destination, it must choose a source address and a exit router. is 
>> that true?
>>

---

From: Lawrence Zou <[email-masked]>
Date: Wed, 07 Jun 2006 11:18:39 +0800

I am not sure the topic  in your document is in the domain of  shim6,in
fact ,I think it will be bettter to discuss in IPV6 WG because you want
to add option in RS/RA message.

>Sent: Wednesday, June 07, 2006 9:34 AM
>To: Kurt Erik Lindqvist; Lawrence Zou
>Cc: [email-masked]
>Kurtis,
>Thank you for your reminder.
>I have subscribed the shim6 WG, and also forwarded the 
>discussion in that group.
>
>Lawrence, maybe you should subscribe shim6 WG, too.
>
>Best regards,
>
>-Haibo
>
>
>> From: Kurt Erik Lindqvist [mailto:[email-masked]]
>> Sent: 2006年6月7日 08:50
>> To: Lawrence Zou
>> Cc: CTO WEN Haibo; [email-masked]
>> Subject: Re: questions about draft-wen-ipv6-rsra-opt-multihoming-00
>> 
>> 
>> 
>> 
>> I'd like to point out that the multi6 WG has completed it's work and
>> should be closed down - and as soon as that happens I will 
>> close this  
>> mailinglist.
>> 
>> - kurtis -
>> 
>> On 6 jun 2006, at 06.04, Lawrence Zou wrote:
>> 
>> > hi,wen:
>> >
>> > in your draft ,all hosts know clearly which ISP they belong to ,I
>> > think
>> > CPE
>> > is a layer2 equipmnet ,so in the section 3.3
>> >    Step (b) : Base on the information in Multi-homing Information
>> > option
>> >               edge router of the desired ISP without
>> sending it to the