Subject: (NAT) Information about SMTP

From: "Raffaele Pellicciotta" <[email-masked]>
Date: Tue, 29 Feb 2000 16:40:35 +0100

Hi, I desire to know what happens when I send a normal e-mail from a
mail-server ( in a private LAN with private ip addresses)
    to public Internet!!! And what happens when I send a normal e-mail from
a mail-server ( in a private LAN with private ip addresses)
    to public Internet through a NAT router!!!
    Thanks a lot,
            Raffaele Pellicciotta

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: [email-masked]
Date: Tue, 29 Feb 2000 08:36:14 -0800

SMTP (e-mail) is an application level protocol, and
is independent of the network layer. This means that
address translation issues have no impact on SMTP.
If the User Agent (client mail program) can connect
and communicate to the SMTP (mail server) then the
email transfer will work. Establishing the connection
is done at the network layer (TCP/IP), where the address
translation issues are involved. If the connection
cannot be made, then email applications (client and server)
cannot communicate, and the email transfer will not
occur.

Hope this answers your question.

George Mattathil

Note: The preceding Email took 23 Min, 12 Sec.
from the time you sent to the time it reached my system.

"Raffaele Pellicciotta" <[email-masked]>
Sent by: [email-masked]
02/29/00 07:40 AM
Please respond to "Raffaele Pellicciotta"

        To:     <[email-masked]>
        cc: 
        Subject:        (NAT) Information about SMTP
Hi, I desire to know what happens when I send a normal e-mail from a
mail-server ( in a private LAN with private ip addresses)
    to public Internet!!! And what happens when I send a normal e-mail 
from
a mail-server ( in a private LAN with private ip addresses)
    to public Internet through a NAT router!!!
    Thanks a lot,
            Raffaele Pellicciotta

-

-

---

From: [email-masked]
Date: Tue, 29 Feb 2000 10:56:24 -0800

CMIP and SNMP are also application level
(network management) protocols. So the issues
at the basic level are the same as that of SMTP.

Original intention of the private addresses was
that there would no need for them to communicate
with "public" address nodes. So the need for
"private" and "public" address nodes to communicate
creates a new situation.

From a protocol perspective, the address issues
(for transport and connectivity) need to be
preserved at the network/transport layers.
But the CMIP/SNMP application needs creates
another dimension to the problem.

In my view, the CMIP/SNMP applications should
preserve the original attributes of private and
public addresses. Because changing those attributes
can have unintended and/or unforeseen consequences.
This reduces the issue in question to how to
develop inter-operability between CMIP/SNMP
nodes with private and public addresses.
My suggestion is to implement a CMIP/SNMP
adapter agent to make the appropriate
transformations on the CMIP/SNMP user data. In
this way all the application level requirements
on the CMIP/SNMP protocol data will be localized
to the CMIP/SNMP adapter agent.
[Disclaimer: What I have expressed is my view on
this issue, without considering any other
approaches that may exist out there :-)]

Hope this helps.

George Mattathil
408 255 9800
"silicom.com - the digital ecosystem"

Note: The preceding Email took 33 Min, 1 Sec.
from the time you sent to the time it reached my system.

Lucy Yang <[email-masked]>
02/29/00 09:07 AM

        To:     [email-masked], Raffaele Pellicciotta <[email-masked]>
        cc:     [email-masked], [email-masked]
        Subject:        Re: (NAT) Information about SMTP

Could you please also help me to figure out
how 'NAT' (ALG) will support CMIP (and SNMP)
applications since the addressing information 
may be inbedded within the user data portion 
which may not be looked at by traditional NAT.

Thanks.

Lucy Yang

>     to public Internet through a NAT router!!!
=====
Lucy Yang
Sr. Software Engineer
Motorola
847-435-0744
Email: [email-masked]
__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

-