Subject: [Nea] WGLC Comments on PT-TLS

From: Stephen Hanna <[email-masked]>
Date: Tue, 13 Mar 2012 16:34:45 -0400

I have a few minor comments on the latest version of PT-TLS
(draft-ietf-nea-pt-tls-02.txt).

Overall, I think this document is quite solid and ready to
go to the IESG. If you agree (or if you don't), please
respond to the WGLC. Short responses are fine.

* In section 3.1.1, the sentence that starts with "This means
  the NEA Client" is repeated.

* In section 3.4.2, "Set-up" should be "Setup" and "protect
  again" should be "protect against".

* In section 3.6 under SASL Mechanisms, what is the meaning
  of the phrase "at another time"? Other than what? Is this
  message only supposed to be sent at a particular time?
  If so, we should say that somewhere. If not, we should
  probably remove the requirement for the NEA Client to
  send an Invalid Message error code in this circumstance.

Thanks,

Steve

---

From: Carolin Latze <[email-masked]>
Date: Sun, 25 Mar 2012 23:15:48 +0200

few minor comments from my side:

- Introduction: Same as with PT-EAP: it is mentioned that there is 
another PT protocol. Maybe it makes sense to reference PT-EAP here?
- Section 3.4.1: new (empty) line missing before first point
- Section 3.4.2: same
- Section 3.5, Message Identifier: "This value can be copied into the 
body of a response message to indicate which message was received and 
caused the response" -> can or SHOULD? I'd prefer a "SHOULD" in order to 
make people implement it as a useful feature. Or was there a reason 
behind the "can"?

Regards
Carolin

On 03/13/2012 09:34 PM, Stephen Hanna wrote:
> _______________________________________________
> Nea mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nea
>