Subject: [Nea] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-nea-pt-tls-07

From: IETF Secretariat <[email-masked]>
Date: Thu, 04 Oct 2012 14:44:51 -0700

Dear Paul Sangster, Nancy Cam-Winget, Joseph A. Salowey:

 An IPR disclosure that pertains to your Internet-Draft entitled "PT-TLS: A TCP-
based Posture Transport (PT) Protocol" (draft-ietf-nea-pt-tls) was submitted to
the IETF Secretariat on 2012-10-04 and has been posted on the "IETF Page of
Intellectual Property Rights Disclosures"
(https://datatracker.ietf.org/ipr/1890/). The title of the IPR disclosure is
"Cisco's Statement of IPR Related to draft-ietf-nea-pt-tls-07."");

The IETF Secretariat

---

From: Stephen Hanna <[email-masked]>
Date: Fri, 5 Oct 2012 00:23:14 -0400

IETF Secretariat wrote:
> An IPR disclosure that pertains to your Internet-Draft entitled
> "PT-TLS: A TCP-based Posture Transport (PT) Protocol"
> (draft-ietf-nea-pt-tls) was submitted to the IETF Secretariat
> on 2012-10-04

Well, that's a pain in the neck! I'm not happy to see these
IPR disclosures come in so late in the process. PT-TLS is
already with the IESG and PT-EAP has passed two WGLCs and
is almost ready to go to the IESG. This IPR should have
been disclosed much earlier, if at all possible.

At this time, I would encourage nea participants to read
(or re-read) RFC 3979, which describes how we handle IPR
disclosures in IETF. Also read the IPR disclosures to see
what's included in the patents in question and what IPR
licensing terms are being offered.

I would ask Cisco to please provide a link to the actual
patent application (since I guess there is no patent yet
and I can't find the patent application) so that we can
see what technology is claimed to be covered.

Thanks,

Steve

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> IETF Secretariat
> Sent: Thursday, October 04, 2012 5:45 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Nea] IPR Disclosure: Cisco's Statement of IPR Related to
> draft-ietf-nea-pt-tls-07
> 
> 
> _______________________________________________
> Nea mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nea

---

From: tglassey <[email-masked]>
Date: Fri, 05 Oct 2012 07:22:46 -0700

On 10/4/2012 9:23 PM, Stephen Hanna wrote:
> Well, that's a pain in the neck!
Actually its much more than that. Its why full disclosure at the start 
of a process of who the parties legally represent and what their 
interests in the standard process are so that full disclosure is there.

But fixing this process is actually VERY SIMPLE... Just a 'component of 
an updated BCP which contractually commits that IETF members and their 
sponsors may not engage in submarining' its actually pretty simple to 
stop this... you folks just have to want to.

The propose text could look something like:

   " Whereas - all parties working in the IETF have an open 
collaboration agreement, it is agreed that any Intellectual Properties 
developed by a commercial sponsor to the IETF will have full disclosure 
of their licensing provisions prior to any development taking place in 
the IETF and that those rights must be properly disclosed to all parties 
in the interest of open collaboration and global standards development."

     "Further any party formally participating or supplying IP to these 
initiative waves any rights to change those access rights and disclosure 
requirements by participating in the process after the development 
commences on any initiative".

Todd
> I'm not happy to see these
> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2013.0.2677 / Virus Database: 2591/5808 - Release Date: 10/03/12
>
>

-- 
Regards TSG
"Ex-Cruce-Leo"

//Confidential Mailing - Please destroy this if you are not the intended recipient.

---

From: Stephen Hanna <[email-masked]>
Date: Mon, 8 Oct 2012 20:48:47 -0400

I have been told that we're not likely to get any more
information about the patent application named in Cisco's
IPR disclosure related to NEA so...

We must now decide how to proceed with PT-TLS and PT-EAP.

Since you have read RFC 3979, you will know that it is not
our job to comment on the validity of the IPR or of the
licensing terms. We're not lawyers. Arguing about patent
law is a waste of time for us.

Instead, the real question for us is:

* Should we proceed with standardizing PT-TLS and PT-EAP
  in their current form (subject to the normal edits that
  will be made during the standardization process)?

Please respond to this email with your opinions on this
question. Feel free to include your arguments pro or con.

Due to the complexity of this matter, I will allow two
weeks for this consensus check. Therefore, please respond
by Monday, October 22 at 9 PM EDT. At that time, I'll
declare a consensus if there is one.

Thanks,

Steve

---

From: tglassey <[email-masked]>
Date: Mon, 08 Oct 2012 21:19:10 -0700

> We must now decide how to proceed with PT-TLS and PT-EAP.
Try this one...  published 9/28/2012.

http://patft.uspto.gov/netacgi/nph-Parser?Sect1=PTO2&Sect2=HITOFF&u=%2Fnetahtml%2FPTO%2Fsearch-adv.htm&r=2&f=G&l=50&d=PTXT&p=1&p=1&S1=cisco&OS=cisco&RS=cisco

> Version: 2013.0.2677 / Virus Database: 2591/5817 - Release Date: 10/08/12
>
>

-- 
Regards TSG
"Ex-Cruce-Leo"

---

From: tglassey <[email-masked]>
Date: Mon, 08 Oct 2012 21:21:04 -0700

> We must now decide how to proceed with PT-TLS and PT-EAP.

oops - posturing...

http://patft.uspto.gov/netacgi/nph-Parser?Sect1=PTO2&Sect2=HITOFF&u=%2Fnetahtml%2FPTO%2Fsearch-adv.htm&r=1&f=G&l=50&d=PTXT&p=1&p=1&S1=cisco&OS=cisco&RS=cisco

-- 
Regards TSG
"Ex-Cruce-Leo"

---

From: Stephen Hanna <[email-masked]>
Date: Tue, 9 Oct 2012 04:45:49 -0400

Todd,

While I appreciate your attempts to help, I have it on good
authority that none of the links that you have sent are links
to the IPR in question and that this IPR is not on the web.

All WG members, please do not post any more possible links
to the IPR in question. If you find something like this and
feel that you must report it, send it to me. I'll investigate.

Believe me, I would love to find a public link to the IPR.
However, I have been convinced that this is not possible,
at least for some rather extended period of time. Therefore,
we must make our decision without having access to the IPR.
We do have access to the licensing terms, which are at

https://datatracker.ietf.org/ipr/1889/
https://datatracker.ietf.org/ipr/1890/

Please review these licensing terms and use that information

> >    will be made during the standardization process)?

Thanks for your help in reaching consensus on this important
matter. Our customers and employers are counting on us to
make the right decision.

BTW, I am going to remain publicly neutral on this matter
so that we can have an impartial Working Group chair to
judge consensus and handle process issues.

Thanks,

Steve

> tglassey
> Sent: Tuesday, October 09, 2012 12:21 AM
> To: [email-masked]
> Subject: Re: [Nea] Deciding How to Proceed with NEA Drafts -
> 
> http://patft.uspto.gov/netacgi/nph-
> Parser?Sect1=PTO2&Sect2=HITOFF&u=%2Fnetahtml%2FPTO%2Fsearch-
> adv.htm&r=1&f=G&l=50&d=PTXT&p=1&p=1&S1=cisco&OS=cisco&RS=cisco
> >

---

From: Alan DeKok <[email-masked]>
Date: Tue, 09 Oct 2012 09:26:14 -0400

>   will be made during the standardization process)?

  One question I would have is can we avoid the IPR by changing PT-TLS
and PT-EAP.  Since we don't know what the IPR is, however, that's
impossible to answer.

> question. Feel free to include your arguments pro or con.

  The terms seem reasonable, though I'm not a lawyer.  I'm OK with
proceeding as-is.

  Alan DeKok.

---

From: tglassey <[email-masked]>
Date: Tue, 09 Oct 2012 06:46:29 -0700

> to the IPR in question and that this IPR is not on the web.
My apologies for the bad link...
> https://datatracker.ietf.org/ipr/1890/
I dont think you can make this decision. I think NEA is dead... or you 
can formally embrace commercial standards and its pretty simple. You 
folks told me for years you would not support commercial standards 
practices where a company asked for a commercial standard to be created. 
Here you are faced with one of those.

I actually think this is the one - the instance where you have to come 
to grips with the real issues here - i.e. whether formal membership is 
necessary and a disclosure process about every participants goals and 
actions in a standard practice effort before the other parties 
contribute IP to what they believe is an open access program which turns 
out to be a patent fiasco.n

I actually applaud Cisco's IPR statement on this perhaps it will force 
clarification of the GSO and its transparency requirements finally. 
Otherwise - rather than killing NEA I suggest you continue and give Big 
C the patented Standard they want.

Todd

-- 
Regards TSG
"Ex-Cruce-Leo"

---

From: Ira McDonald <[email-masked]>
Date: Tue, 9 Oct 2012 20:50:54 -0400

Hi NEA folks,

Speaking as a non-lawyer, the licensing terms are apparently
reasonable (whatever the IPR involves).

I favor proceeding with the IETF standardization of PT-TLS
and PT-EAP.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434
Temporary Cabin *** 2012 only *** 906-494-2523

---

From: <[email-masked]>
Date: Tue, 9 Oct 2012 20:04:34 -0500

+1

Kent Landfield

McAfee | An Intel Company
Direct: +1.972.963.7096
Mobile: +1.817.637.8026
Web: www.mcafee.com<http://www.mcafee.com/>

From: Ira McDonald <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 9, 2012 7:50 PM
To: Stephen Hanna <[email-masked]<mailto:[email-masked]>>, Ira McDonald <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Nea] Deciding How to Proceed with NEA Drafts

Hi NEA folks,

Cheers,
- Ira

mailto:[email-masked]<mailto:[email-masked]>

On Mon, Oct 8, 2012 at 8:48 PM, Stephen Hanna <[email-masked]<mailto:[email-masked]>> wrote:
I have been told that we're not likely to get any more
information about the patent application named in Cisco's
IPR disclosure related to NEA so...

Thanks,

Steve

_______________________________________________
Nea mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nea

---

From: Randy Turner <[email-masked]>
Date: Wed, 10 Oct 2012 01:49:05 -0700

Hi All,

My interpretation of the IPR statement issued by Cisco, in effect, offers two options:

1.  You can use the technology claimed by their patent application in products, royalty-free, as long as you give up all rights to assert ANY patent claim against Cisco, or it's products.  (this is essentially a "patent-kill" option, which would, in theory, grant Cisco the right to use any of your patented technology in products as long as you choose this option #1 to include their claims on PT-TLS in your products.  You're basically agreeing to waive your patent rights if you choose the royalty-free option.)

OR

2.  You can go the royalty option if you decide to ship products based on technology claimed by the patent application

As long as the terms of option #2 are offered in a non-discriminatory fashion to interested parties, I'm assuming this meets the overall spirit of RFC 3979.

I think the WG would agree, that at this point in the process, we would like to see the PT-TLS work advance -- and that any IPR statement asserted against our PT-EAP draft would have to be quite onerous for us to decide otherwise.

If a non-discriminatory policy towards option #2 is available, then I would say the burden of the IPR statement is probably not sufficient to rethink our PT-TLS document.

Randy

---

From: "Carolin Latze" <[email-masked]>
Date: Mon, 22 Oct 2012 13:46:09 +0200 (CEST)

Hi Steve

here are my thoughts:

Out of the IPR disclosures

"Cisco retains the right to assert its patents against any product or
portion thereof that is not necessary for compliance with the standard."

--> I am no lawyer and I have no experience with this, but this sentence
frightens me a bit. If someone has a cool idea that makes use of the RFC
but adds something on top, he might run into troubles with Cisco? The NEA
technologies are great to enable other applications and I somehow fear
that this IPR disclosures might block those. What is the general
experience with statements like this inside the IETF?

The IPR statements relate to specific versions of the I-Ds. My question
is: Can we use an older version (that might have written before the two
different drafts for each of PT-EAP and PT-TLS merged) and progress those
without risking an IPR again? If so, that might be a better way. If not,
well, let's move on as-is.

Regards
Carolin

---

From: Stephen Hanna <[email-masked]>
Date: Mon, 22 Oct 2012 14:58:13 +0000

Carolin,

I'll try to answer some of the questions that you posed below.
Note that I am not a lawyer but only a technical expert and
an experienced IETF participant.

> What is the general experience with statements like this
> inside the IETF?

Cisco's IPR statement (including the part quoted above) is
similar to many others that are provided by IETF participants.

> The IPR statements relate to specific versions of the I-Ds.
> My question is: Can we use an older version (that might have
> written before the two different drafts for each of PT-EAP
> and PT-TLS merged) and progress those without risking an IPR
> again? If so, that might be a better way. If not, well, let's
> move on as-is.

I don't think we have a clear answer to this since we haven't
seen the patent application in question and we haven't received
any statement from Cisco regarding earlier versions of the PT
drafts. The absence of a statement from Cisco on those earlier
drafts does not mean that the earlier drafts would have been
clear of this IPR. I don't think we have any hard information
on this topic. Personally, I doubt that the relatively small
changes that have been made to the drafts since they were
originally submitted would be likely to affect the applicability
of the IPR claimed by Cisco. But we just don't know, at this point.
The earlier drafts might be affected or they might not.

Thanks for your review and comments,

Steve

> Carolin Latze
> Sent: Monday, October 22, 2012 7:46 AM
> To: Stephen Hanna
> Cc: [email-masked]

---

From: Stephen Hanna <[email-masked]>
Date: Tue, 23 Oct 2012 02:27:31 +0000

Thanks to all who participated in this consensus check.
The discussions have been quite helpful.

As a nea co-chair, I declare that there is a clear consensus
in the Working Group in favor of proceeding with the process
of standardizing PT-TLS and PT-EAP in their current form,
even though there is now an IPR declaration from Cisco
pertaining to them.

Therefore, I request that our AD and spec editors move
these documents forward with all appropriate speed.

Thanks,

Steve

> From: Stephen Hanna
> Sent: Monday, October 08, 2012 8:49 PM
> To: [email-masked]
> Subject: Deciding How to Proceed with NEA Drafts
>