Subject: RE: [nemo] Aeronautics Requirements

From: "EXT-Harkness, Duane" <[email-masked]>
Date: Tue, 18 Feb 2003 15:30:51 -0800

Stuart and Will,

I think you will find considerable support from members the aviation community for a sub group focused on aeronautical requirements for NEMO. I am particularly interested in the application of NEMO for the Aeronautical Telecommunications Network (ATN). As you know, the current ICAO Standards and Recommended Practices (SARPs) for ATN are derived from OSI protocols. While no one questions the need for ATN, as Will points out numerous organizations are actively investigating how IP might supplement or even provide an alternative to OSI in meeting the goals of ATN.

IMHO, the most challenging ATN requirements are network mobility, multi-homing, policy-based routing and ultra-high availability. The current ATN solution is based in part on hierarchical OSI addressing, CLNP security labels and IDRP routing policy. Any IP solution must provide analogous capabilities and NEMO seems like the right place to start for network mobility. 

I'd be more than happy to participate in an aeronautical requirements sub-group. Let me know how I can help get this started.

Duane Harkness
Senior Network Engineer
Avaliant, LLC
On contract to Boeing Air Traffic Management

Disclaimer: This message is for technical discussion purposes only. It does not represent the official position of the Boeing Company.

-----Original Message-----
From: Stuart W. Card [mailto:[email-masked]]
Sent: Monday, February 17, 2003 10:24 PM
To: [email-masked]
Subject: Re: [nemo] Aeronautics Requirements

At 09:03 AM 2/18/2003 +1100, Greg Daley wrote:

>... ITS is a way of using computation systems
>to provide information about vehicular
>traffic flow, origin-destination path
>statistics and monitoring of unusual/emergency
>traffic events.
>
>I think that ITS is a broad field...
>
>If we have a list of interested parties/documents...

I would be happy to participate in a sub-group focused
on aeronautics (in my case, Air Force) requirements for
NEMO.  I agree there are some oddities that come up here
more frequently than elsewhere: for instance, multiple
radio link technologies with _very_ different characteristics
(VHF LOS only when near airports, UHF SATCOM everywhere but
with 250 mS single-hop speed of light lag, etc.).  This is
in addition to traffic profiles (at least for the most
essential traffic) very different from standard Internet
access.  Etc.

Stuart W. Card, Chief Scientist & VP, Critical Technologies Inc.
Mohawk Valley Engineers Executive Council 2002 Company of the Year!
Suite 400 Technology Center, 4th Floor 1001 Broad St, Utica NY 13501
315-793-0248 x141 FAX -9710 <[email-masked]> www.critical.com

---

From: "EXT-Harkness, Duane" <[email-masked]>
Date: Tue, 18 Feb 2003 17:31:55 -0800

Alexandru Petrescu wrote:
>> On the other hand, Mobile IP has been designed to permit the use of
>>  a single mobile network at any one time with “make before break” 
>> transition between mobile networks.
>
>I understand the first occurence of the word mobile network, but not
>the second.  Maybe, the second occurence is a confusion: for example
>the word "mobile network" is in wide use in the telecom community to
>stand for a fixed network that supports mobile terminals moving around
>that fixed network.  Is this the intended meaning?

I believe ICAO uses "mobile subnetwork" in the broader sense. The ATN SARPs define it as:

"A subnetwork connecting a mobile system with another system not resident in the same mobile platform. These subnetworks tend to use free-radiating media (e.g. VHF/UHF radio, D band satellite or D band secondary surveillance radar) rather than contained media (e.g. wire or coaxial cable); thus they exhibit broadcast capabilities in the truest sense."

Duane Harkness
Senior Network Engineer
Avaliant, LLC

---

From: "EXT-Harkness, Duane" <[email-masked]>
Date: Tue, 18 Feb 2003 18:57:29 -0800

> >>At this point 
> >>we are investigating various options to satisfy ICAO
> >>  mobility requirements. Some of these options are:
> >>       Incorporate IDRP mobility in IP based networks
> >
> >William, why suggesting IDRP, is this the Inter-Domain Routing
> >Protocol (somehow equivalent to BGP)?
> 
> 
> This is the suggestion of a small group in the aeronautics 
> community.  I have not studied the details of how they may
> want to use IDRP with mobile networks.

In ATN, the aircraft networks and the ground service provider networks are treated as seperate and distinct routing domains. The airborne MR and the AR on the ground each function as an OSI Boundary Intermediate System (BIS). When the MR connects to the AR over a wireless air-to-ground link, an IDRP session is established and routing information is exchanged. Network mobility is achieved by a combination of structured addressing (mobile network prefixes are distinct from fixed network prefixes), a hierarchical routing architecture consisting of routing 'islands', enhanced IDRP route propagation and the extensive use of default routes.

Since IDRP is functionally similar to BGP, Chris Wargo has suggested [see RFC 3002] that it might be possible to duplicate the ATN mobility scheme directly in IP using BGP. I'm not sure how this might fit into a NEMO-based solution, but it's certainly an intersting idea.

Question: Has the issue of mobile autonomous systems been discussed yet?

Duane Harkness
Senior Network Engineer
Avaliant, LLC