Subject: RE: [nemo] about draft-ietf-nemo-requirements-00.txt

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 26 Mar 2003 17:38:35 +0100

> > => What if the two MRs cooperate by forwarding traffic to
  > > the appropriate MR based on src address filtering?
  > > 
  > > A MR can look at the src address of the packet and see
  > > whether it belongs to its Home prefix or another one. 
  > > If it belongs to "another" prefix, it can forward the packet
  > > to the corresponding MR. 
  > 
  > What happens when one of the MRs, or the MR to HA tunnel, fails?
  > Since one of the claimed benefits (perhaps the main one?) 
  > of multihoming is 
  > redundancy this requires consideration.

=> Sure, but I was aiming at a smaller step, i.e. making this 
configuration work. 
My main concern was to accomodate the case where the two
MRs belong to different HAs/ISPs/domains ...etc so that
ingress filtering in the home network cannot be coordinated. 
In this case the benefit of multihoming is not redundancy, 
but potentially because the two MRs can provide different 
access characteristics (cellular, WLAN ...etc). They may also
provide the same access but more than one happened to be available.
I.e. load sharing on the MRs' egress interfaces. 

I think poviding redundancy in this case is fine could 
be a good "next step" IMHO.

Hesham

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 28 Mar 2003 10:10:52 +0100 (CET)

> I.e. load sharing on the MRs' egress interfaces. 

OK. In that case you end up with the "uncoordinated site multihoming"
problem. Solutions have been proposed in that context (in the ipv6mh
discussions and perhaps in multi6 as well).
It wouldn't hurt to have some Nemo document covering multihoming to state
the issue/problem, but I'm assuming that solutions (that are not
Nemo specific) will be developped elsewhere so no need to touch on solutions
in a Nemo document I think.

  Erik