Subject: Re: [nemo] New draft on multihoming scenarios

From: Takeshi TANAKA <[email-masked]>
Date: Thu, 06 Mar 2003 14:18:18 +0900

On 27 Feb 2003 10:34:58 +0800 
Chan-Wah Ng <[email-masked]> wrote :

> http://www.psl.com.sg/draft-ng-nemo-multihoming-issues-00.txt
> 
> This draft first describe various different configuration of multihomed
> mobile network, and some deployment examples.  Next, we identify issues
> that arise in supporting multihomed mobile network, and discusses some
> possible approaches to facilitate multi-homing.  
> 
> The objective of this document is to precipitate discussions in the
> working group in issues regarding multihoming in NEMO.  Hence all
> comments and inputs are welcomed and greatly appreciated.

This draft describes 3 scenarios of multihomed NEMO;
- a MR with multiple egress interfaces bound to a single HA
- a MR with multiple egress interfaces bound to different HAs
- multiple MRs bound to different HAs
We are missing the scenario where multiple MRs bound to a single HA
which is described in draft-wakikawa-nemo-basic-00.txt

These scenarios are based on the term draft;
>   Multihomed Mobile Network
>       From 3.4.1, a mobile network is multihomed when either:
>          - a MR has multiple egress interfaces on the same link, or
>          - a MR has multiple egress interfaces on distinct link, or
>          - there are more than one MR in the mobile network
But does the second condition means 'multiple egress interfaces bound to
distinct home link' ?

Thanks,
Takeshi

---

From: Thierry Ernst <[email-masked]>
Date: Mon, 10 Mar 2003 17:17:23 +0900 (JST)

Hi,

Thanks for posting this draft. I didn't have time to comment yet, but
it is interesting work put on the table. 

> But does the second condition means 'multiple egress interfaces bound to

I think we never assumed anything (so far), so it could be either
cases. May be you need to consider the two cases differently in your
draft ? 

Thierry

---

From: Takeshi TANAKA <[email-masked]>
Date: Mon, 10 Mar 2003 18:54:52 +0900

On Mon, 10 Mar 2003 17:17:23 +0900 (JST) 

> cases. May be you need to consider the two cases differently in your
Ok, that is my misunderstanding.
The second requirements means the case like this, doesn't it?;

   ||
   MR1
   |
---+-?--
     |    ||
     R    MR2
     |     |
   --?-----?--

Actually, we didn't consider the case explicitly.

The possible solution in the draft can provide MR1 alterative route if
MR2 can obtain an address from MR1, but it is main point for the draft
to provide a solution.

Thank you for comments!

-----------------------------------------------
 Takeshi TANAKA
 R&D center, Corporate Engineering Division, 
 Panasonic Mobile Communications
 e-mail: [email-masked]
 phone: +81-46-840-5494 / fax: +81-46-840-5222
-----------------------------------------------