Subject: RE: [nemo] about draft-ietf-nemo-requirements-00.txt

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 19 Mar 2003 18:12:09 +0100

> 
  > But the fact that you use "A" and "B" instead of "C" and "D"
  > is confusing.
  > So let me try to generalize what I think is your "mobile 
  > site multihoming"
  > configuration.
  > 
  > There are two mobile routers: MR_A and MR_B
  > They have separate home agents (HA_A and HA_B) that belong 
  > to two different
  > sites (A/48 and B/48 for example).
  > 
  > As a result of this the mobile network has two prefixes: 
  > A:x/64 and B:y/64.
  > 
  > The MRs attach either to the same ISP or different ISP. For 
  > maximum expansion
  > assume they are different. Thus the CoA for the MRs is C:1 and D:1
  > respectively.
  > 
  > 
  > The first concern in this type of setup is how does routing 
  > work for the
  > LMNs - is there or is there not an assumption that the MR selection
  > (the 1st hop default router the LMNs use) needs to be tied to the
  > source address they use or not?
  > 
  > Thus would it work if the LMN sends a packet with source 
  > A:x:987 to first hop
  > router MR_B?
  > 
  > In the IPv4 and IPv6 models of a host the source address selection
  > is a function of what interface the host is sending on, but 
  > not which
  > 1st hop router it is using.
  > So unless folks are proposing to change this the host 
  > should be able to
  > use source A:x:987 while using router MR_B.
  > Making this work requires some coordination between site A 
  > and B (to accept
  > either source address). This is part of the general *site* 
  > multihoming issues
  > when each host gets an address from each site's prefix.
  > But the point is assuming independence between site A and B 
  > (and indirectly
  > the HAs and MRs) is a non-starter.

=> What if the two MRs cooperate by forwarding traffic to
the appropriate MR based on src address filtering?

A MR can look at the src address of the packet and see
whether it belongs to its Home prefix or another one. 
If it belongs to "another" prefix, it can forward the packet
to the corresponding MR. 

Obviously this means that MRs will need to check other
MRs RAs, which is not difficult. 

I can't see any security issues specific to nemo
here (i.e. other than known ND threats). 

Is this handwaving a starter :) ?

Hesham

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 19 Mar 2003 21:56:36 +0100 (CET)

> If it belongs to "another" prefix, it can forward the packet

What happens when one of the MRs, or the MR to HA tunnel, fails?
Since one of the claimed benefits (perhaps the main one?) of multihoming is 
redundancy this requires consideration.

  Erik

---

From: Chan-Wah Ng <[email-masked]>
Date: 20 Mar 2003 05:23:11 +0800

> If it belongs to "another" prefix, it can forward the packet

Yes, this is a good way to go when both MR's egress links are up.  This
allows MN to choose whichever prefixes it deems fit, and independently
selects a default router regardless of which MR advertises the prefix.

But it means that if the egress link of one MR (say MR_A) has failed,
the packet sent from MN that is supposed to go through the MR_A will
still not go through, altough MN happily thinks that it has forwarded to
MR_B (which still has an active link), where actual fact MR_B
re-forwarded the packet back to MR_A.

/rgds
/cwng