Subject: [nemo] comments on the requirements draft

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 12 Mar 2003 18:54:27 -0800

hi Thierry,

I have a few comments on draft-ietf-nemo-requirements-00.txt.

I am not sure if words like MUST should be used in this 
document. this is already a requirements document. does the 
following requirement become weaker (?) if you say

     - Migration Transparency: a permanent connectivity to the Internet
      must be provided to all MNNs while continuous sessions must be
      maintained as the mobile router changes its point of attachment.
      For doing so, MNNs will be reachable via their permanent IP
      addresses.

instead of 

>       - Migration Transparency: a permanent connectivity to the Internet
>       MUST be provided to all MNNs while continuous sessions MUST be
>       maintained as the mobile router changes its point of attachment.
>       For doing so, MNNs will be reachable via their permanent IP
>       addresses.

I dont know which word (MUST or must) is the right one here. 
Erik, any suggestions?

> 
>    R12: The solution MUST function for multi-homed mobile networks.
>         More precisely:
> 

multihoming is a complex issue. there are issues even with 
multi-home mobile nodes. I think this requirement needs to
be removed. or reworded to say the solution should not prevent
a multi-home mobile network from functioning properly.

>         R14.4: The signaling messages SHOULD be encrypted

R14.4 should be removed. why is it a requirement that the 
signaling messages be encrypted? even in Mobile IPv6, there 
is no requirement that binding update or binding ack need to 
be encryption. there is no harm in an attacker looking at 
these messages. OTOH, HoTi message (a Return Routability 
message) needs to be encrypted because an attacker can cause 
some harm if he/she sees this message. as far as the basic 
support goes, I dont see the need to encrypt any signaling 
message. this requirement should be removed.

do we need all those scalability requirements? they cant be
enforced anyway?

Vijay

---

From: William D Ivancic <[email-masked]>
Date: Thu, 13 Mar 2003 23:34:24 -0500

I believe this should  be a MUST.  Multihoming is my normal mode of 
operation.   The systems I deal with want to connect to 802.11, multiple 
satellite networks, G3 wireless, wired and whatever else may be available.

Will

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 14 Mar 2003 18:06:33 -0800

> satellite networks, G3 wireless, wired and whatever else may be available.

ofcourse the system should be able to connect with whatever 
interface it wants to. but in your system, does the mobile
network maintain two simultaneous uplinks (either through
multiple interfaces on the MR, or through multiple MRs)? this 
is what I consider as multi-homing. it is not multi-homed 
just because the MR has more than one interface (or just 
because the mobile network can connect to an access network 
through two different mobile routers).

if the MR maintains two simultaneous uplinks, which HoA
does it register with the HA? with current MIPv6 spec, a HA 
cannot maintain more than one binding cache entry for the same 
HoA. lets assume the MR (or the mobile network) has different 
home addresses for the two uplinks. then it can create two 
binding cache entries. but which tunnel does the HA select if 
it wants to forward packets to the mobile network?

Vijay

---

From: Alexandru Petrescu<[email-masked]>
Date: Sun, 16 Mar 2003 19:29:26 +0100

Vijay Devarapalli wrote:
>> I believe this should  be a MUST.  Multihoming is my normal mode 
>> of operation.   The systems I deal with want to connect to 
>> 802.11, multiple satellite networks, G3 wireless, wired and 
>> whatever else may be available.
> 
> [...] but which tunnel does the HA select if it wants to forward 
> packets to the mobile network?

If there are two entries keyed by the same HoA, HA could select the
tunnel of the first entry, why not.

This is not to say that something better could not be done.

---

From: William D Ivancic <[email-masked]>
Date: Sun, 16 Mar 2003 02:09:42 -0500

At 06:06 PM 3/14/2003 -0800, Vijay Devarapalli wrote:
>multiple interfaces on the MR,

Yes.  Two of more simultaneous uplinks via multiple interfaces on the 
MR.  Only one HA.  The interface used is the one of highest 
priority.  Priority can be defined by cost in dollars, bandwidth, delay, IP 
address or just predefined preference.

Will

---

From: Vijay Devarapalli <[email-masked]>
Date: Sun, 16 Mar 2003 17:21:06 -0800

Alexandru Petrescu wrote:
>>> operation.   The systems I deal with want to connect to 802.11, 
>>> multiple satellite networks, G3 wireless, wired and whatever else may 
>>> be available.
>>
>>

the first entry could result in a low bandwidth link. (?)

Vijay

---

From: Alexandru Petrescu<[email-masked]>
Date: Mon, 17 Mar 2003 19:30:12 +0100

Vijay Devarapalli wrote:
>>>> I believe this should  be a MUST.  Multihoming is my normal 
>>>> mode of operation.   The systems I deal with want to connect
>>>>  to 802.11, multiple satellite networks, G3 wireless, wired 
>>>> and whatever else may be available.
>>> 
>>> 
>>> 
>>> [...] but which tunnel does the HA select if it wants to 
>>> forward packets to the mobile network?
>> 
>> 
>> 
>> If there are two entries keyed by the same HoA, HA could select 
>> the tunnel of the first entry, why not.
> 
> 

Yes, low bandwidth but entirely private.