Subject: RE: [nemo] moving forward (was: no home network ?)

From: William D Ivancic <[email-masked]>
Date: Fri, 21 Mar 2003 00:19:56 -0500

Bandwidths on mobile links may be very small and often are.  Also,  routing 
protocols have global convergence times.  So, although it may be possible 
to run RIP, OSPF, or some new routing protocol through a tunnel, one should 
really consider if this is appropriate for your mobile network,

Will

At 03:22 AM 3/21/2003 +0000, Pascal Thubert (pthubert) wrote:
>
> > There are more issues though on how to make an existing
> > protocol work over the MRHA tunnel (or other phrasing).  The
> > first thing that I would like to find is whether is there any
> > place where OSPF (example) was made to work over a tunnel.
> > Or maybe that is not the question.
> >
> >
>Both PSBU and draft-wakikawa introduce a new routing protocol. The
>argument is that a protocol such as RIP or OSPF may create an additional
>control traffic overhead for a stub that will always be there, which
>seems to be a costly overkill in some mobility situations.
>
>This is why I raise the point. I do not think it's that clear cut though
>my mind is not made. Vijay's proposal seems to work fine with no
>additional involvement on our part, but seems impractical over 9.6K GSM
>or very little more GPRS.
>
>My point was mostly that *If* we decide that we need a simpler protocol
>in terms of advertisements, routes and the redistribution stays the
>same.
>
>Pascal

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 20 Mar 2003 21:27:46 -0800

thats right. a PAN connected through a low bandwidth link should
depend on its HA to manage routes for it. I dont expect the
mobile router in the PAN to run a routing protocol either.

Vijay

William D Ivancic wrote:
> Bandwidths on mobile links may be very small and often are.  Also,  
> routing protocols have global convergence times.  So, although it may be 
> possible to run RIP, OSPF, or some new routing protocol through a 
> tunnel, one should really consider if this is appropriate for your 
> mobile network,
> 
> Will
> 
> 
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 20 Mar 2003 21:39:10 -0800

my point is it would be good to work on a solution that would
work for a PAN network and at the same time work well for a
huge mobile network. that is why there are two scenarios in
draft-kniveton-mobrtr. a simple PAN would use the consumer
model. and a mobile router capable of lot more (and if it is
not constrained by low bandwidth uplink), should run a routing
protocol with the routers on its home link through the
bi-directional tunnel. the latter model IMO, is lot more
superior than trying to manage static routes on the Home Agent.

Vijay

Vijay Devarapalli wrote:
>> routing protocols have global convergence times.  So, although it may 
>> be possible to run RIP, OSPF, or some new routing protocol through a

---

From: Michael Thomas <[email-masked]>
Date: Fri, 21 Mar 2003 07:57:06 -0800 (PST)

> superior than trying to manage static routes on the Home Agent.

   From my standpoint, I'm not convinced that it's clear
   that keeping down the classic MIP/PAN kind of approach
   that's emerging is even the right approach at all for
   a huge and complicated set of nested routers. Likewise,
   it seems to me that something that did handle the 
   large case well would probably crushed the simple PAN/MR
   case under its own weight.

   So I for one am happy with this partition of the problem
   space. Living with the unpleasent consequences of lack of
   RO and some deployment experience is probably better than
   trying to partially -- and potentially harmfully -- help
   the situation.

	Mike, who suspects that the 
	  large case is IRTF material...