Subject: RE: [nemo] Multiple Egress vs multihoming

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 22 May 2003 09:49:20 +0100

Hi Vijay:

Please look again.

The main trouble is that w=0 and w=1 are not orthogonal. You can have
several MRs and only one registers (hot standby). And you can have
several registrations for the same prefix by a single MR. If we really
want to express that as Boolean, we must introduce a v as well. Like:

v: 0: There is only one registration for a given mobile prefix (like MIP
today for a HoA)
   1: There can be multiple registrations in parallel for a given mobile
prefix

w: 0: There is a single Egress Mobile Router
   1: There is more then one Egress Mobile Router.

And keep the same as it was. My point is then that we have multihoming
if v or w.

From there, v=1 can be subdivided in 2 problems that I called x=0 and
x=1
And w=1 can be subdivided in 2 problems that I called y=0 and y=1
And obviously you can have v=1 and w=1. 

After all discussion with Chan-Wah's and Julien, the best definition is
IMHO:

x: 0: There is single HA for multiple registration of a same Prefix.
   1: There is multiple HA for multiple registration of a same Prefix.

y: 0: A single Prefix is announced by Egress Routers.
   1: Multiple Prefix are announced by Egress Routers.

What do you think?

Pascal

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: mercredi 21 mai 2003 21:12
> To: Chan-Wah Ng
> Cc: Pascal Thubert (pthubert); Julien Charbon; IETF NEMO WG
> Subject: Re: [nemo] Multiple Egress vs multihoming
> 
> can we stick to the following categories when we discuss
> multihoming on this list? half the time I find myself trying
> to figure out which multi-homing scenario is being referred
> to when I read a particular mail on the list.
> 
> I find the following very clear.
> 
> Vijay
> 
> Chan-Wah Ng wrote:
> >>
> >>  w: 0: A Mobile Router have more than one Global IPv6 Address.
> >>        OR a Mobile Router have more than one Interface.
> >>     1: There is more then one Egress Mobile Router.
> >>
> 
> > (0,0,0) = One MR, one HA, one prefix
> > As far as I see it can either have more than one care-of-address
> > addressed to one HoA (multiple interface sharing same HoA but
different
> > CoA), or it can have different CoA-HoA pairs.  Either way, it should
be
> > a MIPv6 problem.
> >
> > (0,0,1) = One MR, one HA, multiple prefix.
> > If the MR has only one HoA with multiple CoA and multiple subnet
prefix,
> > we need a way for HA to be able to register that the multiple
prefixes
> > are tied to that HoA.  I guess it should be a NEMO problem.
> >
> > (0,1,0) = One MR, multiple HA, one prefix
> > Can MR register the same HoA in two different HAs?  If not, the
problem
> > is simply a HoA-CoA pair per HA.  There is also the question of same
> > prefix-careof in two different HA.  Need to analyse further.
> >
> > (0,1,1) = one MR, multiple HA, multiple prefix
> > largely similar to (0,1,0), but now you have additional prefix
coming
> > in.  This may be easily solved if we demand that each prefix be
taken
> > care of by separate HA.
> >
> > (1,0,0) = multiple MR, one HA, one prefix.
> > May not have any problem at all if the MRs are manually configured
to
> > announce same prefix.  Prefix delegation is also possible since the
MRs
> > are handled by same HA.  HA will see two HoA-CoA pair sharing taking
> > care of the same subnet prefix.
> >
> > (1,0,1) = multiple MR, one HA, multiple prefix
> > May not have any problem at all if each MR take care of separate
prefix.
> >
> > (1,1,0) = multiple MR, multiple HA, one prefix
> > Question of multiple HA handling the same prefix.
> > Also question of how to do prefix delegation between two MRs with
> > different HA.
> >
> > (1,1,1) = multiple MR, multiple HA, multiple prefix
> > May not have any problem at all if each MR take care of separate
prefix.

---

From: Chan-Wah Ng <[email-masked]>
Date: 22 May 2003 17:22:14 +0800

Hi Pascal, Vijay, Julien

On Thu, 2003-05-22 at 16:49, Pascal Thubert (pthubert) wrote:
> several MRs and only one registers (hot standby). 

Nope.  If only one MR is active at any one time, and that MR only
register one binding, it is not a multihoming scenario, and we do not
classify non-multihoming scenario.

Correct me if I am wrong, I think you miss the most important point
about our taxonomy: we classify *multihoming* NEMO.  so the correct
interpretation of 'w' is:

w=0: The NEMO has only one active egress MR with multiple care-ofs
w=1: the NEMO has multiple active egress MR.

/cwng

> And you can have