Subject: RE: Policy base MR operation (was Re: [nemo] Design Team draft fo r NEMO Basic Solution)

From: Soliman Hesham <[email-masked]>
Date: Fri, 4 Jul 2003 02:54:06 -0400

> 1. there are multiple intefaces available, and the MR
 >    should pick the best available interface. IMO, this
 >    is not necessarily a NEMO problem. you need something
 >    like a "roaming manager" (there are many synonyms for
 >    this), which figures out which interface is up and 
 >    decides which interface should be used and when. as
 >    far as the NEMO protocol is concerned, it needs an
 >    uplink to the visited network, through which the MR
 >    can reach its Home Agent. I think there is nothing to
 >    standardize here. the "roaming manager" would be
 >    implementation specific.
 > 
 > 2. in your experiment, you said you were required to send
 >    control traffic through a VDL or INMARSAT link and data 
 >    traffic through a Connexion link. isnt this again 
 >    implementation specific? the forwarding code on the 
 >    MR has to figure out the outgoing interface based on the 
 >    message contents. do you see a need to standardize 
 >    something here? do we need an API between the NEMO 
 >    module and the "roaming manager"?

=> There would be a protocol to standardise if 
the MR has a different CoA on each interface. 
We've attempted this in :
http://www.ietf.org/internet-drafts/draft-soliman-mobileip-flow-move-03.txt
for mobile nodes and the same can be used by MRs.
I don't think any of this is NEMO specific though.

Hesham

 > 
 > a list of requirements in the form of an internet draft 
 > would be nice. then we can figure out what exactly needs 
 > to be specified.
 > 
 > > Now let me add some more reality to the mess.   (This is my current
 > > understanding as explained to me by various pilots.  I am open to
 > > correction.)  Commercial aircraft today generally only 
 > have one active VDL
 > > circuit that is performing packetized communication.  The 
 > other is used for
 > > voice.  They are not combined (i.e. VOIP).  Because the 
 > satellite time
 > > costs so much, the INMARSAT system generally is not 
 > powered on unless the
 > > VDL link is lost.    So in reality, only one link is 
 > active.   The question
 > > I keep raising to this community is why policy-based 
 > routing and load
 > > sharing when in reality only one link is active.    I also 
 > suspect that I
 > > could obtain much higher QoS if I used the Connexion link ( or
 > > similar)  for command and control when available and could 
 > sufficiently
 > > secure those messages with today's technologies.  IMHO, 
 > What is really
 > > needed is some type of quality of service requirement such 
 > that command and
 > > control is highest priority.
 > 
 > I agree with you here.
 > 
 > Vijay
 >

---

From: Soliman Hesham <[email-masked]>
Date: Fri, 4 Jul 2003 02:54:06 -0400

Hesham