Subject: Re: [nemo] multi-homing scenarios

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Jul 2003 10:40:55 -0700

> > both HA1 and HA2 start advertising reachability for 
> > the prefix 'p'. this might be okay if both belong to 
> > the same administrative domain. the HA1 and HA2 MUST 
> > NOT belong to different administrative domains. I 
> > think this restriction is necessary. 
> 
> I am a bit confused here.  You first say its okay if HA1 and HA2 belong
> to same administration domain.  But immediately after that, you say they
> MUST NOT belong to the same administration domain.  Which do you mean
> now?

read again. :) I said HA1 and HA2 MUST NOT belong to 
different administrative domains.

> > later in Section 4 you say 
> > 
> > > The case of multiple home agents at different domains
> > >       advertising a route to the same subnet prefix may pose a problem
> > >       in the routing infrastructure as a whole.  The implications of
> > >       this aspect needs further exploration.
> > 
> > this is a serious problem and should be avoided. IMO, 
> > there is no further exploration needed. :)
> > 
> I was actually hoping we come to this conclusion. 

good. 

> > > 2.2.4 (0,1,1): Single MR, Multiple HAs, Multiple Prefixes

> > if HA1 advertises P1 and HA2 advertises P2, it makes 
> > this very simple. so why dont we place such a 
> > restriction? we dont lose any functionality with this 
> > restriction.
> > 
> 
> It is a good simplifying requirement.

great. hope you add this to the next version of your draft.

> 
> Why not? AFAIK, it is perfectly legal for routers to contain two routes
> to the same destination.  The metrics will take priority, and if the
> metrics are identical, its up to implementation.

hmmm... I guess you are right.

Vijay

---

From: Chan-Wah Ng <[email-masked]>
Date: 15 Jul 2003 02:14:15 +0800

> different administrative domains.

Opps, guess I confused myself :).  Sorry!

/rgds
/cwng

---

From: Chan-Wah Ng <[email-masked]>
Date: 15 Jul 2003 02:14:15 +0800

/rgds
/cwng