Subject: Re: Need for text on issue 4? (Re: [nemo] Basic Support Issue List)

From: Greg Daley <[email-masked]>
Date: Fri, 27 Jun 2003 14:15:17 +1000

Hi Vijay,

Vijay Devarapalli wrote:
> Greg Daley wrote:
> 
>>Do you think that we need to handle multicast
>>issues for hosts on the NEMO in the base draft?
> 
> 
> I dont think so. I think more work needs to be done
> on this and is best handled through a separate 
> specification.

Good.  That's what I was checking.

> 
>>I was thinking that getting Multicast ironed out
>>for moving hosts (rather than networks) would be a
>>good idea first, 
> 
> 
> you mean for MIPv6 mobile nodes? if yes, I guess
> Mobile IPv6 would be the right WG for this work.

Actually, it may even be a MAGMA issue since
there's no global signalling (but certainly not NEMO
yet).

>>and then see if we need a document
>>on multicast routing or multicast-ro.
>>
>>Maybe we just need to add a line regarding multicast
>>routing protocols on the MR to section 8?
> 
> 
> for this you would need both the Home Agent and the
> Mobile Router to run a multicast routing protocol. I
> am not sure if we should talk about it in the basic
> support draft....

OK.  We'll let people read between the lines when it
says "dynamic routing protocol".

I've been having a think about this issue too, and
may get a short draft out after the meeting.

Greg

---

From: Thierry Ernst <[email-masked]>
Date: Wed, 9 Jul 2003 00:37:00 +0900

Hi,

About multicast, see below my personal opinion. It may diverge from
Vijay.

> Good.  That's what I was checking.

To be more precise: a separate specification, but under NEMO Basic Support.

Back to requirement R17, we must make sure multicast is functioning for
NEMO Basic, which means, in principle, multicast signaling would be able
to fly across the bi-directional tunnel MR <-> HA.

> says "dynamic routing protocol".

One of the reason I was supporting "dynamic routing protocol" for basic
was precisely to allow multicast signaling. But, of course, now we need
to examine if NEMO Basic Support as is prevents or not the proper
operation of multicast.

> may get a short draft out after the meeting.

An analysis of the issues NEMO Basic Support may cause to multicast is
more than welcome. The soonest the better, because we might be able to
fix draft NEMO basic support based on this analysis before it is in IESG
hands.

Thierry

---

From: Thierry Ernst <[email-masked]>
Date: Wed, 9 Jul 2003 00:37:00 +0900

Hi,

Thierry

---

From: William D Ivancic <[email-masked]>
Date: Wed, 09 Jul 2003 08:20:47 -0400

We have run multicast over bidirectional tunnels using IPv4.  I suspect 
(but cannot yet confirm) that multicast would operate similarly over IPv6 
bidirectional tunnels.   Also,  the HA makes an excellent rendezvous point 
- ideal for multicasting.   Sorry, but I don't think we have written 
anything up yet on this.

Will

 >
> > OK.  We'll let people read been the lines when it

---

From: William D Ivancic <[email-masked]>
Date: Wed, 09 Jul 2003 08:20:47 -0400

Will