Subject: [nemo] multi-homing scenarios

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 11 Jul 2003 17:38:54 -0700

I read draft-ng-nemo-multihoming-issues-01. a very
useful draft. I have some comments on some of the 
scenarios.

> 2.2.3 (0,1,0): Single MR, Multiple HAs, Single Prefix
> 
>    The (0,1,0) mobile network has only one mobile router advertising a
>    single subnet prefix.  The mobile router, however, associates to
>    multiple home agents, possibly one home agent per home addresses. No
>    assumption is made on whether or not the home agents belongs to the
>    same administrative domain.
>
> 
>                                  AR    HA2
>                                   _  |
>                                |-|_|-|  _
>                         _____  |     |-|_|
>         _    p      _  |     |-|
>        |_|-|<-_  |-|_|-|     |
>         _  |-|_|=|     |_____|-|        _
>        |_|-|     |             |  _  |-|_|
>                                |-|_|-|
>                                      |
>        MNNs  MR    AR  Internet  AR    HA1

both HA1 and HA2 start advertising reachability for 
the prefix 'p'. this might be okay if both belong to 
the same administrative domain. the HA1 and HA2 MUST 
NOT belong to different administrative domains. I 
think this restriction is necessary. 

later in Section 4 you say 

> The case of multiple home agents at different domains
>       advertising a route to the same subnet prefix may pose a problem
>       in the routing infrastructure as a whole.  The implications of
>       this aspect needs further exploration.

this is a serious problem and should be avoided. IMO, 
there is no further exploration needed. :)

> 2.2.4 (0,1,1): Single MR, Multiple HAs, Multiple Prefixes
> 
>    The (0,1,1) mobile network has only one mobile router.  However, the
>    mobile router advertises more than one subnet prefix, and also
>    associates to multiple home agents at the same time, possibly one
>    home agent per home address.  No assumptions is made on whether or
>    not the home agents belongs to the same administrative domain.
> 
> 
>                                  AR    HA2
>                                   _  |
>                                |-|_|-|  _
>                         _____  |     |-|_|
>         _   p1,p2   _  |     |-|
>        |_|-|<-_  |-|_|-|     |
>         _  |-|_|=|     |_____|-|        _
>        |_|-|     |             |  _  |-|_|
>                                |-|_|-|
>                                      |
>        MNNs  MR    AR  Internet  AR    HA1

if HA1 advertises P1 and HA2 advertises P2, it makes 
this very simple. so why dont we place such a 
restriction? we dont lose any functionality with this 
restriction.

> 2.2.5 (1,0,0): Multiple MRs, Single HA, Single Prefix
> 
>    The (1,0,0) mobile network has more than one mobile router
>    advertising global routes.  These mobile routers, however, advertise
>    the same subnet prefix and associate to the same home agent.  Since
>    only one subnet prefix is advertised, the mobile network nodes are
>    (usually) not multi-homed.
> 
>              MR2
> 
>              p
>             <-_  |
>         _  |-|_|-|  _____
>        |_|-|     |-|     |
>         _  |       |     |-|        _
>        |_|-|  _  |-|_____| |  _  |-|_|
>            |-|_|-|         |-|_|-|
>             <-   |               |
>              p
> 
>        MNNs  MR1   Internet  AR    HA

so where does the HA forward packets meant for the 
prefix 'p'? to MR1 or MR2? if the HA uses the routing 
table for forwarding packets for P, it clearly cant 
have two routing entries.

> 2.2.6 (1,0,1): Multiple MRs, Single HA, Multiple Prefixes

for this why dont we place a restriction that MR1 and 
MR2 should register P1 and P2, respectively, with the 
single Home Agent? this would make it simple.

> 2.2.7 (1,1,0): Multiple MRs, Multiple HAs, Single Prefix

again, I think the HAs MUST belong to the same 
administrative domain if there is only one Mobile 
Network Prefix.

> From the above analysis, we can identify the following problems
>    relating to multi-homed mobile network:
> 
>    o  Multiple care-of-addresses to one home-address:

the answer is standardize 
draft-wakikawa-mobileip-multiplecoa-00.txt

>    o  Multiple prefixes taken care of by a single home-address:

what is the issue here? you can send multiple prefixes
in the same binding update using the Mobile Network 
Prefix option in draft-ietf-nemo-basic-support-00.txt. 
the prefixes can be of different prefix lengths.

>    o  A single home-address registered to multiple home agents:
> 
>       *  Is this allowed?

should be disallowed.

>    o  A single subnet prefix registered to multiple home agents:
> 
>       *  Is this allowed?

only if both Home Agents belong to the same domain.

I hope all this gets discussed on Wednesday. :)

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Jul 2003 10:40:55 -0700

> I am a bit confused here.  You first say its okay if HA1 and HA2 belong
> to same administration domain.  But immediately after that, you say they
> MUST NOT belong to the same administration domain.  Which do you mean
> now?

read again. :) I said HA1 and HA2 MUST NOT belong to 
different administrative domains.

> I was actually hoping we come to this conclusion. 

good. 

> It is a good simplifying requirement.

great. hope you add this to the next version of your draft.

> 
> Why not? AFAIK, it is perfectly legal for routers to contain two routes
> to the same destination.  The metrics will take priority, and if the
> metrics are identical, its up to implementation.

hmmm... I guess you are right.

Vijay