Subject: [nemo] Re: Closing Issue 3

From: Chan-Wah Ng <[email-masked]>
Date: 29 Jul 2003 14:46:45 +0800

Hello all, 

we will have to reach consensus on this ... may I propose the following
text (its a shameless combination of the two, but I hope it can be one
step towards consensus): 

        The Home Agent MUST keep all necessary information to be able to
        add or delete routes associated with the Mobile Router at the
        time. For instance, the Home Agent MAY store the list of Mobile
        Network Prefixes owned by a Mobile Router in the corresponding
        Binding Cache entry.  However this is done only when the Mobile
        Router has included prefix information in the Binding Update. 
        This list of prefixes should include only those for which the
        Home Agent currently has routes pointing to the Mobile Router's
        current Care-of address.  This information can later be used to
        delete the routes when the Binding Cache entry for the Mobile
        Router is deleted.

Any comments?

/rgds
/cwng

On Tue, 2003-07-29 at 06:50, Vijay Devarapalli wrote:
> TJ, Thierry, should I close this issue? any suggestions
> on how to proceed?
> 
> Vijay Devarapalli wrote:
> > 
> > Pascal and Kent,
> > 
> > I want to close Issue 3. The issue we are discussing is
> > too trivial to warrant so many mails.
> > 
> > the original text that was proposed by me was
> > 
> >   The Home Agent SHOULD store the list of Mobile Network Prefixes
> >   owned by a Mobile Router in the corresponding Binding Cache
> >   entry.  However this is done only when the Mobile Router has
> >   included prefix information in the Binding Update.  This list
> >   of prefixes should include only those for which the Home Agent
> >   currently has routes pointing to the Mobile Router's current
> >   Care-of address.  This information can later be used to delete
> >   the routes when the Binding Cache entry for the Mobile Router
> >   is deleted.
> > 
> > Pascal objected by saying
> > 
> > > Vijay, can you please be less specific about the data in the BCE? Any
> > > handle to the route info is enough; it does not have to take the form of
> > > a list of prefixes. For instance it can be pointers to the prefix table.
> > > Also, In the case of real static routes, the HA does not install or
> > > clear them, so there's no need to keep them in BCE...
> > 
> > I prefer specific text because alteast one person had a
> > question about this. I prefer a tight specification.
> > I dont see any technical reason not to include the text.
> > the only thing I have seen from you is that it is too
> > implementation specific.
> > 
> > you prefer something like
> > 
> >   The Home Agent MUST keep all necessary information to be able
> >   to add or delete routes associated with the Mobile Router at
> >   the time.
> > 
> > I think this sentence is very vague. what information?
> > where do you store this information? which data structure?
> > 
> > nobody else seems to be interested in this issue. I am
> > not sure how to close this issue.
> > 
> > Vijay
> > 
> > ps: TJ, Thierry, the entire discussion is at
> > http://people.nokia.net/vijayd/nemo/issue3.txt
-- 
Chan-Wah Ng <[email-masked]>
Panasonic Singapore Laboratories

---

From: Chan-Wah Ng <[email-masked]>
Date: 29 Jul 2003 14:46:45 +0800

Hello all, 

Any comments?

/rgds
/cwng