Subject: [nemo] comments on draft-droms-nemo-dhcpv6-pd-00.txt

From: Vijay Devarapalli <[email-masked]>
Date: Sat, 12 Jul 2003 17:54:31 -0700

hi Ralph,

thanks for the draft. a few comments

> Other updates to the HA data structures
>    required as a side effect of prefix delegation are specified by the
>    particular network mobility protocol.  For example, in the case of
>    "Basic Network Mobility Support" [8], the HA would add an entry in
>    its binding cache registering the delegated prefix to the MR to which
>    the prefix was delegated.

something is mixed up here. prefix delegation should work
indepedent of the binding cache entries for the mobile
routers. in the basic support NEMO draft the Home Agent
creates routes to the mobile network when it receives
a Binding Update from the mobile router. do you see a need
to store the delegated prefix in the binding cache entry?
this wont work because, the binding cache entry could 
expire. the lifetime of the binding cache entry shouldnt
be related to the lifetime of the delegated prefix.

>    Following the DHCPv6 Prefix Delegation specification, HAs and MRs
>    SHOULD use DHCPv6 authentication as described in section
>    "Authentication of DHCP messages" of the DHCPv6 specification [6], to
>    guard against attacks mounted through prefix delegation.

I dont follow DCHPv6 work. I looked up the DHCPv6 spec. it 
says the messages are authenticated using an authentication
option, while the actual distribution of keys is declared
out of scope. is there any work on distributing keys to the 
DHCPv6 client, especially if the client never comes home. 
this could be true in the case of NEMO. the mobile router 
could be away from home all the time. how does one 
distribute keys? manual keying? I am not saying manual keying 
wont work, I just want to understand this better.

Vijay

---

From: Ralph Droms <[email-masked]>
Date: Mon, 14 Jul 2003 05:15:30 -0400

>be related to the lifetime of the delegated prefix.

I could well be confused as I'm relatively naive about the
mobility and basic NEMO support drafts.  The example I cited
is apparently not a good one and there may be no examples
of HA data structures that have to be updated based on
delegation of prefixes...

>wont work, I just want to understand this better.

Key distribution is not specified by the DHCPv6 spec and
assumes manual keying is available.  Suggestions for
alternatives would be accepted gratefully...

---

From: Ralph Droms <[email-masked]>
Date: Mon, 14 Jul 2003 05:15:30 -0400