Subject: [nemo] comments on draft-paakkonen-nemo-prefix-delegation-00.txt

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 18 Jul 2003 17:14:21 -0700

hi Pekka and Juhani,

this draft is a very good alternative to using DHCPv6
for prefix delegation (however, I will let the WG decide 
if we need an alternative to DHCPv6 for NEMO prefix 
delegation).

some comments

>       MNP Delegator Query (0)
> 
>         The MNP Delegator Query message is used by the MR to query MNP   
>       delegators (HAs) and their abilities to delegate MNP(s). This 
>       message is sent to MR's HA during the MNP Query sequence.
> 
> 
>       MNP Delegator (4)      
> 
>         A MNP Delegator message is sent by the HA during MNP Query 
>       sequence. It is used to inform MR of MNP(s) HA is capable of 
>       delegating.

I suggest getting rid of these two messages. the HA can 
always respond with MNP Unavailable in response to a
MNP Request message. do you need a query round before
the request?

> 5.3.2 MNP Data Option
> 
>   MNP Data Option holds MNP information related to a single MNP.
> 
> Option format:
> 
>   0                   1                   2                   3
>   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>  |     Type      |     Preferred lifetime                        |           
>  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>  |               |     Valid lifetime                            | 
>  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>  |               | Prefix length | IPv6 prefix (16 octets)       |
>  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                               |                                                               
>  |                                                               |
>  |                                                               |
>  |                                                               |
>  |                               +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                                
>  |                               |     Match     |
>  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

I dont think you need both a valid lifetime and preferred
lifetime field. in your examples in section 5.5 you always
set both lifetime fields to the same value :). here is a 
new format with an alignment requirement of 8n+1

   0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
                  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
                  |    Type       | Prefix Length |   Match      
|           
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |                       Lifetime                                |      
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |                                                               |
  +                                                              
+                                                               
  |                                                               |
  +                     IPv6 Prefix                               +
  |                                                               |
  +                                                               +
  |                                                              
|        
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

> After the MR has queried
> the capabilities of its HAs with this sequence, MR should advance to 
> MNP Delegation sequence with the chosen HA to proceed with MNP 
> delegation.

this is clearly not needed. if the HA responds with MNP
Unavailable in case it cant delegate a prefix, you can
do the same in two round trips. OTOH if the HA can
delegate a prefix, you can have a prefix delegated in
just one round trip.

> If these checks are not valid, HA MUST silently ignore the message. 

the HA should generate an ICMP error message instead of 
silently dropping the message.

I just skimmed the rest of the draft. IMHO, you can get 
rid of section 5.5. there isnt much in it. it would 
make the draft shorter.

Vijay

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 21 Jul 2003 16:39:22 +0200 (CEST)

> if we need an alternative to DHCPv6 for NEMO prefix 

IMHO having Nemo reinvent yet another configuration protocol is not
time well spent.
Working on solutions for mobile networks is time better spent.

  Erik

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 21 Jul 2003 16:39:22 +0200 (CEST)

Erik

---

From: Pekka =?iso-8859-1?Q?P��kk�nen?= <[email-masked]>
Date: Tue, 22 Jul 2003 15:31:30 +0300

>MNP Request message. do you need a query round before

Actually the query sequence is optional, and the delegation sequence
can be executed without the query sequence.
IMHO the query sequence can be used in situations in which the MR
first wants to query the capabilities of its HA for MNP delegation, and
after that proceeds to MNP delegation sequence.
Maybe this feature could be used in a situation in which the MR
wants to query for multiple different MNPs and then select one MNP for 
delegation?

>new format with an alignment requirement of 8n+1

I agree.

>delegate a prefix, you can have a prefix delegated in

See my first comment.

>silently dropping the message.

You may be right. Do you have a specific existing ICMP error message in mind?

>rid of section 5.5. there isnt much in it. it would

Section 5.5 is just for illustration. It could be left out of the draft.

Thanks for the comments.
I think the bottom line about dynamic MNP delegation is this:

DHCPv6 can be used in a NEMO environment. Do we need an alternative such as 
the
one depicted in this draft? If people see a need for it then maybe this (or 
some other) solution
should be developed further.

Pekka

---

From: Pekka =?iso-8859-1?Q?P��kk�nen?= <[email-masked]>
Date: Tue, 22 Jul 2003 15:31:30 +0300

I agree.

See my first comment.

Thanks for the comments.

Pekka

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 22 Jul 2003 13:48:07 -0700

> can be executed without the query sequence.

I didnt get that reading the draft.

> after that proceeds to MNP delegation sequence.

if there is a significant delay between the query and request,
then the earlier query might not be useful at all. the MR 
needs to know if the HA can delegate a prefix right now. not
sometime back.

> wants to query for multiple different MNPs and then select one MNP for

I am not sure I understood.

> You may be right. Do you have a specific existing ICMP error message in mind?

ICMP error message with the ICMP code set to different
values based on what caused the HA to drop the packet.

> should be developed further.

I dont have an answer to this question. the WG needs to
decide on this. Erik is right in saying 

> Working on solutions for mobile networks is time better spent

it is upto you to convince the WG.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 22 Jul 2003 13:48:07 -0700

Vijay