Subject: [nemo] WG: [mobile-ip] new I-D on HA filtering

From: "Koojana Kuladinithi" <[email-masked]>
Date: Wed, 23 Jul 2003 14:57:43 +0200

-----Ursprüngliche Nachricht-----
Von: Koojana Kuladinithi [mailto:[email-masked]] 
Gesendet: Mittwoch, 23. Juli 2003 14:56
An: 'Nicolas Montavont'; 'mobileip'
Betreff: AW: [mobile-ip] new I-D on HA filtering 

Hi Nicolas,

There are a lot of drafts related to multiple points of attachments and flow

distribution, especially for MIPv6.

Followings are the list of drafts, (that I am aware of)

MIPv4
-------

http://www.ietf.org/internet-drafts/draft-nomad-mobileip-filters-03.txt.

MIPv6
-------
http://www.ietf.org/internet-drafts/draft-soliman-mobileip-flow-move-03.txt

http://www.ietf.org/internet-drafts/draft-wakikawa-mobileip-multiplecoa-

To be listed at the IETF repository.

http://www.comnets.uni-bremen.de/english/research/draft-nomadv6-mobileip-fi
lters-00.txt

http://www-r2.u-strasbg.fr/~montavont/draft-montavont-mobileip-ha-filtering-
v6-00.txt

Perhaps, we should initiate a discussion in mobile-ip or nemo WG to discuss 
about this topic.

Kind regards

Koojana

-----Ursprüngliche Nachricht-----
Von: [email-masked]
[mailto:[email-masked]] Im Auftrag von Nicolas
Montavont
Gesendet: Mittwoch, 23. Juli 2003 09:55
An: mobileip
Betreff: [mobile-ip] new I-D on HA filtering 

Hi all,

We just submitted a new I-D on Home Agent Filtering for Mobile IPv6, 
available at

http://www-r2.u-strasbg.fr/~montavont/draft-montavont-mobileip-ha-filtering-
v6-00.txt

It will be soon available in the IETF repertories.

This I-D proposes a solution for the MN to set filters on its home 
agent. Filters can be used to spread flows on different CoAs (and 
potentially several network interfaces), and to forbid the redirection 
of certain flows from the home agent.

Here is the abstract:

Mobile IPv6 allows a MN to receive incoming packets to its home address 
while it is away from its home network. In a heterogeneous environment, 
a MN may have multiple interfaces, each with different characteristics. 
While a MN is in a visited network, due to the performance of the 
interfaces or to the user preferences, the MN may want to forbid the 
redirection from its home agent of a kind of flow, or to indicate a 
target CoA for a kind of flow.
In this draft, we propose new mobility options that allow a MN to 
advertise filters to its home agent. A filter is associated with a CoA, 
in such a way that the MN can register several CoA and can register 
several filters for one CoA. A filter may indicate that a flow which map 
to a filter must be dropped or must be redirected to the indicated CoA.

Regards,
Nicolas

---

From: Soliman Hesham <[email-masked]>
Date: Wed, 23 Jul 2003 09:15:58 -0400

> I Agree with you, we have now several drafts and it will be 
 > interesting
 > to converge towards an unique solution to solve this issue.
 > 
 > Perhaps, Nemo is the ideal WG to discuss about this topic.

=> Definitely not the right WG for this. The right WG
is MIP6 or if MIPSHOP had a more flexible name/charter
it could go there as well. There is nothing NEMO specific
for this problem.

Hesham

 > Regards
 > Thomas Noel
 > LSIIT

---

From: Soliman Hesham <[email-masked]>
Date: Thu, 24 Jul 2003 04:07:00 -0400

> Sorry, I tend to disagree. Ideally, the solution should work for both
 > Mobile IPv6 and NEMO Basic Support. So, if design team there is, we
 > should have people from both working groups, making sure it work for
 > both protocol. This said, whether the report is actually done, during
 > the IETF meeting, in the NEMO WG or another WG may not be important.

=> Well, the problem is how to allow flow-based mobility,
where the flow is a connection or more. To do this, 
there are 2 aspects to consider:
- How to decide which flow goes where (policy)
- How to manipulate a binding cache in the HA/CN to achieve
  this. 

Since we're talking about multiple CoAs, this does not
apply to an MNN (node behind the MR) until an RO
solution for NEMO comes up. It could certainly apply to an
MR with more than one interface, but I fail to see
why anything designed for a MN would not work
for the MR. 

Having said all that, there is no WG membership in IETF :)
So if the chairs decide to have a DT, which is not at all
clear, then it is likely that people with interest in
NEMO and MIP will be in it. ButI don't know if
a DT is needed anyway.

Hesham

---

From: Soliman Hesham <[email-masked]>
Date: Thu, 24 Jul 2003 04:25:59 -0400

Hi Thierry, 

 > In NEMO Basic Support, one issue we already have is how to select the
 > interface/CoA at the MR. It would probably be useful that 
 > the MNN kind
 > of interact with the MR (to exchange policies, for 
 > instance), and this
 > doesn't break the NEMO "Mobility Transparency to MNNs". 

=> I completely agree, but this seems to be quite 
a separate issue from the binding cache manipulation
in the CN/HA. I thought about this problem for nemo
but didn't think people would be interested in it. 
I think it's needed but basically it would belong
to the "policy" bullet in my previous mail. 
So you could envision a MIP solution for binding cache
manipulation which can be used by MNs and MRs.
At the same time, NEMO could develop a solution that
runs between nemo-aware MNNs and MRs to set specific
policies for each nemo-aware MNN. 

 > Let's have another BoF for interface switching and CoA 
 > selection ! :-) 

=> :) 

 > Just kidding - there are already so many WGs to follow :-(

=> Too true! 

Hesham