Subject: RE: Implementation requirements for the different modes (was Re: [nemo] Issue 10)

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 5 Aug 2003 08:08:07 +0100

Excellent :) 

I understand from the discussion with Thierry that you could say 
"The Mobile Router MUST support at least one of" to make it more specific but this is minor...

Pascal

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: lundi 4 août 2003 19:36
> To: Alexandru Petrescu
> Cc: Pascal Thubert (pthubert); [email-masked]
> Subject: Implementation requirements for the different modes (was Re: [nemo] Issue 10)
> 
> Alexandru Petrescu wrote:
> 
> >
> > But I have another related question.  I was wondering whether there
> > might be a necessity to clearly state in the draft which modes must be
> > implemented by whom for this to be a relevant spec.  An example would
> > be: all MR's MUST implement at least "explicit prefixlen" and all HA's
> > must implement all three modes.  This is just an example, I'm looking to
> > know whether it is good or not to be specific about what's mandatory to
> > be implemented.
> 
> good point. IMO, the Home Agent MUST implement all
> modes in section 5.2. support for running an IGP over
> the MR-HA tunnel is still optional. the MR may
> implement any method it wants.
> 
> I made this issue 11.
> 
> proposed text
> 
> 6. Home Agent Operation
> 
>    In order for a Mobile Router to operate correctly, the Home Agent
>    MUST satisfy all the requirements listed in section 8.4 of [1].  The
>    Home Agent MUST implement all the modes described in Section 5.2.
> 
> as for the MR we already have some text in section 5.2
> 
>    The Mobile Router uses
>    one of the following modes to instruct the Home Agent to determine
>    the prefixes owned by the Mobile Router.
> 
> Vijay

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 5 Aug 2003 08:08:07 +0100

Excellent :) 

Pascal