Subject: [nemo] crossover tunnel....

From: Muhammad Ali Malik <[email-masked]>
Date: Thu, 7 Aug 2003 15:08:12 +1000 (EST)

Hi

When a visting mobile node (VMN) needs to communicate with local fixed
node (LFN) of mobile network, can they communicate directly or the
communication need to pass via home agent of VMN.

Cheers

Malik

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 7 Aug 2003 15:37:15 +0900

> communication need to pass via home agent of VMN.

Good question. And the answer is "(may be) no", in NEMO Basic
Support. If VMN performs MIPv6 Route Optimization, direct communication
may be possible once HoTi/CoTi is performed (so if for some reasons the
MR is disconnected, it won't work). Such optimization should be taken of
by extended support, once we come to work on it (if we do).

Hope this helps.
Thierry

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 7 Aug 2003 15:37:15 +0900

Hope this helps.
Thierry

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 07 Aug 2003 10:46:29 +0200

Muhammad Ali Malik wrote:
> When a visting mobile node (VMN) needs to communicate with local 
> fixed node (LFN) of mobile network, can they communicate directly or 
> the communication need to pass via home agent of VMN.

If VMN uses its permanent Home Address for this communication and
neither VMN nor MR are at home, then communication passes via both HA of
MR and HA of VMN.

If VMN still uses its Home Address and MR is at home then communication
passes only through HA of VMN.  One might be tempted to think that if
VMN does RO with LFN then that HA of VMN is eliminated too; however, LFN
is said to not have Mobile IPv6 capabilities and thus can't support the
CN side, so communication will necessarily go through HA of VMN.

If VMN uses its CoA (not the permanent Home Address) then no
communication with any HA is needed, it's all straight between VMN and LFN.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 07 Aug 2003 10:46:29 +0200

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 11:37:26 -0700

Alexandru Petrescu wrote:
> however, LFN
 
MIPv6 requirements are split into CN, HA, and MN requirements.
I understood LFN to mean that there is no MIPv6 MN capability.
I dont it means there is no MIPv6 CN functionality.

for the terminology document

>    Local Fixed Node (LFN)
> 
>       A fixed node (FN), either a host or a router, that belongs to the
>       mobile network and which doesn't move topologically with respect
>       to the MR.
> 
>    Local Mobile Node (LMN)
> 
>       A mobile node (MN), either a host or a router who can move
>       topologically with respect to the MR and whose home link belongs
>       to the mobile network.

a LMN implements MIPv6 MN functionality. then it is obvious
from the above that LFN does not just implement MIPv6 MN
functionality. LFN is like any fixed IPv6 host. so it could
still support MIPv6 CN functionality

correct me if I am wrong.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 11:37:26 -0700

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 08 Aug 2003 10:28:15 +0200

Vijay Devarapalli wrote:
>> however, LFN is said to not have Mobile IPv6 capabilities and thus
>>  can't support the CN side, so communication will necessarily go 
>> through HA of VMN.
> 
> 
> MIPv6 requirements are split into CN, HA, and MN requirements. I 
> understood LFN to mean that there is no MIPv6 MN capability. I dont 
> it means there is no MIPv6 CN functionality.

Right, so there is a world where LFN supports CN.  I always thought that
"LFN" stands for no MIPv6 functionality whatever that is.

Maybe we can suggest clarification to the terminology document and say
that LFN does support CN, but does not support MN.  At which point I
will propose FN to stand for an IPv6 host that does not support neither
MH nor CN nor HA.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 08 Aug 2003 10:28:15 +0200

Alex
GBU

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 08 Aug 2003 10:32:33 -0700

Alexandru Petrescu wrote:
> that LFN does support CN, but does not support MN.  

IMO, there is no need to make such a distinction. LFN 
is just a fixed IPv6 host. it might or might not 
implement MIPv6 CN functionality. any mobile node that 
attempts to do route optimization with the LFN will be 
able to figure out whether the LFN supports route 
optimization.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 08 Aug 2003 10:32:33 -0700

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 11 Aug 2003 15:58:20 +0200

Vijay Devarapalli wrote:
>> Maybe we can suggest clarification to the terminology document and
>> say that LFN does support CN, but does not support MN.
> 
> 
> IMO, there is no need to make such a distinction. LFN is just a fixed
> IPv6 host. it might or might not implement MIPv6 CN functionality.
> any mobile node that attempts to do route optimization with the LFN
> will be able to figure out whether the LFN supports route 
> optimization.

Ok.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 11 Aug 2003 15:58:20 +0200

Ok.

Alex
GBU