Subject: RE: [nemo] Implementation requirements for the different modes (wasRe:[nemo] Issue 10)

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Aug 2003 07:47:17 +0100

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: mardi 5 août 2003 19:22
> To: Alexandru Petrescu
> Cc: Pascal Thubert (pthubert); Ryuji Wakikawa; [email-masked]; [email-masked]
> Subject: Re: [nemo] Implementation requirements for the different modes (wasRe:[nemo] Issue
> 10)
> 
> Alexandru Petrescu wrote:
> >
> > Pascal Thubert (pthubert) wrote:
> > > The Mobile Router can be a tiny embedded logic. It may be an IP
> > > forwarder with no routing logic but Nemo itself. Please allow it to
> > > be simple. IMHO, the modus operandi with static routes can be enough
> > > for some situations with mass produced such devices. So unless you
> > > prove me that we have an interoperability problem by allowing MRs
> > > that support only static and implicit, please detail.
> > >
> > > Otherwise, I suggest we either:
> > >
> > > - keep saying that the MR MUST support at least one mode
> > > or
> > > - make static + implicit the minimum set.
> >
> > I favour the latter since it seems to require the minimum effort in
> > terms of additional implementation on top of Mobile IPv6 IMHO.
> 
> I prefer saying the MR MUST support at least one mode
> (which the text already says). IMHO, the explicit
> network mode will be most widely used. this gives you
> the maximum flexibility of setting forwarding for
> specific prefixes when there are multiple MNPs in the
> mobile network. anyway it is too early to tell.

Indeed :)

I'm with Vijay on this. Because it's the most open wording and it still does not create interop problem that I can foresee at the moment. 

> Vijay

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Aug 2003 07:47:17 +0100

Indeed :)