Subject: [nemo] RE: Text changes to close issue 10

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Aug 2003 09:40:28 +0100

Sorry for being unclear

I agree other OGP stuff should be a side discussion.

My point about that bit for issue 10 is that to answer 143, the HA must know that the MR expects implicit. Maybe that MR will use explicit later but does not want the HA to get its prefixes yet. Maybe the prefixes will come from PD over the tunnel. Also this may be useful for multihoming probes sometime. 

So the HA can not reject blindly all BUs with no prefixes by saying sorry, 143, I do not have a prefix for you. 

I told you I did not want a 143 in the first place... If you have it you want to make sure that both ends understand they are in the implicit situation. Hence the return of the implicit bit. In issue 6, it was about the HA internal behavior, for setting routes and there was no 143 code in the picture. 

It all pains me. I feel it's all useless complexity. You think it's important for the consistency of the protocol. What does the rest of the list say?

Pascal

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: jeudi 7 août 2003 19:22
> To: Pascal Thubert (pthubert)
> Cc: [email-masked]
> Subject: Re: Text changes to close issue 10
> 
> "Pascal Thubert (pthubert)" wrote:
> >
> > I Vijay:
> >
> > I favor these changes too. Thanks for all the work.
> >
> > There's still the original question of differentiating implicit and IGP?
> 
> ??? this was issue 6. please read your own comments.
> the concensus was it is a matter of config at the
> HA and the HA would be able to distinguish between
> implicit mode and running an IGP over the MR-HA
> tunnel.
> 
> moreover, it would be a good idea to keep the IGP
> part separate from rest of the specification. I dont
> think we have considered all the issues.
> 
> >
> > Also, MUST is a bit severe for the 143, ain't it?
> 
> MUST is needed. we dont want the MR assuming everything
> is fine, when the HA actually couldnt setup forwarding
> for the Mobile Network.
> 
> Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 08 Aug 2003 10:41:37 -0700

> My point about that bit for issue 10 is that to answer 143, the HA must know that the MR expects implicit. Maybe that MR will use explicit later but does not want the HA to get its prefixes yet. Ma…

hmm.... if the MR does not want the HA to setup forwarding
yet, then it is better off sending a binding update with
the R flag turned off. and when it is ready to send prefixes
through explicit, send another binding update with R flag
turned on. isnt that a better solution?

I am not sure how multi-homing fits in here.

> It all pains me. I feel it's all useless complexity. You think it's important for the consistency of the protocol.

I think it is far more important to take care of all the
error conditions, then to optimize the protocol right from
the start.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 08 Aug 2003 10:41:37 -0700

Vijay