Subject: RE: [nemo] crossover tunnel....

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Aug 2003 09:29:08 +0100

Hi Vijay:

I like your text, I'm OK to add it, and it answers the initial question.

But it misses my point quite completely.

I was not talking about a mobile network specifically but any mobile node visiting a link and starting a connection with an IPv6 node on that link. The mobile node being a host or a router.
I was talking about a MR behavior for SAS when not at home.

When a MR joins a new link, there's more that happens than we actually described. 

I suggest to insert a 5.7 chapter: SAS for mobile router

	In the process of Source Address Selection, the MRHA tunnel is considered as
	Any other link, with the restriction that only a global address may be selected.

	So when the MR is not at Home, the Home Address will be selected as source 
	address when and only when the destination is reached via the MRHA tunnel.  

	The MR has a set of connected routes for its attached MNPs. It may also 
	have some static routes and a set of routes obtained from a routing protocol.
	For all these routes, SAS takes place normally and if the MRHA tunnel is not
	the link to the next hop, the best scoped global address on that link should 
	be preferred, avoiding the MIP encapsulation and the dog leg.

	In particular, when a MR forms a CoA from a visited prefix, it inserts a
	connected route to that prefix, over the associated egress interface, in 
	its routing table. So when the MR initiates a socket to a node on that link,
	SAS will select the CareOf address as source.

Now if the MR acts as the VMN in your text, the question is how does the MR know whether the connection will be still running when the MR moves, and if in that case using the mechanism you describe should be preferred? Hard to know. Maybe some mobility heuristics. But I believe this is all optimizations, or maybe a config option to override the default operation that I just presented (note it's mostly a description of the current standards).

Pascal   

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: jeudi 7 août 2003 20:52
> To: Pascal Thubert (pthubert)
> Cc: Jongkeun Na; [email-masked]
> Subject: Re: [nemo] crossover tunnel....
> 
> "Pascal Thubert (pthubert)" wrote:
> 
> > Now for an MN talking to an FN on the same network (FN's address has same prefix as MN's
> CareOf), they both have a connected route to the prefix; so for the MN, the next hop is not
> over the tunnel but over the roaming interface, and the CareOf is the natural global address
> there, thus it's selected as source.
> >
> > This is even more crucial for a Mobile Router since it also has connected routes to the
> Mobile Network Prefix, and it's much better for a MR to use its MNP based address to talk to
> a device on the mobile network, isn't it?
> >
> > This all works fine even if the HA is not reachable; but if the MN moves, the connections
> will be broken. Trade Off.
> >
> > Should we make an issue of this?
> 
> I think so.
> 
> > Discuss a little bit SAS in the basic Nemo draft? Personally I'd go for it.
> 
> I think we should write up a short separate specification on
> how a VMN is supposed to behave in a Mobile Network. here is
> an outline.
> 
> 1. VMN attaches to Mobile Network and acquires a CoA from MNP.
> 2. if it wants to start a session with an LFN, and if the session
>    is a short lived one, uses CoA as source address.
> 3. if the session is a long lived one, uses MIPv6 Route Optimization
> 4. performs Return Routability with LFN
> 5. if LFN does not support Route Optimization, it sends ICMP error
>    message (from MIPv6 spec).
> 6. VMN reverse tunnels through its Home Agent
> 7. if MR is not connected to a network, both step 5 and 6 will fail.
>    then VMN defaults to using CoA. if the VMN moves in the middle
>    of the session, the session just breaks. hard luck. since the
>    MR is disconnected, LFN cant be reached anyway.
> 
> comments?
> 
> Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 19 Aug 2003 15:24:15 -0700

"Pascal Thubert (pthubert)" wrote:

>         any other link, with the restriction that only a global address may be selected.

this is not necessarily true. link local addresses can be 
used as source and destination address in the inner IPv6 
header. infact link local address are used, for example, 
if DHCPv6 messages are exchanged over the MR-HA tunnel. 
the outer IPv6 header ofcourse will contain MR's CoA and 
HA's address.

>         address when and only when the destination is reached via the MRHA tunnel.  

right.

>         be preferred, avoiding the MIP encapsulation and the need for global connectivity.

I am not sure what you mean by global connectivity here? 
the rest of the paragraph makes sense.

>         SAS will select the CareOf address as source.

why? the MR may want to use Route Optimization with the
node on the visited link. in this case, the MR-HA tunnel
wouldnt be outgoing interface. the application on the
MR may initiate a socket with the home address and depend
on the kernel to add the Home Address option. when the
packet is actually sent out on the visited link, the 
source address would be the CoA with the home address in 
the Home Address Option.

but I agree with the general idea in your text. and I think
it can be simplified.

    For any packet, if the interface through which the packet
    is sent out is the MR-HA tunnel, then the Home Address must
    be selected as the source address. The source must be set
    to the link local address, if the destination of the packet 
    is a link local address. The Mobile Router MUST NOT set the
    source address to Home Address if the packets are sent to
    the visited link.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 19 Aug 2003 15:24:15 -0700

right.

Vijay