Subject: RE: [nemo] crossover tunnel....

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 7 Aug 2003 12:38:30 +0100

Source Address Selection in IPv6... Look at MIPv6 chapter 11.3.1, second bullet:

There's this thing that:

	The mobile node MAY choose to directly use one of its care-of
      addresses as the source of the packet, not requiring the use of a
      Home Address option in the packet.  This is particularly useful
      for short-term communication that may easily be retried if it
      fails.

The way I see it, for SAS, the MIP tunnel is yet another interface, with the home address on it. So if the packet goes over that tunnel, the home address is the natural source address selection.

Now for an MN talking to an FN on the same network (FN's address has same prefix as MN's CareOf), they both have a connected route to the prefix; so for the MN, the next hop is not over the tunnel but over the roaming interface, and the CareOf is the natural global address there, thus it's selected as source.

This is even more crucial for a Mobile Router since it also has connected routes to the Mobile Network Prefix, and it's much better for a MR to use its MNP based address to talk to a device on the mobile network, isn't it?

This all works fine even if the HA is not reachable; but if the MN moves, the connections will be broken. Trade Off.

Should we make an issue of this? Discuss a little bit SAS in the basic Nemo draft? Personally I'd go for it.

Pascal

> -----Original Message-----
> From: Jongkeun Na [mailto:[email-masked]]
> Sent: jeudi 7 août 2003 13:04
> To: Pascal Thubert (pthubert)
> Subject: RE: [nemo] crossover tunnel....
> 
> SAS in MIP .. what mean?
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Pascal
> > Thubert (pthubert)
> > Sent: Thursday, August 07, 2003 7:19 PM
> > To: Thierry Ernst; [email-masked]
> > Subject: RE: [nemo] crossover tunnel....
> >
> > Hum...
> >
> > Actually this is not a Nemo but a MIP question, since it's a MN
> talking to a FN in a
> > given network.
> >
> > What the MN should have done is set a connected route to the visited
> prefix.
> >
> > If the MN starts a connection with the FN, its source address
> selection should have
> > used the CareOf to talk to the FN, and the routing should not have
> encapsulated
> > the packet over the tunnel. So the MN can send packets to the FN, and
> the FN can
> > respond.
> >
> > But I'm not sure all implementations work that way. Mine does (since
> MR extends
> > MN). We should have mentioned SAS in MIP (as I said at the last Nemo
> WG :) ...
> >
> > Pascal
> >
> > > -----Original Message-----
> > > From: Thierry Ernst [mailto:[email-masked]]
> > > Sent: jeudi 7 août 2003 08:37
> > > To: [email-masked]
> > > Subject: Re: [nemo] crossover tunnel....
> > >
> > >
> > > > When a visting mobile node (VMN) needs to communicate with local
> fixed
> > > > node (LFN) of mobile network, can they communicate directly or the
> > > > communication need to pass via home agent of VMN.
> > >
> > > Good question. And the answer is "(may be) no", in NEMO Basic
> > > Support. If VMN performs MIPv6 Route Optimization, direct
> communication
> > > may be possible once HoTi/CoTi is performed (so if for some reasons
> the
> > > MR is disconnected, it won't work). Such optimization should be
> taken of
> > > by extended support, once we come to work on it (if we do).
> > >
> > > Hope this helps.
> > > Thierry
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 11:51:43 -0700

"Pascal Thubert (pthubert)" wrote:

> Should we make an issue of this? 

I think so.

> Discuss a little bit SAS in the basic Nemo draft? Personally I'd go for it.

I think we should write up a short separate specification on
how a VMN is supposed to behave in a Mobile Network. here is
an outline.

1. VMN attaches to Mobile Network and acquires a CoA from MNP.
2. if it wants to start a session with an LFN, and if the session
   is a short lived one, uses CoA as source address.
3. if the session is a long lived one, uses MIPv6 Route Optimization
4. performs Return Routability with LFN
5. if LFN does not support Route Optimization, it sends ICMP error
   message (from MIPv6 spec).
6. VMN reverse tunnels through its Home Agent
7. if MR is not connected to a network, both step 5 and 6 will fail.
   then VMN defaults to using CoA. if the VMN moves in the middle
   of the session, the session just breaks. hard luck. since the 
   MR is disconnected, LFN cant be reached anyway.

comments?

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 11:51:43 -0700

I think so.

comments?

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 12:02:04 -0700

>    MR is disconnected, LFN cant be reached anyway.

its very easy for the VMN to figure out the MR is 
not currently attached to any network. the MR
would be generating ICMP error messages when VMN
tries to do 5 or 6. then VMN defaults to using CoA
for the session with LFN.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 12:02:04 -0700

Vijay

---

From: Ryuji Wakikawa<[email-masked]>
Date: Fri, 08 Aug 2003 09:33:43 +0900

Hi Vijay

At Thu, 07 Aug 2003 11:51:43 -0700,
>    MR is disconnected, LFN cant be reached anyway.

How does VMN can determine whether a destination is LFN or not.
If LFN is subset of VMN, LFN can suddenly become VMN and vice versa.
Actually if LMN is attached to the home (i.e. mobile network), it can
be treated as LFN.

Unless there is some trick to determine the type of destination node,
there is no advantage to use LFN term in this texts.

can't we use MNN term instead of LFN?
Even if I replaced LFN to MNN, your texts works fine.

regards,
ryuji

---

From: Ryuji Wakikawa<[email-masked]>
Date: Fri, 08 Aug 2003 09:33:43 +0900

Hi Vijay

regards,
ryuji

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 17:42:25 -0700

> Even if I replaced LFN to MNN, your texts works fine.

you are right. just use MNN (Mobile Network Node). the 
VMN (Visiting Mobile Node) cannot figure out if a host 
in the mobile network is a fixed node or a mobile node.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 17:42:25 -0700

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 08 Aug 2003 10:46:57 +0200

>    MR is disconnected, LFN cant be reached anyway.

That sounds like the seeds of a good technique for VMN to efficiently
talk to LFN, regardless of MR being or not connected.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 08 Aug 2003 10:46:57 +0200

Alex
GBU

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 08 Aug 2003 10:55:57 -0700

I prefer a short spec on this. or do you think it could
go into a appendix for the basic support draft?

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 08 Aug 2003 10:55:57 -0700

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 11 Aug 2003 16:02:51 +0200

> go into a appendix for the basic support draft?

Depends on what members want.

My oppinion is that this is like part of initial steps in the RO work, 
not basic work.

>>>   MR is disconnected, LFN cant be reached anyway.

The technique should be modified/enhanced to also work for an LFN of a 
VMR (or MR for that matter) that attaches under another MR, and that 
talks to a LFN of the latter.

Alex
GBU

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 11 Aug 2003 16:02:51 +0200

Alex
GBU

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 11 Aug 2003 10:10:14 -0700

> My oppinion is that this is like part of initial steps in the RO work,

all right then. we wont add anything to the NEMO Basic
support spec.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 11 Aug 2003 10:10:14 -0700

Vijay

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 12 Aug 2003 10:15:54 +0900

> all right then. we wont add anything to the NEMO Basic

I tend to agree. So, would be good to have a separate specification for
that. The question is shall we work on it right now (if someone
volunteer) ?

Thierry

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 12 Aug 2003 10:15:54 +0900

Thierry

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 11 Aug 2003 19:26:44 -0700

> that. The question is shall we work on it right now (if someone

I can write up something short based on 

1. VMN attaches to Mobile Network and acquires a CoA from MNP.
2. if it wants to start a session with an MNN, and if the session
   is a short lived one, uses CoA as source address.
3. if the session is a long lived one, uses MIPv6 Route Optimization
4. performs Return Routability with MNN
5. if MNN does not support Route Optimization, it sends ICMP error
   message (from MIPv6 spec).
6. VMN reverse tunnels through its Home Agent
7. if MR is not connected to a network, both step 5 and 6 will fail.
   then VMN defaults to using CoA. if the VMN moves in the middle
   of the session, the session just breaks. hard luck. since the 
   MR is disconnected, MNN cant be reached anyway.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 11 Aug 2003 19:26:44 -0700

Vijay