Subject: RE: [nemo] crossover tunnel....

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 7 Aug 2003 11:19:11 +0100

Hum...

Actually this is not a Nemo but a MIP question, since it's a MN talking to a FN in a given network.

What the MN should have done is set a connected route to the visited prefix. 

If the MN starts a connection with the FN, its source address selection should have used the CareOf to talk to the FN, and the routing should not have encapsulated the packet over the tunnel. So the MN can send packets to the FN, and the FN can respond.

But I'm not sure all implementations work that way. Mine does (since MR extends MN). We should have mentioned SAS in MIP (as I said at the last Nemo WG :) ...

Pascal

> -----Original Message-----
> From: Thierry Ernst [mailto:[email-masked]]
> Sent: jeudi 7 août 2003 08:37
> To: [email-masked]
> Subject: Re: [nemo] crossover tunnel....
> 
> 
> > When a visting mobile node (VMN) needs to communicate with local fixed
> > node (LFN) of mobile network, can they communicate directly or the
> > communication need to pass via home agent of VMN.
> 
> Good question. And the answer is "(may be) no", in NEMO Basic
> Support. If VMN performs MIPv6 Route Optimization, direct communication
> may be possible once HoTi/CoTi is performed (so if for some reasons the
> MR is disconnected, it won't work). Such optimization should be taken of
> by extended support, once we come to work on it (if we do).
> 
> Hope this helps.
> Thierry

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 11:40:30 -0700

> But I'm not sure all implementations work that way. Mine does (since MR extends MN). We should have mentioned SAS in MIP (as I said at the last Nemo WG :) ...

check out
http://www.ietf.org/internet-drafts/draft-chakrabarti-ipv6-addrselect-api-01.txt

Vijay

> > Sent: jeudi 7 ao{t 2003 08:37
> > To: [email-masked]

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Aug 2003 11:40:30 -0700

check out

Vijay