Subject: [nemo] crossover tunnel....

From: Muhammad Ali Malik <[email-masked]>
Date: Thu, 7 Aug 2003 15:08:12 +1000 (EST)

Hi

When a visting mobile node (VMN) needs to communicate with local fixed
node (LFN) of mobile network, can they communicate directly or the
communication need to pass via home agent of VMN.

Cheers

Malik

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 7 Aug 2003 11:19:11 +0100

Hum...

Actually this is not a Nemo but a MIP question, since it's a MN talking to a FN in a given network.

What the MN should have done is set a connected route to the visited prefix. 

If the MN starts a connection with the FN, its source address selection should have used the CareOf to talk to the FN, and the routing should not have encapsulated the packet over the tunnel. So the MN can send packets to the FN, and the FN can respond.

But I'm not sure all implementations work that way. Mine does (since MR extends MN). We should have mentioned SAS in MIP (as I said at the last Nemo WG :) ...

Pascal

> -----Original Message-----
> From: Thierry Ernst [mailto:[email-masked]]
> Sent: jeudi 7 août 2003 08:37
> To: [email-masked]
> Subject: Re: [nemo] crossover tunnel....
> 
> 
> Good question. And the answer is "(may be) no", in NEMO Basic
> Support. If VMN performs MIPv6 Route Optimization, direct communication
> may be possible once HoTi/CoTi is performed (so if for some reasons the
> MR is disconnected, it won't work). Such optimization should be taken of
> by extended support, once we come to work on it (if we do).
> 
> Hope this helps.
> Thierry

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 7 Aug 2003 12:38:30 +0100

Source Address Selection in IPv6... Look at MIPv6 chapter 11.3.1, second bullet:

There's this thing that:

	The mobile node MAY choose to directly use one of its care-of
      addresses as the source of the packet, not requiring the use of a
      Home Address option in the packet.  This is particularly useful
      for short-term communication that may easily be retried if it
      fails.

The way I see it, for SAS, the MIP tunnel is yet another interface, with the home address on it. So if the packet goes over that tunnel, the home address is the natural source address selection.

Now for an MN talking to an FN on the same network (FN's address has same prefix as MN's CareOf), they both have a connected route to the prefix; so for the MN, the next hop is not over the tunnel but over the roaming interface, and the CareOf is the natural global address there, thus it's selected as source.

This is even more crucial for a Mobile Router since it also has connected routes to the Mobile Network Prefix, and it's much better for a MR to use its MNP based address to talk to a device on the mobile network, isn't it?

This all works fine even if the HA is not reachable; but if the MN moves, the connections will be broken. Trade Off.

Should we make an issue of this? Discuss a little bit SAS in the basic Nemo draft? Personally I'd go for it.

Pascal

> From: Jongkeun Na [mailto:[email-masked]]
> Sent: jeudi 7 août 2003 13:04
> To: Pascal Thubert (pthubert)
> Subject: RE: [nemo] crossover tunnel....
> 
> SAS in MIP .. what mean?
> 
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Pascal
> > Thubert (pthubert)
> > Sent: Thursday, August 07, 2003 7:19 PM
> > To: Thierry Ernst; [email-masked]
> > Subject: RE: [nemo] crossover tunnel....
> >
> > Hum...
> >
> > Actually this is not a Nemo but a MIP question, since it's a MN
> talking to a FN in a
> > given network.
> >
> > If the MN starts a connection with the FN, its source address
> selection should have
> > used the CareOf to talk to the FN, and the routing should not have
> encapsulated
> > the packet over the tunnel. So the MN can send packets to the FN, and
> the FN can
> > respond.
> >
> > But I'm not sure all implementations work that way. Mine does (since
> MR extends
> > MN). We should have mentioned SAS in MIP (as I said at the last Nemo
> WG :) ...
> >
> > Pascal
> >

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Aug 2003 08:39:43 +0100

So just say a node :)

Pascal

> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: vendredi 8 août 2003 02:42
> To: Ryuji Wakikawa
> Cc: Pascal Thubert (pthubert); [email-masked]; [email-masked]
> Ryuji Wakikawa wrote:
> > > I think we should write up a short separate specification on
> > > how a VMN is supposed to behave in a Mobile Network. here is
> > > an outline.
> > >
> > > 1. VMN attaches to Mobile Network and acquires a CoA from MNP.
> > > 2. if it wants to start a session with an LFN, and if the session
> > >    is a short lived one, uses CoA as source address.
> > > 3. if the session is a long lived one, uses MIPv6 Route Optimization
> > > 4. performs Return Routability with LFN
> > > 5. if LFN does not support Route Optimization, it sends ICMP error
> > >    message (from MIPv6 spec).
> > > 6. VMN reverse tunnels through its Home Agent
> > > 7. if MR is not connected to a network, both step 5 and 6 will fail.
> > >    then VMN defaults to using CoA. if the VMN moves in the middle
> > >    of the session, the session just breaks. hard luck. since the
> > >    MR is disconnected, LFN cant be reached anyway.
> > >
> > > comments?
> >
> > How does VMN can determine whether a destination is LFN or not.
> > If LFN is subset of VMN, LFN can suddenly become VMN and vice versa.
> > Actually if LMN is attached to the home (i.e. mobile network), it can
> > be treated as LFN.
> >
> > Unless there is some trick to determine the type of destination node,
> > there is no advantage to use LFN term in this texts.
> >
> > can't we use MNN term instead of LFN?
> > Even if I replaced LFN to MNN, your texts works fine.
> 
> you are right. just use MNN (Mobile Network Node). the
> VMN (Visiting Mobile Node) cannot figure out if a host
> in the mobile network is a fixed node or a mobile node.
> 
> Vijay

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Aug 2003 08:39:43 +0100

So just say a node :)

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Aug 2003 09:29:08 +0100

Hi Vijay:

I like your text, I'm OK to add it, and it answers the initial question.

But it misses my point quite completely.

I was not talking about a mobile network specifically but any mobile node visiting a link and starting a connection with an IPv6 node on that link. The mobile node being a host or a router.
I was talking about a MR behavior for SAS when not at home.

When a MR joins a new link, there's more that happens than we actually described. 

I suggest to insert a 5.7 chapter: SAS for mobile router

	In the process of Source Address Selection, the MRHA tunnel is considered as
	Any other link, with the restriction that only a global address may be selected.

	So when the MR is not at Home, the Home Address will be selected as source 
	address when and only when the destination is reached via the MRHA tunnel.  

	The MR has a set of connected routes for its attached MNPs. It may also 
	have some static routes and a set of routes obtained from a routing protocol.
	For all these routes, SAS takes place normally and if the MRHA tunnel is not
	the link to the next hop, the best scoped global address on that link should 
	be preferred, avoiding the MIP encapsulation and the dog leg.

	In particular, when a MR forms a CoA from a visited prefix, it inserts a
	connected route to that prefix, over the associated egress interface, in 
	its routing table. So when the MR initiates a socket to a node on that link,
	SAS will select the CareOf address as source.

Now if the MR acts as the VMN in your text, the question is how does the MR know whether the connection will be still running when the MR moves, and if in that case using the mechanism you describe should be preferred? Hard to know. Maybe some mobility heuristics. But I believe this is all optimizations, or maybe a config option to override the default operation that I just presented (note it's mostly a description of the current standards).

Pascal   

> Sent: jeudi 7 août 2003 20:52
> Cc: Jongkeun Na; [email-masked]
> "Pascal Thubert (pthubert)" wrote:
> 
> > Now for an MN talking to an FN on the same network (FN's address has same prefix as MN's
> CareOf), they both have a connected route to the prefix; so for the MN, the next hop is not
> over the tunnel but over the roaming interface, and the CareOf is the natural global address
> there, thus it's selected as source.
> >
> > This is even more crucial for a Mobile Router since it also has connected routes to the
> Mobile Network Prefix, and it's much better for a MR to use its MNP based address to talk to
> a device on the mobile network, isn't it?
> >
> > Should we make an issue of this?
> 
> I think so.
> 
> > Discuss a little bit SAS in the basic Nemo draft? Personally I'd go for it.
>