Subject: RE: [nemo] Implementation requirements for the different modes (wasRe: [nemo] Issue 10)

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 5 Aug 2003 08:15:12 +0100

The Mobile Router can be a tiny embedded logic. It may be an IP forwarder with no routing logic but Nemo itself. Please allow it to be simple. IMHO, the modus operandi with static routes can be enough for some situations with mass produced such devices. So unless you prove me that we have an interoperability problem by allowing MRs that support only static and implicit, please detail.

Otherwise, I suggest we either:

- keep saying that the MR MUST support at least one mode
or
- make static + implicit the minimum set. 

Pascal

> -----Original Message-----
> From: Ryuji Wakikawa [mailto:[email-masked]]
> Sent: lundi 4 août 2003 13:50
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; Pascal Thubert (pthubert);
> [email-masked]
> Subject: Re: [nemo] Implementation requirements for the different modes (wasRe: [nemo] Issue
> 10)
> 
> 
> Hi,
> 
> At Tue, 5 Aug 2003 09:52:32 +0900,
> Thierry Ernst wrote:
> >
> >
> > Hi,
> >
> > > > This sounds reasonable to me to have only HA implementing all modes. As
> > > > for the HA,
> > >
> > > you mean the MR?
> >
> > Sorry, misstyping. Yes, MR.
> >
> > > > isn't it one of the modes that MUST at least be supported ?
> > >
> > > I thought thats obvious from the current text
> > >
> > > >    The Mobile Router uses
> > > >    one of the following modes to instruct the Home Agent to determine
> > > >    the prefixes owned by the Mobile Router.
> > >
> > > this means that the Mobile Router MUST implement one of the
> > > modes.
> > >
> > > > What happens if 2 MRs in the same mobile network don't implement the
> > > > same mode ?
> > >
> > > shouldnt be a problem as long as the HA implements both. do
> > > you see a problem?
> >
> > I don't see any specific problem but it may be one once we do some
> > testing (?): what happens if a multihomed mobile network has 2 MRs, and
> > 1 MR uses implicit, the other uses explicit ? Will it work ? It this
> > reasonable to allow this ?
> 
> I don't see any problem, neither:-)
> 
> I personally think this evaluation should be done in the multihoming
> draft, but not in the basic.
> 
> regards,
> ryuji

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 05 Aug 2003 12:26:04 +0200

Pascal Thubert (pthubert) wrote:
> The Mobile Router can be a tiny embedded logic. It may be an IP
> forwarder with no routing logic but Nemo itself. Please allow it to
> be simple. IMHO, the modus operandi with static routes can be enough
> for some situations with mass produced such devices. So unless you
> prove me that we have an interoperability problem by allowing MRs
> that support only static and implicit, please detail.
>

I favour the latter since it seems to require the minimum effort in
terms of additional implementation on top of Mobile IPv6 IMHO.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 05 Aug 2003 12:26:04 +0200

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 05 Aug 2003 10:21:42 -0700

> terms of additional implementation on top of Mobile IPv6 IMHO.

I prefer saying the MR MUST support at least one mode
(which the text already says). IMHO, the explicit 
network mode will be most widely used. this gives you 
the maximum flexibility of setting forwarding for 
specific prefixes when there are multiple MNPs in the 
mobile network. anyway it is too early to tell.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 05 Aug 2003 10:21:42 -0700

Vijay