Subject: [nemo] NEMO or MANET?

From: Wanrong Yu <[email-masked]>
Date: Wed, 8 Oct 2003 17:25:06 +0800 (HKT)

Hi,all
  I have read some drafts of NEMO and MANET, but I 
have some doubts. If there are several mobile networks,
each has one or more MRs(we can imagine several cars), 
these cars meet and want to communication with each 
other, if the fixed infrastructure is unsable for some 
reasons, does the communication possible? and how?
  From the aspect of NEMO, we can loose the restrict 
of the existence of fixed infrastructure, from the 
aspect of MANET, we can extend the single node in the 
ad hoc to a subnet, both will point to the scenario 
above. I think this maybe a new scenario neithor NEMO 
or MANET has covered, and there are new issues arise 
such as routing and security.
   Does there any researchs on this scenario, or some 
current technology have solve the problem perfectly?
   Any comments or advices are welcomed, thanks a lot!

 Wanrong Yu

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 8 Oct 2003 10:42:54 +0100

Hi:

I like your summary, and agree with most of it.

From the Nemo standpoint, you need the HA in the picture to set the
initial pointers, and then RO can take over, even if you loose
connectivity to the HA. Also, if you build an engineered structure with
the relevant HAs in place -you may have a hierarchical pyramid of HAs-,
you can move the structure independently of the global infrastructure
and preserve inner connectivity. 

But more than that seems to me out of the scope of Nemo.

Pascal
> -----Original Message-----
> From: Wanrong Yu [mailto:[email-masked]]
> Sent: mercredi 8 octobre 2003 11:25
> To: [email-masked]; [email-masked]
> Subject: [nemo] NEMO or MANET?
> 
> Hi,all

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 8 Oct 2003 10:42:54 +0100

Hi:

Pascal

---

From: "HyunWook Cha" <[email-masked]>
Date: Wed, 15 Oct 2003 15:30:44 +0900

Hi all,

I re-post my reply about this overwraped issue to two mailing list since
it seems to be rejected as a spam mail because of non-english character.

If I have misunderstood, please enlighten me.

Regards,
HyunWook Cha
 
-----Original Message-----
From: HyunWook Cha [mailto:[email-masked]] 
Sent: Wednesday, October 15, 2003 2:51 PM
To: 'Alexandru Petrescu'
Cc: [email-masked]'; [email-masked]'
Subject: FW: [manet] RE: NEMO or MANET?

Hi Alex,
I apologize that my second comment on A-C-B seems to be repeated. Please
ignore that. 
And, I modify my first comment.
Since an MR which does not have global prefixes requests prefix
delegation, MR_B delegates its prefix to MR_A in case A-(B-C) that I
mentioned below. How about this case where one group(cluster or partion
in terms of MANET) of mobile networks is connected to another group of
mobile netwroks? 
(A->B)-(C->D)
I think prefix delegation should be extended to propagate route
information for prefix of one group to other group although prefix
delegation is not needed.  
If so, why don't you use MANET routing protcols?
If I have misunderstood, please enlighten me.

Thank you in advance.

HyunWook Cha

[Previous discussion is as following. ]

Hi Alex,
Ok, Since the scenario which we are considering is with no
infrastructure, we do not need to mention issue like "HoA expiration".
Please see inline comments.
 
> If A delegates 2002:aaaa:aaaa:b::/52 to B and B delegates 
> 2002:aaaa:aaaa:bc::/54 to C then MR_A will use its usual default route

> to everything different than 2002:aaaa:aaaa::/52 through its usual 
> default route.  MR_A does not need to change its default route.
> 
> It is sufficient for MR_A to a have a route towards the delegated 
> prefix 2002:aaaa:aaaa:b::/52 towards MR_B and MR_B to have a route 
> towards the delegated prefix 2002:aaaa:aaaa:bc::54 towards MR_C.
> 

I agree partially. You assume that MR_C is connected to MR_B after MR_B
is connected to MR_A and configure a prefix delegated from MR_A.
However, let's consider another scenario. 
What happens if MR_C is connected to MR_B before MR_B is connected to
MR_A and configure a prefix delegated from MR_A. In this case, the
prefix which MR_C is delegated from MR_B is not 2002:aaaa:aaaa:bc::56
but 2002:bbbb:bbbb:c/52. 
If a node in network A wants to communicate one with 2002:bbbb:bbbb:c/52
as prefix in network C, it is not possible if default route entry of
MR_A is not changed to MR_B  
or  route entry for 2002:bbbb:bbbb/48 is not added in MR_A when MR_A
delegates its prefix to MR_B. 
If the latter is perfomed, it satisfies this scenario.
But, how about the case where 4 mobile networks are connected in
direction of bottem_up, that is D is connected to C, C to B, and B to A
and a node in A starts to communicate one( 2002:cccc:cccc:d::/52)  in D.
Routing protocls including manet protocols is necessary to do this.