Subject: RE: [nemo] About BA status 141

From: Soliman Hesham <[email-masked]>
Date: Thu, 23 Oct 2003 22:08:43 -0400

> >  > I guess so. For example if a similar entry already exists in 
 > >  > the table,
 > >  > or if the prefix is larger than 128.  No?
 > > 
 > > => But that sounds more like a message format error
 > > which should be generic for any incorrect field in the 
 > > BU. I thought this was already covered in the base MIPv6
 > > spec. 
 > 
 > prefix information is not sent in the BU in MIPv6. in Nemo
 > we are trying to deal with the Mobile Router including
 > some invalid prefix in the Binding Update. the prefix could
 > be invalid due to many reasons (invalid prefix length,
 > site-local Mobile Network Prefix, reserved IPv6 prefix as
 > Mobile Network Prefix, prefix that cannot be aggregated at
 > the Home Network, etc.....).

=> I understand. If that's what it's used for 
then perhaps the error code should reflect that, 
i.e. 'invalid prefix' or something like that. 
Of course you can still reuse the 'format error'
anyway for a new field, but if you want to be specific
you can create a new error code (e.g. 141) and give it
a specific meaning. 

Hesham

 > Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 24 Oct 2003 10:36:11 -0700

> i.e. 'invalid prefix' or something like that. 

actually it is. :)

       141     Invalid Prefix

section 4.2 of 
http://www.ietf.org/internet-drafts/draft-ietf-nemo-basic-support-01.txt

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 24 Oct 2003 10:36:11 -0700

actually it is. :)

       141     Invalid Prefix

section 4.2 of 

Vijay