Subject: RE: [nemo] review of the nemo basic spec

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Dec 2003 09:28:57 -0000

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: mardi 2 décembre 2003 00:09
> To: Vijay Devarapalli
> Cc: Pascal Thubert (pthubert); [email-masked]
> Subject: Re: [nemo] review of the nemo basic spec
> 
> Vijay Devarapalli wrote:
> 
> >> I'm referring to the first paragraph of Section 7.
> >> Remember that according to MIPv6 base spec, unknown
> >> flags are ignored, as are unknown moboptions. One good
> >> way past this is to send one moboption and expect another
> >> one back as an ack that the receiver understood what you
> >> requested; then you know the HA supports NEMO. Alternatively,
> >> you can track a flag value on the Binding Ack. If it comes
> >> back as zero, HA did not support NEMO.
> >>
> >> In nemo, you do neither. Instead you have added a new flag
> >> in DHAAD. That is useful, but I would also handle the BU/BA
> >> in a way that the mobile router becomes certain the home
> >> agent understood what it was being asked to do.
> >>
> >> Does this help explain my issue about the current nemo R=1
> >> usage?
> >
> >
> > this was discussed earlier. Issues 15 and 16 capture the
> 
> I need to take a look at that, right now its too late (1 am)
> here for that ;-)
> 
> > discussion. the first solution to support inter-working with
> > MIPv6 Home Agents was to add a new binding ack status which
> > says forwarding was setup. MIPv6 Home Agents would return
> > just 0. the second suggestion was to add a flag in the binding
> > ack which would be set to 1 if the Home Agents sets up
> > forwarding for the mobile network. MIPv6 Home Agent would not
> > set this flag. neither of this will work because, the Mobile
> > Router now has to repeatedly try other Home Agents until it
> > gets an indication from a Home Agent that it has set up
> > forwarding. the mobile router also has to deregister with the
> > MIPv6 Home Agent before trying another Home Agent.
> >
> > so modifying DHAAD was the right solution. the mobile router
> > should not have attempted registration with a Home Agent that
> > does not support mobile routers.
> >
> > IMO, a flag in the binding ack is just extra specification and
> > extra code for something that shouldnt have happened. what do
> > you think?
> 
> I think I agree that modifying DHAAD was a good thing to
> do. WHat I am less sure about is whether that is sufficient.
> One thing is that I'd rather not do DHAAD at all, if I can avoid
> it. The second thing is making the decision of what you support
> local. The HA that responds to a BU certainly knows what
> it supports; another home agent might not know, for sure,
> what the other home agents support. Or at least there could
> be config errors in it. In conclusion, while I agree that
> DHAAD support is good, it may be necessary to make the
> BU/BA protocol itself robust enough to survive even
> mistakes or old information in DHAAD. Does that make
> sense?
> 

My point exactly. I agree we need both, since DHAAD is not always wanted. 
Note that for DHAAD, we need also to modify the Router Advertisement Message to add a Nemo bit...

Pascal

---

From: Jari Arkko <[email-masked]>
Date: Tue, 02 Dec 2003 11:28:37 +0200

> Note that for DHAAD, we need also to modify the Router Advertisement Message to add a Nemo bit...

Or a vector of capabilities bits for every HA... ok, maybe
that's an overkill.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Tue, 02 Dec 2003 11:28:37 +0200

--Jari