Subject: RE: [nemo] review of the nemo basic spec

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Dec 2003 10:43:13 -0000

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: mardi 2 décembre 2003 10:29
> To: Pascal Thubert (pthubert)
> Cc: Vijay Devarapalli; [email-masked]
> Subject: Re: [nemo] review of the nemo basic spec
> 
> Pascal Thubert (pthubert) wrote:
> 
> > Note that for DHAAD, we need also to modify the Router Advertisement Message to add a Nemo
> bit...
> 
> Or a vector of capabilities bits for every HA... ok, maybe
> that's an overkill.
> 
Well I think it's not in the end. This is why we started HAHA. But for Nemo, maybe yes :)

Pascal

---

From: Jari Arkko <[email-masked]>
Date: Tue, 02 Dec 2003 13:15:19 +0200

> Well I think it's not in the end. This is why we started HAHA. But for Nemo, maybe yes :)

If there are multiple features (and there will be, nemo, haha,
security extensions, and so on), response flags would probably
work better than request flags. The problem with request flags
is that if you don't get exactly what you asked for, you are stuck
with trying a bunch of other combinations. With response flags
you can see what the nodes support, and go from there.

That being said, I'm not sure if the DHAAD response has a suitable
place for response flags per home agent.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Tue, 02 Dec 2003 13:15:19 +0200

--Jari