Subject: RE: [nemo] Re: issue xxx: requirements chapter for Nemo.

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 3 Dec 2003 09:52:46 -0000

My text looks ugly, I must agree on that. It's more like an initial dump to be filtered out.  

The key is that basic nemo has dependencies, and at the moment they are implicit, thus Jari's comment on the deps on MIPv6. On top of MIPv6, we have dependencies on several RFCs like IPv6 spec, nd, autoconf, dhcpv6, tunnels. Most MUST be fully implemented, but it's not the case of MIPv6. I agree with Jari that there's a need to say so. Maybe it takes much less text then I actually used.

Something like:

Dependencies:
-------------
Basic Nemo MRs MUST implement this specification, [MIPv6] chapter 8.1 and 8.3, and RFCs 2460, 2461, 2462, 2463 and 2473.
Basic Nemo MRs MAY implement [MIPv6] chapter 8.2 and 8.5, and RFC 3041.
Basic Nemo HAs MUST fully implement this specification, [MIPv6] chapter 8.1, 8.3 and 8.4,  and RFCs 2460, 2461, 2462, 2463 and 2473.

> -----Original Message-----
> From: T.J. Kniveton [mailto:[email-masked]]
> Sent: mercredi 3 décembre 2003 02:10
> To: Pascal Thubert (pthubert)
> Cc: [email-masked]
> Subject: Re: [nemo] Re: issue xxx: requirements chapter for Nemo.
> 
> Question: Is there a specific complaint, or reason why the current spec
> does not adequately spell out the requirements of nodes to operate with
> NEMO? It seems like it's not too hard to see or figure out. I'd like to
> avoid making the draft longer than necessary.. best to keep it simpler
> if adequate.
> 
> tj

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 03 Dec 2003 11:35:31 -0800

> Dependencies:

apart for saying NEMO Mobile Routers MAY implement return
routability based Route Optimization (both CN and MN
functionality), everything else seems to be mandatory. maybe
that is all that needs to be said. (?)

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 03 Dec 2003 11:35:31 -0800

Vijay

---

From: Jari Arkko <[email-masked]>
Date: Wed, 03 Dec 2003 21:53:46 +0200

> that is all that needs to be said. (?)

Yes.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Wed, 03 Dec 2003 21:53:46 +0200

Yes.

--Jari