Subject: RE: MR returning home (was Re: [nemo] review of the nemo basic spec)

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 3 Dec 2003 11:45:58 -0000

TJ: 

With current ND, in order to advertise a prefix, you have to send an RA. Why would we want to do that?

If you consider the aggregated mode, the prefix on the Home link is the aggregation of all MNPs (say that it is a /48 while MNPs are /64, for the sake of the discussion). When a MR comes Home using the egress interface, it has to setup some bridging between the egress and the ingress. 

Alternatively, it could act as a proxy, and as opposed to answering every NS one by one for all MNNs, it would be nice to advertise that this MR LL2 matches the full MNP on the home link. Which can be done by sending an RA with the MNPs as not onlink, no auto. I'm not sure how nodes on the home link would react to that but if it's unclear we can raise an issue since RFCs 2461/2 are being updated. I'd expect nodes to create a route to the prefix that depends on the REACHability of the MR on the home link, or something.

There's one thing we do not have today (like I said I already mentioned this in the v6 WG), which is the capability to advertise a Network in or behind a Node. I call the option NINO for Network In Node Option, and I call NINA a NA with such an option. 

This would allow addressing devices inside a (virtual) PC, this would allow addressing devices inside a car or whatever such for of stub, this would allow a MR to present itself on the egress interface, whether at home or not. And this would help proxying subnets in general.

Nino could benefit from  Dave Thaler's draft  http://www.ietf.org/internet-drafts/draft-thaler-ipv6-ndproxy-01.txt and in particular it should have a minimum set of metrics and info like MTU.

I believe there's value for Nemo and if someone agrees support would be appreciated.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of T.J. Kniveton
> Sent: mercredi 3 décembre 2003 04:28
> To: Vijay Devarapalli
> Cc: [email-masked]
> Subject: Re: MR returning home (was Re: [nemo] review of the nemo basic spec)
> 
> 
> 
> Vijay Devarapalli wrote:
> 
> >
> >     -  The Mobile Router MAY send router advertisements on its egress
> >        interfaces.  But the router lifetime SHOULD be set to 0, so that
> >        hosts on the home link do not pick the Mobile Router as the
> >        default router.
> 
> I'm missing something.. Why would the MR put out RAs on the egress
> interface? I can see why it would put them out on the ingress interface,
> and use a routing protocol on the egress interface to advertise the
> mobile network.. but what would the RA contain?
> 
> tj
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 3 Dec 2003 11:45:58 -0000

TJ: 

Pascal