Subject: [nemo] RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

From: "Jung-Hoon Cheon" <[email-masked]>
Date: Fri, 16 Jan 2004 10:48:56 +0900

Hi...Hosik and Eunkyung.

your solution is very applicable for nested networks.
if MRs know their correct age, MRs can manage a hierarchy within overall
mobile network.
The MR sends a RA message including its age. 
Also,  knows its current position from received RA message.

I have a question.
How can MR know its age?
I think that before comparing its age with other age, MR should know its
age.

Sincerely.

Jung-Hoon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of [email-masked]
Sent: Friday, January 16, 2004 6:10 AM
To: IETF-Announce:
Subject: I-D ACTION:draft-cho-nemo-hmra-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Hierarchical Mobile Router Advertisement for
nested mobile networks
	Author(s)	: H. Cho
	Filename	: draft-cho-nemo-hmra-00.txt
	Pages		: 7
	Date		: 2004-1-15
	
This document describes needs for hierarchical mobile router
     advertisement for nested mobile networks. When ingress and egress
     interfaces of a Mobile Router are both wireless, the MR cannot
     distinguish the Router Advertisement of the parent MR from the RA
     of the child MR. To maintain hierarchical information of wireless
     nested mobile networks, RA message needs to be extended to deliver
     additional information for hierarchy.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-cho-nemo-hmra-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the
message.

Internet-Drafts are also available by anonymous FTP. Login with the
username "anonymous" and a password of your e-mail address. After
logging in, type "cd internet-drafts" and then
	"get draft-cho-nemo-hmra-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-cho-nemo-hmra-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Jung-Hoon Cheon" <[email-masked]>
Date: Fri, 16 Jan 2004 10:48:56 +0900

Hi...Hosik and Eunkyung.

I have a question.
How can MR know its age?

Sincerely.

Jung-Hoon

-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type:

---

From: "Hosik Cho" <[email-masked]>
Date: Fri, 16 Jan 2004 12:12:46 +0900

Hi Jung-Hoon,

Thank you for your interest in our draft.

age.

Every mobile router has the initial value of zero.
Every access router has the initial value of the maximum age.
(In our draft, the field size for AGE is three bits, so the maximum age is
defined 7. But this value of maximum age may be extended later, if we need.)

The age of each child MR is re-calculated when if receives a RA message from
its parent MR. If the received age, i.e. the parent MR's age, is bigger than
its age, the child MR re-assigns its age to (received age)-1.

Regards,
Hosik

-----Original Message-----
From: Jung-Hoon Cheon [mailto:[email-masked]] 
Sent: Friday, January 16, 2004 10:49 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi...Hosik and Eunkyung.

I have a question.
How can MR know its age?

Sincerely.

Jung-Hoon

-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type:

---

From: "Hosik Cho" <[email-masked]>
Date: Fri, 16 Jan 2004 12:12:46 +0900

Hi Jung-Hoon,

age.

Regards,
Hosik

-----Original Message-----
From: Jung-Hoon Cheon [mailto:[email-masked]] 
Sent: Friday, January 16, 2004 10:49 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi...Hosik and Eunkyung.

I have a question.
How can MR know its age?

Sincerely.

Jung-Hoon

-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type:

---

From: "Jung-Hoon Cheon" <[email-masked]>
Date: Fri, 16 Jan 2004 12:53:39 +0900

Hi. Hosik and all,

If MR2 and MR3 arrive at foreign network almost simultaneously

and MR2 receives two RA message from the both MR1(age=6) and MR3(age=7)
before sending RA message, 

at this time, how can the MR2 determine MR1 with its parent MR?

  AR
   |
 MR1
   |
 MR2
   |
 MR3

As my understanding, every MR update its position according to other
MR's age, 
whenever receiving RA message.

It's not easy to solve this problem.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Hosik Cho
Sent: Friday, January 16, 2004 12:13 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [nemo] RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi Jung-Hoon,

age.

Every mobile router has the initial value of zero.
Every access router has the initial value of the maximum age. (In our
draft, the field size for AGE is three bits, so the maximum age is
defined 7. But this value of maximum age may be extended later, if we
need.)

The age of each child MR is re-calculated when if receives a RA message
from its parent MR. If the received age, i.e. the parent MR's age, is
bigger than its age, the child MR re-assigns its age to (received
age)-1.

Regards,
Hosik

-----Original Message-----
From: Jung-Hoon Cheon [mailto:[email-masked]] 
Sent: Friday, January 16, 2004 10:49 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi...Hosik and Eunkyung.

your solution is very applicable for nested networks.
if MRs know their correct age, MRs can manage a hierarchy within overall
mobile network. The MR sends a RA message including its age. 
Also,  knows its current position from received RA message.

I have a question.
How can MR know its age?

Sincerely.

Jung-Hoon

-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type:

---

From: "Jung-Hoon Cheon" <[email-masked]>
Date: Fri, 16 Jan 2004 12:53:39 +0900

Hi. Hosik and all,

  AR
   |
 MR1
   |
 MR2
   |
 MR3

-----Original Message-----

Hi Jung-Hoon,

age.

Regards,
Hosik

-----Original Message-----
From: Jung-Hoon Cheon [mailto:[email-masked]] 
Sent: Friday, January 16, 2004 10:49 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi...Hosik and Eunkyung.

I have a question.
How can MR know its age?

Sincerely.

Jung-Hoon

-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type:

---

From: "Hosik Cho" <[email-masked]>
Date: Fri, 16 Jan 2004 13:30:31 +0900

Hi Jung-Hoon,

> before sending RA message, at this time, how can the MR2 determine MR1
with its parent MR?

Only access routers can have the maximum age 7.

When MR2 and MR3 enter into the network, the ages of MR are initially zero.
And MR2 can receive two RAs from MR1(age=6) and MR3(age=0).
So MR2(age=0) accepts the RA from MR1(age=6) and sets its age to 5.

Regards,
Hosik

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jung-Hoon Cheon
Sent: Friday, January 16, 2004 12:54 PM
To: 'Hosik Cho'
Cc: [email-masked]; [email-masked]
Subject: RE: [nemo] RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi. Hosik and all,

  AR
   |
 MR1
   |
 MR2
   |
 MR3

-----Original Message-----

Hi Jung-Hoon,

age.

Regards,
Hosik

-----Original Message-----
From: Jung-Hoon Cheon [mailto:[email-masked]] 
Sent: Friday, January 16, 2004 10:49 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi...Hosik and Eunkyung.

I have a question.
How can MR know its age?

Sincerely.

Jung-Hoon

-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type:

---

From: "Hosik Cho" <[email-masked]>
Date: Fri, 16 Jan 2004 13:30:31 +0900

Hi Jung-Hoon,

with its parent MR?

Regards,
Hosik

-----Original Message-----

Hi. Hosik and all,

  AR
   |
 MR1
   |
 MR2
   |
 MR3

-----Original Message-----

Hi Jung-Hoon,

age.

Regards,
Hosik

-----Original Message-----
From: Jung-Hoon Cheon [mailto:[email-masked]] 
Sent: Friday, January 16, 2004 10:49 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-cho-nemo-hmra-00.txt

Hi...Hosik and Eunkyung.

I have a question.
How can MR know its age?

Sincerely.

Jung-Hoon

-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type: