Subject: Re: [nemo] MNP in the explicit BU when returning home?

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 27 Feb 2004 16:52:50 -0800

hi Alex,

sorry for the very late reply. :(

Alexandru Petrescu wrote:
> Hi,
> 
> I suggest, if explicit mode is used, to have the MNP's Mobility Options
> included in the Mobility Header of a BU sent by MR when it returns home.
> 
> The existing section 5.8 Returning Home of basic support 02 is silent
> about this.  Or maybe it is understood that when MR comes back home
> _all_ MNP's must be deregistered?  If yes, this is IMHO a feature of
> implicit mode, and for the explicit mode it should be stated.

if the BU is a de-registration BU, the HA is not going to
process any Mobile Network Prefix options in the BU. once
it sees the lifetime set to 0, it just removes the binding
cache entry for the MN and all the associated MNP routes
for a particular MR.

so there is no need for the MR to include MNPs in the BU
in the explicit mode. the HA is going to ignore them
anyway.

I will add some text to make this more explicit.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 27 Feb 2004 16:52:50 -0800

hi Alex,

Vijay