Subject: [nemo] RE: DND test [was Assigning the same prefix to multiple MRs]

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Thu, 18 Mar 2004 12:51:49 -0000

> -----Original Message-----
> From: Soliman Hesham [mailto:[email-masked]]
> Sent: jeudi 18 mars 2004 12:14
> To: Pascal Thubert (pthubert); IETF NEMO WG
> Subject: RE: DND test [was Assigning the same prefix to multiple MRs]
> 
> 
> 
>  > > => Right so MR2 and the network behind it become
>  > > unreachable because MR1 is possible down! That's not
>  > > good.
> 
>  > If the test works, the registration is accepted and you get the
>  > redundancy you want.
> 
>  > If MR1 is down, the registration for MR1 was cleaned up so
>  > the test is
>  > not even run for MR2.
>  > If that's your point, I do agree that there's a window if
>  > MR2 binds just
>  > at the time MR1 dies and before the BCE for MR1 is cleaned
>  > up.
> 
> => Thanks you!
> 
> 
>    There's
>  > also a risk of collision like MR1 and MR2 startup at the same time
(I
>  > think that that one is a bit more realistic, like you start the
>  > entertainment power in a train or a plane).
> 
> => Exactly. And we're only just discussing this on email.
> I'd imagine that there is a few more cases than that.
> 
>  > It's possible to make the test a bit more complex if the
>  > list finds it
>  > worthwhile. HA2 pings MR1 first and then pings MR2 via MR1.
>  > If MR1 does
>  > not answer, then accept the registration for MR2. IF MR1
>  > answers but MR2
>  > does not, reject the registration.
> 
> => I didn't intend to try to design a solution right now,
> I was trying to show that there are several problems that
> are not addressed in this case.
> 
Agreed:
  The test was not designed yet. The requirement for the test is still
not agreed upon. So if this thread ends up anywhere, maybe it's to an
answer to that question: Is there a need for a Duplicate Network
Detection test that would check that when a prefix is registered twice,
you end up on the same link for both registrations?

Pascal

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 18 Mar 2004 14:07:48 +0100

> you end up on the same link for both registrations?

Good question. Today, I can manually enter two routing table entries
towards the same prefix but through different next-hops. Is there a need
for the system to check when a prefix is registered twice and warn me I
did so, or ban me from doing so?

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 18 Mar 2004 14:07:48 +0100

Alex