Subject: RE: [nemo] RE: splitting moving networks (was: DND test)

From: "Soliman Hesham" <[email-masked]>
Date: Sat, 27 Mar 2004 03:00:22 -0500

> >  > When each MR registers to different HAs, we need to 
 > verify whether
 > >  > prefix table of each HA is consistent or not. 
 > > 
 > > => No we don't need to do that, they're two independent 
 > > entries.
 > 
 >  For some purposes, the consistency *would* be preferable. 
 > If we want some
 >  fault tolerance, multiple HAs and replication (or 
 > consistency) can be helpful.
 >  And this consistency problem can be solved by the HAHA protocol. 
 >  So, we don't need to close the possibility.

=> There is no inconsistency here to address.
I think there is a lot of confusion about multihoming
actually. I intend to put my thoughts in a draft to
avoid repetition.

 > > 
 > > => As I stated before, I think it's cleaner to have 
 > > different MNPs for MRs. If that's the decision, then
 > > of course we can treat this case as an error just like
 > > MIP treats multiple MNs with the same HoA as an error. 
 > > 
 > 
 >  IMO, multiple MRs can have the same MNP for the fault tolerance.
 >  That's one of the purpose of multihomed mobile networks, and
 >  that can be also the decision.

=> You're mixing a solution with a requirement. Start by
putting requirements then we can discuss solutions THEN
we can decide which solution is better. 

 > > => If the MR registered for an hour how is 
 > > the binding removed?
 > 
 >  The periodic BU can solve this problem. 

=> No it doesn't, perhaps some interaction between
the IGP and the binding cache management function
can be done but this is still handwaving without any 
concrete ideas.

Hesham

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 27 Mar 2004 17:39:23 +0900

At Sat, 27 Mar 2004 03:00:22 -0500,
> actually. I intend to put my thoughts in a draft to

Which draft are you talking about?
I will wait for your definition.

> => You're mixing a solution with a requirement. Start by

You mixed both, too. How can you give such strong statement (1MNP-1MR)
without requirement thought.

> we can decide which solution is better. 

I agree.
The facts are we are still working on requirement and problem
statement in NEMO WG.  At this stage, we have the scenario where
multiple MRs have same MNP in the ChanWah's pb statement draft.

ryuji

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 27 Mar 2004 17:39:23 +0900

I agree.

ryuji