Subject: RE: [nemo] can an HA itself be an MNN under NEMO?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Mar 2004 08:08:50 -0000

Hi:

If Felix's case is what the nemo basic usages draft (http://www.ietf.org/mail-archive/ietf-announce/Current/msg28703.html)refers to as (hierarchical) Mobile Home, then IMHO, yes, it makes a lot of sense, for the reasons explained in the draft. Actually the bottom MR advertises X' which is only a subnet of X...
 
To recap (from my presentation at the WG:)

* A bitwise hierarchy of Home Networks 
->MRs are recursively Home Agent(s) for their NEMO-prefixes

* A head HA advertises the global Home to the infrastructure 
->Head HA gets packets from the infrastructure 
->tunnels them to the MR that is responsible of the next level of hierarchy

* Home is further subnetted in NEMO-prefixes that are Home Networks as well 
->MRs decapsulate the packets as MR and reencapsulate them as HA
->MRs are recursively Home Agent(s) for their NEMO-prefixes

Advantages:

* Easier Network Management for IT
->Preconfiguration and testing of regional (branch) offices
->Deployment with no reconfiguration
->Easier to move an office every so often

* if Mobile Home Agent is root-MR of a mobile cloud of its MRs:
->Nested Route Optimization 
->No pinball routing
->Nemo-network to Nemo-network communication confined within mobile cloud 

Opinions?

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of T.J. Kniveton
> Sent: dimanche 29 février 2004 15:00
> To: S. Felix Wu
> Cc: IETF NEMO WG
> Subject: Re: [nemo] can an HA itself be an MNN under NEMO?
> 
> I still don't get it.. Why would there be HAs on two different links
> supporting the same prefix?? In the fixed case, it's analogous to two
> routers on different links, advertising the same global prefix.
> 
> On Feb 29, 2004, at 10:53 PM, S. Felix Wu wrote:
> 
> >
> > I was really thinking about the MR for prefix Y moving into
> > another network (prefix X) without knowing that one of its own
> > MNN is actually the HA for that network.
> >
> > I agree that, for fixed topology/configuration, this doesn't
> > make sense. But, I am not sure about the "moving" case (plus
> > nested).
> > -Felix
> >
> >
> > T.J. Kniveton wrote:
> >
> >> I don't get why you would have a Parent HA advertising prefix X, and
> >> then a Mobile HA and MNN inside the top MR's prefix X... doesn't seem
> >> like a topologically correct arrangement of routers. The Mobile HA is
> >> under MR with prefix Y, so why is it advertising prefix X.
> >> Think about the fixed case, would you have this arrangement?
> >> Router
> >>   | prefix X
> >>   |
> >>   |
> >> Router
> >>   | prefix Y
> >>   |
> >>   |
> >> Router
> >>   | prefix X
> >>   |
> >>   |
> >> Fixed node with prefix X
> >> it wouldn't make sense, right? It seems the scenario in the slide is
> >> just taking this case, and nesting it inside MRs.
> >> On Feb 29, 2004, at 4:11 PM, S. Felix Wu wrote:
> >>>
> >>> Hi,
> >>>
> >>> During our analysis of multi-homing and nested NEMO cases, we
> >>> have encountered a question, hopefully get some clarifications
> >>> from the NEMO working group:
> >>>
> >>>     -- Can an HA itself be an MNN under the NEMO context?
> >>>
> >>> Please see our attached PDF file for our preliminary analysis on
> >>> this issue. It seems to us that this can be allowed for MIPv6, but
> >>> should NOT be allowed for NEMO (otherwise, we might have a loop,
> >>> and the multi-homing issue might be more complex).
> >>>
> >>> -Felix
> >>> --
> >>> ---------------------------------------------------------------------
> >>> -
> >>> Dr. S. (Shyhtsun) Felix Wu
> >>> [email-masked]
> >>> Associate Professor
> >>> http://www.cs.ucdavis.edu/~wu
> >>> Computer Science Department                     office:
> >>> 1-530-754-7070
> >>> University of California at Davis               fax:
> >>> 1-530-752-4767
> >>> ---------------------------------------------------------------------
> >>> -
> >>> <NEMO-HA-as-MNN.pdf>
> >
> > --
> > ----------------------------------------------------------------------
> > Dr. S. (Shyhtsun) Felix Wu                           [email-masked]
> > Associate Professor                      http://www.cs.ucdavis.edu/~wu
> > Computer Science Department                     office: 1-530-754-7070
> > University of California at Davis               fax:    1-530-752-4767
> > ----------------------------------------------------------------------
> >

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Mar 2004 08:08:50 -0000

Hi:

Advantages:

Opinions?

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Mar 2004 08:19:22 -0000

"Option# 1:
- do NOT allow HA as MNN"

* Option# 2:
- An HA can be an MNN, but it can never be
"included" by its own MR.
- But, how about those eight cases in Multi-
homing?

Disagree. With nemo basic there's a limitation on how this can work as you present and as HY Lach presented last IETF (Mobile Home must be Root-MRs).

Note that one application of Mobile Home is a 'quasi fixed' Home or branch office gateway. Usage is preconfiguration by IT or ISP, and plug and play deployment (and moving when office is displaced).

Note: With RRH support, any configuration works (even a HA attached to its own MRs). Reason is MR forward RRH up the tree to the AR even when not bound (note: DHAAD is issued with a all zeroes RRH and it traverses too). As a result, the fixed 'super' HA can answer by echoing the RRH, then mobile Home binds, and then MRs bind via the fixed 'super' HA. Demo available :)

This is not the only advantage of RRH since it's mostly aimed at RO, but it's pretty neat. 

Pascal

> From: [email-masked] [mailto:[email-masked]] On Behalf Of S. Felix Wu
> Sent: dimanche 29 février 2004 08:12
> To: IETF NEMO WG
> Cc: Fan Zhao; Souhwan Jung; [email-masked]
> Subject: [nemo] can an HA itself be an MNN under NEMO?
> 
> 
> Hi,
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Mar 2004 08:19:22 -0000

"Option# 1:

* Option# 2:

Pascal