Subject: [nemo] RE: summary of same MNP to mutliple MRs discussion

From: "Soliman Hesham" <[email-masked]>
Date: Wed, 31 Mar 2004 19:56:14 -0500

Vijay, 

Thanks for the summary. see below.

 > first of all, the current spec prevents assigning the
 > same MNP to two mobile routers _if required_. 

=> typo? you mean "does not prevent"?

   it depends
 > on what is configured in the Prefix Table on the Home
 > Agent. if the Prefix Table on the Home Agent says that
 > a particular MNP was given out only to MR1, the Home
 > Agent sends a binding ack with status 142 to MR2 when
 > MR2 sends a BU to the Home Agent.
 > 
 > if the Prefx Table says both MR1 and MR2 are authorized
 > for a MNP, then it _is_ possible for both MR1 and MR2
 > to register with the Home Agent with the same MNP at
 > the same time. the HA then has two routes to the MNP,
 > one route pointing to MR1 and the second pointing to MR2.
 > this is what Hesham is talking about. the current NEMO
 > basic support spec works in this case.
 > 
 > if the Mobile Network splits, with MR1 in one network
 > and MR2 in another network, both advertising the same
 > MNP and both registered with the Home Agent, then there
 > is a problem. Hesham wants this stated in the spec. the
 > Home Agent could pick the wrong route.

=> Yes.

 > 
 > then again, others have argued that if you expect two
 > mobile routers which were part of the same Mobile
 > Network (but not nested, both have uplinks) to move
 > away and split the mobile network into two, it is
 > stupid to assign the same MNP to both. each MR should
 > be delegated a unique MNP.

=> That opinion should be stated in the spec.

 > did I miss something?

=> This is a good and specific summary. 

Hesham

 > Vijay
 > 
 > ps: I created an issue for this. issue 37 at
 > http://people.nokia.net/vijayd/nemo/issues.html
 > 

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 31 Mar 2004 17:24:45 -0800

> => typo? you mean "does not prevent"?

no. based on information in the Prefix Table, the Home
Agent can prevent more than one MR claiming the same
MNP. or to put it more accurately, detect this and
prevent the second MR from registering (and creating
routes).

see section 6.1.2.

if the Prefix Table says both MRs are authorized for
a particular MNP, then they can both register with
the same MNP in the BU.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 31 Mar 2004 17:24:45 -0800

see section 6.1.2.

Vijay