Subject: Re: [nemo] MNP in the explicit BU when returning home?

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 01 Mar 2004 12:57:47 +0100

Vijay Devarapalli wrote:
>> The existing section 5.8 Returning Home of basic support 02 is silent
>> about this.  Or maybe it is understood that when MR comes back home
>> _all_ MNP's must be deregistered?  If yes, this is IMHO a feature of
>> implicit mode, and for the explicit mode it should be stated.
> 
> 
> if the BU is a de-registration BU, the HA is not going to
> process any Mobile Network Prefix options in the BU. once
> it sees the lifetime set to 0, it just removes the binding
> cache entry for the MN and all the associated MNP routes
> for a particular MR.
> 
> so there is no need for the MR to include MNPs in the BU
> in the explicit mode. the HA is going to ignore them
> anyway.

I was wondering whether _any_ Mobility Options sub-header should be 
present in the de-registering BU (for my threat analysis doc and stack), 
maybe I can find it in the MIP6 draft, but if you know by heart, please 
let me know.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 01 Mar 2004 12:57:47 +0100

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 01 Mar 2004 10:17:49 -0800

> maybe I can find it in the MIP6 draft, but if you know by heart, please 

in a Binding Update sent to a HA, only altCoA option is
valid. the HA could ignore the altCoA option if it sees
a zero lifetime in the BU.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 01 Mar 2004 10:17:49 -0800

Vijay