Subject: [nemo] issue 35 on how MR spec is relaxed with respect to MH RO

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 01 Apr 2004 15:14:58 +0200

IESG Reviewer
> In the third paragraph under section 5, the wording is quite strange.
>  I'm not sure what they are doing without more research than I have 
> time for, but my guess is that they are saying at the end that under
> a specific set of criteria, they are relaxing a MUST in another
> document to a MAY, but they need to be clearer on the intent.

The paragraph in question is:
> A Mobile Router MUST implement all requirements for IPv6 Mobile 
> Nodes, Section 8.5 in [1].  However if a Mobile Router is not 
> expected to initiate sessions of its own and behaves purely as a 
> router serving the mobile network most of the time, then the Route 
> Optimization functionality MAY be implemented.

I would suggest insertion of a preceding phrase like: A Mobile IPv6
Mobile Host SHOULD implement Route Optimization [2]; however, if a
Mobile Router is not ... (relaxing the Mobile IPv6 MH RO SHOULD to NEMO
MR RO MAY).

Alex

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 2 Apr 2004 07:07:13 +0100

As a router provider, I agree with the MAY. I already fought that war in
Yokohama in the general case of MIPv6. There are a lot of types of
devices for which RO is not necessarily wanted (clustered servers,
routers, embedded devices).

NEMO MRs may be implemented in PCs running applications while they serve
as home gateway. But in the latter case, it is the applications that
really cause the need for RO, not the NEMO support. There's nothing in
the basic NEMO flows that trigger a need for RO today.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alexandru Petrescu
> Sent: jeudi 1 avril 2004 15:15
> To: IETF NEMO WG
> Subject: [nemo] issue 35 on how MR spec is relaxed with respect to MH
RO

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 2 Apr 2004 07:07:13 +0100

Pascal

Alexandru Petrescu
RO

---

From: "Soliman Hesham" <[email-masked]>
Date: Fri, 2 Apr 2004 10:42:54 -0500

I'm trying to understand the need for this statement
at all. If RO is implemented it's implemented in the 
context of host mobility (read: nothing to do with nemo).
In this case the MR looks like a host and should follow
MIPv6 in this context. 

So why is this statement needed at all, independently
of whether it's a should or may?

Hesham

 > > Mobile Router is not ... (relaxing the Mobile IPv6 MH RO SHOULD to

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 6 Apr 2004 05:31:45 -0400

> I agree with Hesham for RO stuff. 
 > The NEMO basic draft has enough pointers to MIP6 spec in 
 > each Section.
 > We even give Section number of MIP6 draft for some pointers.
 > 
 > One thing I feel uncomfortable is when MR acts as Mobile Node.
 > For example, the draft says below in Section3.
 >   "For traffic originated by itself, the Mobile Router can use either
 >    reverse tunneling or route optimization as specified in [1]."
 > 
 > When a Mobile Router supporting both MIP6 and NEMO uses the same HoA
 > for both protocols, can MR use Binding Cache created by NEMO BU
 > (i.e. R flag set) for host mobility purpose?

=> Sure, why not ?

 > 
 > I think when MR uses the same HoA, the MR should not send MIP6
 > BU. 

=> Nemo extends the BU but AFAICS it doesn't exclude using 
it for host mobility. I think this would be a mistake.

 > Or MR must use different HoAs for NEMO and MIP? 

=> I think one address is enough and simple.

Hesham

 > 
 > comments?
 > 
 > regards,
 > ryuji
 > 
 > 
 > 
 > At Fri, 2 Apr 2004 10:42:54 -0500,
 > Soliman Hesham wrote:
 > > 
 > >  > > From: [email-masked] 
 > [mailto:[email-masked]] On Behalf Of
 > >  > Alexandru Petrescu
 > >  > > Mobile Router is not ... (relaxing the Mobile IPv6 MH 
 > RO SHOULD to
 > >  > NEMO
 > >  > > MR RO MAY).
 > >  > > 
 > >  > > Alex
 > >  > 
 > >

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 6 Apr 2004 06:19:51 -0400

> You missed my point. 
 > I wanted to say that 
 > when a MR uses the same HoA, the MR should not send both a normal BU
 > (without R flag) and a BU with R-flag simultaneously for the 
 > same HoA.
 > We should prohibit sending normal Binding Updates to HA for MR's HoA.

=> Sorry, it wasn't clear to me. Of course I agree with that.
It's one BU, loaded with whatever extensions a node needs.

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Wed, 14 Apr 2004 22:54:30 -0400

> I dont see any concensus on this thread. 

=> Who disagreed? I'll go thru emails again
but I don't recall anyone disagreeing.

   I ofcourse
 > favor removing this sentence.

=> ok.

Hesham

 > Vijay