Subject: [nemo] issue 35 on Error in error processing

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 01 Apr 2004 18:07:36 +0200

[repost to include CC]

IESG Reviewers H. Alvestrand and Michael Patton (GEN-ART rev):
| In section 6.6 under a certain condition (which is independent of
| whether implicit or explicit mode is in use) it describes sending
| error status code 140.  However, in the description of what a MR does
|  with responses in explicit mode, error code 140 implies discard
| response. If the MR is going to discard it, why send it?  The MR
| needs to know there was a problem, so I think the fix is to make it
| process these.

Right.  The idea of MR dropping BAck 140 in explicit mode was to have
the loop stopped, I'll explain below "loop".  However, since this is the
third time this issue comes up, I agree with having MR process BAck 140
explicit (or have HA send BAck 141 explicit) (two different ways).

Idea of "loop" was that MR starts sending BU's implicit, gets back
negative BAcks, then sends BU's explicit, and if still error then stop,
avoid re-starting to send BU's implicit.  But this loop could still be
avoided with the suggested modifciations.

Alex

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 06 Apr 2004 14:19:55 -0700

Alex,

I've checked back with Michael - he says that to the limit of his 
understanding, either change would work - it's the WG's business to decide 
which one you take....

thanks!

                 Harald

--On 1. april 2004 18:07 +0200 Alexandru Petrescu 
<[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> [repost to include CC]
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iD8DBQFAbD5IMmC0w56zj54RApLoAJ9Qgad1KKYPWwZ5ADJTvBOL+VM54QCg5oIw
> I1zncBHxWNNohB53qwTI208=
> =d6eJ
> -----END PGP SIGNATURE-----
>
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 06 Apr 2004 14:19:55 -0700

Alex,

thanks!

                 Harald