Subject: RE: [nemo] issue 35 on how MR spec is relaxed with respect to MH RO

From: "Soliman Hesham" <[email-masked]>
Date: Fri, 2 Apr 2004 10:42:54 -0500

I'm trying to understand the need for this statement
at all. If RO is implemented it's implemented in the 
context of host mobility (read: nothing to do with nemo).
In this case the MR looks like a host and should follow
MIPv6 in this context. 

So why is this statement needed at all, independently
of whether it's a should or may?

Hesham

 > > -----Original Message-----
 > > From: [email-masked] [mailto:[email-masked]] On Behalf Of
 > Alexandru Petrescu
 > > Sent: jeudi 1 avril 2004 15:15
 > > To: IETF NEMO WG
 > > Subject: [nemo] issue 35 on how MR spec is relaxed with 
 > respect to MH
 > RO
 > > 
 > > IESG Reviewer
 > > > In the third paragraph under section 5, the wording is quite
 > strange.
 > > >  I'm not sure what they are doing without more research 
 > than I have
 > > > time for, but my guess is that they are saying at the 
 > end that under
 > > > a specific set of criteria, they are relaxing a MUST in another
 > > > document to a MAY, but they need to be clearer on the intent.
 > > 
 > > The paragraph in question is:
 > > > A Mobile Router MUST implement all requirements for IPv6 Mobile
 > > > Nodes, Section 8.5 in [1].  However if a Mobile Router is not
 > > > expected to initiate sessions of its own and behaves purely as a
 > > > router serving the mobile network most of the time, then 
 > the Route
 > > > Optimization functionality MAY be implemented.
 > > 
 > > I would suggest insertion of a preceding phrase like: A Mobile IPv6
 > > Mobile Host SHOULD implement Route Optimization [2]; however, if a
 > > Mobile Router is not ... (relaxing the Mobile IPv6 MH RO SHOULD to
 > NEMO
 > > MR RO MAY).
 > > 
 > > Alex
 > 

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: Ryuji Wakikawa <[email-masked]>
Date: Tue, 06 Apr 2004 17:19:25 +0900

I agree with Hesham for RO stuff. 
The NEMO basic draft has enough pointers to MIP6 spec in each Section.
We even give Section number of MIP6 draft for some pointers.

One thing I feel uncomfortable is when MR acts as Mobile Node.
For example, the draft says below in Section3.
  "For traffic originated by itself, the Mobile Router can use either
   reverse tunneling or route optimization as specified in [1]."

When a Mobile Router supporting both MIP6 and NEMO uses the same HoA
for both protocols, can MR use Binding Cache created by NEMO BU
(i.e. R flag set) for host mobility purpose?

I think when MR uses the same HoA, the MR should not send MIP6
BU. Even when MR re-registers its HoA without R-flag (MIP6 BU), HA
just overwrites the BC created with NEMO BU.  This may cause loop of
sequence number errors. The returning home is more critical.

Or MR must use different HoAs for NEMO and MIP? 

comments?

regards,
ryuji

At Fri, 2 Apr 2004 10:42:54 -0500,

---

From: Ryuji Wakikawa <[email-masked]>
Date: Tue, 06 Apr 2004 17:19:25 +0900

comments?

regards,
ryuji