Subject: RE: [nemo] Section 8 comment in IESG review

From: "Soliman Hesham" <[email-masked]>
Date: Sat, 3 Apr 2004 02:22:18 -0500

> > => Basically I think we need to make sure that the HA
 > > checks the routing information exchanged and matches it 
 > > against the prefix information that it already knows from
 > > the MNP table/manual config/BCEs ..etc to make sure that
 > > MRs are authorised to advertise such prefix(es). 
 > > So we need tight coupling between the routing protocol
 > > content and the content in the BU/manual config.
 > > Otherwise Bad Guy could send a vaild BU and start announcing
 > > someone else's prefix. 
 > 
 > we actually wanted to avoid exactly this kind of tight
 > coupling between running an IGP and NEMO basic support
 > protocol.

=> That intention is reflected in the current text.

 > 
 > consider two fixed routers running an IGP inside a
 > domain. is it possible for one router to advertise routes
 > to prefixes that it acutally does not own? if yes, I
 > dont think we need to fix it in NEMO if a mobile router
 > lies to its Home Agent. 

=> But this is not a fair comparison. Today routers will
only do that due to misconfiguration. All routers in
the same domain trust each other. However, this trust 
could not be assumed in the case where the MR does not
belong to the same admin domain. 

 > the bi-directional tunnel between the MR and the HA
 > actually extends the IGP domain to include the MR. thats
 > all. 

=> I don't think that's the point. The point is whether
the two nodes trust each other because they're under
the same admin domain. 

   NEMO basic support protocol only creates the
 > bi-directional tunnel (and few more things). we dont want
 > NEMO to do the verification for routing protocol updates.

=> I don't think we can get away with saying that 
"we don't want to do this". If the WG decides that this 
should not be done, then the draft MUST state that:
"In the case where the MR and the Home Agent are not under
the same administrative domain, the MR MUST not run 
a routing protocol to the Home Agent". 

I think this will avoid any ambiguity. But I don't know
if this is what the WG wants.

Hesham

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: Mattias Pettersson <[email-masked]>
Date: Mon, 05 Apr 2004 10:18:38 +0200

> if this is what the WG wants.

Asking this question: does IGP fill an important role in the scenario 
where MRs and HA belong to different domains and MRs don't trust each 
other? IGP doesn't fit into that model. So would any sane admin allow 
that to be used?

I think Vijay summarized it well with:
"if there is sufficient trust between the MR and HA and they are
configured to exchange routing updates, just do that. nothing
for NEMO to do here. NEMO only creates the bi-directional tunnel
(and few other things).

if IGP cannot be run, the MR includes prefixes in binding update
in explicit mode. "

I would be happy with your statement above, Hesham.

I would also like to hear from any implementor whether they have 
included IGP (dynamic routing) in their prototypes and what they think 
whether or not tying NEMO to IGP is considered a simple thing to do.

/Mattias

---

From: Mattias Pettersson <[email-masked]>
Date: Mon, 05 Apr 2004 10:18:38 +0200

/Mattias