Subject: [nemo] Section 8 comment in IESG review

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 01 Apr 2004 18:01:39 +0200

[repost, included reviewer in CC]

Steve Bellovin wrote about section 8 draft-nemo-02 in IESG review:
| Do you mean "be careful to include the same information in both
| places" -- redunancy is sometimes good.  Or do you mean "be careful
| to avoid doing this"?  Personally, I think the former is more
| appropriate, because it allows a check on the validity of the routing
|  information.

I also think the text should be along the lines of "careful with that
prefix, include same information in both places", and not "careful to
avoid doing this".

| Note that the prefixes announced via binding updates are checked for
|  authorization; routing data generally is not.  I would thus suggest
|  that routing advertisements MUST NOT contain any prefixes not known
|  to the home agent by either implicit mode configuration or explicit
|  mode announcement.

Basically, I agree with this; this is a useful check.

My preferred way to solve this potential conflicting information between
the prefixes advertised by NEMO and the ones advertised by rt protocol
is to have NEMO _not_ have prefixes in the BU, that is: implicit mode.
Let only the rt protocol make do about prefixes.

Moreover, there are at least three ways by which a host learns routes
(rt protocol, icmp redirects, static config). Adding NEMO as a fourth
means only complicates the picture: one wants all four means to
distribute the same routing information; why not let NEMO just do the
Home-Address - Care-of-Address binding.

Alex

---

From: "Soliman Hesham" <[email-masked]>
Date: Sat, 3 Apr 2004 02:22:18 -0500

> > => Basically I think we need to make sure that the HA
 > > checks the routing information exchanged and matches it 
 > > against the prefix information that it already knows from
 > > the MNP table/manual config/BCEs ..etc to make sure that
 > > MRs are authorised to advertise such prefix(es). 
 > > So we need tight coupling between the routing protocol
 > > content and the content in the BU/manual config.
 > > Otherwise Bad Guy could send a vaild BU and start announcing
 > > someone else's prefix. 
 > 
 > we actually wanted to avoid exactly this kind of tight
 > coupling between running an IGP and NEMO basic support
 > protocol.

=> That intention is reflected in the current text.

 > 
 > consider two fixed routers running an IGP inside a
 > domain. is it possible for one router to advertise routes
 > to prefixes that it acutally does not own? if yes, I
 > dont think we need to fix it in NEMO if a mobile router
 > lies to its Home Agent. 

=> But this is not a fair comparison. Today routers will
only do that due to misconfiguration. All routers in
the same domain trust each other. However, this trust 
could not be assumed in the case where the MR does not
belong to the same admin domain. 

 > the bi-directional tunnel between the MR and the HA
 > actually extends the IGP domain to include the MR. thats
 > all. 

=> I don't think that's the point. The point is whether
the two nodes trust each other because they're under
the same admin domain. 

   NEMO basic support protocol only creates the
 > bi-directional tunnel (and few more things). we dont want
 > NEMO to do the verification for routing protocol updates.

=> I don't think we can get away with saying that 
"we don't want to do this". If the WG decides that this 
should not be done, then the draft MUST state that:
"In the case where the MR and the Home Agent are not under
the same administrative domain, the MR MUST not run 
a routing protocol to the Home Agent". 

I think this will avoid any ambiguity. But I don't know
if this is what the WG wants.

Hesham

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: "Soliman Hesham" <[email-masked]>
Date: Mon, 5 Apr 2004 05:15:33 -0400

> Asking this question: does IGP fill an important role in the 
 > scenario 
 > where MRs and HA belong to different domains and MRs don't 
 > trust each 
 > other? IGP doesn't fit into that model. So would any sane 
 > admin allow 
 > that to be used?

=> I consider myself sane and I wouldn't want to use IGPs
in this scenario ;)

 > 
 > I think Vijay summarized it well with:
 > "if there is sufficient trust between the MR and HA and they are
 > configured to exchange routing updates, just do that. nothing
 > for NEMO to do here. NEMO only creates the bi-directional tunnel
 > (and few other things).
 > 
 > if IGP cannot be run, the MR includes prefixes in binding update
 > in explicit mode. "
 > 
 > I would be happy with your statement above, Hesham.

=> Ok. I'm also fine with Vijay's "sufficient trust" part. 
So something along those lines is ok with me.

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Mon, 5 Apr 2004 05:15:33 -0400

Hesham