Subject: RE: Issue 42 (was Re: [nemo] Including prefix information in BU inexplicit mode)

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 20 Aug 2004 15:25:24 +0200

Hi Mattias:

It's just pretty hard to prevent configuring static routes and using explicit prefix at the same time. And this does not necessarily lead to wrongdoing. But it could, and this would lead to packets bouncing over MRHA till TTL. To avoid this, the key is that when the MR receives a packet from the HA, it should NEVER send it back to the HA. This is usual router behaviour, but it very critical to enforce it here.

Pascal

> -----Original Message-----
> From: Mattias Pettersson [mailto:[email-masked]]
> Sent: mardi 17 août 2004 10:56
> To: Pascal Thubert (pthubert)
> Cc: Vijay Devarapalli; Ryuji Wakikawa; [email-masked]
> Subject: Re: Issue 42 (was Re: [nemo] Including prefix information in BU inexplicit mode)
> 
> It is important that the HA and the MR has exactly the same perception
> on what prefixes are in use and what their respective registration
> lifetimes are.
> 
> IMHO I think it may be dangerous to mix explicit and implicit like you
> describe below. Do you think it will add functionality?
> 
> /Mattias
> 
> Pascal Thubert (pthubert) wrote:
> > If the MR has no prefix it can not add them. It needs to learn them. I'm not sure we ever
> said that explicit excluded implicit; If the HA has some prefixes for the MR, it can install
> them (e.g. static routes). If the MR claims others, then the HA can install them too. When
> the MR stops claiming prefixes it claimed before in explicit mode (HA knows because of prefix
> list) then the HA removes the forwarding states for those prefixes only.
> >
> > What do you think?
> >
> >

---

From: Mattias Pettersson <[email-masked]>
Date: Fri, 20 Aug 2004 16:14:32 +0200

Pascal Thubert (pthubert) wrote:
> Hi Mattias:
> 
> It's just pretty hard to prevent configuring static routes and using
> explicit prefix at the same time. And this does not necessarily lead to
> wrongdoing. But it could, and this would lead to packets bouncing over
> MRHA till TTL. To avoid this, the key is that when the MR receives a
> packet from the HA, it should NEVER send it back to the HA. This is
> usual router behaviour, but it very critical to enforce it here.

You may be correct that it is in fact up to the HA and MR to deal with 
synchronization of the static routes and that the BU signalling doesn't 
deal with them at all. Which in turn means that we can mix static and 
explicit.

To answer your last sentence, I didn't know this was usual router 
behaviour. To my knowledge the MR would forward the packet back over the 
MRHA tunnel and also send an ICMP redirect as the outgoing interface == 
receiving interface.

/Mattias

>>Subject: Re: Issue 42 (was Re: [nemo] Including prefix information in
> 
> BU inexplicit mode)
> 
>>>If the MR has no prefix it can not add them. It needs to learn them.
> 
> I'm not sure we ever
> 
>>said that explicit excluded implicit; If the HA has some prefixes for
> 
> the MR, it can install
> 
>>them (e.g. static routes). If the MR claims others, then the HA can
> 
> install them too. When
> 
>>the MR stops claiming prefixes it claimed before in explicit mode (HA
> 
> knows because of prefix
> 
>>list) then the HA removes the forwarding states for those prefixes
> 
> only.
> 
>>>What do you think?
>>>
>>>
> 
>