Subject: [nemo] Mobile Network Conops

From: "Davis, Terry L" <[email-masked]>
Date: Tue, 3 Aug 2004 00:23:38 -0700

TJ/Thierry

Sometime it helps if you have some rough CONOP requirements for the problem you are discussing.  For the aircraft (or ship), I can give you a bit of future view of what an aircraft CONOP requirements set "might" include.  Very little of this could be considered absolutely definite at this time but they are topics of discussion.

Some (probably most) of this does not apply to the NEMO problem space but it will give an idea of the challenges facing mobile networks and I think it will give you an idea why I favor HA-HA work remaining in NEMO.

Take care

Terry L Davis, P.E.

Associate Technical Fellow
Chief Network Engineer
Connexion by Boeing

Desk: 206-655-2359
Cell:   206-280-3716
Email: [email-masked]

===================================================================================================================

*	The aircraft will typically have access to Internet connectivity via three or more layer 2 communications.  Typically these will include: multiple satcom links, multiple wireless networks (802.11a/b/g & 802.15/20(?)), hardwired terrestrial, or infared.

*	The aircraft will periodically be on the operator/owners networks, the aircraft manufacturer's networks, multiple airline comm providers (Arinc, Sita, Inmarsat, CBB, etc), maintenance repair stations, multiple regulatory control networks (FAA/JAA/CAA/Eurocontrol), and multiple airports.  It will likely be normally on three or more of these simultaneously.

*	The aircraft will have continuous access to NO single layer 2 communication link.

*	The aircraft will be mixed v4 and v6 systems; some offboard communication support for both will be required.  V6 will likely not predominate until aircraft manufactured dates past 2020.

*	The aircraft may require specific comm types be sent over the layer 2 links in a very specific hierarchy to meet regulatory constraints.

*	The aircraft operator will require specific message prioritization and queueing by "link cost", priority, and bandwidth.

*	Most link connectivity points will move in hundreds or thousands of miles when they transfer between ground stations or airports.

*	Security will be different for all the networks the aircraft connects to.

*	Link performance characteristics and latency will be different for all links.

*	The solution must provide for ground based systems to connect to the mobile platform regardless what network it is connected to or where it is in the world.  (DNS/DHCP/etc)  Current aerospace standards make this impossible; only the aircraft can currently initiate communications.

*	Multiple DNS systems will be registered on the different links.  In some cases, due to the aerospace specs, link specific DNS services will likely be required.

*	Security, QoS, and reachability states must be maintained across link and ground station changes.

*	The aircraft will sometimes go for extended periods in hours with no Internet connectivity.

*	The aircraft will encounter areas where it will FLAP routes by crossing in and out satellite coverage fringe areas and during terminal approach (circling) holding patterns.

*	The aircraft will have multiple types of onboard networks as well; wired, wifi, infared, etc.

*	The aircraft may have multiple routers; each may be associated with different links and onboard networks.

*	The aircraft will most likely only receive communication and network major updates every 10 or 20 years.

*	There may be regulatory limitations on when and how configurations and routing can be updated.

---

From: Thierry Ernst <[email-masked]>
Date: Wed, 4 Aug 2004 01:55:08 +0900

Hi Terry,

Thank for your post.

Would you tell us what CONOP stands for, and would you provide the
official reference so that we could Lcite the goals below ?

About your goalsI'm pretty confident that these fit the objectives of
the NEMO WG activity (draft-requirements and draft-multihoming-issues)
as far as network mobility support is concerned.

- abality to set up multiple tunnels between MR and HA pairs -> we are
working to achieve this, tough we haven't yet decided which issues are
relevant to the NEMO WG, and which ones are relevant to other WGs

- v4/v6 interoperatbility: I don't think there is an issue; the question
I would ask is "what are the plans" to v6fy the **infrastructure** (on
the HA's side). It's not a problems if LFNs / VMNs do operate IPv4.

On the overall, I think that what you need in aircrafts spans a large
pannel of protocols (including security, AAA). So, is there any
requirement document that would specify what protocols specifically
would be used, and what are the missing pieces ? Is tere any community
like ISO or anything else working on such architecture design ?

Thierry.

On Tue, 3 Aug 2004 00:23:38 -0700

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 05 Aug 2004 15:28:48 +0200

Davis, Terry L wrote:
> Sometime it helps if you have some rough CONOP requirements for the 
> problem you are discussing.

Absolutely.

> For the aircraft (or ship), I can give you a bit of future view of 
> what an aircraft CONOP requirements set "might" include.  Very little
>  of this could be considered absolutely definite at this time but
> they are topics of discussion.

Terry, do these CONOP's relate somehow to the Card/Zabele/DoD demo
mentioned previously on this list?  They also talk aircraft and LOS.

> Some (probably most) of this does not apply to the NEMO problem space
>  but it will give an idea of the challenges facing mobile networks 
> and I think it will give you an idea why I favor HA-HA work remaining
>  in NEMO.

Yes, HAHA is intriguing.

[CONOPS]

Thanks for providing these requirements.

I think there is a need for an additional CONOP that says that there are
times when all wireless links of an airplane (except the ultra-urgent)
should be turned off (not just lowered its QoS, but switched off), I think.

> *	The aircraft will typically have access to Internet connectivity 
> via three or more layer 2 communications.  Typically these will 
> include: multiple satcom links, multiple wireless networks 
> (802.11a/b/g & 802.15/20(?)), hardwired terrestrial, or infared.
> 
> *	The aircraft will periodically be on the operator/owners networks,
>  the aircraft manufacturer's networks, multiple airline comm
> providers (Arinc, Sita, Inmarsat, CBB, etc), maintenance repair
> stations, multiple regulatory control networks
> (FAA/JAA/CAA/Eurocontrol), and multiple airports.  It will likely be
> normally on three or more of these simultaneously.

Are all those networks connected together in a sort of mesh of
high-speed links?  Or is each one of them connecting to the Internet via
its own ISP?

Can the HAHA concept help with this sort of deployment mentioned above?
  How?  Is there anything missing in HAHA that needs improvement?

> *	The aircraft will be mixed v4 and v6 systems; some offboard 
> communication support for both will be required.  V6 will likely not
>  predominate until aircraft manufactured dates past 2020.
> 
> *	The aircraft may require specific comm types be sent over the layer
>  2 links in a very specific hierarchy to meet regulatory constraints.
> 
> 
> 
> *	The aircraft operator will require specific message prioritization
>  and queueing by "link cost", priority, and bandwidth.
> 
> *	Most link connectivity points will move in hundreds or thousands of
>  miles when they transfer between ground stations or airports.
> 
> *	The solution must provide for ground based systems to connect to 
> the mobile platform regardless what network it is connected to or 
> where it is in the world.  (DNS/DHCP/etc)  Current aerospace 
> standards make this impossible; only the aircraft can currently 
> initiate communications.
> 
> *	Multiple DNS systems will be registered on the different links.  In
>  some cases, due to the aerospace specs, link specific DNS services 
> will likely be required.
> 
> *	The aircraft will encounter areas where it will FLAP routes by 
> crossing in and out satellite coverage fringe areas and during 
> terminal approach (circling) holding patterns.
> 
> *	The aircraft will most likely only receive communication and 
> network major updates every 10 or 20 years.
> 

This should be a bit re-formulated.  "Routing" and "regulatory body"
don't quite match.

Alex