Subject: Re: [nemo] NAT/PAT transfersal over IPv4 networks

From: Thierry Ernst <[email-masked]>
Date: Thu, 21 Oct 2004 11:58:03 +0900

Dear all,

There was this discussion in early August, so I wonder if there is
anything that we should do in the NEMO WG regarding this, and otherwise
if there is anyone in our group willing to take a close look at the work
done in v6ops. 

Thanks,
Thierry.

On Wed, 4 Aug 2004 07:30:03 +0100
Tim Chown <[email-masked]> wrote:

> I think NAT is a consideration for the assisted tunneling requirements
> analysis that is happening in v6ops.   Have you read that?
> http://www.ietf.org/internet-drafts/draft-ietf-v6ops-assisted-tunneling-requirements-00.txt
> 
> It is NAT-PT that is pushed to the "last resort" status in v6ops (there is
> a new push to write up why in an applicability statement, agreed this week).
> 
> I can't find any active  reference to "doors" - could you provide a pointer?
> Looks like nemo should be talking to v6ops here :) 
> 
> thanks,
> tim
> 
> On Wed, Aug 04, 2004 at 07:23:19AM +0200, Pascal Thubert (pthubert) wrote:
> > Well, as I understand the work being done at the MIP6 or v6Ops, Doors is not considered because of IPR. On the other hand, since the IPR encumbering is the basically same as that of nemo basic support, doors should be acceptable within Nemo. So there IS something that is Nemo specific after all.
> > 
> > There was a discussion in Seoul about NAT traversal (I asked Hesham over the mike) - correct me if I'm wrong - they are not covering NAT in the current ipv4/IPv6 interoperability solutions. So we end up with in one hand a non standard thing (doors) that has now been thoroughly tested and goes though all sorts of NAT including reverse and symmetrical, or in the other end the beginning of what may be a MIP remake of v6ops transition story.
> > 
> > Could we just standardize doors so we can deliver something efficient to our customers? And then if alternates pop up, they'll have to prove they are better in that space.
> > 
> > Pascal
> > 
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On Behalf Of Thierry Ernst
> > > Sent: mercredi 4 août 2004 01:41
> > > To: nemo
> > > Subject: Re: [nemo] NAT/PAT transfersal over IPv4 networks
> > > 
> > > 
> > > Hi Will,
> > > 
> > > Actually, the draft-iett-nemo-requirements mention NAT traversal and
> > > IPv4-IPv6 transitin, so that is something we do care about. This said,
> > > we concluded last year that there wasn't NEMO-specific issues. If there
> > > is one, I think the WG should defintely address it. If these are issues
> > > not specific to NEMO, we need to make sure these issues are addressed by
> > > the relefvant WG.
> > > 
> > > In any case, I agree with your statement.
> > > 
> > > Thierry.
> > > 
> > > 
> > > 
> > > 
> > > On Tue, 03 Aug 2004 18:21:37 -0400
> > > ivancic <[email-masked]> wrote:
> > > 
> > > > Thierry and/or TJ asked if there was additional work that NEMO should
> > > > address prior to closing or rechartering.
> > > >
> > > > I strongly believe that the group should standardize on a NAT/PAT
> > > > transversal over IPv4 backbones.   This will greatly increase the
> > > > ability to deploy NEMO IPv6 networks.  The US DoD, Japan, Korea, the
> > > > European Nations and just about any Industrial nations is trying to help
> > > > kick-start IPv6 deployments.  However, the ISP's and industry do not yet
> > > > have a good business case.  Making the transission easier will help ALL
> > > > of IPv6 deployments.   I used some of Pascal's IPv6  NEMO code with the
> > > > "Doors" protocol and demonstrated this to the CIO of the US DoD.  The
> > > > ability to run IPv6 over IPv4 and mix networks was very very important.
> > > >
> > > > See:
> > > > http://roland.grc.nasa.gov/~ivancic/ICNS2004_Demo/ICNS2004_Demo.htm
> > > > Note, the "off-site demonstrations in Washington D.C. area" was for the
> > > > Office of Secretary of Defense in order to show a migration path from
> > > > IPv4 to IPv6.
> > > >
> > > >
> > > > Will
> > > >
> > > > --
> > > > ******************************
> > > > William D. Ivancic
> > > > Phone 216-433-3494
> > > > Fax  216-433-8705
> > > > Lab  216-433-2620
> > > > Mobile  440-503-4892
> > > > http://roland.grc.nas.gov/~ivancic
> > > >
> > > >
> > > >
> > > 
> > 
> > 
> 
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 21 Oct 2004 14:09:03 -0700

Thierry,

I personally prefer a solution based on Ryuji's draft
http://www.ietf.org/internet-drafts/draft-wakikawa-nemo-v4tunnel-00.txt

the Mobile Router basically registers its IPv4 CoA with its Home Agent
which supports both IPv4 and IPv6. the outer tunnel would be between
the MR's IPv4 CoA and HA's IPv4 address. the inner tunnel would be
between the MR's IPv6 HoA (MNN's IPv6 address) and the CN's IPv6
address. for traffic between the MR and the HA, the inner tunnel would
be between the MR's IPv6 HoA and HA's IPv6 address.

this eliminates double tunneling. with "Doors", for example you end
up with a NEMO tunnel inside a Doors tunnel. with the above solution,
you end up with a single NEMO tunnel with outer IPv4 header and inner
IPv6 header.

I was planning to write up something on this, but didnt get to do it
before the ID cutt-off deadline. if its okay with the chairs, I would
like to present a couple of slides at the next meeting.

Vijay

Thierry Ernst wrote:

>>>>Sent: mercredi 4 ao{t 2004 01:41
>>>>To: nemo

---

From: ivancic <[email-masked]>
Date: Fri, 22 Oct 2004 10:02:44 -0400

I was one of the people suggesting that the Doors work or something 
functionally similar be standardized for NEMO.  That is,  NAT/PAT 
transversal needs to be done for initial deployments.  In the US, I have 
run over Sprint, Verizon and T-Mobile.  All were using IPv4 in the 
backbone for GPRS and 1xRTT wireless networks at the time.   In 
addition, T-Mobile was doing administrative filtering which acted just 
like a NAT.  The Doors implementation worked well. 

I looked at what v6ops was doing regarding transitions, and, to the best 
of my knowledge and interpretation,  they are not addressing mobility 
issues at this time.  In addition, how quickly or if this draft will 
result in anything is anyones guess.

Requirements for assisted tunneling
<draft-ietf-v6ops-assisted-tunneling-requirements-00.txt>

Pascal already has working code.  It seems to me that the v6ops group 
could learn much from the Doors work, at least regarding functional 
aspects - assuming they want to stay away from the IPR issues.

Regardless, IMHO, if one wants to really deploy nemo implementations 
throughout the world, integrating NAT Transversal and IPv4 tunneling is 
necessary.  Obviously, a direct IPv6 connection is desired, but, if you 
only have IPv4 connectivity at you WAN attachment points, you really do 
not have much choice.

Will

Thierry Ernst wrote:

>quoted-printable
>MIME-Version: 1.0
>Content-Type: text/plain; charset="ISO-8859-1"
>Content-Transfer-Encoding: quoted-printable
>quoted-printable
>
>
>Dear all,
>
>if there is anyone in our group willing to take a close look at the =
>work
>done in v6ops.=20
>
>Thanks,
>Thierry.
>
>
>
>
>
>>I think NAT is a consideration for the assisted tunneling =
>>    
>>
>requirements
>  
>
>>=
>http://www.ietf.org/internet-drafts/draft-ietf-v6ops-assisted-tunneling-=
>requirements-00.txt
>  
>
>>=20
>>It is NAT-PT that is pushed to the "last resort" status in v6ops =
>>    
>>
>(there is
>  
>
>>a new push to write up why in an applicability statement, agreed this =
>>    
>>
>week).
>  
>
>>=20
>>I can't find any active  reference to "doors" - could you provide a =
>>    
>>
>pointer?
>  
>
>>Looks like nemo should be talking to v6ops here :)=20
>>=20
>>thanks,
>>tim
>>=20
>>On Wed, Aug 04, 2004 at 07:23:19AM +0200, Pascal Thubert (pthubert) =
>>    
>>
>wrote:
>  
>
>>>Well, as I understand the work being done at the MIP6 or v6Ops, =
>>>      
>>>
>Doors is not considered because of IPR. On the other hand, since the =
>IPR encumbering is the basically same as that of nemo basic support, =
>doors should be acceptable within Nemo. So there IS something that is =
>Nemo specific after all.
>  
>
>>>=20
>>>There was a discussion in Seoul about NAT traversal (I asked Hesham =
>>>      
>>>
>over the mike) - correct me if I'm wrong - they are not covering NAT in =
>the current ipv4/IPv6 interoperability solutions. So we end up with in =
>one hand a non standard thing (doors) that has now been thoroughly =
>tested and goes though all sorts of NAT including reverse and =
>symmetrical, or in the other end the beginning of what may be a MIP =
>remake of v6ops transition story.
>  
>
>>>=20
>>>Could we just standardize doors so we can deliver something =
>>>      
>>>
>efficient to our customers? And then if alternates pop up, they'll have =
>to prove they are better in that space.
>  
>
>>>=20
>>>Pascal
>>>=20
>>>=20
>>>      
>>>
>>>>From: [email-masked] [mailto:[email-masked]] On =
>>>>        
>>>>
>Behalf Of Thierry Ernst
>  
>
>>>>Sent: mercredi 4 ao=FBt 2004 01:41
>>>>To: nemo
>>>>=20
>>>>=20
>>>>=20
>>>>Actually, the draft-iett-nemo-requirements mention NAT traversal =
>>>>        
>>>>
>and
>  
>
>>>>IPv4-IPv6 transitin, so that is something we do care about. This =
>>>>        
>>>>
>said,
>  
>
>>>>we concluded last year that there wasn't NEMO-specific issues. If =
>>>>        
>>>>
>there
>  
>
>>>>is one, I think the WG should defintely address it. If these are =
>>>>        
>>>>
>issues
>  
>
>>>>not specific to NEMO, we need to make sure these issues are =
>>>>        
>>>>
>addressed by
>  
>
>>>>the relefvant WG.
>>>>=20
>>>>=20
>>>>=20
>>>>=20
>>>>=20
>>>>=20
>>>>=20
>>>>>Thierry and/or TJ asked if there was additional work that NEMO =
>>>>>          
>>>>>
>should
>  
>
>>>>>I strongly believe that the group should standardize on a =
>>>>>          
>>>>>
>NAT/PAT
>  
>
>>>>>transversal over IPv4 backbones.   This will greatly increase =
>>>>>          
>>>>>
>the
>  
>
>>>>>ability to deploy NEMO IPv6 networks.  The US DoD, Japan, =
>>>>>          
>>>>>
>Korea, the
>  
>
>>>>>European Nations and just about any Industrial nations is =
>>>>>          
>>>>>
>trying to help
>  
>
>>>>>kick-start IPv6 deployments.  However, the ISP's and industry =
>>>>>          
>>>>>
>do not yet
>  
>
>>>>>have a good business case.  Making the transission easier will =
>>>>>          
>>>>>
>help ALL
>  
>
>>>>>of IPv6 deployments.   I used some of Pascal's IPv6  NEMO code =
>>>>>          
>>>>>
>with the
>  
>
>>>>>"Doors" protocol and demonstrated this to the CIO of the US =
>>>>>          
>>>>>
>DoD.  The
>  
>
>>>>>ability to run IPv6 over IPv4 and mix networks was very very =
>>>>>          
>>>>>
>important.
>  
>
>>>>>See:
>>>>>=
>>>>>          
>>>>>
>>>>>Note, the "off-site demonstrations in Washington D.C. area" was =
>>>>>          
>>>>>
>for the
>  
>
>>>>>Office of Secretary of Defense in order to show a migration =
>>>>>          
>>>>>
>path from
>  
>
>>>>>IPv4 to IPv6.
>>>>>
>>>>>
>>>>>Will
>>>>>
>>>>>--
>>>>=20
>>>=20
>>>=20
>>=20
>>=20