Subject: RE: [nemo] New draft on prefix delegation

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 20 Oct 2004 11:54:56 +0200

Sorry for being unclear:

My understanding was to base the WG doc on the initial (00) draft by
Ralph. The LMM solution that was added in 01 will be taken out as far as
I understand. Does not mean it's not a good solution, but it addresses a
different topic. So we split. The MR to HA PD becomes the WG doc, and
the LMM stays in the author-named doc.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of Vijay Devarapalli
> Sent: mercredi 20 octobre 2004 07:19
> To: Alexandru Petrescu
> Cc: IETF NEMO WG; Pascal Thubert (pthubert); T.J.Kniveton
> Subject: Re: [nemo] New draft on prefix delegation
> 
> Alexandru Petrescu wrote:
> > Pascal Thubert (pthubert) wrote:
> >
> >>> Other methods could be DHCP, and even piggybacking with Mobile
Prefix
> >>> Discovery or with Dynamic Home Agent Address Discovery, etc.
> >>>  I'm tempted to favor DHCP, see below.
> >>>
> >> You mean DHCPv6PD right? Well, Ralph's draft is more valid then
ever.
> >>  In fact, it's a WG doc.
> >
> >
> > You mean draft-droms-nemo-dhcpv6-pd-01.txt is a WG item?  There are
> > aspects in that draft that are not necessary in order to delegate
> > prefixes from HA to MR (Tree Options, MR obtaining a prefix from AR,
etc.)
> I agree.
> Vijay

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 20 Oct 2004 14:51:40 +0200

Hi Vijay:

What they did at the time was pretty different in goals and features
than what we propose now. Yet, their work is acknowledged in the draft. 

You might want to go through the new draft, in particular there is a
long and detailed chapter on the Motivation for NEMO prefix delegation.

Pascal

Of Vijay Devarapalli
> Sent: mercredi 20 octobre 2004 04:05
> To: Alexandru Petrescu
> Cc: IETF NEMO WG; T.J.Kniveton; Pascal Thubert (pthubert)
> > Finally, my oppinion is that the method used by the MIP6 WG to
assign a
> > Home Address to MN should be used by NEMO too, for prefixes.  That
is,
> > if MIP6 MN generates the Home Address from DHAAD+MPD then NEMO
should do
> > MNP from MPD.  If MIP6 assigns the Home Address from DHCP, then NEMO
> > should do MNP from DHCP too.  Same with BU/BAck.
> 
> there was such a draft proposed in March 2003 extending the Mobile
> Prefix discovery mechanism to delegate prefixes for the Mobile Router.
> see
>
http://www.mobilenetworks.org/nemo/drafts/draft-paakkonen-nemo-prefix-de
legation-00.txt
> 
> at that time, the NEMO WG rejected the draft saying that we already
> have a mechanism through DHCPv6.
> 
> Vijay