Subject: [nemo] NEMO RO problem draft submit

From: "Fan Zhao" <[email-masked]>
Date: Mon, 18 Oct 2004 00:17:01 -0700 (PDT)

Dear all,

We have submitted a NEMO RO problem draft.
In case that it has not been up in the I-D list,
you can access it at:
http://wwwcsif.cs.ucdavis.edu/~zhaofa/NEMORO/draft-zhao-nemo-ro-ps-00.txt
or http://wwwcsif.cs.ucdavis.edu/~zhaofa/NEMORO/draft-zhao-nemo-ro-ps-
00.html.
Your comments are greatly appreciated. Thanks.

Sincerely,
fan

---

From: 박기용_건국대 <[email-masked]>
Date: Mon, 18 Oct 2004 21:35:16 +0900

Dear all,

I already read a draft about the solution of NEMO RO problem using Prefix Delegation Mechanism in IPv6
You can access it at :
http://www-users.cs.umn.edu/~jjeong/publications/ietf-internet-draft/draft-leekj-nemo-ro-pd-01.txt

I think it is abolutely correct solution of NEMO RO problem.
Any other opinion, it will be great to me.

Best regard
Kiyong Park.

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 18 Oct 2004 17:44:02 +0200

박기용_건국대 wrote:
> I already read a draft about the solution of NEMO RO problem using 
> Prefix Delegation Mechanism in IPv6 You can access it at : 
> I think it is abolutely correct solution of NEMO RO problem. Any 
> other opinion, it will be great to me.

Hello Kiyong Park.

IMHO it is debatable whether that PD with Neighbour Discovery solution
is a correct solution for the NEMO RO problem since we don't know
exactly what the RO problem is.

If the RO problem is that MN-behind-MR communication to CN goes through
HA (instead of directly) then yes, that PD solution is solving it.  If
on the other hand the problem is that LFN-behind-MR communication to CN
goes through HA (instead of directly) then no, that PD solution is not
solving it, because that draft does not describe how MR performs RO on
behalf of LFN (LFN does not do Mobile IPv6).  In my understanding.

Alex

---

From: Park KiYong <[email-masked]>
Date: Tue, 19 Oct 2004 03:09:15 +0900

Dear Alex,

I have different opinion

If the case is MN behind MR, it is right as you said.

If the case is LFN behind MR, it can be solved by existing IPv6 techniques

the case of LFN behind MR must be routed through HA.

I think that the MR keeps home network prefixes it received from Home Network's Router.

And CN to LFN will be routed through CN-HA-LFN, because the MR did registration 
request with its home network prefixes to its HA.

Although the network prefixes was changed and LFN's address was changed in new 
network, the communication will be kept by 'Address renumbering mechanism in IPv6'.

Because of that, the communication will not be lost.

Please, reply me with your opinion.

Best regard.
Kiyong Park.

Alexandru Petrescu <[email-masked]> wrote:

> Kiyong Park wrote:

--------------------------------------------
This mail sent through CCLab web mail server

---

From: Park KiYong <[email-masked]>
Date: Tue, 19 Oct 2004 03:46:27 +0900

Dear Alex.

Please, ignore my opinion.

I didn't think about the case that the MR moves from old Foreign Network to new Foreign 
Network.

I'll think over the solution.

Best regard.
Kiyong Park.