Subject: RE: [nemo] Re: Comments ondraft-clausen-nemo-ro-problem-statement-00.txt

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Thu, 18 Nov 2004 09:56:56 +0100

Right.

I believe that there is a great interest in digging more into a MANET based solutions. 

But We can not say 'any MANET' will do. We must explicit what our priorities are and what features we care for. And we must come back with a single MANET version so there's a chance to get standard track one day.

Example of requirements:

1) The MObile Adhoc for NEMO should primarily focus on providing a default route to the infrastructure for each node.

2) Then it should provide the capability for routers to exchange routes and communicate even if a connection to the infrastructure is not available.

3) It should allow the formation of a nested NEMO in a controlled fashion. In particular, it should be possible to form specific groups, control the size and other topological criteria. 

4) There should be a solution to interconnect nested NEMOs as opposed to forming ever larger structures.

5) The Protocol must fit in a nested NEMO solution where redistribution of the NEMO prefixes into the infrastructure is not required. In that solution, Mobile Routers can form a NEMO CareOf address from an address or a prefix that is topologically correct at the edge of the nested NEMO.

6) ...

In my mind, 

1) is more in the proactive side since it is the most important route for NEMO. 

2) means that our specific MANET must exchange prefixes, but does not imply it should be proactive. In fact, in many scenarios, it is not used at all (eg. Individuals in Bus, trains, etc...) . But in some scenarios, it is mandatory and has to cope with some good degree of inner mobility (eg. Earthquake). So It see that as either on-demand, or in a LORA space, to limit the operational cost. 

I'm not sure that from the current charter, the NEMO list is the right place to discuss all this, though... sorry about that.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ryuji Wakikawa
> Sent: jeudi 18 novembre 2004 08:20
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [nemo] Re: Comments ondraft-clausen-nemo-ro-problem-statement-00.txt
> 
> 
> Hello Carlos
> 
> Sorry for late reply.
> 
> You are right.
> 
> We can not achieve an optimal route for Internet-toNEMO only with
> MANET. In the Internet-to-"Nested"NEMO case, MANET can help optmized
> routing for a few hops (that are inside nested NEMO).
> 
> For example, if nested MR sends BU with root-MR's CoA, packets are
> directly reached to root-MR and root-MR can route packets to the
> nested MR by MANET. You may be interested in ORC draft.
> http://www1.ietf.org/internet-drafts/draft-wakikawa-nemo-orc-00.txt
> 
> thanks
> ryuji
> 
> 
> 
> At Mon, 08 Nov 2004 10:34:50 +0100,
> Carlos Jesús Bernardos Cano wrote:
> >
> > [1  <text/plain; iso-8859-15 (quoted-printable)>]
> > Hi Ryuji,
> >
> > First of all, thanks for submitting the draft.
> >
> > Your draft seems to address the problem of the Internet-to-NEMO
> > communication and the NEMO-to-NEMO communication when nesting is
> > involved, using a MANET approach. I agree with you that in the
> > NEMO-to-NEMO approach, having the MRs in a nested-NEMO running an Ad-Hoc
> > routing protocol would help to avoid traversing the Internet and also
> > avoid the encapsulation. On the other hand, I don't see that clear how
> > this would help the Internet-to-NEMO, at least as it is now described in
> > the current version of your draft.
> >
> > The draft says:
> >
> >    "Additionally, this would also ease the Internet-to-NEMO scenario. In
> >    order to deliver an IP datagram to a node in the nested NEMO network,
> >    only a path to the access router between the nested NEMO network and
> >    the Internet would be required: once an IP datagram arrives in the
> >    nested NEMO network, the routing tables in the mobile routers, as
> >    provided by OLSR, would allow direct routing to the destination.
> >    Thus, there would no longer be a requirement to do nested encapsula-
> >    tion on each logical hop (i.e. each transversal of a Home Agent) in
> >    order to be able to decapsulate and correctly forward IP datagrams in
> >    the nested NEMO network.
> >
> >
> >    Thus even if no route optimizations are performed in the Internet-to-
> >    NEMO scenario, an overhead reduction can still be achieved through
> >    much lower encapsulation requirements."
> >
> > How this improvements are achieved? If a CN in the Internet sends a
> > packet to a MNN that is connected to a nested-NEMO, the packet would
> > traverse the HAs of every MR in the nested-NEMO until the MNN is finally
> > reached. Therefore, I don't see how this encapsulation would be avoided,
> > without making any additional change to the MR and/or HA and/or CN. Am I
> > missing something?
> >
> > Thanks in advance.
> >
> > Kind Regards,
> >
> > Carlos J.
> >
> > --
> > Carlos Jesús Bernardos Cano - http://www.it.uc3m.es/cjbc/
> > GPG FP: 58C3 4227 AF8D 01D4 5A09  A617 E6F2 B23E DAD6 AA40
> > [2 Esta parte del mensaje está firmada	digitalmente <application/pgp-signature (7bit)>]
> >

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 19 Nov 2004 05:24:36 +0900

Hi Pascal

At Thu, 18 Nov 2004 09:56:56 +0100,
pascal wrote:
> But We can not say 'any MANET' will do. We must explicit what our
> priorities are and what features we care for. And we must come back
> with a single MANET version so there's a chance to get standard
> track one day.

I did not say "any MANET";-)

The draft is problem statement and tries to expose the possibility of
MANET to some NEMO issue.

> Example of requirements:
> 
> 1) The MObile Adhoc for NEMO should primarily focus on providing a
>    default route to the infrastructure for each node.

This feature is discussed at MANET WG.

> 2) Then it should provide the capability for routers to exchange
>     routes and communicate even if a connection to the infrastructure
>     is not available.

Yes, it is MANET's original feature.

> 3) It should allow the formation of a nested NEMO in a controlled
>    fashion. In particular, it should be possible to form specific
>    groups, control the size and other topological criteria.

Yes, this is operational. 

> 4) There should be a solution to interconnect nested NEMOs as
>    opposed to forming ever larger structures.

aggregation?

> 5) The Protocol must fit in a nested NEMO solution where
>    redistribution of the NEMO prefixes into the infrastructure is
>    not required. In that solution, Mobile Routers can form a NEMO
>    CareOf address from an address or a prefix that is topologically
>    correct at the edge of the nested NEMO.

which address is used for CoA?

> 1) is more in the proactive side since it is the most important route for NEMO. 

ok

> 2) means that our specific MANET must exchange prefixes, but does
> 2) not imply it should be proactive. In fact, in many scenarios, it
> 2) is not used at all (eg. Individuals in Bus, trains, etc...) . But
> 2) in some scenarios, it is mandatory and has to cope with some good
> 2) degree of inner mobility (eg. Earthquake). So It see that as
> 2) either on-demand, or in a LORA space, to limit the operational
> 2) cost.

The overhead depends on which MANET routing is used for MR and how big manet is.

> I'm not sure that from the current charter, the NEMO list is the
> right place to discuss all this, though... sorry about that.

well, the discussion of RO solution is not begun yet, too.
But it might be true that we need more thoughts on this with people
from NEMO and MANET WG.

regards,
ryuji