Subject: RE: [nemo] Re: [Mip6] draft-soliman and draft-wakikawa

From: [email-masked]
Date: Wed, 6 Apr 2005 10:33:07 -0700

Alex,

I think you misunderstood what Ryuji sent. we do plan to
use UDP encapsulation if a NAT is present. nobody is
throwing that out. 

Ryuji was talking about the scenario where a mobile binds
a IPv6 CoA to a IPv4 HoA. he saying he is not interested
in this scenario.

Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Alexandru Petrescu
> Sent: Wednesday, April 06, 2005 4:55 AM
> To: Ryuji Wakikawa
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [nemo] Re: [Mip6] draft-soliman and draft-wakikawa
> 
> 
> Ryuji Wakikawa wrote:
> > We will design an extension using mobility option to solve 
> NAT issue 
> > and throw away MIPv4 support which is not our goal in the draft.
> 
> Ryuji, how are you going to design this extension with a mobility
> option?  I know of a NAT that blocks all IP-in-IP and as long as the
> mobility option is deep below IP it's going to be of no use.
> 
> MIP4 has a nice feature for NAT traversal, that I know implemented. 
> That feature could be re-used.  I don't understand why you 
> would throw 
> it away and design a new option in the mobility header?
> 
> Alex
> 
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Apr 2005 20:01:41 +0200

> a IPv6 CoA to a IPv4 HoA. he saying he is not interested

I agree with that.  The scenario me too I'm interested in is traversing 
the v4.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Apr 2005 20:11:38 +0200

[email-masked] wrote:

> Alex,
> 
> I think you misunderstood what Ryuji sent. we do plan to use UDP
> encapsulation if a NAT is present. nobody is throwing that out.

Sorry to misunderstanding Ryuji.  I think v6-in-UDPv4 should be used
independently of NAT being used or not used.  Whether I misunderstand
anybody with this - it's your call.  All I want to say is that this
aspect (use IPv6-in-UDPv4 independently of NAT/no NAT) should be considered.

> Ryuji was talking about the scenario where a mobile binds a IPv6 CoA
> to a IPv4 HoA. he saying he is not interested in this scenario.

Me too I'm not interested in this particular scenario here and today.
But I am interested in MIP4 using UDP for NAT traversal and MIP6 using
the same UDP tunnel.

And I'll take the remark from Pekka into account here - maybe it's too 
early to discuss these solution technicalities.  In this case let's see 
about scoping and requirements.

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 06 Apr 2005 11:24:02 -0700

> aspect (use IPv6-in-UDPv4 independently of NAT/no NAT) should be 

okay. infact, using UDP all the time is quite popular (even my
corporate VPN access uses UDP tunneling all the time). but we
shouldnt specify that UDP tunneling should be on all the time
in an IETF standard. if a NAT is not there (being optimistic),
we dont want the additional per-packet overhead.

Vijay

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 11 Apr 2005 04:43:54 +0900

Hi Alex

excuse my late reply. 

At Wed, 06 Apr 2005 20:11:38 +0200,
> aspect (use IPv6-in-UDPv4 independently of NAT/no NAT) should be considered.

There are many options which tunnel we will use on MIPv6 for NAT or no
NAT network. However, we need to think about signaling between MN-HA
to deal with IPv4 network. In our draft, we provide many tunnel
methods support,but I don't have strong intention for this. I mean we
can discuss this later.

> But I am interested in MIP4 using UDP for NAT traversal and MIP6 using

That's one possibility if it's worth to consider. Maybe yes in terms
of filitering/blocks.

> about scoping and requirements.

let's discuss these once WG takes action:-)

ryuji