Subject: RE: [nemo] Re: [Mip6] Consensus call on making ID draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 1 Apr 2005 16:58:28 +0200

Agreed...

Another angle is that HAs are already being sold and deployed. There is
value in incremental features that do not change the HA and the
surrounding infrastructure.

For instance, in the PE-Based model, corporations only own the routing
within their VPN, and the global addresses are owned by the service
provider. Unless they deploy a specific exit with DMZ, firewall and so
on, they will not have a single box with a global IPv4 address to put an
HA on. 

Do we want to limit the solution to these corps that have a DMZ?

Pascal

| -----Original Message-----
| From: [email-masked] [mailto:[email-masked]] On Behalf
Of
| Sri Gundavelli (sgundave)
| Sent: Friday, April 01, 2005 1:18 AM
| To: Narayanan Vidya-CVN065
| Cc: [email-masked]; [email-masked]; 'Vijay Devarapalli'; Henrik
Levkowetz;
| [email-masked]
| Subject: RE: [nemo] Re: [Mip6] Consensus call on making ID
draft-wakikawa-
| nemo-v4tunnel a MIP6/NEMO WGs document
| 
| 
| Vidya,
| 
| Any transition solution should offer a way for a phased
| migration. I do not see how the current solution will
| enable the operator to push the v4 network in a phased
| manner. The requirements that the HA should be on the
| edge or if 90% of the deployments will go for that model
| is debatable and can only be answered by going for a
| problem statement.
| 
| Regards
| Sri
| 
| 
| 
| On Thu, 31 Mar 2005, Narayanan Vidya-CVN065 wrote:
| 
| > Sri,
| > I also understood your comments exactly as Vijay did. A couple of
years
| ago, I did hear about some concerns on placing the HA in the DMZ, but
I
| didn't think any of those were very deep. Is there really a deployment
| issue in placing the HA in the DMZ?
| >
| > Actually, even if you did place the HA deep in the IPv6 network,
forcing
| the need for a tunneling box in the DMZ that does v4-v6 tunneling, is
that
| really that bad?
| >
| > If most deployments don't have an issue with the placement of the HA
in
| the DMZ and a small percentage of the cases do, it does not seem too
bad
| to me to say that a solution is simple since it solves the 90% case.
I'd
| vote for that rather than make it really complex to also solve the 10%
| case.
| >
| > My 2 cents,
| > Vidya
| >
| > -----Original Message-----
| > From: [email-masked] [mailto:[email-masked]] On Behalf
Of
| Vijay Devarapalli
| > Sent: Thursday, March 31, 2005 2:02 PM
| > To: Henrik Levkowetz
| > Cc: [email-masked]; [email-masked]; [email-masked]
| > Subject: [nemo] Re: [Mip6] Consensus call on making ID
draft-wakikawa-
| nemo-v4tunnel a MIP6/NEMO WGs document
| >
| >
| > Henrik,
| >
| > there is some mis-understanding regarding the relation
| > between draft-soliman and draft-wakikawa. both solve the scenario of
a
| v6 MN or MR accessing its v6 home agent from a v4 only access network.
| draft-soliman talks about using a IPv4 mapped IPv6 address to convey
the
| IPv4 CoA to the HA. draft-wakikawa uses a new mobility option to carry
the
| IPv4 CoA. I personally prefer carrying it in a separate mobility
option,
| because it makes processing on the HA easier. we can debate the pros
and
| cons of this later. but this *does* not impact the scenario. both
solve
| the same scenario.
| >
| > there are other scenarios, but IMHO, they are not relevant.
| >
| > regarding Sri's concerns, we do intend to address them. dont worry
about
| that. we have an assumption in the draft.
| >
| > - the HA's IPv4 address is reachable through the IPv4 internet
| >
| > Sri is questioning this assumption. he is claiming this is
| > not so easy. he doesnt want IPv4 routing inside his IPv6 network.
the HA
| is deep inside in the IPv6 network. for the HA's IPv4 address to be
| reachable, you might need a box in the DMZ, which traps the packets
for
| the HA's IPv4 address and tunnels them to the HA deep in the IPv6
network.
| but here we end with extra tunneling between the box sitting in the
DMZ
| and the HA deep in the IPv6 network. another option is to place the HA
in
| the DMZ. but he doesnt want to do that. I will be discussing with him
to
| see how we can come up with a solution. Sri, let me know if I still
dont
| understand the issue you are bringing up.
| >
| > Vijay
| >
| > Henrik Levkowetz wrote:
| > > Hi,
| > >
| > > On 2005-03-30 9:33 pm [email-masked] said the
following:
| > > [...]
| > >
| > >>A number of transition scenarios have been identified in IDs:
| > >>1. draft-larsson-v6ops-mip-scenarios-01
| > >>2. draft-tsirtsis-dsmip-problem-03
| > >>While discussion of these scenarios in the larger scope makes
sense,
| > >>there is a need to focus on the most critical scenario that would
| > >>address the MIP6 host and router problem. The problem in a single
| > >>sentence can be stated as: "Mobile IPv6 hosts and routers (NEMO)
need
| > >>to be able to reach its (IPv6) home agent and services when
roaming in
| > >>and attached to an IPv4 access network."
| > >>It makes sense to focus on just this one scenario and solve the
| > >>problem immediately.
| > >
| > >
| > > Given that there already exists at least 3 solution drafts in this
| > > area:
| > >
| > >   draft-thubert-nemo-ipv4-traversal
| > >   draft-soliman-v4v6-mipv6
| > >   draft-wakikawa-nemo-v4tunnel
| > >
| > > and Sri clearly indicates that there are requirements which these
| > > don't cover, I think it would be good to have a clear and agreed
upon
| > > statement of what to achieve before adopting an approach and
draft.
| > > So I'm not for adopting draft-wakikawa before there is an agreed
upon
| > > problem statement.
| > >
| > > That said, I'm very much in favour of doing this work; and doing
it by
| > > extensions to MIP6 (and MIP4) rather than trying to adapt any of
the
| > > other approaches which would mix MIP6 with non-MIP tunnels, as
listed
| > > in draft-larsson-v6ops-mip-scenarios-01.
| > >
| > > If the decision is to write a problem statement, I'd be willing to
| > > work on such a draft, and I also have a potential co-editor who
have
| > > indicated willingness.
| > >
| > >
| > >>The ID: draft-wakikawa-nemo-v4tunnel-01 solves the problem of a
MIPv6
| > >>mobile node or a NEMO mobile router roaming onto a IPv4 only
access
| > >>network in a simple manner.
| > >>It is intended that the standardization of this solution in the
IETFs
| > >>MIP6 and/or NEMO working groups proceed. The working group chairs
have
| > >>reviewed and discussed this work item. It has also been presented
at
| > >>the MIP6 and NEMO WGs at IETF62.
| > >>
| > >>The chairs would like to hear your thoughts in order to see if
there
| > >>is consensus to make it a WG document and progress it as a
standards
| > >>track RFC. Comments should be sent to both the NEMO and MIP6 WGs.
| > >>
| > >>If we have consensus, then the document will be pursued as a dual
WG
| > >>item and called draft-ietf-mip6-nemo-v4tunnel-xx.txt
| > >>
| > >>Make I-D draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WG ID:
| > >>	For 		[  ]
| > >>	Against 	[  ]
| > >>
| > >
| > >
| > > 	Not currently	[ X ]
| > >
| > >
| > > Henrik
| > >
| > > _______________________________________________
| > > Mip6 mailing list
| > > [email-masked]
| > > https://www1.ietf.org/mailman/listinfo/mip6
| >
| >
| >
| > _______________________________________________
| > Mip6 mailing list
| > [email-masked]
| > https://www1.ietf.org/mailman/listinfo/mip6
| >

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 2 Apr 2005 18:33:31 +0900

Hello Pascal

I don't think we should exclude your scenario by this consensus call.
The mail sent by Chairs did not say exclusion of this scenario.
We look at the different scenario.

regards,
ryuji