Subject: RE: About the proposed charter and global HAHA (was Re: [nemo] RE: About route aggregation in global HAHA

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 21 Apr 2006 13:37:18 +0200

One of the motivations is to get rid of the issues associated with the Home Link (single site, single point of failure) and enable distributing Home and L3. RO comes when we introduce the satellites and route projection, which is another aspect of the draft.

Pascal

>-----Original Message-----
>From: Alexandru Petrescu [mailto:[email-masked]]
>Sent: Friday, April 21, 2006 12:12 PM
>To: Vijay Devarapalli
>Cc: marcelo bagnulo braun; [email-masked]; Pascal Thubert (pthubert)
>Subject: Re: About the proposed charter and global HAHA (was Re: [nemo] RE: About route aggregation
>in global HAHA
>
>Vijay Devarapalli wrote:
>> marcelo bagnulo braun wrote:
>>>
>>> El 20/04/2006, a las 1:03, Vijay Devarapalli escribió:
>>>
>>>> marcelo bagnulo braun wrote:
>>>>
>>>>>> Let me give you an example. Say that 3-4 ISPs from different
>>>>>> continents
>>>>>> form a mobile ISP consortium.
>>>>>>
>>>>>> That consortium obtains a short prefix from one of the NICs, call
>>>>>> it the
>>>>>> mobile prefix. Internally, the consortium shares that addressing space
>>>>>> between members, leaving big chunks free for new comers. The rule is
>>>>>> that only the big aggregation is redistributed over the Internet BGP,
>>>>>> from most POP of members ISPs. But internally, the consortium of
>>>>>> service
>>>>>> providers runs a second BGP which deals with the subnetting of mobile
>>>>>> prefix, over a mesh of tunnels and private links.
>>>>> but this seems to be complettelly different that what other people
>>>>> have been claiming here on the list.
>>>>> Past comments have strongly argued that global mobile network need
>>>>> PI addressing and global HAHA seemed a mechanisms to provide access
>>>>> to this PI prefix that the airline company gets.
>>>>
>>>> well, your home prefix, along with the set of mobile
>>>> network prefixes is a set of PI addresses. as long
>>>> as the distributed set of home agents let the mobile
>>>> network keep the same home address and mobile network
>>>> prefix while providing mobility, you have a solution.
>>>>
>>>
>>> yes, so the contribution of this solution to the global routing table
>>> would be one entry per home prefix
>>
>> since global HAHA is not a generic route optimization
>> solution,
>
>What is global HAHA for if not for shortening paths?  Isn't its main
>goal to "use a HA that is closer to MR"?
>
>Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 21 Apr 2006 14:26:16 +0200

Pascal Thubert (pthubert) wrote:
> One of the motivations is to get rid of the issues associated with 
> the Home Link (single site, single point of failure)

Address "single site - single point of failure"????

I could understand addressing single HA - single point of failure (in
which case multiple HAs can co-exist on the home link), but "single site
- single point of failure" can't be addressed by any protocol, should
better be addressed by some administrative organizations.  Or by shim6.

Good food for thought but no protocol to be designed here.  Imagine I
want to test that protocol; how could I inflict some failure to some
site to illustrate the benefits of my protocol?

> and enable distributing Home and L3.

I am afraid the network is made in such a way that IP addresses can't be
distributed.  Have you looked at shim6?

> RO comes when we introduce the satellites and route projection, which
> is another aspect of the draft.

The draft seems to have too many aspects it tries to deal with.

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 21 Apr 2006 12:04:57 -0700

Alexandru Petrescu wrote:
>> One of the motivations is to get rid of the issues associated with the 
>> Home Link (single site, single point of failure)
> 

not really. thats why we split them into three
different drafts.

Vijay

---

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 24 Apr 2006 15:41:13 +0300

Hi Alex,

> better be addressed by some administrative organizations.  Or by shim6.

agree that shim6 could be used to provide some support for this

> distributed.  Have you looked at shim6?

same thing

> The draft seems to have too many aspects it tries to deal with.

probably you could even do some shim6 based RO also...

that is one of the reasons why i am asking about the requirements and 
the use cases that we want to address...

first we need to define the problem that we want to work on and then 
move to solution space...

regards, marcelo