Subject: RE: [nemo] Re: is global HAHA so complex?

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Sat, 29 Apr 2006 09:02:52 +0200

Hi Marcelo;

There's a lot of good sense in your words; and I'd agree in general terms. 

Now please consider this angle: the design point we want to fix in MIP6 is the Home Link, which is a single point of failure, a bottleneck and anchors Home at a given location. We want to replace the ND based operation by a protocol over IP and enable a real (site or HA) redundancy using routing protocols.

In other words, we want to fix MIP problems within MIP. Not to force ISP to deploy multiple prefixes, and either SHIM6 or PRESENCE to fix a limitation of another protocol. I do not think that HAHA breaks the end to end principle. I think it obeys another principle, Give back to Cesar what is Cesar's, fix a problem where it occurs.

Pascal

>-----Original Message-----
>From: marcelo bagnulo braun [mailto:[email-masked]]
>Sent: Friday, April 28, 2006 10:22 AM
>To: Pascal Thubert (pthubert)
>Cc: [email-masked]; Henrik Levkowetz; Vijay Devarapalli
>Subject: Re: [nemo] Re: is global HAHA so complex?
>
>
>El 28/04/2006, a las 9:54, Pascal Thubert (pthubert) escribió:
>
>>
>>>>>
>>>>> 4G telephones are multihomed by definition. besides, the end device
>>>> [Pascal]
>>>> [Pascal] I am afraid there is some confusion here. I think we were
>>>> talking about multiple Home Networks not multiple interfaces on the
>>>> phone. In that context, could you please elaborate why 4G phones are
>>>> multi-homed by definition?
>>>>
>>>
>>> Ok, you mean why a telephone may need multiple Home Networks?
>>>
>>> Well, i guess that if you have a 4G phone and you have multiple
>>> provider, you want to be able to be reachable through all the
>>> providers.
>>>
>>> We do agree thFrom [email-masked] Sat Apr 29 03:03:29 2006
Content-class: urn:content-classes:message
Subject: RE: [nemo] Re: is global HAHA so complex?
Date: Sat, 29 Apr 2006 09:02:52 +0200
From: "Pascal Thubert \(pthubert\)" <[email-masked]>
To: "marcelo bagnulo braun" <[email-masked]>
Cc: [email-masked], Henrik Levkowetz <[email-masked]>,
	Vijay Devarapalli <[email-masked]>

Hi Marcelo;

There's a lot of good sense in your words; and I'd agree in general terms. 

Now please consider this angle: the design point we want to fix in MIP6 is the Home Link, which is a single point of failure, a bottleneck and anchors Home at a given location. We want to replace the ND based operation by a protocol over IP and enable a real (site or HA) redundancy using routing protocols.

In other words, we want to fix MIP problems within MIP. Not to force ISP to deploy multiple prefixes, and either SHIM6 or PRESENCE to fix a limitation of another protocol. I do not think that HAHA breaks the end to end principle. I think it obeys another principle, Give back to Cesar what is Cesar's, fix a problem where it occurs.

Pascal

>-----Original Message-----
>From: marcelo bagnulo braun [mailto:[email-masked]]
>Sent: Friday, April 28, 2006 10:22 AM
>To: Pascal Thubert (pthubert)
>Cc: [email-masked]; Henrik Levkowetz; Vijay Devarapalli
>Subject: Re: [nemo] Re: is global HAHA so complex?
>
>
>El 28/04/2006, a las 9:54, Pascal Thubert (pthubert) escribió:
>
>>
>>>>>
>>>>> 4G telephones are multihomed by definition. besides, the end device
>>>> [Pascal]
>>>> [Pascal] I am afraid there is some confusion here. I think we were
>>>> talking about multiple Home Networks not multiple interfaces on the
>>>> phone. In that context, could you please elaborate why 4G phones are
>>>> multi-homed by definition?
>>>>
>>>
>>> Ok, you mean why a telephone may need multiple Home Networks?
>>>
>>> Well, i guess that if you have a 4G phone and you have multiple
>>> provider, you want to be able to be reachable through all the
>>> providers.
>>>
>>> We do agree that is a desired feature to be able to have differetn
>>> providers for different technologies, right? So that you don't have to
>>> rely on a single provider giving UMTS, WIFI services for instance.
>>>
>>> In this scenario, you probably also want to have a stable address from
>>> each of the providers, so that you can by pass any of the providers. I
>>> mean if you are going to have a communication through the WiFI
>>> interface, you don't want to have to exchange the initial packets and
>>> the HoTI packets through the UMTS interface, right?
>>>
>>> So i really think that it is a very useful feature that 4G phones hame
>>> multiple Home Addresses associated to different providers and
>>> different
>>> technologies
>>>
>>> makes sense to you?
>>>
>> [Pascal] May happen... for some geeks who can tweak their phones.
>
>I don't know.. i would expect that if i pay my mobile phone, this is
>supported wihtout tweaks  (of course this would be differetn if the
>operator is subsidizing the phone)
>
>> That would not be the normal case for my grand ma. And I would not base
>> any RO on this. Again redundancy but no RO (and a lot of hidden
>> complexities).
>
>
>
>>
>> When my phone number is an IP address,
>
>not really i would expect that for IP phones my phone number is a URI,
>FQDN or something like this that is easier to remember and it can
>easily be mapped to multiple IP addresses
>
>>  I want to be always reachable at
>> that IP address. So providing a real redundancy to Home makes sense,
>> before you enter complex solutions based on presence or SHIM6 to
>> duplicate everything on the clients.
>>
>
>well, that is idea in putting intelegence in the edges and not in the
>core, which seems to be the basis for scalability. I guess bottom line
>disucssion here is about design principles. Of course that having the
>clients to perform the functions imply additional complexities in the
>clients, but making the network providing the fucntions, adds
>compelxity to the netowrk, makes it less scalable and makes it more
>rigid.
>
>regards, marcelo
>
>> Pascal
>>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Sat, 29 Apr 2006 21:35:24 +0300

El 29/04/2006, a las 10:02, Pascal Thubert (pthubert) escribió:

> Now please consider this angle: the design point we want to fix in 
> MIP6 is the Home Link, which is a single point of failure, a 
> bottleneck and anchors Home at a given location. We want to replace 
> the ND based operation by a protocol over IP and enable a real (site 
> or HA) redundancy using routing protocols.
>
> In other words, we want to fix MIP problems within MIP. Not to force 
> ISP to deploy multiple prefixes, and either SHIM6 or PRESENCE to fix a 
> limitation of another protocol. I do not think that HAHA breaks the 
> end to end principle. I think it obeys another principle, Give back to 
> Cesar what is Cesar's, fix a problem where it occurs.
>

but the goal is to try to provision certain capability as i understand 
it. There are different tools that can be used to provide (or can be 
tweaked to provide) the required capabilities.

the tool that provides a better trade-offs will is the one that needs 
to be selected.

Please note that my point is that we need to have a scale to evaluate 
the different proposals. This scale are the requirements imposed by the 
user (in this case the aviation community)

Once we have those we can see which solution fits their needs better. 
If the case is that their needs require a global haha like and it make 
sense to add routing table entries for this, i am all for it. But this 
analysis needs still to be done and this needs to be part of the 
charter imho.

First define requirements for aviation
Second define a solution (i.e. select the solution that fits the best 
the requirements defined)

(as opposed to pick one solution based on other criteria)

regards, marcelo