Subject: Re: [nemo] Fragmentation at mobile router

From: Takaaki Moriya <[email-masked]>
Date: Mon, 03 Apr 2006 18:58:16 +0900

Hi Vijay, Brian and all,

Thanks for comments.

Since RFC3963 does not refer to this issue, it seems to be outside of
the scope of NEMO specification.
Can we conclude it's implementation-dependent ?
If so, TAHI interoperability guideline will not specify fragmentation at
mobile router as well as sending ICMP packet too big by mobile router.

Best Regards
Takaaki Moriya
[email-masked]

On Fri, 31 Mar 2006 10:40:25 -0800
"Vijay Devarapalli" <[email-masked]> wrote:

> > I have a question about fragmentation at mobile router.
> > When mobile router receives a long packet from a node in the mobile
> > network, should mobile router fragment this packet?
> 
> I would prefer the mobile router to tell the
> MNN to reduce MTU.
> 
> > Of course, normally it is end node to manage fragmentation after
> > receiving ICMP. However, if so, when the mobile network 
> > moves, MTU size
> > toward tunneling path may be changed and then end nodes in the mobile
> > network receive ICMP packet too big.
> > (e.g. when mobile router moves under another mobile router, 
> > MTU size is
> > changed.)
> > It means that movement forses end node to retransmit the 
> > packet. It goes
> > against the rule of hiding movement from end node. 
> 
> receiving ICMP packet too is not the same as
> the MNN being aware of the movement.
> 
> Vijay
> 
> > 
> > 
> > The problem in mobile router is the same in home agent.
> > 
> > 
> > Thanks in advance.
> > 
> > ---
> > Best Regards
> > Takaaki Moriya
> > <[email-masked]>
> > 
> > 
> > 

---

---

From: Keiichi SHIMA <[email-masked]>
Date: Tue, 04 Apr 2006 09:50:59 +0900 (JST)

Hi,

From: Takaaki Moriya <[email-masked]>
Subject: Re: [nemo] Fragmentation at mobile router
Date: Mon, 03 Apr 2006 18:58:16 +0900

> mobile router as well as sending ICMP packet too big by mobile router.

Let me ask a clarification question.

A mobile router have to send an ICMP too big, if the forwarded packet
exceeds the MTU of the tunnel interface between the MR and its HA.
Otherwise, we lose connectivity.

A mobile router may not send a too big message if the packet is bigger
than the physical path MTU (not the MTU for the tunnel i/f).  It is
implementation dependent.

Do I understand correctly?

BTW, is there any word about the MTU between an MN/MR and an HA?  Our
implementation uses the IPv6 minimum MTU (1280) for the interface, but
I know some implementations use bigger MTU size, which may cause a
Path MTU discovery problem.

---
Keiichi SHIMA
IIJ Research Laboratory <[email-masked]>
WIDE Project <[email-masked]>

---

From: Takaaki Moriya <[email-masked]>
Date: Tue, 04 Apr 2006 17:41:46 +0900

Hi Shima-san,

Thanks for comments.

> Otherwise, we lose connectivity.

It seems to be good to send ICMP too big. But I guess some MR
implementations may fragment the packet instead of sending ICMP too big.
Isn't it what Brian says ?

On Thu, 30 Mar 2006 23:23:23 -0500
Brian Haley <[email-masked]> wrote:

> The MR will encapsulate it to traverse the MR-HA 
> tunnel which will cause the outer IPv6 packet to be fragmented.

> implementation dependent.

I agree about it.

> Path MTU discovery problem.

RFC does not refer to this issue including MTU. It seems to be outside
of the scope of NEMO specification.

---
Best Regards
Takaaki Moriya