Subject: Re: draft-thubert-nemo-global-haha-01.txt (was: [nemo]Charter proposal)

From: Ryuji Wakikawa <[email-masked]>
Date: Wed, 5 Apr 2006 11:34:08 +0900

Hi Marcelo

Sorry, I'm a bit late to join the discussion..

It is not necessary to inject home prefix to BGP. The global HAHA can  
run inside IGP,  too.
It depends how scale do you operate NEMO on the Internet.

ryuji

On 2006/03/30, at 20:01, marcelo bagnulo braun wrote:

> So, we do agree that global HAHA implies announcing the home  
> network into the global BGP routing table, and that each  
> distributed home network impacts with an additional entry in the  
> bgp table, right?
>
> wouldn't this imply global routing system scalability concerns?
>
> Regards, marcelo
>
>
> El 30/03/2006, a las 13:54, Ben McCarthy escribió:
>
>> Sorry, I read your initial question wrong, I thought you were  
>> referring to
>> Boeing's BGP manipulation technique they use...
>> http://www.apnic.net/meetings/19/docs/sigs/routing/routing-pres- 
>> skeen-global
>> -ip-netmob.pdf
>>
>> not Global HA-HA, my mistake.
>>
>> -----Original Message-----
>> From: marcelo bagnulo braun [mailto:[email-masked]]
>> Sent: 30 March 2006 11:26
>> To: Ben McCarthy
>> Cc: 'ml-nemo WG'; 'Simon Oosthoek'
>> Subject: Re: draft-thubert-nemo-global-haha-01.txt (was: [nemo] 
>> Charter
>> proposal)
>>
>>>
>>> [Ben] Apart from optimising the route between the MR and CNs or
>>> altering
>>> BGP, then the other option is exactly what Pascal is proposing
>>> (switching to
>>> a HA closer to the point-of-attachment to optimise the triangular
>>> route).
>>>
>>
>> perhaps i am failing to understand how this works, but wouldn't this
>> implies that each home network must be announced separately in BGP?
>>
>> regards, marcelo
>>
>>> Apart from that...???
>>>
>>> Cheers,
>>>
>>> Ben
>>>
>>>> Ben
>>>>
>>>>
>>>
>>
>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 5 Apr 2006 13:18:02 +0300

Hi Ryuji,

> It depends how scale do you operate NEMO on the Internet.

section 5.1.1 states

    In return, each site advertises the aggregation that encompasses the
    Distributed Home Network aggregation back into the service provider
    network, to the outside world (the internet).

this seems to me to imply that the home network prefix is announced  
through BGP to the rest of the internet...  i mean if you want to  
announce something to the rest of the internet it needs to be done with  
BGP right?

so i am not following your point here...

regards, marcelo

>> So, we do agree that global HAHA implies announcing the home network  
>> into the global BGP routing table, and that each distributed home  
>> network impacts with an additional entry in the bgp table, right?
>>
>>> Subject: Re: draft-thubert-nemo-global-haha-01.txt (was:  
>>> [nemo]Charter
>>> proposal)
>>>
>>>>

---

From: Ryuji Wakikawa <[email-masked]>
Date: Wed, 5 Apr 2006 19:54:46 +0900

Hi Marcelo

On 2006/04/05, at 19:18, marcelo bagnulo braun wrote:

>> It is not necessary to inject home prefix to BGP. The global HAHA  
>> can run inside IGP,  too.
> announce something to the rest of the internet it needs to be done  
> with BGP right?
>

Well, if a mobile node roams inside a network (AS) , IGP based  
anycast routing is enough.
Ex. a mobile terminal always connects to operator's network.
HAHA running in an AS is also useful if the operator's network covers  
big area. 1 HA in Madrid, another HA in Barcelona.

ryuji

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 05 Apr 2006 17:13:04 +0200

Ryuji Wakikawa wrote:
>  run inside IGP,  too. It depends how scale do you operate NEMO on
> the Internet.

"Global" HAHA inside a "Interior"GP?

Inside an IGP domain netlmm can be used, not HAHA.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 05 Apr 2006 17:53:13 +0200

Ryuji Wakikawa wrote:
> Well, if a mobile node roams inside a network (AS) , IGP based anycast 
> routing is enough.

Right.

Ryuji, if anycast inside an IGP is able to solve the mobility problem 
inside that IGP then it wouldn't need Mobile IP at all, neither the HA 
concept.  Would you agree?

> big area. 1 HA in Madrid, another HA in Barcelona.

I think we really have a problem of assimilating geographical distances 
to IP routing distances...  I really think it's a problem.  They're so 
different: my phone and my pda are both in my pocket and they talk to 
each other but the number of hops between them is about 10.  A plane 
over US talks to a ground site in UK and the IP distance is 1.

Mixing these arguments can happen in any direction, to help any proposal.

Alex

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 6 Apr 2006 09:16:21 +0300

> concept.  Would you agree?

this is especailly true considering than the current solution that they 
are using relies in announcing the airplane prefix through BGP, so if 
they can rely on BGP convergence times, i guess they can definetly rely 
on IGP convergence times

regards, marcelo