Subject: RE: About the proposed charter and global HAHA (was Re: [nemo] RE: About route aggregation in global HAHA

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Tue, 25 Apr 2006 09:04:12 +0200

Marcelo, Alexandru:

I fail to understand this. Are you saying that SHIM6 can help resolve the case where the MIP6/NEMO Home Link goes down? 

Pascal

>-----Original Message-----
>From: marcelo bagnulo braun [mailto:[email-masked]]
>Sent: Monday, April 24, 2006 2:41 PM
>To: Alexandru Petrescu
>Cc: Pascal Thubert (pthubert); Vijay Devarapalli; [email-masked]
>Subject: Re: About the proposed charter and global HAHA (was Re: [nemo] RE: About route aggregation
>in global HAHA
>
>Hi Alex,
>
>El 21/04/2006, a las 15:26, Alexandru Petrescu escribió:
>
>> Pascal Thubert (pthubert) wrote:
>>> One of the motivations is to get rid of the issues associated with
>>> the Home Link (single site, single point of failure)
>>
>> Address "single site - single point of failure"????
>>
>> I could understand addressing single HA - single point of failure (in
>> which case multiple HAs can co-exist on the home link), but "single
>> site
>> - single point of failure" can't be addressed by any protocol, should
>> better be addressed by some administrative organizations.  Or by shim6.
>>
>
>agree that shim6 could be used to provide some support for this
>
>>
>>> and enable distributing Home and L3.
>>
>> I am afraid the network is made in such a way that IP addresses can't
>> be
>> distributed.  Have you looked at shim6?
>>
>
>same thing
>
>>> RO comes when we introduce the satellites and route projection, which
>>> is another aspect of the draft.
>>
>> The draft seems to have too many aspects it tries to deal with.
>>
>
>probably you could even do some shim6 based RO also...
>
>
>that is one of the reasons why i am asking about the requirements and
>the use cases that we want to address...
>
>first we need to define the problem that we want to work on and then
>move to solution space...
>
>regards, marcelo
>
>
>> Alex
>>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 25 Apr 2006 10:16:19 +0300

Hi Pascal,

El 25/04/2006, a las 10:04, Pascal Thubert (pthubert) escribió:

> Marcelo, Alexandru:
>
> I fail to understand this. Are you saying that SHIM6 can help resolve 
> the case where the MIP6/NEMO Home Link goes down?
>

when the HA are distributed among different sites, yes, and in a bgp 
routing table friendly manner

i mean, suppose that you have multiple HAs located in different sites 
and that each HA has a different PA home prefix assigned. then each 
nemo has multiple home prefixes and each MNN has multiple addresses one 
per available home prefix

then you can use the shim6 to move from one home prefix to another, in 
case that there is a failure in one of the HAs

that is exactly what the shim6 protocol has been designed to do

Again, maybe the global moving networks have some additional 
requirements that don't fit in this approach, that is why i have been 
asking for a requirement specification, in order to find out which 
solution is  acceptable

Regards, marcelo