Subject: [nemo] NEMO rechartering -- moving forward

From: Jari Arkko <[email-masked]>
Date: Fri, 19 Jan 2007 12:47:57 +0200

All,

Some support was received for both PMR and automotive
work on this list.

My initial plan was to force you to focus on exactly
one item in addition to the airline industry needs,
in order to ensure that the group has sufficient
focus.

However, after considering the situation and talking
to the chairs, I would like to go forward with a slightly
changed plan. The below charter allows requirements
work for all three scenarios, but places some limits
on how many solutions the group can work at the
same time. Essentially, you need to complete either
PMR or automotive solution before you take on the
other one. I think this is sufficient to ensure that
the editor, reviewer, etc. resources in this group are
not spread too thin.

Hopefully this works for everyone.

I have sent this charter to the IESG. It will hopefully
be approved in an initial review, at which time it will
go for a 2-week IETF-wide review.

Jari
-----

Proposal for new NEMO Charter
Version: January 14, 2007

Description of Working Group:

The NEMO Working Group is concerned with managing the mobility of an
entire network, which changes its point of attachment to the Internet
and thus its reachability in the network topology. The mobile network
includes one or more mobile routers (MRs) which connect the rest of
the mobile network to the global Internet.

For the purposes of this working group, a mobile network is a leaf
network; it does not carry transit traffic.  Nonetheless, it could be
multihomed, either with a single MR that has multiple attachments to
the Internet, or by using multiple MRs that attach the mobile network
to the Internet.

For the basic NEMO support case, none of the nodes behind the MR need
be aware of the network's mobility; thus, the network's movement is
completely transparent to the nodes inside the mobile network. This
design consideration was made to accommodate nodes inside the network
that are not generally aware of mobility.

Basic network mobility support is described in RFC 3963. This RFC
contains NEMO Basic Support, which is a protocol based on Mobile IPv6
(RFC 3775, 3776) that enables network mobility in an IPv6 network.

The working group is tasked with continuing to evolve RFC 3963 to
correct errors and address deployment issues. In addition, the group
works in co-operation with the MIP6 WG to design a mechanism to
allow mixed IPv4/IPv6 networks to be used.

At this point, the working group is concerned with solving deployment
issues of NEMO, primarily relating to the identified needs of the
automotive and aviation communities. The group will gather requirements
from those builders and users, and then solve the route optimization
issues necessary for optimized deployments.

Among the deployments that have issues which may be solved by NEMO
Route Optimization feature(s), we have identified three cases that
have a likelihood of requirements gathering and an Optimization
solution. Those comprise the Automotive case, the Aviation case, and
the Personal Mobile Router (consumer electronics) case. The group will
explore these options to gather requirements and, if those
requirements match the capability of a NEMO RO solution space, proceed
with solving the open issues.

The WG will:

- Finish working group documents that are currently in process, and
  submit for RFC.

- Gather requirements for NEMO Route Optimization in deployment
  scenarios.

    - Automotive industry who are deploying NEMO for in-car
      communication, entertainment, and data gathering, possible
      control systems use, and communication to roadside devices.

    - Airline and spacecraft community, who are deploying NEMO for
      control systems, as well as Internet connectivity and
      entertainment systems.

    - Personal Mobile Routers, which are consumer devices that allow
      the user to bring a NEMO network with the user while mobile, and
      communicate with peer NEMO networks/MNNs.

  After gathering the requirements for these types of deployments, the
  working group will evaluate what type of route optimization needs to
  be performed (if any), and formulate a solution to those problems.

  If no requirements for those scenarios can be collected by the
  deadline, it will be assumed that the work is premature, and that
  type of deployment will be dropped from the list of use cases
  currently addressed by NEMO.

  In order to retain focus, the group needs to sequence the
  solution work for Personal Mobile Routers and Automotive
  industry. I.e., one solution needs to be completed before
  another one can be adopted as a WG document.

The WG will not:

- consider routing issues inside the mobile network. Existing routing
  protocols (including MANET protocols) can be used to solve these
  problems.

- consider general route optimization, multihoming, or other problems
  that are not related to the deployment and maintenance of NEMO
  networks.

The working group will endeavor to separate research issues, and refer
them to the IRTF as appropriate.

Goals and Milestones:

Feb 2007	  	Submit final doc(s) on Prefix Delegation for NEMO
Apr 2007	  	Submit final doc Multihoming Problem Statement
Apr 2007	  	Submit final doc on MIB for NEMO Basic Support

May 2007		Submit -00 draft on Route Optimization Needs for
			Aircraft and Spacecraft Deployments
May 2007		Submit -00 draft on Route Optimization Needs for
			Automobile and Highway Deployments
May 2007		Submit -00 draft on Route Optimization needs for
			Personal Mobile Router

Jul 2007		Submit -00 draft for solution to aircraft/spacecraft
			problem
Jul 2007		Submit -00 draft for solution to first remaining problem

Aug 2007		Submit final doc on Route Optimization Needs for
			Aircraft and Spacecraft Deployments
Aug 2007		Submit final doc on Route Optimization Needs for
			Automobile and Highway Deployments
Aug 2007		Submit final doc on Route Optimization needs for
			Personal Mobile Router

Aug 2007		Determine how to proceed (if appropriate) with one
			or more route optimization solutions
Dec 2007		Submit final doc for solution to aircraft/spacecraft
			problem
Dec 2007		Submit final doc for solution to first remaining problem
Dec 2007		Submit -00 draft for solution to second remaining problem
Mar 2008		Submit final doc for solution to second remaining problem
Apr 2008	  	Shut down or recharter the WG to solve further
			identified topics

---

From: "Davis, Terry L" <[email-masked]>
Date: Fri, 19 Jan 2007 07:39:38 -0800

Jari

I am glad to see this going forward and I believe that the aviation
industry can meet your proposed timelines for compiling our requirements
for Internet mobility.

I would like to make one clarification to the following paragraph from
below
> the Internet, or by using multiple MRs that attach the mobile network

For the aviation industry it is highly likely, that in at least some
scenarios, an aircraft mobile network will carry transit traffic as we
are looking at MANET type options that would allow aircraft to aircraft
traffic routing especially over the oceans.

Take care
Terry

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: Friday, January 19, 2007 2:48 AM
> To: IETF NEMO WG
> Subject: [nemo] NEMO rechartering -- moving forward
> 
> All,
> 
> Dec 2007		Submit -00 draft for solution to second
remaining
> problem
> Mar 2008		Submit final doc for solution to second
remaining

---

From: "Roberto Baldessari" <[email-masked]>
Date: Fri, 19 Jan 2007 18:15:40 +0100

Dear Jari, dear all,

I'm currently collecting use cases and requirements inside the Car2Car Communication Consortium, which is standardizing vehicular communications in Europe, into an I-D to be submitted to the NEMO WG within end of February.

What Terry asked regarding aviation industry is important for automotive industry as well, at least in Europe. 
The Car2Car Consortium mainly focuses on VANETs (Vehicular ad-hoc networks) based on short-range communication devices and therefore considers direct vehicle-to-vehicle as fundamental. Dedicated points of attachment will be installed, but their diffusion will be rather limited at least in the short/mid term.

Is integration of VANETs and NEMO to be considered out of scope of the charter as consequence of the "leaf network" assumption?

Thanks and best regards,

Roberto

> From: Davis, Terry L [mailto:[email-masked]] 
> Sent: Friday, January 19, 2007 4:40 PM
> To: Jari Arkko; IETF NEMO WG; Mobile Platform Internet Mailing List
> Subject: RE: [nemo] NEMO rechartering -- moving forward
> 
> Jari
> 
> I am glad to see this going forward and I believe that the 
> aviation industry can meet your proposed timelines for 
> compiling our requirements for Internet mobility.
> 
> I would like to make one clarification to the following 
> paragraph from below
> For the aviation industry it is highly likely, that in at 
> least some scenarios, an aircraft mobile network will carry 
> transit traffic as we are looking at MANET type options that 
> would allow aircraft to aircraft traffic routing especially 
> over the oceans.
> 
> Take care
> Terry
> 
> 
> > Some support was received for both PMR and automotive work on this 
> > list.
> > 
> > My initial plan was to force you to focus on exactly one item in 
> > addition to the airline industry needs, in order to ensure that the 
> > group has sufficient focus.
> > 
> > However, after considering the situation and talking to the 
> chairs, I 
> > would like to go forward with a slightly changed plan. The below 
> > charter allows requirements work for all three scenarios, 
> but places 
> > some limits on how many solutions the group can work at the 
> same time. 
> > Essentially, you need to complete either PMR or automotive solution 
> > before you take on the other one. I think this is 
> sufficient to ensure 
> > that the editor, reviewer, etc. resources in this group are 
> not spread 
> > too thin.
> > 
> > I have sent this charter to the IESG. It will hopefully be 
> approved in 
> > an initial review, at which time it will go for a 2-week IETF-wide 
> > review.
> > 
> > Jari
> > -----
> > 
> > works in co-operation with the MIP6 WG to design a 
> mechanism to allow 
> > mixed IPv4/IPv6 networks to be used.
> >

---

From: Jari Arkko <[email-masked]>
Date: Wed, 24 Jan 2007 15:40:22 +0200

Hi Terry,
> industry can meet your proposed timelines for compiling our requirements
Great!
> traffic routing especially over the oceans.
I think that makes sense for your case.

First, I have a question to you: does the MANET part have
an impact on the used NEMO techniques? I'm not sure
there has to be any impact; an MR can be a MANET router
at the same time, and from the perspective of the hosts served
by the MR or the ground base infrastructure, it does
not matter if the MR - infrastructure path uses
a single link, traditional routing, or ad hoc routing.

So to answer your question about the charter,
if these two issues are independent then you'll
be able to develop all the network mobility
stuff in NEMO and then apply that together
with MANET technology (either existing or
developed in parallel somewhere else).
That is, the charter only talks about what
we think about when design the solutions --
it does not limit how you deploy it with other
complementary solutions.

If the issues are not independent, then I guess we
are talking about something along the lines
that the MANEMO BOF wants to do. In that
case my first reaction would be that you already
have a very challenging technical problem in
front of you -- maybe we should solve that first
before expanding the space further.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Wed, 24 Jan 2007 15:42:10 +0200

Roberto,
> Is integration of VANETs and NEMO to be considered out of scope of the charter as consequence of the "leaf network" assumption?
Does my answer to Terry answer your question as well?

Jari

---

From: "Roberto Baldessari" <[email-masked]>
Date: Thu, 25 Jan 2007 14:43:18 +0100

Jari,

Thank you for your feedback.

> Does my answer to Terry answer your question as well?

Yes, it does. VANETs naturally fit into MANEMO BOF, though C2C-C Consortium approach is quite different from what described in current MANEMO problem statement draft. Anyway, I'll submit the ID from C2C-CC then the discussion will probably continue in MANEMO.

Thanks,

Roberto