Subject: [nemo] RE: [Mip6] I-D ACTION:draft-ietf-mip6-nemo-v4traversal-05.txt

From: <[email-masked]>
Date: Tue, 17 Jul 2007 10:47:45 +0300

Hi Hesham,

The new version has the IPv4-mapped IPv6 address text changed according
to the new IPv4 CoA option except
in a couple of occasions.

Section 2.3.2.2

"All entries MUST point to the mobile node's IPv4 care-of address
included 
in the source address of the IPv6 packet and represented as an
IPv4-mapped IPv6 address."

Section 4.2

"When the home agent receives the encapsulated binding update it 
compares the IPv4 address of the source address field in the 
IPv4 header with the IPv4 address in the source address of the IPv6
header."

Was it so that the TLV would never be used in BU/BACK or is it allowed
after the initial binding has been created? This could be clarified in
section 4.1.

Cheers,
Markku

>-----Original Message-----
>From: ext [email-masked] [mailto:[email-masked]] 
>Sent: 12 July, 2007 20:16
>To: [email-masked]
>Cc: [email-masked]
>Subject: [Mip6] I-D ACTION:draft-ietf-mip6-nemo-v4traversal-05.txt 
>
>A New Internet-Draft is available from the on-line 
>Internet-Drafts directories.
>This draft is a work item of the Mobility for IPv6 Working 
>Group of the IETF.
>
>	Title		: Mobile IPv6 support for dual stack 
>Hosts and Routers (DSMIPv6)
>	Author(s)	: H. Soliman
>	Filename	: draft-ietf-mip6-nemo-v4traversal-05.txt
>	Pages		: 27
>	Date		: 2007-7-12
>	
>The current Mobile IPv6 and NEMO specifications support IPv6 only.
>   This specification extends those standards to allow the registration
>   of IPv4 addresses and prefixes, respectively, and the transport of
>   both IPv4 and IPv6 packets over the tunnel to the HA. This
>   specification also allows the Mobile Node to roam over both IPv6 and
>   IPv4, including the case where Network Address Translation 
>is present
>   on the path between the mobile node and its home agent.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-ietf-mip6-nemo-v4trav
ersal-05.txt
>
>To remove yourself from the I-D Announcement list, send a 
>message to [email-masked] with the word 
>unsubscribe in the body of the message. 
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
>to change your subscription settings.
>
>Internet-Drafts are also available by anonymous FTP. Login 
>with the username "anonymous" and a password of your e-mail 
>address. After logging in, type "cd internet-drafts" and then 
>"get draft-ietf-mip6-nemo-v4traversal-05.txt".
>
>A list of Internet-Drafts directories can be found in 
>http://www.ietf.org/shadow.html or 
>ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>	[email-masked].
>In the body type:
>	"FILE /internet-drafts/draft-ietf-mip6-nemo-v4traversal-05.txt".
>	
>NOTE:	The mail server at ietf.org can return the document in
>	MIME-encoded form by using the "mpack" utility.  To use this
>	feature, insert the command "ENCODING mime" before the "FILE"
>	command.  To decode the response(s), you will need "munpack" or
>	a MIME-compliant mail reader.  Different MIME-compliant 
>mail readers
>	exhibit different behavior, especially when dealing with
>	"multipart" MIME messages (i.e. documents which have been split
>	up into multiple messages), so check your local documentation on
>	how to manipulate these messages.
>
>Below is the data which will enable a MIME compliant mail 
>reader implementation to automatically retrieve the ASCII 
>version of the Internet-Draft.
>

---

From: "Hesham Soliman" <[email-masked]>
Date: Tue, 17 Jul 2007 17:54:20 +1000

Hi Markku, 

It wasn't intentional, I thought I changed them but obviously I missed those
two. I'll fix it up i nthe next rev. 

Thanks,
Hesham 

 > From: [email-masked] 
 > [mailto:[email-masked]] 
 > Sent: Tuesday, July 17, 2007 5:48 PM
 > To: [email-masked]
 > Cc: [email-masked]; [email-masked]
 > Subject: RE: [Mip6] I-D 
 > ACTION:draft-ietf-mip6-nemo-v4traversal-05.txt 
 > 
 > Hi Hesham,
 > 
 > >You can also visit 
 > https://www1.ietf.org/mailman/listinfo/I-D-announce