Subject: [MEXT] Clarifications required on BRI sequence number [draft-muhanna-mext-binding-revocation-02]

From: Kowsalya Subramanian <[email-masked]>
Date: Fri, 30 Jan 2009 09:51:31 +0530

Hi,
 
In the draft, there is text mentioning that the initiator of the BRI message
MUST choose a monotonically increasing sequence number. 
 
Lets consider a case where the BCE has 3 HNPs bound to it. If the LMA sends
a BRI with seq number 5 for {MN-ID, HNP1} and then wants to send a BRI for
{MN-ID, HNP2}. Should it wait till it gets a BRA for the previous BRI that
it sent? If LMA need not wait for the BRA, then it is possible that MAG
receives BRI 5, 6 out of order. In which case, what should the MAG do,
should it ignore BRI 5 as it has already got BRI 6.
 
In other words, is the sequence number in BRI indicates some form of
versioning for the deletion or is it just to match only BRA and identify BRI
re-transmissions. If it is the latter, why should it be monotonically
increasing, it can just be unique.
 
Am I missing something here?
 
Thanks
Kowsalya
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 30 Jan 2009 01:33:21 -0600

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Kowsalya Subramanian
	Sent: Thursday, January 29, 2009 10:22 PM
	To: [email-masked]
	Subject: [MEXT] Clarifications required on BRI sequence
number[draft-muhanna-mext-binding-revocation-02]

	Hi,
	 
	In the draft, there is text mentioning that the initiator of the
BRI message MUST choose a monotonically increasing sequence number.  
	 
	[Ahmad]
	Where are you reading from. Please refer to the latest MEXT wg
draft at the below link:
	
http://www.ietf.org/internet-drafts/draft-ietf-mext-binding-revocation-0
3.txt 

	Lets consider a case where the BCE has 3 HNPs bound to it. If
the LMA sends a BRI with seq number 5 for {MN-ID, HNP1} and then wants
to send a BRI for {MN-ID, HNP2}. Should it wait till it gets a BRA for
the previous BRI that it sent? If LMA need not wait for the BRA, then it
is possible that MAG receives BRI 5, 6 out of order. In which case, what
should the MAG do, should it ignore BRI 5 as it has already got BRI 6.
	 
	In other words, is the sequence number in BRI indicates some
form of versioning for the deletion or is it just to match only BRA and
identify BRI re-transmissions. If it is the latter, why should it be
monotonically increasing, it can just be unique.

	Thanks
	Kowsalya