Subject: any difference between startup and running?

From: "王罕" <[email-masked]>
Date: Fri, 22 Oct 2004 20:20:13 +0800

dear all:

  I just read the draft-03, and I am confused by some description.

the draft said the running configure is the default target of many operation,

but later it mentioned the "startup" configure.

  I want to ask what is the difference between startup and running?

does the startup meaning the confuguration of a device when it is just begin to

running , in another word , the configuration before it send <hello>

element to others. 

  if it is , why we need a startup configuration? we can get the same information

through <get-config> , if we want to save the configuration when the device work

normally, we can save the configuration to candidate.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 22 Oct 2004 08:27:29 -0700

>dear all:

<running> is the active configuration
<startup> is the config that will be used on the next reboot

Some devices keep the <running> and <startup> config in synch
automatically.

Other devices do not automatically update the <startup> when
the <running> config is changed.  These devices will advertise 
the #startup capability to indicate that the <startup> config 
must be explicitly updated (e.g., copy-config from <running> 
to <startup>).

Andy