Subject: RE: Testing and Diagnostics

From: "Andrea Westerinen" <[email-masked]>
Date: Wed, 3 Nov 2004 13:24:48 -0800

Brian, This begins to move from protocol to model, and may be better
addressed in the proposed NetConf Modeling group (also copied on this).
 
There has been significant work on diagnostics in the CIM System Model - see
the attached paper.  This paper is still in review in the DMTF (since it is
based on CIM V2.9 that is in the process of going Final now), but provides a
good, general overview of the topic.  It might provide a base to build on.
 
Andrea

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hedstrom, Brian
Sent: Friday, October 29, 2004 11:24 AM
To: [email-masked]'
Subject: Testing and Diagnostics

I realize that the NETCONF protocol is addressing the network configuration
and provisioning peice of network management.  It also seems to cover the
Performance Management side by specifying messages to retreive state data
which can include PM statistics.  In addition, it can also cover Inventory
Management by a similar state data retreival.
Obvisouly, it does not provide any fault management capabilities due to the
lack of autonomous message support (although SOAP/Web Services can solve
this).
But, has there been any discussion about Diagnostics and Testing?  Is this a
distictly different area than Configuration Management?  The model would
need to support:
1. Creating a standby configuration that will support the required testing
and take interfaces out of service, etc.
2. Activate/Commit this configuration while backing up the running config
3. Allowing a manager to initiate a test or series of tests (this can be
treated like a config change).
4. After the tests have completed (need a way to signify this since we
shouldn't necessarily rely on Trap notifications), need the ability for the
manager to retreive the testing results.
4a. May need the ability to cancel/abort any running tests
5. Replace the testing configuration with the backup running configuration.
 
Thanks,

Brian Hedstrom 
CarrierAccess 
NetworkValet EMS Product Development 
303.218.5429 - Office 
303.218.5629 - Fax 
[email-masked]

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 3 Nov 2004 13:59:48 -0800

Hi -

> From: "Andrea Westerinen" <[email-masked]>
> To: "'Hedstrom, Brian'" <[email-masked]>; <[email-masked]>; "'Netconf Data Model Discussion'"
<[email-masked]>
> Sent: Wednesday, November 03, 2004 1:24 PM
> Subject: RE: Testing and Diagnostics
>

> good, general overview of the topic.  It might provide a base to build on.
...

The reference to the DMTF work is appreciated, but the process geek in me
is a little concerned.  Specifically, I'd like some clarification regarding the
copyright notice in the PDF file sent to these WG mailing lists.  In particular,
how does that material relate to the "Note Well" associated with IETF WG
mailing lists? (An example is at http://www.ietf.org/maillist.html)

Randy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Andrea Westerinen" <[email-masked]>
Date: Wed, 3 Nov 2004 14:53:33 -0800

The DMTF copyright says that you can use the work, but should attribute the
source.  No IPR implications.

Andrea 

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]] 
> Sent: Wednesday, November 03, 2004 2:00 PM
> To: Andrea Westerinen
> Cc: Netconf Data Model Discussion; netconf
> Subject: Re: Testing and Diagnostics
> 
> Hi -
> 
> > To: "'Hedstrom, Brian'" <[email-masked]>; 
> <[email-masked]>; "'Netconf Data Model Discussion'"
> > There has been significant work on diagnostics in the CIM 
> System Model 
> > - see the attached paper.  This paper is still in review in 
> the DMTF 
> > (since it is based on CIM V2.9 that is in the process of 
> going Final 
> > now), but provides a good, general overview of the topic.  
> It might provide a base to build on.
> ...
> 
> The reference to the DMTF work is appreciated, but the 
> process geek in me is a little concerned.  Specifically, I'd 
> like some clarification regarding the copyright notice in the 
> PDF file sent to these WG mailing lists.  In particular, how 
> does that material relate to the "Note Well" associated with 
> IETF WG mailing lists? (An example is at 
> http://www.ietf.org/maillist.html)
> 
> Randy
> 
> 
>