Subject: RE: Begin WG Last Call: draft-ietf-netconf-prot-04

From: "Rob Enns" <[email-masked]>
Date: Tue, 30 Nov 2004 13:05:26 -0800

Since the term "Expect scripts" only shows up in the section
talking about other things that may interact with NETCONF, we
could change the term to "CLI scripts", which 
should be clear to all without an additional reference.
Does that sound ok?

Rob

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
> Sent: Sunday, November 28, 2004 7:43 AM
> To: Simon Leinen
> Cc: Andy Bierman; [email-masked]
> Subject: RE: Begin WG Last Call: draft-ietf-netconf-prot-04
> 
> Simon,
> 
> Unless I am the last person on the list learning about this, 
> I would suggest that a short note and an Informative 
> Reference be added. 
> 
> Regards,
> 
> Dan
> 
> 
> 
> > -----Original Message-----
> > From: Simon Leinen [mailto:[email-masked]]
> > Sent: 28 November, 2004 5:41 PM
> > To: Romascanu, Dan (Dan)
> > Cc: Andy Bierman; [email-masked]
> > Subject: Re: Begin WG Last Call: draft-ietf-netconf-prot-04
> > 
> > 
> > Dan,
> > 
> > thanks for your review.  Here's a quick response to one of your
> > questions:
> > 
> > > 4. Section 7.5 - what is an 'Expect script'?
> > 
> > From http://expect.nist.gov/ -
> > 
> >     "Expect is a tool for automating interactive 
> applications such as
> >     telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect really makes
> >     this stuff trivial. Expect is also useful for testing these same
> >     applications. [...]"
> > 
> > Operators use it a lot to script interactions with devices 
> that have a
> > CLI (command line interface).  Expect scripts are often the 
> basis for
> > specialized higher-layer tools such as configuration control systems
> > (see RANCID, http://www.shrubbery.net/rancid/).
> > 
> > The original "Expect" was written in Tcl, but there are 
> many variants
> > of the idea, such as the Chat.pl, Comm.pl, and Expect.pm modules for
> > Perl.
> > 
> > So when we talk about "Expect scripts", we usually refer to all
> > scripted usage of the CLI.  Which should gradually be replaced by
> > scripts that use NETCONF.
> > -- 
> > Simon.
> > 
> > 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Michael Hallgren" <[email-masked]>
Date: Tue, 30 Nov 2004 23:00:12 +0100

> could change the term to "CLI scripts", which should be clear 
> to all without an additional reference.
> Does that sound ok?

Positive, covering enough, simple enough. (Oups, sorry, very late 
but anyway first input.)

mh (as6453)

> > Unless I am the last person on the list learning about 
> this, I would 
> > suggest that a short note and an Informative Reference be added.
> > 
> > Regards,
> > 
> > Dan
> > 
> > 
> > 
> > to unsubscribe send a message to 
> [email-masked] with the 
> > word 'unsubscribe' in a single line as the message text body.
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.