Subject: RE: Begin WG Last Call: draft-ietf-netconf-prot-04

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Sun, 28 Nov 2004 15:56:14 +0200

A few comments, mostly editorial:

1. The Abstract section includes acronyms that would better be expanded (XML, RPC)
2. Section 1.3 - '  Note that the NETCONF protocol is concerned only with information
   required to get the system software into its desired running state.'
   Isn't this too limitating? Are other aspects of device configuration really excluded, or should we rather say 
   '  Note that the NETCONF protocol is concerned only with information
   required to get the device behavior into its desired state (for example getting the system software into its desired running state).'?
3.  No DTDs - The introduction says 'The contents of both the request and the response are fully described in XML DTDs or XML schemas, or both, allowing both parties to recognize the syntax constraints imposed on the exchange. while secttion 3.2 dully specifies that ' Document type declarations (DTDs) are not permitted to appear in NETCONF content.' Is not this a contradiction?
4. Section 7.5 - what is an 'Expect script'?
5. Section 9, second paragraph - what means 'unbnownest'? 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Andy Bierman
> Sent: 31 October, 2004 6:25 PM
> To: [email-masked]
> Subject: Begin WG Last Call: draft-ietf-netconf-prot-04
> 
> 
> Hi,
> 
> The NETCONF WG has completed work on the NETCONF Configuration
> Protocol.  The WG proposes that the Internet draft
> 'draft-ietf-netconf-prot-04.txt' is the completed version of 
> this document.  This document can be found at:
> http://www.ietf.org/internet-drafts/draft-ietf-netconf-prot-04.txt
> 
> Abstract:
>    The NETCONF configuration protocol defined in this 
> document provides
>    mechanisms to install, manipulate, and delete the configuration of
>    network devices.  It uses an XML-based data encoding for the
>    configuration data as well as the protocol messages.  The NETCONF
>    protocol operations are realized on top of a simple RPC layer.
> 
> The WG members are strongly urged to review this document as 
> soon as possible, and express any concerns, or identify any errors,
> in an email to the NETCONF WG mailing list.
> 
> Unless there are strong objections, published on the NETCONF 
> WG mailing
> list by November 28, 2004, this document will be forwarded to the OPS 
> Area Directors for standards track consideration by the IESG.
> 
> Please send all comments to the WG mailing list at 
> [email-masked].
> 
> Andy and Simon
> 
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Margaret Wasserman <[email-masked]>
Date: Sun, 28 Nov 2004 09:24:07 -0500

>5. Section 9, second paragraph - what means 'unbnownest'?

This appears to be a misspelling of the word "unbeknownst", a 
dictionary entry for which appears below.

Margaret

Main Entry:  un·be·knownst
  Pronunciation:  "&n-bi-'nOn(t)st
  Variant(s):  also un·be·known  /-'nOn/
  Function:  adjective
  Etymology:  1un- + obsolete English beknown known; unbeknownst, 
irregular from unbeknown
: happening without one's knowledge : UNKNOWN -- usually used with to

---

From: Simon Leinen <[email-masked]>
Date: Sun, 28 Nov 2004 16:40:38 +0100

Dan,

thanks for your review.  Here's a quick response to one of your

> 4. Section 7.5 - what is an 'Expect script'?

From http://expect.nist.gov/ -

    "Expect is a tool for automating interactive applications such as
    telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect really makes
    this stuff trivial. Expect is also useful for testing these same
    applications. [...]"

Operators use it a lot to script interactions with devices that have a
CLI (command line interface).  Expect scripts are often the basis for
specialized higher-layer tools such as configuration control systems
(see RANCID, http://www.shrubbery.net/rancid/).

The original "Expect" was written in Tcl, but there are many variants
of the idea, such as the Chat.pl, Comm.pl, and Expect.pm modules for
Perl.

So when we talk about "Expect scripts", we usually refer to all
scripted usage of the CLI.  Which should gradually be replaced by
scripts that use NETCONF.
-- 
Simon.