Subject: RE: Begin WG Last Call: draft-ietf-netconf-prot-04

From: "Rob Enns" <[email-masked]>
Date: Tue, 30 Nov 2004 14:06:57 -0800

Thanks for your comments Dan.

> 1. The Abstract section includes acronyms that would better 
> be expanded (XML, RPC)

Done.

> 2. Section 1.3 - '  Note that the NETCONF protocol is 
> concerned only with information
>    required to get the system software into its desired 
> running state.'
>    Isn't this too limitating? Are other aspects of device 
> configuration really excluded, or should we rather say 
>    '  Note that the NETCONF protocol is concerned only with 
> information
>    required to get the device behavior into its desired state 
> (for example getting the system software into its desired 
> running state).'?

What about changing "system software" to "device" in this sentence
(I agree with you but want a shorter sentence):

Note that the NETCONF protocol is concerned only with information
required to get the device into its desired running state.

> 3.  No DTDs - The introduction says 'The contents of both the 
> request and the response are fully described in XML DTDs or 
> XML schemas, or both, allowing both parties to recognize the 
> syntax constraints imposed on the exchange. while secttion 
> 3.2 dully specifies that ' Document type declarations (DTDs) 
> are not permitted to appear in NETCONF content.' Is not this 
> a contradiction?

The "No DTDs" restriction means that DTDs are not allowed to
be embedded directly inside NETCONF content. Embedded DTDs are
an official feature of XML that nobody seems to use these days,
as they are awkward and not useful or desirable in NETCONF (we
don't want to require a NETCONF entity to be able to parse DTDs,
for one thing).

The use of DTDs themselves to describe XML content that could
be used with NETCONF is fine.

> 4. Section 7.5 - what is an 'Expect script'?

Changed to "CLI script", pending WG approval.

> 5. Section 9, second paragraph - what means 'unbnownest'? 

Fixed (the spelling mistake was unbeknownst to me, when I
submitted -04).

Rob

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 30 Nov 2004 16:12:43 -0800

>>>>> On Tue, 30 Nov 2004 14:06:57 -0800, "Rob Enns" <[email-masked]> said:

Rob> Note that the NETCONF protocol is concerned only with information
Rob> required to get the device into its desired running state.

As I mentioned in my comments.  This whole sentence is untrue.  You
already have operations that request state information.

-- 
"In the bathtub of history the truth is harder to hold than the soap,
 and much more difficult to find."  -- Terry Pratchett