Subject: re:Begin WG Last Call: draft-ietf-netconf-prot-04

From: Len Nieman <[email-masked]>
Date: Fri, 12 Nov 2004 02:35 -0500 (EST)

Para 1.3 Separation of Configuration and State Data states:

" To account for these issues, the NETCONF protocol recognizes the
  difference between configuration data and state data and provides
  commands that operate on each independently.  The <get-config>
  command retrieves configuration data only while the <get> command
  retrieves configuration and state data."

I realize NETCONF is primarily concerned with device
configuration. But a large part of the activity on devices in
larger networks are state queries by network monitoring centers
and troubleshooters.

If the <get-config> command retrieves configuration data only,
how difficult would it be to add a <get-state> command that
retrieves state data only?

This would, hopefully, reduce the need to add a bunch of filters
to a <get> command to strip out config information that might not
be needed by a network monitoring center.

Len Nieman

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 23 Nov 2004 12:34:13 +0100

I see:
  9.  Security Considerations

   This standard does not specify an authorization scheme, as such a

I think it is better to say

   This document does not specify ....

Bert

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Sun, 28 Nov 2004 17:42:58 +0200

Simon,

Unless I am the last person on the list learning about this, I would suggest that a short note and an Informative Reference be added. 

Regards,

Dan

> -----Original Message-----
> From: Simon Leinen [mailto:[email-masked]]
> Sent: 28 November, 2004 5:41 PM
> To: Romascanu, Dan (Dan)
> Cc: Andy Bierman; [email-masked]
> Subject: Re: Begin WG Last Call: draft-ietf-netconf-prot-04
> 
> 
> Dan,
> 
> thanks for your review.  Here's a quick response to one of your
> questions:
> 
> > 4. Section 7.5 - what is an 'Expect script'?
> 
> From http://expect.nist.gov/ -
> 
>     "Expect is a tool for automating interactive applications such as
>     telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect really makes
>     this stuff trivial. Expect is also useful for testing these same
>     applications. [...]"
> 
> Operators use it a lot to script interactions with devices that have a
> CLI (command line interface).  Expect scripts are often the basis for
> specialized higher-layer tools such as configuration control systems
> (see RANCID, http://www.shrubbery.net/rancid/).
> 
> The original "Expect" was written in Tcl, but there are many variants
> of the idea, such as the Chat.pl, Comm.pl, and Expect.pm modules for
> Perl.
> 
> So when we talk about "Expect scripts", we usually refer to all
> scripted usage of the CLI.  Which should gradually be replaced by
> scripts that use NETCONF.
> -- 
> Simon.
> 
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 28 Nov 2004 17:01:55 +0100

Well, by now (in fact a few years back when we did our NM-road-show
so to speak) I do know about expect scripts. But since these 
documents may get in hands of many people who do not know about
such things, it might indeed be useful to add at least a reference
or some explanatory text (as Simon provided for example).

bert

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Romascanu, Dan (Dan)
> Sent: Sunday, November 28, 2004 16:43
> To: Simon Leinen
> Subject: RE: Begin WG Last Call: draft-ietf-netconf-prot-04
> 
> 
> Simon,
> 
> Unless I am the last person on the list learning about this, 
> I would suggest that a short note and an Informative 
> Reference be added. 
> 
> Regards,
> 
> Dan
> 
> 
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 29 Nov 2004 00:14:29 +0100

On Sun, Oct 31, 2004 at 09:25:00AM -0700, Andy Bierman wrote:
 
> The WG members are strongly urged to review this document as 
> soon as possible, and express any concerns, or identify any errors,
> in an email to the NETCONF WG mailing list.

Attached is my review of the NETCONF protocol document. I did not
manage to read the transport mapping documents before the last call
timer has expired.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany