Subject: default-operation

From: Sandeep Adwankar <[email-masked]>
Date: Mon, 01 Nov 2004 16:03:49 -0600

What is the result of this rpc?

1. Is this a data model that specifies default merge behavior
2. Is this a data model that doesn't support optional "operation"
attribute
and hence the default-operation replace will happen

<rpc message-id="101" xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
   <edit-config>
     <target>
        <running/>
     </target>
     <default-operation>replace</default-operation>
     <config>
        <top xmlns="http://example.com/schema/1.2/config">
           <interface>
              <name>Ethernet0/0</name>
              <mtu>1500</mtu>
           </interface>
        </top>
      </config>
    </edit-config>
</rpc>

thanks,
Sandeep

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 01 Nov 2004 15:38:58 -0700

>2. Is this a data model that doesn't support optional "operation"

I'm not sure I understand your questions. 
 
We can't tell the defaults and optional parameters from an
XML instance document fragment.  You need to have the schema
for that.  

The intent of the "replace" operation is that only
the specified configuration parameters are affected.

It appears that the MTU on interface "Ethernet0/0" is 
being changed in this example.   I'm not sure it's specified
in the document if that is the case or not.  

This example could also be interpreted as "Remove all parameters 
for interface Ethernet0/0 and just set the MTU to 1500".
If this is correct, then are all parameters unset or do the
parameters with defaults get changed to the default value?

In a strict interpretation, "replace only the subtree(s) that 
are specified in the request" will wipe out almost the whole config 
because <top> is specified in the request.  

I think we need some clarifying text on this issue.
Thanks for bringing it up.

>        <top xmlns="http://example.com/schema/1.2/config">

Andy

---

From: Sandeep Adwankar <[email-masked]>
Date: Wed, 03 Nov 2004 11:38:21 -0600

> I'm not sure I understand your questions.

The question is simple. If same rpc as shown below is
send to two devices, one that understands "operation" attribute
and one whose configuration doesn't, What happens then?
The device that understands "operation" attribute will do replace.
What about device that don't have "operation" in schema, will
it do merge?

      <rpc message-id="101"
xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
         <edit-config>
           <target>
             <running/>
           </target>
           <config xmlns:xc="urn:ietf:params:xml:ns:netconf:base:1.0">
             <top xmlns="http://example.com/schema/1.2/config">
               <interface xc:operation="replace">
                 <name>Ethernet0/0</name>
                 <mtu>1500</mtu>
                 <address>
                   <name>1.2.3.4</name>
                   <mask>255.0.0.0</mask>
                 </address>
               </interface>
             <top>
           </config>
         </edit-config>
       </rpc>

thanks,
Sandeep

---

From: Andy Bierman <[email-masked]>
Date: Wed, 03 Nov 2004 09:51:06 -0800

>and one whose configuration doesn't, What happens then?

One implementation is conformant and the other is not.

Andy

---

From: Sandeep Adwankar <[email-masked]>
Date: Wed, 03 Nov 2004 12:03:09 -0600

> One implementation is conformant and the other is not.

The statement in the draft is:
Elements in the <config> subtree may contain an "operation" attribute.

This opens up possibilities of configurations without "operation"
attribute.
Are conformance requirements documented?

thanks,
Sandeep