Subject: Proposed Resolution to PROT I-D Issues List

From: Andy Bierman <[email-masked]>
Date: Fri, 11 Feb 2005 12:48:37 -0800

Hi,

The attached list contains the previous issues list with my suggested resolutions.
Since the WG has not commented on this list, there seems little consensus
to make many requested changed.  

The status values are:
  ** CLOSED ** - change not accepted or no concrete change requested
  ** CLOSED ** CHANGE REQUIRED ** - all or part of change accepted;
                                    change considered a clarification
  ** OPEN ** - no resolution yet

Please review this list and send comments to the WG mailing list ASAP.
The editor needs to finalize the changes for the -05 version before
the ID cutoff.

thanks,
Andy

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 11 Feb 2005 19:15:37 -0500

A comment on issue I002:

I002)

Session ID)  How is this conveyed to the client?

   ** OPEN **
   Doesn't seem to be a mechanism for an app to know its
   own session ID.

I have suggested in the past that the server should return the 
session ID to the client in the server's <hello> message.  Is there 
some reason why that is impractical or undesirable?

Margaret

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 11 Feb 2005 16:39:31 -0800

At 04:15 PM 2/11/2005, Margaret Wasserman wrote:

>I have suggested in the past that the server should return the session ID to the client in the server's <hello> message.  Is there some reason why that is impractical or undesirable?

no -- it needs to be specified in all the drafts.

Andy

---

From: Phil Shafer <[email-masked]>
Date: Fri, 11 Feb 2005 20:25:25 -0500

>some reason why that is impractical or undesirable?

Nope, sounds good.

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Sat, 12 Feb 2005 08:39:51 -0800

>>some reason why that is impractical or undesirable?

Okay, now let's help Rob understand the edits.
Here's the <hello> example from the draft:

OLD:
   <hello>
     <capabilities>
       <capability>
         urn:ietf:params:xml:ns:netconf:base:1.0
       </capability>
       <capability>
         urn:ietf:params:xml:ns:netconf:base:1.0#startup
       </capability>
       <capability>
         http:/example.net/router/2.3/core#myfeature
       </capability>
    </capabilities>
   </hello>

NEW:

   <hello>
      <capabilities>
         ...
      </capabilities>
      <session-id>4</session-id>
   </hello>

<element name="session-id" type="positiveInteger"/>

okay?

Andy