Subject: RE: Proposed Resolution to PROT I-D Issues List

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 18 Mar 2005 10:54:59 -0800

Hi Steve,

I agree that the XML Schema should be normative and that
the body text should say that a received message that does
not parse _perfectly_ under the XML Schema is corrupt and
should be subject to some appropriate error handling (but
never quietly accepted).

Reconfiguration of network systems is not a use case for
"close enough for rock and roll".

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Steven Berl (sberl)
Sent: Friday, March 18, 2005 12:03 PM
To: 'Wes Hardaker'; 'Andy Bierman'
Cc: [email-masked]
Subject: RE: Proposed Resolution to PROT I-D Issues List

<snip>

> ----------------------
> 
> New text for the beginning of appendix B:
> 
> The following XML schema is for informational purposes.  It 
> has reviewed but there is no guarantee that the schema 
> exactly matches the definitions defined in the protocol 
> description above.
> Implementations MUST NOT assume that an incoming message is 
> free from malicious intent because it has been successfully 
> verified against this schema.
> 

Are you saying that we have a formal language description of the syntax of
the protocol messages, but that is there just for information? The real
definition of the syntax is in the narrative text? It seems to me that this
is kind of backwards. Is this the way that MIBs work? Is the ASN.1 there
just for information and the real description of the MIB is in the text? The
normative reference for message syntax should be the schema, and the text
should be there to describe the schema, and to explain things that are not
expressed in the schema such as the sequence of messages, or additional
constrains.

-steve

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 18 Mar 2005 11:23:49 -0800

Hi -

> From: "McDonald, Ira" <[email-masked]>
> To: <[email-masked]>; "'Wes Hardaker'" <[email-masked]>; "'Andy Bierman'" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, March 18, 2005 10:54 AM
...
> should be subject to some appropriate error handling (but

I'm inclined to agree, but we should be mindful of
http://www.ietf.org/IESG/STATEMENTS/pseudo-code-in-specs.txt
which gives primacy to the English text.

> "close enough for rock and roll".
...

Agreed, and let's not lose sight of the point of the passage Steve
Berl cited:

...
> > verified against this schema.
...

Simply passing XML validation does not guarantee that the message is
benign.

Randy