Subject: Attributes on rpcType elements

From: "Steven Berl \(sberl\)" <[email-masked]>
Date: Mon, 14 Mar 2005 14:05:48 -0800

According to section 4.1 <rpc> Element of
http://www.ietf.org/internet-drafts/draft-ietf-netconf-prot-05.txt 

   If additional attributes are present in an <rpc> element, a NETCONF
   peer must return them unmodified in the <rpc-reply> element.

But thus is not reflected in the XML Schema in appendix B. 

We either need to remove the above text from section 4.1, or we need to
modify the XML Schema in appendix B as below.

	<xs:complexType name="rpcType">
		<xs:sequence>
			<xs:element ref="rpcOperation"/>
		</xs:sequence>
		<xs:attribute name="message-id" type="xs:string"
use="required"/>
	</xs:complexType>

Needs to become:

	<xs:complexType name="rpcType">
		<xs:sequence>
			<xs:element ref="rpcOperation"/>
		</xs:sequence>
		<xs:attribute name="message-id" type="xs:string"
use="required"/>
		<xs:anyAttribute/>
	</xs:complexType>

And 

     <xs:complexType name="rpc-replyType">
       <xs:choice>
         <xs:element name="ok" minOccurs="0"/>
         <xs:element name="rpc-error"
           type="rpc-errorType" minOccurs="0"/>
         <xs:element ref="data" minOccurs="0"/>
       </xs:choice>
       <xs:attribute name="message-id" type="xs:string" use="required"/>
     </xs:complexType>

Needes to become 

     <xs:complexType name="rpc-replyType">
       <xs:choice>
         <xs:element name="ok" minOccurs="0"/>
         <xs:element name="rpc-error"
           type="rpc-errorType" minOccurs="0"/>
         <xs:element ref="data" minOccurs="0"/>
       </xs:choice>
       <xs:attribute name="message-id" type="xs:string" use="required"/>
	 <xs:anyAttribute/>
     </xs:complexType>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Rob Enns" <[email-masked]>
Date: Tue, 15 Mar 2005 12:10:08 -0800

Ack. Thanks Steven. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Steven Berl (sberl)
> Sent: Monday, March 14, 2005 2:06 PM
> To: [email-masked]
> Subject: Attributes on rpcType elements
>