Subject: What happened to <format> parameter on <get-config>?

From: "Steven Berl \(sberl\)" <[email-masked]>
Date: Mon, 14 Mar 2005 17:08:04 -0800

Hi,

I know we used to have a <format> parameter as part of the <get-config>
operation, and that it got removed in an earlier draft. I can't seem to find
the reason why it was removed, and what alternative has been provided to
allow me to send an additional parameter as part of a <get-config> request.

Basically my problem is that the config can be represented in 2 different
ways and I need to tell <get-config> which way to return it. 

I can see 2 ways to do it at the moment and I'm wondering which would be
preferred. I can put the format option inside of an implementation specific
<filter> element, or I can use the "extra attributes" that can be added on
the <rpc> element to pass in additional parameters.

Is one of these preferred?

I think in an ideal world, I would be able to specify additional attributes
on the <get-config> element, but that isn't allowed by the current XSD.

-steve

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Mon, 14 Mar 2005 20:40:29 -0500

>allow me to send an additional parameter as part of a <get-config> request.

The concensus was that namespaces could be used to determine
the sort of information that was being requested.

<rpc>
  <get-config>  <!-- from memory; caveat xmler -->
    <config>
       <configuration-text xmlns="http://example.com/text/1.0"/>
    </config>
  </get-config>
</rpc>

It does give a richer set of possible configs (and the strings
the describe them), but is a bit uglier.

>ways and I need to tell <get-config> which way to return it. 

Same here.  We default to xml and allow the above hook to
get normal text output (ala "show configuration").

Thanks,
 Phil

---

From: "Steven Berl \(sberl\)" <[email-masked]>
Date: Mon, 14 Mar 2005 20:36:23 -0800

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Phil Shafer
> Sent: Monday, March 14, 2005 5:40 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: What happened to <format> parameter on <get-config>? 
> 
> >operation, and that it got removed in an earlier draft. I 
> can't seem to 
> >find the reason why it was removed, and what alternative has been 
> >provided to allow me to send an additional parameter as part 
> of a <get-config> request.
> 

This actually isn't value by the XSD. It would need to be:

<rpc>
   <get-config>
     <source>
        <config>
     </source>
  </get-config>
</rpc>

I didn't see the <config> element available inside of the <source> as a
choice before. The problem with this is that I can't specify both a <config>
and a <config-name> in the same <source> element. This "format specifier" or
"implementation specific parameter" doesn't really seem like it belongs in
the <source> anyway. I'd think that it should be child of <get-config>, a
part of the sequence that includes <source> and <filter>. 

Any chance that we can fix this? Put <config> as a child of <get-config>
instead of a child of <source>?

-steve

> 
> It does give a richer set of possible configs (and the 
> strings the describe them), but is a bit uglier.
> 
> >Basically my problem is that the config can be represented in 2 
> >different ways and I need to tell <get-config> which way to 
> return it.
> 
> Same here.  We default to xml and allow the above hook to get 
> normal text output (ala "show configuration").
> 
> Thanks,
>  Phil
> 
> --
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.

---

From: Hector Trevino <[email-masked]>
Date: Tue, 15 Mar 2005 08:34:37 -0700

Couple of additonal questions...

- Can you provide any further insight into the discussions leading to 
the decision to use namespaces vs. the format param
- Any plans to provide some examples to clarify this

thanks

Hector

-- 
Hector Trevino
Network Management Technology Group (NMTG)
Cisco Systems Inc.        Voice:  720-875-1369
Suite 400                      
9155 E. Nichols Ave     Fax:    720-875-3014
Englewood, CO             E-mail: [email-masked]
80112

---

From: Phil Shafer <[email-masked]>
Date: Tue, 15 Mar 2005 12:43:11 -0500

>the decision to use namespaces vs. the format param

Check the minutes of the San Diego IETF.  I think that
was when this changed.

>- Any plans to provide some examples to clarify this

Sounds reasonable.

Thanks,
 Phil