Subject: RE: lang attribute in netconf schema

From: "Rob Enns" <[email-masked]>
Date: Thu, 10 Mar 2005 17:34:31 -0800

Thanks Steve. In addition to the schema changes you suggest,
are you happy with the following text:

   error-message: Contains a string suitable for human display which
      describes the error condition.  This element will not be present
      if no appropriate message is provided for a particular error
      condition.  This element SHOULD include an xml:lang attribute as
      defined in [1] and discussed in [11]. 

where [1] is the XML spec and [11] is RFC 3470.

Rob

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Steven Berl (sberl)
> Sent: Tuesday, February 22, 2005 11:01 AM
> To: [email-masked]
> Subject: xml:lang attribute in netconf schema
> 
> 
> Looking at 
> 
> http://www.ietf.org/internet-drafts/draft-ietf-netconf-prot-05.txt
> 
> Sorry I didn't notice this earlier, but in order to comply 
> with RFC3470 the
> <error-message> element should have an xml:lang attribute. 
> This should at
> least be an optional attribute if an implementation should 
> choose to provide
> it.
> 
> The edits would look like:
> 
> In the example on pg 41
> 
>          <error-message>
>            Lock failed, lock is already held
>          </error-message>
> 
> Would become
> 
>          <error-message xml:lang="EN">
>            Lock failed, lock is already held
>          </error-message>
> 
> In the XML schema insert an import for the xml namespace at the top
> 
> Before: 
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <xs:schema targetNamespace="urn:ietf:params:xml:ns:netconf:base:1.0"
> xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"
> xmlns:xs="http://www.w3.org/2001/XMLSchema" 
> elementFormDefault="qualified"
> attributeFormDefault="unqualified">
> 	<!--
> 	import standard XML definitions
> 	-->
> 	<xs:import namespace="http://www.w3.org/XML/1998/namespace"
> schemaLocation="http://www.w3.org/2001/xml.xsd">
> 		<xs:annotation>
> 			<xs:documentation>
>        Get access to the xml: attribute groups for xml:lang
>        as declared on 'schema' and 'documentation' below
>      </xs:documentation>
> 		</xs:annotation>
> 	</xs:import>
> 	<!--
>        <rpc> element
>        -->
> 
> After:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <xs:schema targetNamespace="urn:ietf:params:xml:ns:netconf:base:1.0"
> xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"
> xmlns:xs="http://www.w3.org/2001/XMLSchema" 
> elementFormDefault="qualified"
> attributeFormDefault="unqualified">
> 	<!--
> 	import standard XML definitions
> 	-->
> 	<xs:import namespace="http://www.w3.org/XML/1998/namespace"
> schemaLocation="http://www.w3.org/2001/xml.xsd">
> 		<xs:annotation>
> 			<xs:documentation>
>        Get access to the xml: attribute groups for xml:lang
>        as declared on 'schema' and 'documentation' below
>      </xs:documentation>
> 		</xs:annotation>
> 	</xs:import>
> 	<!--
>        <rpc> element
>        -->
> 
> And finally 
> 
> 			<xs:element name="error-message" 
> type="xs:string"
> minOccurs="0"/>
> 
> Should become:
> 
> 			<xs:element name="error-message" minOccurs="0">
> 				<xs:complexType>
> 					<xs:simpleContent>
> 						<xs:extension
> base="xs:string">
> 							<xs:attribute
> ref="xml:lang" type="xs:language" use="optional"/>
> 						</xs:extension>
> 					</xs:simpleContent>
> 				</xs:complexType>
> 			</xs:element>
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Steven Berl \(sberl\)" <[email-masked]>
Date: Thu, 10 Mar 2005 18:01:05 -0800

That text looks fine to me.

Thanks,

-steve 

> [mailto:[email-masked]] On Behalf Of Rob Enns
> Sent: Thursday, March 10, 2005 5:35 PM
> To: [email-masked]; [email-masked]
> Subject: RE: lang attribute in netconf schema
> 
> > Sorry I didn't notice this earlier, but in order to comply with 
> > RFC3470 the <error-message> element should have an xml:lang 
> attribute.
> > This should at
> choose to 
> > provide it.
> > <?xml version="1.0" encoding="UTF-8"?> <xs:schema 
> > targetNamespace="urn:ietf:params:xml:ns:netconf:base:1.0"
> > <?xml version="1.0" encoding="UTF-8"?> <xs:schema 
> > targetNamespace="urn:ietf:params:xml:ns:netconf:base:1.0"
> > to unsubscribe send a message to 
> [email-masked] with the 
> > word 'unsubscribe' in a single line as the message text body.
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.