Subject: NetConf over SOAP normative reference issue

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 15 Mar 2005 09:53:06 -0800

Hi,

[Bert Wijnen asked me to pass on this comment.]

The latest NetConf over SOAP <draft-ietf-netconf-soap-04.txt>
has a serious problem for advancement on the IETF "standards
track", to whit, these two normative references:

   [3]   Box, D., Ehnebuske, D., Kakivaya, G., Layman, A., Mendelsohn,
         N., Nielsen, H., Thatte, S. and D. Winer, "Simple Object Access
         Protocol (SOAP) 1.1", W3C Note NOTE-SOAP-20000508, May 2000,
         <http://www.w3.org/TR/2000/NOTE-SOAP-20000508>.

   [16]  O'Tuathail, E. and M. Rose, "Using the Simple Object Access
         Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP)",
         RFC 3288, June 2002, <http://www.ietf.org/rfc/rfc3288.txt>.

SOAP/1.1 is a W3C Note.  It will never advance on the W3C "standards
track".  In fact, W3C has approved SOAP/1.2 as a final Recommendation.

RFC 3288 was illegitimately published with the same normative
reference dependency without a formal IESG variance.

We've encountered this problem in our IEEE/ISTO Printer Working Group 
(PWG) work on management of multifunction devices using Web services.

Please don't use SOAP/1.1 (or WSDL/1.1) in NetConf solutions.  This
perpetuates non-interoperability and breaks IETF process rules.

Cheers,
- Ira, co-editor of PWG WIMS (Web-based Imaging System Mgmt Service)
  ftp://ftp.pwg.org/pub/pwg/wims/wd/wd-wims10-20050303.pdf

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 15 Mar 2005 11:59:03 -0800

Hi -

Are you suggesting we re-cast the document in terms of SOAP 1.2,
and drop the BEEP dependency?

Randy

> From: "McDonald, Ira" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, March 15, 2005 9:53 AM
> Subject: NetConf over SOAP normative reference issue
>
> Hi,
>

---

From: Andy Bierman <[email-masked]>
Date: Tue, 15 Mar 2005 12:24:19 -0800

>and drop the BEEP dependency?
what do you mean "drop the BEEP dependency"?
[note WG mailing list cc:ed -- use this address instead of [email-masked]]

>Randy
Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 15 Mar 2005 12:24:19 -0800

Andy

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 15 Mar 2005 16:25:33 -0800

Hi -

> From: "Andy Bierman" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Tuesday, March 15, 2005 12:24 PM
> Subject: Re: NetConf over SOAP normative reference issue
...
> what do you mean "drop the BEEP dependency"?

Ira's note said there was a normative reference to RFC 3288.

Randy

> >>         RFC 3288, June 2002, <http://www.ietf.org/rfc/rfc3288.txt>.
...