Subject: RE: NetConf over SOAP normative reference issue

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 16 Mar 2005 08:42:58 -0800

Hi,

I'm agnostic about the use or non-use of BEEP in NetConf.

But, yes I am urging you to change to SOAP/1.2 and NOT use 
the SOAP/1.1 mapping over BEEP defined in RFC 3288.

RFC 3288 slipped through the side door somehow and got published
without the IESG objecting to the RFC 3288 normative dependency 
on the non-standards-track SOAP/1.1 W3C Note.

The IESG (or at least Bert Wijnen) is now aware of this same
normative dependency (SOAP/1.1) in the NetConf over SOAP I-D.

I submit this issue as a last call comment.

Could someone please update the "Goals and Milestones" on the
IETF main page for NetConf WG, so that outsiders could tell 
what's going on?

Cheers,
- Ira 

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Randy Presuhn
Sent: Tuesday, March 15, 2005 7:26 PM
To: [email-masked]
Subject: Re: NetConf over SOAP normative reference issue

Hi -

> From: "Andy Bierman" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Tuesday, March 15, 2005 12:24 PM
> Subject: Re: NetConf over SOAP normative reference issue
...
> >Are you suggesting we re-cast the document in terms of SOAP 1.2,
> >and drop the BEEP dependency?
> >
> >
> what do you mean "drop the BEEP dependency"?

Ira's note said there was a normative reference to RFC 3288.

Randy

> >>From: "McDonald, Ira" <[email-masked]>
> >>To: <[email-masked]>
> >>Sent: Tuesday, March 15, 2005 9:53 AM
> >>Subject: NetConf over SOAP normative reference issue
> >>
> >>Hi,
> >>
> >>[Bert Wijnen asked me to pass on this comment.]
> >>
> >>The latest NetConf over SOAP <draft-ietf-netconf-soap-04.txt>
> >>has a serious problem for advancement on the IETF "standards
> >>track", to whit, these two normative references:
> >>
> >>   [3]   Box, D., Ehnebuske, D., Kakivaya, G., Layman, A., Mendelsohn,
> >>         N., Nielsen, H., Thatte, S. and D. Winer, "Simple Object Access
> >>         Protocol (SOAP) 1.1", W3C Note NOTE-SOAP-20000508, May 2000,
> >>         <http://www.w3.org/TR/2000/NOTE-SOAP-20000508>.
> >>
> >>   [16]  O'Tuathail, E. and M. Rose, "Using the Simple Object Access
> >>         Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP)",
> >>         RFC 3288, June 2002, <http://www.ietf.org/rfc/rfc3288.txt>.
...

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Ted Goddard <[email-masked]>
Date: Wed, 16 Mar 2005 10:28:14 -0700

One of the original concerns about SOAP 1.2 was the lack of
available implementations and the lack of compliance exhibited
by SOAP 1.2 implementations.

It seems that SOAP 1.2 is now implemented widely enough to insist
on it.  Are there any comments on the current implementation status
of SOAP 1.2 vs SOAP 1.1?  (Is this even open to discussion, given
the standards status of SOAP 1.2 vs SOAP 1.1?)

Thanks,
Ted.

---

From: Andy Bierman <[email-masked]>
Date: Wed, 16 Mar 2005 10:56:19 -0800

> by SOAP 1.2 implementations.

I don't remember this being discussed by the WG

> the standards status of SOAP 1.2 vs SOAP 1.1?)

It's an issue that needs to be addressed. 
Here are the differences between SOAP 1.1 and 1.2:
http://www.w3.org/TR/2003/REC-soap12-part0-20030624/#L4697

Are there any differences that impact NETCONF?

It doesn't seem like we can remove reference [16] (RFC 3288)
without removing all of section 2.6.  Is there an update
planned for SOAP over BEEP? 

> Ted.

Andy