Subject: netconf engine ID

From: Andy Bierman <[email-masked]>
Date: Wed, 16 Mar 2005 18:48:43 -0800

Hi,

Can anyone remember why we don't have a netconf engine ID defined,
and why it isn't exchanged in the <hello> message?  Is this too
hard for 1.0?  From an NMS POV, it would be nice to tell different
netconf agents apart with something other than the transport address.

Comments?

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "David T. Perkins" <[email-masked]>
Date: Wed, 16 Mar 2005 19:19:40 -0800 (PST)

HI,

On the research that I've done for SNMPv3/ISMS, I've come to
the belief that the SNMP engineID is just extra work. In
SNMPv3, it's "only" use is for proxies. However, SNMPv3 to
SNMPv3 proxy has not seen widestread usage (let me know if
this is not the case). It's a pain to set up, and I don't
know of any tools to help. The other use of SNMP engineID
is for use in SNMPv3/USM to qualify user names. This has
proved problematic, and is the motivation for the ISMS WG.

So, is there a particular use that you want for a
netcond engineID? Then we can try to figure out
if the benefit exceeds the cost.

> netconf agents apart with something other than the transport address.

Regards,
/david t. perkins

---

From: Andy Bierman <[email-masked]>
Date: Wed, 16 Mar 2005 19:59:57 -0800

>if the benefit exceeds the cost.
I'd like to have a standard identifier for a particular netconf agent,
independent of the agent's network address.  This can be deferred until
the data modeling work I guess.

Andy