Subject: configuration vs operational requests

From: "Daniel Mcgillivray \(LN/EAB\)" <[email-masked]>
Date: Thu, 28 Apr 2005 14:37:19 +0200

Hi,

I am familiar with the Junoscript protocol as used by Juniper on its routers. It is clear that Netconf has many the same concepts as Junoscript (or vice versa?).

My question is, whether there exists a similar development of a protocol for so called operational requests towards network elements? Are there plans to extend Netconf into this area, although it is not directly configuration related. SNMP of course is an obvious answer, but I would like to know if there are others alternatives which go hand in hand with Netconf.

The reason being, that many network elements require certain actions before and/or after committing a new configuration, and then it is rather awkward to have to switch protocol for this.

I hope you can give me some hints here.

Kind regards,
Daniel

Daniel McGillivray MSc

Ericsson AB
Mail: [email-masked]
Web: www.ericsson.com

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Thu, 28 Apr 2005 11:41:32 -0400

"Daniel Mcgillivray \(LN/EAB\)" writes:
>I am familiar with the Junoscript protocol as used by Juniper on its routers. It is clear that
> Netconf has many the same concepts as Junoscript (or vice versa?).

Yes, netconf builds on the experience we gained with Junoscript.

>My question is, whether there exists a similar development of a protocol for so called operati
>onal requests towards network elements? Are there plans to extend Netconf into this area, alth
>ough it is not directly configuration related. SNMP of course is an obvious answer, but I woul
>d like to know if there are others alternatives which go hand in hand with Netconf.

Netconf is primarily concerned with configuration, but the capability
mechanism allows the creation of additional RPCs, including operational
requests.  Defining such RPCs wasn't the initial target of the working
group, but will likely come up as the current drafts are put to bed.

Thanks,
 Phil