Subject: Question: Expected Behaviour when edit-config matches two instanc es

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 4 Apr 2005 09:14:22 -0400

hi

Section 6 of the protocol speciation, which discussed subtree filtering,
claims to apply to <get> or <get-config> operation. My question is whether
we expect this behaviour to be different for the <edit-config> command, and
if so, where is this defined?

In particular, if the <edit-config> matches more than once instance of
something, are they both modified or is this an invalid command? If we
follow the model in 6, then they are both modified. If the command is
instead invalid, is this because 1) I did not provide the entire record, 2)
because it matched more than one instance at runtime or 3) because of some
yet to be defined concept of a key?

Given a bit of XML that looks like

<grommets>
<grommet>
  <foo> 12</foo>
  <bar> 1 </bar>
  <state> up </state>
</grommet>
<grommet>
   <foo> 12 </foo>
   <bar> 2 </bar>
   <state> up </state>
</grommet>
<grommets>

and we send the following command

     <rpc message-id="101"
          xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
       <edit-config>
         <target>
           <running/>
         </target>
         <config>
           <top xmlns="http://example.com/schema/1.2/config">
             <grommets>
               <grommet>
                 <foo>12</foo>
                 <state>down</state>
               </grommet>
             </grommets>
           </top>
         </config>
       </edit-config>
     </rpc>

Sharon Chisholm
Nortel 
Ottawa, Ontario
Canada

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 04 Apr 2005 07:32:06 -0700

>if so, where is this defined?
The filtering doesn't apply to edit-config.
The data models used in edit-config must exactly match some schema
(outside the scope of the current charter).  It depends on the data model
semantics whether or not "wildcard via omission" is a feature or a bug.
IMO, it's a bug and an NMS must provide all the required instance 
identifiers
or the agent returns an error.

Andy