Subject: no NETCONF WG meeting planned for Paris

From: Andy Bierman <[email-masked]>
Date: Tue, 10 May 2005 09:07:54 -0700

Hi,

At this time, it appears all WG milestones will be completed
before the next IETF, so there are no plans to hold a NETCONF
WG meeting at the Paris IETF. 

We understand that some people want to continue adding features
to the protocol and/or work on standard data models, but this
work would need to be chartered first -- a process that has not
been started, and not likely to be completed before the next IETF.

Andy and Simon

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 26 May 2005 18:45:46 +0300

Anything prevents us drafting (or re-drafting) a charter update,
circulating it for comments, and having it approved before the August
meeting? We have another ten weeks to go. 

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Sharon Chisholm
> Sent: Thursday, May 26, 2005 6:34 PM
> To: netconf
> Subject: RE: no NETCONF WG meeting planned for Paris
> 
> hi
> 
> So, as I indicated in Minneapolis, I plan two presentations 
> into the Paris meeting. One on the Netmod work proposing that 
> gets added to the charter and another on asynchronous 
> messaging with a similar objectives. The technical work is 
> being progressed as we speak.
> 
> Are you suggesting that you would like to see the proposed 
> updated charter before Paris?
> 
> Sharon
> 
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Tuesday, May 10, 2005 12:08 PM
> To: netconf
> Subject: no NETCONF WG meeting planned for Paris
> 
> 
> Hi,
> 
> We understand that some people want to continue adding 
> features to the protocol and/or work on standard data models, 
> but this work would need to be chartered first -- a process 
> that has not been started, and not likely to be completed 
> before the next IETF.
> 
> 
> Andy and Simon
> 
> --
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.

---

From: "Glenn Waters" <[email-masked]>
Date: Fri, 27 May 2005 11:58:46 -0400

Inline.

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Andy Bierman
> Sent: Friday, May 27, 2005 09:23
> To: [email-masked]
> Cc: Chisholm, Sharon [CAR:5K50:EXCH]; 'netconf'
> Subject: Re: no NETCONF WG meeting planned for Paris
>
> I disagree.
> The 2 main deferred features -- partial locking and notifications --
> are both simply speed optimizations, which impact a relatively small
> number of use cases.   We don't have any serialization in SNMP or
> CLI at all!  Concurrent writes can clobber config now, but this
> doesn't seem to be a big problem.  I'm not convinced the lack
> of locked concurrent writes in NETCONF is a problem yet.

While I would prefer that NETCONF supports partial locking I can live
without this feature for now. However this feature is number 2 on my feature
list with the number 1 feature listed below.
 
> Notifications essentially provide a speed improvement over polling
> techniques.  Currently, many CLI applications use SNMP notifications
> and SYSLOG for this purpose.  The convenience of receiving async
> messages within a NETCONF session is probably balanced out by
> the increased localized cost of the NETCONF implementation, and
> most likely does not represent a significant percentage of either
> the implementation or deployment complexity.

Polling is not a good substitute for notifications. Polling does not scale
both with a large box and across large networks. Notifications are simply
required and required within NETCONF. Using SNMP or Syslog for notifications
does not provide the integrated solution required to build consolidated and
robust applications.
 
> IMO, the lack of these deferred features has no significant impact
> on the usefulness of NETCONF 1.0.
> 
> As for NETMOD -- I don't see much hope of a WG agreeing on the
> one true NETCONF data modeling language.  I agree that would
> be the ideal from a standards-POV, but not realistic or even
> close to operationally optimal.  E.g., A scheme tuned for SNMP
> integration isn't going to work well for CLI-oriented configuration.
> 
> Andy

Regards, /gww

---

From: "Faye Ly" <[email-masked]>
Date: Fri, 27 May 2005 10:11:32 -0700

Andy,

Very well said!  I wonder if anybody has considered the following
requirements for the need of notification besides SNMP and SYSLOG:
(Sharon, if this duplicates your requirements I apologize.)

1. Customer may or may not want to punch so many holes in their firewall
for management purpose.  SNMP, SYSLOG and NETCONF all have different
ports.  Having a single TLS port helps eliminate the administration
cost.
2. SNMP is not secure despite of v3.  I think we have gone through this
many times and not many customers seem to be deploying v3?  Why, I am
not an expert.  I think NETCONF is very well designed with the security
and notification channel is a natural next step.  Again this saves admin
cost that once you setup one secured management port you do both config
and notification using the same port.  
3. The scalability of SNMP traps is great for network devices but there
has been some new requirement like the security device.  The later sends
a lot more logs than regular network device.  Soaking no longer works as
each log needs to be sent to the server to be examined.  But I do agree
with you that this might be a special case and we should not change the
overall model just because some corner case.  This largely depends on
the member of this mailing list.  Is this a high requirement for other
network device as well?

Best,

-faye

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Andy Bierman
Sent: Friday, May 27, 2005 6:23 AM
To: [email-masked]
Cc: 'Sharon Chisholm'; 'netconf'
Subject: Re: no NETCONF WG meeting planned for Paris

David B Harrington wrote:

>Hi Andy 
>
>  
>
>>There are some pretty powerful features within a
>>decent transaction model to act on that bucket of XML content.
>>I know some of us on the design team we're really just
>>trying to eliminate screen-scraping the CLI with 1.0.
>>Even if NETCONF is just used as a programmatic interface
>>to the CLI at first, this is better than screen-scraping.
>>    
>>
>
>And I strongly support that vision. Screen-scraping needs to go. 
>
>But we also need to move past the constraint that any operator must be
>able to lock the whole configuration to modify it, and a large number
>of other issues that you have collected during the development of
>netconf 1.0. Just changing from screen-scraping to XML isn't enough to
>meet operators' needs, even if it is a big step in the right
>direction.
>  
>

I disagree.

Andy

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Sun, 29 May 2005 14:10:49 +0300

> From: Juergen Schoenwaelder [mailto:[email-masked]] 
> Sent: Thursday, May 26, 2005 9:08 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]; Sharon Chisholm; netconf
> On Thu, May 26, 2005 at 06:55:21PM +0300, Romascanu, Dan (Dan) wrote:
> 
> > In Minneapolis the Netconf WG decided to continue the NETMOD work 
> > within Netconf rather than creating a new WG.
> 
> Can a WG decide something during an IETF meeting?
> 

Here are the minutes:

----------------------------

NETMOD

Passes to Sharon for her presentation on data modeling. 

Discussion ended with the suggestion to produce drafts about data
modeling before the Paris meeting, and discuss them there. 

---------------------------

... Let us not become lawyers ... It was a discussion about if and where
to do future work ... No decision, just room consensus, or what I got
from it ... And we can debate this on the list ... Which seems to be
what we are doing ... 

Dan