Subject: RE: few comments on the prot-06 draft

From: "Steven Berl \(sberl\)" <[email-masked]>
Date: Thu, 5 May 2005 15:05:54 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Thursday, May 05, 2005 9:36 AM
> To: netconf
> Subject: few comments on the prot-06 draft
> 
> Hi,
> 
> Throughout the text, whenever a parameter value is mentioned, 
> such as test-then-set, it should appear in single quotes, 
> e.g., 'test-then-set'.  Some text like this could be 
> confusing if you don't have all the tag names memorized yet ;-)
> 
> The 'confirm-commit' parameter in the XSD is incorrect.
> There is no 'type' attribute defined so an empty element is 
> the only allowed construct.  The following text is needed
> in the 'confirm-timeout' element:   type="xs:positiveInteger"

I would have thought it should be type="xs:duration".

> 
> It appears an issue (which was brought up on the mailing 
> list) slipped through the cracks, which would cause a semantic change:
> 
>   - PROT, sec. 8.4.5.1  (confirmed commit parameters)
>     units of confirm-timeout not granular enough

Xs:duration gives all the granularity you could ever want from years
down to milliseconds.

-steve

> 
> I strongly agree with the proposal to change the units of the 
> confirm-timeout parameter from minutes to seconds.  There are 
> already use cases where the minimum rollback trigger of one 
> minute is too slow.  Networks get faster not slower, so we 
> should fix this now before it's too late.  The default can 
> still be 10 minutes (value == 600 instead of 10).
> 
> Please comment on the mailing list regarding this issue, so 
> we can decide if there is consensus to make this change.
> 
> thanks,
> Andy
> 
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 05 May 2005 18:45:58 -0700

>I would have thought it should be type="xs:duration".
Yikes!  This is way more complicated than we need!
(Look at the example in the Primer Part 0 spec:
P1Y2M3DT10H30M12.3S is 1 year, 2 months, 3 days, 10 hours, 30 min. and 
12.3 sec

I don't think we need a minimum interval less than one second or
a maximum interval over billions of seconds.  I prefer to keep the
encoding as simple as possible -- which is a positiveInteger.

Andy

---

From: Eliot Lear <[email-masked]>
Date: Fri, 06 May 2005 08:48:40 +0200

> Yikes!  This is way more complicated than we need!

On the other hand, it's there.  There must be stuff to parse it already?!

---

From: Andy Bierman <[email-masked]>
Date: Fri, 06 May 2005 09:10:54 -0700

> On the other hand, it's there.  There must be stuff to parse it already?!

This is a pretty weak argument.  The type 'positiveInteger' is also there
and it's really easy to parse -- way easier than 'duration'.  It's way 
easier
for operators to use in their scripts as well.

More importantly -- this parameter has been a positiveInteger in every 
I-D version.
The XSD has had a bug all along -- the confirm-timeout parameter was
not defined to correctly model the normative text.  The fix (make the XSD
match the normative text) is type="xs:positiveInteger.

A separate issue arose - whether 'minutes' was the proper units for this 
parameter.
There is a proposal to change the units from minutes to seconds.  Now there
is another proposal to change the data type to 'duration'.

I do not think there is consensus to make any change at this time.

I wonder what the rest of the WG thinks?

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 7 May 2005 07:32:09 +0200

> I wonder what the rest of the WG thinks?

I think positiveInteger is what we should use and I like the idea
to allow for a resolution in seconds.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany