Subject: another XSD alignment nit

From: Andy Bierman <[email-masked]>
Date: Wed, 11 May 2005 13:21:01 -0700

Hi,

Section 8.8.5 lists proto-op extensions for the #url capability.
The XSD does not match the normative text  in one place:

  - complexType editConfigType : the <config> element is type 
'configInlineType'
    but it should be a choice between configInlineType and configURIType

[Rob understands the edits... :-) ]

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Rob Enns" <[email-masked]>
Date: Fri, 13 May 2005 11:22:29 -0700

>     but it should be a choice between configInlineType and 

Elsewhere (source/target parameters) NETCONF uses the 
<url> element as a sibling of <config>, so I suspect
we should do the same in <edit-config>. The resulting
XSD would be:

  <xs:complexType name="editConfigType">
    <xs:complexContent>
      <xs:extension base="rpcOperationType">
        <xs:sequence>
          <xs:annotation>
            <xs:documentation>
              Use of the test-option element requires the
              #validate capability. Use of the url element
              requires the #url capability.
            </xs:documentation>
          </xs:annotation>
          <xs:element name="target"
                      type="rpcOperationTargetType"/>
          <xs:element name="default-operation"
                      type="defaultOperationType"
                      minOccurs="0"/>
          <xs:element name="test-option"
                      type="testOptionType"
                      minOccurs="0"/>
          <xs:element name="error-option"
                      type="errorOptionType"
                      minOccurs="0"/>
          <xs:choice>
            <xs:element name="config"
                        type="configInlineType"/>
            <xs:element name="url"
                        type="configURIType"/>
          </xs:choice>
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>

I think this is better than stuffing <url> inside <config>
in here, and using it as a sibling of <config> in other spots.
Cool?

Rob