Subject: Proposed change to capability URNs

From: "Rob Enns" <[email-masked]>
Date: Wed, 29 Jun 2005 16:51:13 -0700

Based on the XML directorate comments that the # naming scheme for
capabilities
is problematic, I'm proposing that we change NETCONF capability URNs to
the 
following format:

urn:ietf:params:xml:ns:netconf:capability:{name}:1.0

For example:

urn:ietf:params:xml:ns:netconf:capability:startup:1.0

(the old style was urn:ietf:params:xml:ns:netconf:base:1.0#startup)

Does this sound reasonable?

thanks,
 Rob

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 30 Jun 2005 08:09:11 +0200

On Wed, Jun 29, 2005 at 04:51:13PM -0700, Rob Enns wrote:
> capabilities is problematic, I'm proposing that we change NETCONF 
> capability URNs to the following format:
> 

Yes.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Andy Bierman <[email-masked]>
Date: Wed, 29 Jun 2005 18:24:01 -0700

>Does this sound reasonable?

It seems okay to me.
Unless anyone strongly objects to this proposal on the mailing list,
we should just add it into the next prot update.

> Rob

Andy