Subject: RE: I-D Publication Request: draft-ietf-netconf-soap-05.txt

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 11 Jul 2005 13:57:32 -0700

Hi Phil,

The draft certainly doesn't track that 'concensus'.  The draft
should explicitly say SHOULD NOT use port 80 for NetConf for
reliability and security reasons.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Phil Shafer [mailto:[email-masked]]
> Sent: Monday, July 11, 2005 4:59 PM
> To: McDonald, Ira
> Cc: [email-masked]'; Ted Goddard; 'Sharon Chisholm';
> netconf
> Subject: Re: I-D Publication Request: draft-ietf-netconf-soap-05.txt 
> 
> 
> "McDonald, Ira" writes:
> >If you use a dedicated port, then much simpler protection can be
> >performed.
> 
> I think this issue is an old one.  We had concensus on
> not using port 80 and on requesting an official port.
> If the draft doesn't track this, it needs an update.
> 
> Thanks,
>  Phil
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Ted Goddard <[email-masked]>
Date: Mon, 11 Jul 2005 15:37:01 -0600

How about the following?

    A NETCONF SOAP service could be offered on any desired port, but a
    new standard port for NETCONF over SOAP (over HTTP) will be defined,
    as requested in the IANA considerations of this document.
    For reliability and security reasons, NETCONF SHOULD NOT be
    offered on port 80, and instead SHOULD use the IANA defined port.

(This also removes the comment about possibly defining a standard
port for SOAP over HTTP in general -- an interesting discussion on its
own, but not essential for NETCONF.)

Thanks,
Ted.

---

From: Phil Shafer <[email-masked]>
Date: Mon, 11 Jul 2005 17:59:37 -0400

Simplify?

     A NETCONF SOAP service SHOULD be offered over a new standard
     port for NETCONF over SOAP (over HTTP) that will be defined
     as requested in the IANA considerations of this document.

Maybe add something in the security section about the evils
of using port 80?

Thanks,
 Phil