Subject: how long should the manager maintain the connection with his device?

From: "王罕" <[email-masked]>
Date: Wed, 6 Jul 2005 11:20:30 +0800

hi all:

   I have read the netconf-pro06 and "scalability of netconf" topic on the list, I saw 
Juergen Schoenwaelder said he find that holding 300 TCP connections is not a hard thing.

   but I want to know in the real world , does the manager just hold the connection when there are still some config operation need to be performed and the connection will be kill as soon as these operations completed?  Or it will hold the connection with his "agent" all the time until some accident happens? 

thanks for coming in!

Best Regards

---------------------------------------------------
Wang Han

[email-masked]
Research Center of Network Technology
Nanjing University of Posts and Telecommunications
---����������������������������������������������������

h�{.n�+���zwZ��,j��w�r�߭�z�h�Ȟ��+����^ݺ{.n�+�����"�	^�)�j�azg�����mn�rj�!�������l��_��?�+-��޵�'

---

From: "王罕" <[email-masked]>
Date: Thu, 7 Jul 2005 09:42:36 +0800

Dear Kent Watsen， 
  thanks for your reply. 
    
      but I really can't image a single machine has the capability that maintains  persistence connections
with *6000*  device.  
 So  could you please tell me the machine's type, and how do you get the number "6000" ??
　　

======== 2005-07-07 06:41:56  Kent Watsen said： =====

The duration of the connection is closely related to how often the non-initiating side needs to flush its buffers (i.e. event notifications).  We find that persistent connections work fine for up to 6000 devices - this is the practical connection limit for a single machine.  For more than 6000 devices, either a server-cluster or a periodic-poll architecture needs to be considered - the choice pending on the interaction requirements of your system

When NetConf pursues event notifications, in addition to following the publish/subscribe messaging pattern it would be good to also consider the durable-subscriber and priority-queuing patterns for NMSs wishing to have non-persistent connections

Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, July 05, 2005 8:21 PM
To: netconf
Subject: how long should the manager maintain the connection with his device?

hi all:

thanks for coming in!

Best Regards

[email-masked]
Research Center of Network Technology
Nanjing University of Posts and Telecommunications
---——————————————————————————

恫rzu瞶z潽秹叚瞨z矔澏z伷wrzЕ祪矟

Regards

Wang Han
------------------------------------------------------------
Wang Han

[email-masked]
Research Center of Network Technology
Nanjing University of Posts and Telecommunications
——————————————————————————

---

From: "Kent Watsen" <[email-masked]>
Date: Wed, 6 Jul 2005 15:41:56 -0700

Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, July 05, 2005 8:21 PM
To: netconf
Subject: how long should the manager maintain the connection with his device?

hi all:

thanks for coming in!

Best Regards

[email-masked]

恫rzu瞶z潽秹叚瞨z矔澏z伷wrzЕ祪矟
-��칻�&ޱ��jg�����޵�'~����-��"z��"�a{
+v�칻�&ފv��x%zX�y�-�鞲Ơzױ��ɪ܆+ކ�i��)�'�~���X����z�(��

---

From: "Kent Watsen" <[email-masked]>
Date: Fri, 8 Jul 2005 15:27:58 -0700

Hi Wang,

Our product achieves 6000 connections with both stock Solaris-9 and RedHat-ES based systems.  As for the hardware, our sizing guides suggest customers have about 4 gigs of memory, but the majority of this memory is not for TCP.  Honestly, we did this without much consideration for if it could be done – in fact, we have another product that does over 10,000 connections on a single machine…  Maybe it is because we are using the C programming language with a single select()-driven thread?

But the point I was trying to make, in answering your original question, is that managers do like to hold persistent connections – I say “like” as it is easy to implement without great impact to either the endpoints or the network in-between.

Kent

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, July 06, 2005 6:43 PM
To: netconf; Kent Watsen
Subject: Re: how long should the manager maintain the connection with his device?

Dear Kent Watsen， 

  thanks for your reply. 

with *6000*  device.  

　　

	 

	Kent

	-----Original Message-----

	To: netconf

	hi all:

	 

	thanks for coming in!

	Best Regards

	Wang Han

	[email-masked]

	 

	恫rzu瞶z潽秹叚瞨z矔澏z伷wrzЕ祪矟

Regards

Wang Han

Wang Han

[email-masked] <mailto:[email-masked]>