Subject: Full support of a capability

From: Vincent Cridlig <[email-masked]>
Date: Tue, 12 Jul 2005 10:23:32 +0200

Hi,

A few questions on the Netconf draft:

If an agent advertises the #writable-running capability, does it mean 
that the full data model has to support it ?
Differently: if a part of the agent data model doesn't support 
#writable-running capability, is the agent allowed to advertise this 
capability ?

Or can this be managed with "operation-not-supported" or 
"operation-failed" error when needed ?

Vincent Crdlig

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Vincent Cridlig <[email-masked]>
Date: Wed, 13 Jul 2005 09:34:52 +0200

The #write-running capability was just an example for my question.
If a data model is made of multiple parts, say datamodel1, datamodel2, 
datamodel3:
<netconf>
<datamodel1>[...]</datamodel1>
<datamodel2>[...]</datamodel2>
<datamodel3>[...]</datamodel3>
</netconf>

and if an agent advertises a capability c1, my question was:
Does it mean that all parts (datamodel1, datamodel2, datamodel3) of the 
data model have to support this capability ?
If yes, it means that all parts have to support exactly the same set of 
capabilities.

If a vendor integrates a proprietary data model (like a MIB) in an 
existing Netconf agent and comes with its own proprietary capability, do 
all other sub data models have to implement this capability so that it 
can be advertised ?

I hope it is more understandable.

Thanks,
Vincent

Andy Bierman wrote:

> Vincent Cridlig wrote:
> The capability is for the whole device and is independent of the data 
> model
> being modified.
>
>>
> You mean the error-tag for the <copy-config> from <running> to <startup>
> (i.e., explicit NV-save for #writable-running) or some other operation?
>
> Let me see if I understand the details here...
>
> Depending on the data model content that is altered (or simply 
> installed?)
> during a particular NETCONF session,  the agent sometimes updates
> the non-volatile storage as soon as the <running> config is altered,
> and sometimes it waits for an explicit <copy-config> operation to
> update the <startup> config.    What a mess.   How is an application
> supposed to know when it needs to use <copy-config> or not?
> Also, <startup> only exists if #writable-running is true, and it is
> supposed to be a conceptual mirror or <running>, not a subset.
>
> Perhaps you mean that you have some data models that do not
> get saved in NV-storage at all.  In NETCONF terms, this is
> state data, not config data.
>
>
>
>>
>> Vincent Crdlig
>
>
>
> Andy
>
>>
>> --

---

From: Andy Bierman <[email-masked]>
Date: Wed, 13 Jul 2005 00:37:31 -0700

Vincent Cridlig wrote:

> Does it mean that all parts (datamodel1, datamodel2, datamodel3) of 
> the data model have to support this capability ?
> If yes, it means that all parts have to support exactly the same set 
> of capabilities.

I suppose it would depend on how the capability is defined.
The ones in the NETCONF document are global and apply to
the entire device.

> existing Netconf agent and comes with its own proprietary capability, 
> do all other sub data models have to implement this capability so that 
> it can be advertised ?
>

Andy

>>> If an agent advertises the #writable-running capability, does it 
>>> mean that the full data model has to support it ?

---

From: Andy Bierman <[email-masked]>
Date: Tue, 12 Jul 2005 08:08:08 -0700

> #writable-running capability, is the agent allowed to advertise this 

The capability is for the whole device and is independent of the data model
being modified.

Depending on the data model content that is altered (or simply installed?)

Andy