Subject: Implementations

From: Balazs Lengyel <[email-masked]>
Date: Wed, 16 Nov 2005 10:19:44 +0100

Is there somewhere a list of existing or planned netconf implementations ? I currently 
know about the following:

EnSuite - Extended Netconf SUITE (Yencap)
	http://madynes.loria.fr/ensuite/
	Written in Python, freeware (?)

Erlang implementation by small Swedish company

Wipro - XML Based Device Management 	
	http://www.wipro.com/prodesign/reusableframeworks/ip/xml.htm
	written in Java

NEC Europe Ltd Germany
	written in C

Postech Korea
	written in C

Balazs

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Damien Routier <[email-masked]>
Date: Wed, 16 Nov 2005 11:30:48 +0100

Hi all,

Let's add:
6WIND - XMS (eXtensible Management System)
    http://www.6wind.com
    written in C

Best regards,
Damien Routier

> Is there somewhere a list of existing or planned netconf 
> implementations ? I currently know about the following:
>

---

From: Vincent Cridlig <[email-masked]>
Date: Wed, 16 Nov 2005 11:45:14 +0100

EnSuite is under LGPL.
Vincent CRIDLIG

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 16 Nov 2005 13:38:42 +0100 (CET)

We have an extensible NETCONF agent implementation with C-APIs, see
http://www.tail-f.com.

/martin

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 16 Nov 2005 11:28:38 -0800

Hi -

Is it too early for someone to put together a web site that
consolidates this information, perhaps in a manner similar
to http://www.ibr.cs.tu-bs.de/projects/snmpv3/ ?

Randy

---

From: Simon Leinen <[email-masked]>
Date: Wed, 16 Nov 2005 22:44:34 +0100

> to http://www.ibr.cs.tu-bs.de/projects/snmpv3/ ?

Not the same level of detail, but I just added pointers to these
implementations to

http://www.ops.ietf.org/netconf/#implementations

Please don't hesitate to contact me if you have any additions.

Regards,
-- 
Simon.