Subject: One request multiple replies

From: Balazs Lengyel <[email-masked]>
Date: Wed, 16 Nov 2005 17:28:29 +0100

Is it allowed for a netconf device to issue multiple replies for one netconf request ?

We have operations in our nodes that may take  10 minutes to execute. I order the 
execution but I don't want to sit there waiting for a reply for 10 minutes. I also don't 
want to block the netconf session for 10 minutes. How do you solve this situation ?

I was thinking about sending a provisional reply back immediately e.g. operation started 
and then sending a final reply e.g. operation finished when the thing really is executed.

Another solution could be to open a separate netconf session for the long running operation.

Any ideas ?

regards Balazs

P.S. Thanks for all the help today.
-- 
Balazs Lengyel                       Ericsson Hungary Ltd.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Wed, 16 Nov 2005 11:56:35 -0500

>Is it allowed for a netconf device to issue multiple replies for one netconf request ?

No, it's a one-to-one relationship between request and reply.

>want to block the netconf session for 10 minutes. How do you solve this situation ?

Two schemes:  simplest is to just open a second connection.  Gives
you a completely independent communication path.

The other option is to return some token which future RPCs can poll
for status on the operation.

Thanks,
 Phil

---

From: Miguel Angel Fernandez Gutierrez <[email-masked]>
Date: Wed, 16 Nov 2005 17:56:15 +0100

> We have operations in our nodes that may take  10 minutes to execute. I 
> order the execution but I don't want to sit there waiting for a reply for 
> 10 minutes. I also don't want to block the netconf session for 10 minutes. 
> How do you solve this situation ?
>
> I was thinking about sending a provisional reply back immediately e.g. 
> operation started and then sending a final reply e.g. operation finished 
> when the thing really is executed.
>

The problem with this is approach is that support for multiple concurrent 
netconf sessions is not a MUST but only a SHOULD, if I'm not mistaken. So 
you cannot rely on this idea as a general solution.

I think you can get only one reply to a request. Perhaps the reply could be 
an immediate "operation started", and then you can issue subsequent requests 
for processing progress, that could be also immediately answered like 
"operation in process (X% complete)" and, finally, "operation complete" 
(with success or error). Sorry if this sounds silly. I'm only a couple of 
weeks worth on NetConf yet.

---
Miguel Angel Fernandez
Telefonica I+D - Spain