Subject: RE: notification charter proposal

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 23 Nov 2005 10:09:45 -0800

Hi,

I urge you folks to choose at least option (b), i.e., protocol
level acknowledgement of receipt of a notification.

This both improves the sender logging functionality (as Juergen
S. has observed) and also lets the sender know that the notification 
receiver is indeed alive and running.  Repeated missing acks should
lead to abandonment of notifications to that target, at least for
some reasonable period of time.

Notifications that are not received are NOT notifications - they're
just noise on the network.

Unconfirmed notifications are only defensible when delivered by a
connectionless transport (e.g., UDP).  SNMP Informs (confirmed) 
significantly improve the functionality of mid-level SNMP managers.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Juergen Schoenwaelder
> Sent: Wednesday, November 23, 2005 11:20 AM
> To: Phil Shafer
> Cc: Sharon Chisholm; [email-masked]
> Subject: Re: notification charter proposal
> 
> 
> On Tue, Nov 22, 2005 at 10:42:17AM -0500, Phil Shafer wrote:
> > Juergen Schoenwaelder writes:
> > >c) The notification sender sends a notification and gets a 
> confirmation
> > >   that an entity dealing with notifications actually 
> understood the
> > >   semantics associated with the notification.
> > 
> > Dumb question:  what does one do with a system that supports you
> > option (c)?  If I sent a notification, the receiver tells me my
> > semantics are off, then what happens?  I resend?  I resend 
> to another
> > target?  I auto-correct my semantics?  Are there realistic options
> > that I have as a non-intelligent notification sender?
> 
> If you talk to a person, you can get back either
> 
> a) nothing
> b) "I heard you"
> c) "I understood what you were saying"
> 
> It of course depends on the smartness of the whole system how you
> react. Some humans are fine when they achieve b), some other
> implementations feel better if they know they have achieved c).
> 
> Sure, implementation complexity goes up from a) to c) and the added
> value of c) might not be worth the extra effort it causes. So perhaps
> the decision is between a) and b).
> 
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 23 Nov 2005 19:13:29 +0100

> level acknowledgement of receipt of a notification.

You get this for free with BEEP.