Subject: Detailed locking

From: Balazs Lengyel <[email-masked]>
Date: Wed, 16 Nov 2005 10:59:02 +0100

What is the reason that we only allow locking of a complete datastore.

Ericsson might need a more fine grained locking mechanism. E.g. If we have subscriber data 
and device configuration data in the same node one manager might be updating the 
subscriber data while the other migh be changing OSPF settings. It could work perfectly as 
the two areas are quite separate. However if you lock the whole configuration this is not 
possible.

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 16 Nov 2005 11:46:39 +0100

On Wed, Nov 16, 2005 at 10:59:02AM +0100, Balazs Lengyel wrote:
> Ericsson might need a more fine grained locking mechanism. E.g. If we have 
> subscriber data and device configuration data in the same node one manager 
> might be updating the subscriber data while the other migh be changing OSPF 
> settings. It could work perfectly as the two areas are quite separate. 
> However if you lock the whole configuration this is not possible.

The WG had a long discussion on the granularity of locking and finally
ended up supporting only per datastore locks for netconf 1.0 in order
to get netconf out of the door. I think people are encouraged to
experiment with more granular locking schemes and can propose their
solutions for incorporation into future netconf versions.

If you want to see the details, see the meeting minutes and the
mailing list archives.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany