Subject: RE: IANA considerations update for NETCONF protocol draft

From: "Rob Enns" <[email-masked]>
Date: Mon, 5 Dec 2005 10:02:44 -0800

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Tom Petch
> Sent: Monday, December 05, 2005 1:10 AM
> To: Randy Presuhn; netconf
> Subject: Re: IANA considerations update for NETCONF protocol draft
> 
> From: "Randy Presuhn" <[email-masked]>
> To: "netconf" <[email-masked]>
> Sent: Monday, December 05, 2005 2:42 AM
> Subject: Re: IANA considerations update for NETCONF protocol draft
> 
> 
> > Hi -
> >
> > > From: "McDonald, Ira" <[email-masked]>
> > > To: "'Andy Bierman'" <[email-masked]>; "Rob Enns" 
> <[email-masked]>
> > > Cc: "Wijnen, Bert (Bert)" <[email-masked]>; 
> <[email-masked]>
> > > Sent: Saturday, December 03, 2005 3:37 PM
> > > Subject: RE: IANA considerations update for NETCONF protocol draft
> > ...
> > > Instead, simply specify that Enterprise Capabilities MUST choose a
> > > _durable_ globally unique URI within one of the 
> registered DNS domains
> > > for that enterprise (i.e., using GUIDs based on MAC address is NOT
> > > allowed).
> > ...
> 
> > What happens when that domain name is recycled?  (E.g., the company
> > is swallowed by another, the domain registration is allowed 
> to lapse,
> > and some other orgnaization starts using it for thir own URIs.)
> >
> > Randy
> >
> 
> Then we should have used URN 'which are required to remain 
> globally unique
>    and persistent even when the resource ceases to exist or 
> becomes unavailable'
> [RFC3986]
> 
> Not sure that it is worth it though.

I'm not sure it's worth it either. My preference is to drop the IANA
allocated enterprise capability registry. Enterprises defining their
own capabilities can choose URIs that make sense to them. Much like
XML namespaces, common sense would dictate the choice of a URI that
won't clash with others. 

Rob

> Tom Petch

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Eliot Lear <[email-masked]>
Date: Mon, 05 Dec 2005 19:10:03 +0100

> XML namespaces, common sense would dictate the choice of a URI that

Common sense is something that works with small numbers, but not with
large.  Why can't we solve this problem the same way SNMP solved it?  I
do think we can defer this until we see large numbers of netconf agent
implementations.

Eliot