Subject: nit in NETCONF XSD in prot-09

From: Andy Bierman <[email-masked]>
Date: Wed, 07 Dec 2005 09:54:40 -0800

Hi,

I was studying the XSD again, and I noticed 2 new things:

  1) errorInfoContent maxOccurs is all wrong
     - ok-element should be "1", the rest are "unbounded"
       or maybe they are all "unbounded"?
  2) errorInfoContent isn't used anywhere in the schema
     - so maybe it should just be removed?

  <xs:group name="errorInfoContent">
       <xs:sequence>
         <xs:element name="bad-attribute" type="xs:QName"
           minOccurs="0" maxOccurs="1"/>
         <xs:element name="bad-element" type="xs:QName"
           minOccurs="0" maxOccurs="1"/>
         <xs:element name="ok-element" type="xs:QName"
           minOccurs="0" maxOccurs="unbounded"/>
         <xs:element name="err-element" type="xs:QName"
           minOccurs="0" maxOccurs="unbounded"/>
         <xs:element name="noop-element" type="xs:QName"
           minOccurs="0" maxOccurs="unbounded"/>
         <xs:element name="session-id" type="SessionId"
           minOccurs="0" maxOccurs="1"/>
       </xs:sequence>
     </xs:group>

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Rob Enns" <[email-masked]>
Date: Wed, 7 Dec 2005 10:34:41 -0800

Removing it is fine for now. This part of NETCONF (error contents) has 
had perhaps the least attention from implementors, judging from the 
number of questions and comments we've received. Once we get some 
experience it would be nice to tighten the XSD up a little.

Rob 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Wednesday, December 07, 2005 9:55 AM
> To: Netconf (E-mail)
> Subject: nit in NETCONF XSD in prot-09
> 
> Hi,
>