Subject: RE: IANA considerations update for NETCONF protocol draft

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 3 Dec 2005 15:37:58 -0800

Andy Bierman wrote:
> 
> Rob Enns wrote:
> 
> >
> >The last alternative would be to forget the idea of IANA allocated
> >enterprise capabilities, and let enterprises do their own thing 
> >with URIs.
> >
> >I'd like the WG to weigh in on this question.
> >  
> >
> 
> I don't think we really need this Enterprise Capability Registry.
> We created our own template for extending the standard (Appendix C)
> but that does not mean that IANA or the IETF needs to be involved
> whatsoever in proprietary extensions to the NETCONF protocol.
> 

Forget the IANA Enterprise Capability Registry.  Unless you bend
IETF best practices badly, an IANA allocation should ALWAYS require 
_at_least_ IETF Designated Expert review.  

Instead, simply specify that Enterprise Capabilities MUST choose a
_durable_ globally unique URI within one of the registered DNS domains 
for that enterprise (i.e., using GUIDs based on MAC address is NOT
allowed).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 4 Dec 2005 17:42:54 -0800

Hi -

> From: "McDonald, Ira" <[email-masked]>
> To: "'Andy Bierman'" <[email-masked]>; "Rob Enns" <[email-masked]>
> Cc: "Wijnen, Bert (Bert)" <[email-masked]>; <[email-masked]>
> Sent: Saturday, December 03, 2005 3:37 PM
> Subject: RE: IANA considerations update for NETCONF protocol draft
...
> for that enterprise (i.e., using GUIDs based on MAC address is NOT
...

What happens when that domain name is recycled?  (E.g., the company
is swallowed by another, the domain registration is allowed to lapse,
and some other orgnaization starts using it for thir own URIs.)

Randy

---

From: "Tom Petch" <[email-masked]>
Date: Mon, 5 Dec 2005 10:09:37 +0100

From: "Randy Presuhn" <[email-masked]>
To: "netconf" <[email-masked]>
Sent: Monday, December 05, 2005 2:42 AM
Subject: Re: IANA considerations update for NETCONF protocol draft

> and some other orgnaization starts using it for thir own URIs.)

Then we should have used URN 'which are required to remain globally unique
   and persistent even when the resource ceases to exist or becomes unavailable'
[RFC3986]

Not sure that it is worth it though.

Tom Petch

---

From: Phil Shafer <[email-masked]>
Date: Mon, 05 Dec 2005 11:27:08 -0500

"Randy Presuhn" writes:
>What happens when that domain name is recycled?

The capability out-lasts the company that defined it without becoming
a standard?  Is this a real world scenario?  Doesn't the act of
implementing netconf cement a company's future?  ;^)

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Mon, 05 Dec 2005 08:52:02 -0800

>Not sure that it is worth it though.

I doubt this is an operational problem.
If acme.com goes away, the MGMT SW and NETCONF agent
using a capability string with this value in it will still work.

The odds that a new owner will release a NETCONF agent using
the exact same capability strings (entire string matters--domain name is
just a substring) is quite remote.

The odds that this will happen and the new and old devices with matching
capability strings will show up in the same administrative domain are
even lower.

>Tom Petch

Andy