Subject: RE: pending edits for prot-10

From: "Rob Enns" <[email-masked]>
Date: Wed, 28 Dec 2005 11:55:29 -0800

> The following changes will be made in the next version:
> 
>    1)  change the order of the <source> and <target> parameters
>        in the <copy-config> command
> 
>    2) add a maxLength="4095" constraint to the <message-id> attribute
> 
>    3) provide XSD for standard <error-info> content
>       (was removed from prot-10; needs to be fixed and replaced)

Sounds good. 

Also:

   o  Update authors and acknowledgements (fix Andy's email, spell
Sharon's
      name correctly).
   o  Clarify that restrictions on locking a modified configuration
      apply to the candidate configuration.
   o  Update IANA considerations.  New NETCONF capabilities require IETF
      Standards Action.

> The following change is agreed upon, but the replacement text
> with all the details has not been written yet:
> 
>   4) optionally advertise your own max-message-size in the
>      capabilities exchange
> 
>    <element name="max-message-size" type="integer" minOccurs="0"/>

Put this one on hold until we understand the implications?

Rob

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 28 Dec 2005 17:14:27 -0800

Rob Enns wrote:

> >...

Yes -- I'm not sure everyone understands the 'hint' concept.

If the agent sends me a hint that it will drop requests over 1 MB in size,
then I can either take that into account and do the extra work in
my manager to keep my requests to that agent under 1MB and
get the job done -- or deal with the 'too-big' error and not get
the job done.  My choice.

The optional part -- if I don't have a max-size for messages sent to me,
or I don't want to bother letting anybody know what it is,
then I don't advertise any max-message-size in the capabilities exchange.

>Rob

Andy