Subject: RE: [Capabilities] SMIv2 to XML Schema conversions

From: "McDonald, Ira" <[email-masked]>
Date: Sun, 19 Feb 2006 10:41:31 -0800

Hi Juergen,

Sorry, I'm not familiar with 'smidump', so I don't know the
answer.  No doubt people should probably just use 'smidump'.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: Sunday, February 19, 2006 1:38 PM
> To: McDonald, Ira
> Cc: [email-masked]
> Subject: Re: [Capabilities] SMIv2 to XML Schema conversions
> 
> 
> On Sun, Feb 19, 2006 at 08:56:44AM -0800, McDonald, Ira wrote:
> 
> > I wrote a tool three years ago that converts SMIv2 MIBs to
> > XSD files.  It's been used for the canonical translations
> > of printer industry MIBs (e.g., Printer MIB v2, RFC 3805)
> > for the IEEE-ISTO PWG's standard Semantic Model.
> > 
> > I'm not willing to open source this tool, but if anyone's
> > interested in the approaches used, I'd be happy to talk
> > offline.
> 
> How does the tools output differ from what 'smidump -f xsd' generates?
> 
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 20 Feb 2006 08:37:06 +0100

> answer.  No doubt people should probably just use 'smidump'.

While you can download smidump and see what it generates and how the
XSD differs from what your tool generates, I can't do the same with
your tool.

Since you are familiar with the Printer-MIB, I have put the output of
'smidump -f xsd' online:

	ftp://ftp.eecs.iu-bremen.de/netconf/Printer-MIB.xsd

I would be curious to know what you did differently, but perhaps this
is getting off-topic for this mailing list and we should either move
that discussion to the netconfmodel list or yet somewhere else.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany