Subject: Clarifications

From: Balazs Lengyel <[email-masked]>
Date: Mon, 06 Feb 2006 10:26:46 +0100

Hello,
- The validate operation might contain inline config as well as I understand the XSD. In 
the text only datastore name is mentioned. Which is correct ?

- Is it true that one RPC can contain only one operation? The XSD seems to indicate this, 
but maybe it should be mentioned in the text as well.

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 10 Feb 2006 07:16:29 -0800

Balazs Lengyel wrote:
> Hello,
> - The validate operation might contain inline config as well as I 
> understand the XSD. In the text only datastore name is mentioned. 
> Which is correct ?

inline also -- this bug was already found

>
> - Is it true that one RPC can contain only one operation? The XSD 
> seems to indicate this, but maybe it should be mentioned in the text 
> as well.
>

yes.

I believe this is the text in question (from prot-10 [4.1]):

   The <rpc> element is used to enclose a NETCONF request sent from the
   client to the server.

If we meant N requests this sentence would say
"enclose one or more NETCONF requests" instead.

All along, we keep referring to our operations layer as if
it really is independent of the RPC layer.  But as sec. 4
clearly indicates (to me anyway), from the RPC layer POV,
there is no operations layer.   There is a top node which
indicates the RPC method to call, and any child nodes of
that are just input parameters to the RPC method.

There is only one RPC method call per <rpc> element.

Andy