Subject: RE: Capabilities and MIBs

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 16 Feb 2006 13:08:05 -0800

Hi Andy,

Excellent set of questions, showing the depth of the problem
space!

If NetConf ever succeeds in standardizing a data model, then
Relax NG and Schematron are going to become very important
tools, because XSD is terminally deficient to answer many of
your questions.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Andy Bierman
> Sent: Thursday, February 16, 2006 3:32 PM
> To: Randy Presuhn
> Cc: [email-masked]
> Subject: Re: Capabilities and MIBs
> 
> 
> Randy Presuhn wrote:
> > Hi -
> >
> >   
> >> From: "Romascanu, Dan (Dan)" <[email-masked]>
> >> To: "Vincent Cridlig" <[email-masked]>; 
> <[email-masked]>; <[email-masked]>
> >> Sent: Thursday, February 16, 2006 12:38 AM
> >> Subject: RE: Capabilities and MIBs
> >>
> >>     
> >
> >   
> >> That's an important clarification, because the discussion since
> >> yesterday very much related to SNMP MIBs. 
> >>
> >> If we are talking about supported versions (capabilities) 
> of the netconf
> >> data model in agents, my assumption was that a list of 
> namespace URIs
> >> would be enough, and those would include information about 
> versions. 
> >>     
> > ...
> >
> > This brings us full circle to my question.  To re-phrase:
> >  will there be anything analogous to AGENT-CAPABILITIES for
> > netconf data models?
> >   
> 
> Good question. 
> One of many completely unknown aspects of netconf data modeling.
>  - what does a netconf data model look like, independent of 
> the NETCONF 
> protocol?
>    (different subsets are allowed for different operations 
> and different 
> capabilities.
>     How does XSD deal with this again? ;-)
>  - what does netconf modularity look like?
>  - how do modules easily use definitions from other modules?
>  - what do nested tables and "row" instance naming look like? 
>  - what does netconf data model conformance look like?
>  - what does netconf data model conformance variation look 
> like? (your 
> question)
>  - what is the access control model that provides for RPC 
> method invocation
>     control in addition to data access control?
>  - what is the model for partial database locking?
> 
> However all this is out of scope for the time being.
> That doesn't mean that individuals and vendors can't work on 
> the answers 
> now.
> It would be good to have reasonable answers before any 
> standards effort 
> begins.
> 
> > Randy
> >   
> 
> Andy
> 
> >
> > --
> > to unsubscribe send a message to [email-masked] with
> > the word 'unsubscribe' in a single line as the message text body.
> > archive: <http://ops.ietf.org/lists/netconf/>
> >
> >
> >   
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 16 Feb 2006 13:40:38 -0800

> tools, because XSD is terminally deficient to answer many of

I will have to look into Schematron.
I agree with you about XSD.
IMO, RelaxNG is overkill in some areas,
perfect in other areas, and totally deficient in still other areas.
(Not the right mailing list to go into details...)

Andy

---

From: Christian Lynbech <[email-masked]>
Date: Mon, 20 Feb 2006 14:36:35 +0100

Admittedly dangerous territory to enter for a newcomer, but has
anybody considered Document Structure Descriptions:

        http://www.brics.dk/DSD/dsd2.html

as a possible vehicle for model definitions?

------------------------+-----------------------------------------------------
Christian Lynbech       | Ericsson Telebit, Skanderborgvej 232, DK-8260 Viby J
------------------------+-----------------------------------------------------