Subject: netconf implementation guide

From: Andy Bierman <[email-masked]>
Date: Fri, 10 Feb 2006 16:50:42 -0800

Hi,

I think eventually we will keep collecting clarifications,
maybe even enough for a NETCONF Implementation Guide RFC.

Are there any WG members willing to work on a
NETCONF Implementation Guide (Informational) RFC?
Is there community interest in having such a document?

If so, the first step is collecting implementation experience,
FAQ material, document clarifications and errata, etc.

==========================================

2 more issues that aren't very obvious
(No, nothing more is going into prot-11;
NETCONF Version 1 is in the can.)

1) Error processing hierarchy

There are some errors that need to be processed before others.
It is reasonable for an agent to stop looking for certain types
of errors after particular errors have already occurred.

For example, if the target of an edit-config is an unknown
configuration name, or the user doesn't have access rights to
invoke the edit-config method, then the <config> element sub-tree
may not be analyzed for errors, regardless of the 'continue-on-error' flag.

It is therefore possible (e.g., big edit-config request) for a manager
to receive an rpc-reply before it finishes sending the matching
<rpc> request.

2) Edit-config processing

The merge order is data model dependent.
A NETCONF data model definition which allows
multiple instances of an element must indicate the
merge order somehow.

When processing a replace operation, it is important
to know if a sub-node (in the data model, not the PDU!) is
  1) mandatory
  2) mandatory-with-default
  3) optional

If (1) then missing sub-elements are errors.
If (2) then missing sub-elements with defaults are filled in before
   checking for missing elements.
If (3) then this is not an error, but any corresponding nodes
  in the target that match the missing nodes must be removed

A NETCONF data model definition must indicate the <edit-config>
replace behavior somehow.

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 13 Feb 2006 08:30:34 -0800

Martin Bjorklund wrote:
> Andy Bierman <[email-masked]> wrote:
>   
>> Hi,
>>
> I think this is a great idea, and I'm willing to help with this work.
>   

Great -- will you be at the Dallas IETF?
I am planning to hold an Editors meetings/Bar BoF in Dallas
to get this started.

> /martin

Andy

---

From: Adel_JARIFI <[email-masked]>
Date: Mon, 13 Feb 2006 21:37:47 +0100

Dear Sir, Madam,

We are a group of students from ENST Brittany (National School of 
telecommunication of Brittany) – located in Rennes - France 
(http://international.enst-bretagne.fr/welcome/).
We work on a network management project based on the Netconf protocol. 
In a first place we were interested in the protocol itself and currently 
we are looking into the various open source and proprietary 
implementations of Netconf.
We know that MADYNES team of INRIA has developed a set of software 
called “Ensuite”, but we don’t know if industrial companies and network 
equipment providers such as Cisco, HP, Juniper, etc…are developing on 
there side any solution based on Netconf.
I would like to know if you have some information about some proprietary 
implementation.
Thank you in advance for your help and support.

Best regards,
Adel JARIFI

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 13 Feb 2006 13:19:16 +0100 (CET)

/martin