Subject: XSD session-id clarification

From: Andy Bierman <[email-masked]>
Date: Sat, 04 Feb 2006 13:57:58 -0800

Hi Rob,

I hate to make you add another change,
but I think the XSD is supposed to help automate
tool development, and the 'session-id' schema is wrong.
Zero is never a valid value for session-id in a hello
message or kill-session operation.

There are really 2 types:

 SessionId  (type="unsignedInt" minInclusive="1")

 SessionIdOrZero    (type="unsignedInt")

The places SessionId is used (should leave alone):

  - kill-session : session-id parameter

  - hello : session-id parameter

The place SessionId should be changed to SessionIdOrZero:

  - not in the XSD!
  - the <error-info> content for a lock-denied error is
    a session-id element (type is really SessionIdOrZero)
  - I guess we don't technically need this simpleType

If you add a minInclusive="1" restriction to the SessionId
simpleType, then the XSD will be correct (for sessionId at least ;-)

thanks,
Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Rob Enns" <[email-masked]>
Date: Mon, 6 Feb 2006 08:29:10 -0800

No worries, this is a good change.

Rob 

> -----Original Message-----
> From: Andy Bierman [mailto:[email-masked]] 
> Sent: Saturday, February 04, 2006 1:58 PM
> To: Rob Enns
> Cc: Netconf (E-mail)
> Subject: XSD session-id clarification
> 
> Hi Rob,
>