Subject: RE: XSD session-id clarification

From: "McDonald, Ira" <[email-masked]>
Date: Sun, 5 Feb 2006 11:15:23 -0800

Hi,

Agreed, but 'SessionIdOrZero' should definitely have
a 'minInclusive=0' facet.  A negative session ID is
meaningless.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Andy Bierman
> Sent: Saturday, February 04, 2006 4:58 PM
> To: Rob Enns
> Cc: Netconf (E-mail)
> Subject: XSD session-id clarification
> 
> 
> Hi Rob,
> 
> I hate to make you add another change,
> but I think the XSD is supposed to help automate
> tool development, and the 'session-id' schema is wrong.
> Zero is never a valid value for session-id in a hello
> message or kill-session operation.
> 
> There are really 2 types:
> 
>  SessionId  (type="unsignedInt" minInclusive="1")
> 
>  SessionIdOrZero    (type="unsignedInt")
> 
> 
> The places SessionId is used (should leave alone):
> 
>   - kill-session : session-id parameter
> 
>   - hello : session-id parameter
> 
> The place SessionId should be changed to SessionIdOrZero:
> 
>   - not in the XSD!
>   - the <error-info> content for a lock-denied error is
>     a session-id element (type is really SessionIdOrZero)
>   - I guess we don't technically need this simpleType
> 
> 
> If you add a minInclusive="1" restriction to the SessionId
> simpleType, then the XSD will be correct (for sessionId at least ;-)
> 
> 
> 
> thanks,
> Andy
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Sun, 05 Feb 2006 15:00:48 -0500

>Andy Bierman said:

>a 'minInclusive=0' facet.  A negative session ID is

unsignedInt can't be negative.

Thanks,
 Phil