Subject: RE: Capabilities and MIBs

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 16 Feb 2006 10:38:07 +0200

That's an important clarification, because the discussion since
yesterday very much related to SNMP MIBs. 

If we are talking about supported versions (capabilities) of the netconf
data model in agents, my assumption was that a list of namespace URIs
would be enough, and those would include information about versions. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Vincent Cridlig
> Sent: Thursday, February 16, 2006 10:32 AM
> To: [email-masked]; [email-masked]
> Subject: Re: Capabilities and MIBs
> 
> David B Harrington wrote:
> 
> >Hi,
> >
> >Are you referring to SNMP (SMIv1 or v2) MIBs, or are you 
> talking about 
> >data models designed for use with netconf?
> >  
> >
> I was talking about data models designed for use with netconf.
> I realize now that my question was ambiguous. I meant "MIB" 
> in the general meaning of a Management Information Base (not 
> SNMP MIB). Sorry about that.
> 
> Vincent
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 16 Feb 2006 11:59:14 -0800

Hi -

> From: "Romascanu, Dan (Dan)" <[email-masked]>
> To: "Vincent Cridlig" <[email-masked]>; <[email-masked]>; <[email-masked]>
> Sent: Thursday, February 16, 2006 12:38 AM
> Subject: RE: Capabilities and MIBs
>

> would be enough, and those would include information about versions. 
...

This brings us full circle to my question.  To re-phrase:
 will there be anything analogous to AGENT-CAPABILITIES for
netconf data models?

Randy

---

From: "David B Harrington" <[email-masked]>
Date: Thu, 16 Feb 2006 15:25:49 -0500

Will there be any netconf data models? ;-)

David Harrington
[email-masked]

> [mailto:[email-masked]] On Behalf Of Randy Presuhn
> Sent: Thursday, February 16, 2006 2:59 PM
> To: [email-masked]
> > To: "Vincent Cridlig" <[email-masked]>; 
> <[email-masked]>; <[email-masked]>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 16 Feb 2006 12:31:51 -0800

>  will there be anything analogous to AGENT-CAPABILITIES for

Good question. 
One of many completely unknown aspects of netconf data modeling.
 - what does a netconf data model look like, independent of the NETCONF 
protocol?
   (different subsets are allowed for different operations and different 
capabilities.
    How does XSD deal with this again? ;-)
 - what does netconf modularity look like?
 - how do modules easily use definitions from other modules?
 - what do nested tables and "row" instance naming look like? 
 - what does netconf data model conformance look like?
 - what does netconf data model conformance variation look like? (your 
question)
 - what is the access control model that provides for RPC method invocation
    control in addition to data access control?
 - what is the model for partial database locking?

However all this is out of scope for the time being.
That doesn't mean that individuals and vendors can't work on the answers 
now.
It would be good to have reasonable answers before any standards effort 
begins.

> Randy

Andy