Subject: proposal to change URL capability syntax

From: Andy Bierman <[email-masked]>
Date: Wed, 01 Feb 2006 09:07:54 -0800

Hi,

Our URL capability uses the term 'protocol':
   
urn:ietf:params:netconf:capability:url:1.0?protocol=http,ftp,file

As this snippet of RFC 3986 shows, we are using the term "protocol"
instead of the proper term "scheme".  ("file" is not a protocol)

         foo://example.com:8042/over/there?name=ferret#nose
         \_/   \______________/\_________/ \_________/ \__/
          |           |            |            |        |
       scheme     authority       path        query   fragment
          |   _____________________|__
         / \ /                        \
         urn:example:animal:ferret:nose

We are proposing to change the term "protocol" to "scheme"
in the URL capability syntax to align with RFC 3986 terminology. 

This change will require existing pre-standard implementations to be 
updated.

Unless there are any strong objections, prot-11 will include this update.

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Wed, 01 Feb 2006 13:14:43 -0500

Sounds good to me.

Thanks, 
 Phil