Subject: FW: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed Standar d [I06-051127-0011]

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 28 Feb 2006 10:13:46 +0100

The question on IETF Last Call from IANA was:

  Date and Time: 2005-11-27, 17:16:49 
  Version: 05 
  Commented by: Michelle Cotton 
  State before Comment: In Last Call 
  State after Comment: In Last Call 
  Comment: IANA Last Call Comments:
  Upon approval of this document the IANA will assign a TCP port number for NETCONF
  over SSH in the following registry:
  http://www.iana.org/assignments/port-numbers
  Which range should this port be assigned in?

  The IANA will also assign "netconf" as an SSH Service Name in the following
  registry: 
  http://www.iana.org/assignments/ssh-parameters 

We still seem to not be clear on it. But maybe IANA/Michelle did not
see the notes to RFC-Editor and IANA:

In Section 7 IANA Considerations:

OLD:

    IANA is requested to assign a TCP port number which will be the
    default port for NETCONF over SSH sessions as defined in this
    document.

NEW:

    IANA is requested to assign a TCP port number which will be the
    default port for NETCONF over SSH sessions as defined in this
    document.

    IANA has assigned port <TBD> for this purpose.

    [RFC Editor, please replace two instances of <TBD> in Section 3
    and one instance of <TBD> in this section to the port number
    assigned by IANA.]

Michelle, will that be sufficient?

Bert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 28, 2006 07:18
To: [email-masked]
Subject: RE: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed
Standard [I06-051127-0011]

IANA NOT OK.  Comments in tracker.
IANA Actions - YES

Question from Last Call has not yet been answered.

Michelle Cotton
(on behalf of IANA)

-----Original Message-----
From: IESG Secretary [mailto:[email-masked]] 
Sent: Thursday, February 23, 2006 11:58 AM
To: Internet Engineering Steering Group
Subject: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed Standard,
draft-ietf-netconf-prot-11.txt to Proposed Standard 

--------

Evaluation for draft-ietf-netconf-ssh-05.txt, draft-ietf-netconf-prot-11.txt

can be found at 
https://datatracker.ietf.org/cgi-bin/idtracker.cgi?command=view_id&dTag=1075
1&rfc_flag=0 

Last Call to expire on: 2005-12-07

        Please return the full line with your position.

                      Yes  No-Objection  Discuss  Abstain
Brian Carpenter      [   ]     [   ]     [   ]     [   ]
Bill Fenner          [   ]     [   ]     [   ]     [   ]
Ted Hardie           [   ]     [   ]     [   ]     [   ]
Sam Hartman          [   ]     [   ]     [   ]     [   ]
Scott Hollenbeck     [   ]     [   ]     [   ]     [   ]
Russ Housley         [   ]     [   ]     [   ]     [   ]
David Kessens        [   ]     [   ]     [   ]     [   ]
Allison Mankin       [   ]     [   ]     [   ]     [   ]
Jon Peterson         [   ]     [   ]     [   ]     [   ]
Mark Townsley        [   ]     [   ]     [   ]     [   ]
Margaret Wasserman   [   ]     [   ]     [   ]     [   ]
Bert Wijnen          [ X ]     [   ]     [   ]     [   ]
Alex Zinin           [   ]     [   ]     [   ]     [   ]

"Yes" or "No-Objection" positions from 2/3 of non-recused ADs, 
with no "Discuss" positions, are needed for approval.

DISCUSSES AND COMMENTS:
======================

^L 
---- following is a DRAFT of message to be sent AFTER approval ---
From: The IESG &lt;[email-masked]&gt;
To: IETF-Announce &lt;[email-masked]&gt;
Cc: Internet Architecture Board &lt;[email-masked]&gt;,
    RFC Editor &lt;[email-masked]&gt;, 
    netconf mailing list &lt;[email-masked]&gt;,
    netconf chair &lt;[email-masked]&gt;,
    netconf chair &lt;[email-masked]&gt;
Subject: Protocol Action: 'NETCONF Configuration Protocol' to Proposed 
         Standard 

The IESG has approved the following documents:

- 'Using the NETCONF Configuration Protocol over Secure Shell (SSH) '
   &lt;draft-ietf-netconf-ssh-05.txt&gt; as a Proposed Standard
- 'NETCONF Configuration Protocol '
   &lt;draft-ietf-netconf-prot-11.txt&gt; as a Proposed Standard

These documents are products of the Network Configuration Working Group. 

The IESG contact persons are Bert Wijnen and David Kessens.

A URL of this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-netconf-prot-11.txt

Technical Summary
 
  NETCONF Configuration Protocol

  The NETCONF configuration protocol defined in this document provides
  mechanisms to install, manipulate, and delete the configuration of
  network devices.  It uses an Extensible Markup Language (XML) based
  data encoding for the configuration data as well as the protocol
  messages.  The NETCONF protocol operations are realized on top of a
  simple Remote Procedure Call (RPC) layer.

  Using the NETCONF Configuration Protocol over Secure Shell (SSH)

  This document describes a method for invoking and running the NETCONF
  configuration protocol within a Secure Shell (SSH) session as an SSH
  subsystem.

  Note:  The WG could not decide on a single transport mapping for
  NETCONF, because different types of programmers want to use the
  protocol.  Therefore, NETCONF defines three transport mappings: 
  SSH, BEEP, and SOAP, where SSH is the mandatory-to-implement
  protocol. 

Working Group Summary
 
  The NETCONF Working Group has consensus to publish these documents
  as a Proposed Standard.  

Protocol Quality

  It is likely that there are several implementations of these
  documents in various stages of completion at this time.
  Several major equipment vendors have indicated interest in
  supporting this document, and some non-commercial
  implementations are also expected.
  An interoperability event (just prior to Paris IETF) was held
  in which 4 implementations participated and feedback was
  considered in revisions of these documents.

  Bert Wijnen reviewed these documents for the IESG.

Note to RFC Editor
 
 (Insert note to RFC Editor here)

IESG Note

 (Insert IESG Note here)

IANA Note

 (Insert IANA Note here)

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "IANA" <[email-masked]>
Date: Tue, 28 Feb 2006 09:44:19 -0800

Bert,

I still don't see what range the port needs to go in...
User (0-1023) or system (1024-49151) range?

Am I missing a note somewhere that give this information?

Thanks,

Michelle
IANA

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
Sent: Tuesday, February 28, 2006 1:14 AM
To: IANA (E-mail)
Cc: Margaret Wasserman (E-mail); Netconf (E-mail)
Subject: FW: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed Standard
[I06-051127-0011]

  Upon approval of this document the IANA will assign a TCP port number for
NETCONF

  The IANA will also assign "netconf" as an SSH Service Name in the
following
  registry: 
  http://www.iana.org/assignments/ssh-parameters 

We still seem to not be clear on it. But maybe IANA/Michelle did not see the
notes to RFC-Editor and IANA:

OLD:

NEW:

Bert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 28, 2006 07:18
To: [email-masked]
Subject: RE: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed Standard
[I06-051127-0011]

Michelle Cotton
(on behalf of IANA)

-----Original Message-----
From: IESG Secretary [mailto:[email-masked]]
Sent: Thursday, February 23, 2006 11:58 AM
To: Internet Engineering Steering Group
Subject: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed Standard,

--------

can be found at

"Yes" or "No-Objection" positions from 2/3 of non-recused ADs, with no
"Discuss" positions, are needed for approval.

DISCUSSES AND COMMENTS:
======================

^L
---- following is a DRAFT of message to be sent AFTER approval ---
From: The IESG &lt;[email-masked]&gt;
To: IETF-Announce &lt;[email-masked]&gt;
Cc: Internet Architecture Board &lt;[email-masked]&gt;,
    RFC Editor &lt;[email-masked]&gt;, 
    netconf mailing list &lt;[email-masked]&gt;,
    netconf chair &lt;[email-masked]&gt;,
    netconf chair &lt;[email-masked]&gt;
Subject: Protocol Action: 'NETCONF Configuration Protocol' to Proposed 
         Standard 

Technical Summary

Working Group Summary

Protocol Quality

Note to RFC Editor

IESG Note

 (Insert IESG Note here)

IANA Note

 (Insert IANA Note here)