Subject: [Capabilities] SMIv2 to XML Schema conversions

From: "McDonald, Ira" <[email-masked]>
Date: Sun, 19 Feb 2006 08:56:44 -0800

Hi,

I wrote a tool three years ago that converts SMIv2 MIBs to
XSD files.  It's been used for the canonical translations
of printer industry MIBs (e.g., Printer MIB v2, RFC 3805)
for the IEEE-ISTO PWG's standard Semantic Model.

I'm not willing to open source this tool, but if anyone's
interested in the approaches used, I'd be happy to talk
offline.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 19 Feb 2006 19:38:21 +0100

> interested in the approaches used, I'd be happy to talk

How does the tools output differ from what 'smidump -f xsd' generates?

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany