Subject: RE: [Capabilities] SMIv2 to XML Schema conversions

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 20 Feb 2006 09:12:12 -0800

Hi Juergen,

I hadn't realized that there _was_ a netconf model list.  
NetConf and IETF Languge Tag Registration Updates are 
accounting for 80 messages a day that I mostly try to read.

The link you sent below appears to be broken (I can't
use a command line FTP or a web browser to that site).

The translations of the two modules in Printer MIB v2 
(RFC 3805) from my tool are permanently posted at:

ftp://ftp.pwg.org/pub/pwg/wims/schemas/rfc3805a-20040805.xsd
- IANA-PRINTER-MIB (textual conventions registry)

ftp://ftp.pwg.org/pub/pwg/wims/schemas/rfc3805b-20040805.xsd
- Printer-MIB

If you send me your translation as an attachment, I'll try
to find time to look at it and compare.  I'm very busy just
now, so it may take a little while.

And since you make smidump available and you're the expert,
it's probably the right choice for others to use.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: Monday, February 20, 2006 2:37 AM
> To: McDonald, Ira
> Cc: [email-masked]
> Subject: Re: [Capabilities] SMIv2 to XML Schema conversions
> 
> 
> On Sun, Feb 19, 2006 at 10:41:31AM -0800, McDonald, Ira wrote:
> 
> > Sorry, I'm not familiar with 'smidump', so I don't know the
> > answer.  No doubt people should probably just use 'smidump'.
> 
> While you can download smidump and see what it generates and how the
> XSD differs from what your tool generates, I can't do the same with
> your tool.
> 
> Since you are familiar with the Printer-MIB, I have put the output of
> 'smidump -f xsd' online:
> 
> 	ftp://ftp.eecs.iu-bremen.de/netconf/Printer-MIB.xsd
> 
> I would be curious to know what you did differently, but perhaps this
> is getting off-topic for this mailing list and we should either move
> that discussion to the netconfmodel list or yet somewhere else.
> 
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 20 Feb 2006 19:24:43 +0100

> use a command line FTP or a web browser to that site).

Seems to be a middlebox issue - some clients seem to work while
others don't.
 
> now, so it may take a little while.

I am attaching it. Note that we tried to keep as much information as
possible and hence your translation appears much more verbose. (Some
people have used the translation in an SNMP/XML gateway where this
additional information was useful.)

> it's probably the right choice for others to use.

I like to understand what proper mappings are. I am sure that are
differences in the details and I like to understand them and perhaps
improve upon what we have. I am not talking about implementations here
- I am interested to figure out whether there have been common ways to
do things or whether it is possible to agree on a common way to do
things. This is IMHO the first step in writing up a specification.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany