Subject: RE: Notification Message Processing Model

From: "Hector Trevino \(htrevino\)" <[email-masked]>
Date: Thu, 23 Mar 2006 12:11:18 -0800

Hi, in-line
Hector

> -----Original Message-----
> From: Shane Kerr [mailto:[email-masked]] 
> Sent: Thursday, March 23, 2006 12:38 PM
> To: Hector Trevino (htrevino)
> Cc: Netconf (E-mail)
> Subject: Re: Notification Message Processing Model
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hector Trevino (htrevino) wrote:
> >>From an operational standpoint it makes much more sense to have
> > dedicated connections or channels for commands/control & 
> notifications.
> > When using SSH it is an operational/resource constraint decision 
> > whether or not a full dedicated SSH session is used for commands & 
> > notifications or a single session with multiple channels is 
> utilized.
> > A notifications session/channel needs to allow the transfer of 
> > commands (i.e. rpcs and notifications mixed) because for 
> example (just 
> > one, there are others) a management application dedicated to 
> > monitoring/troubleshooting may need to retrieve additional 
> information 
> > in response to a received fault-notification. I think that in this 
> > situations it is ok to simply interleave messages.
> 
> Why not perform the query to retrieve additional information 
> on a separate channel?
> 
> As a client developer, it would be simplier. You avoid the case:
> 
> server -> client
>   event A
> client -> server
>   RPC asking for more info about event A server -> client
>   event B (sent before RPC began)
> 
> The client has to either handle the event asynchronously, or 
> save it in some buffer somewhere (or perhaps ignore it).

HT: Sure, you can do that but IMO that's an operational/deployment
decision. From my perspective, I'd like provide as much deployment
flexibility as possible and minimize the complexity. Hence the example
of a possible usage. 
 
> 
> - --
> Shane
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.2.2 (GNU/Linux)
> Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org
> 
> iD8DBQFEIvkdMsfZxBO4kbQRAg+fAJ9bKEopxrJIMU+YMsh/juEjC3BtrACffiWe
> aeAdc9InfNEOwE+b/MDZiF0=
> =Pq7j
> -----END PGP SIGNATURE-----
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 23 Mar 2006 13:41:31 -0800

>...

1) Flexible as possible never means simple as possible

2) I'm still unclear on this use case you mention

Andy