Subject: Re: DISCUSS: draft-ietf-netconf-beep

From: Eliot Lear <[email-masked]>
Date: Thu, 02 Mar 2006 10:20:02 +0100

Brian,

As Andy and I responded to Elwyn, this was discussed within the working
group.  The consensus was at the time that the client knows its a client
and the server knows its a server so this isn't really a problem.  I was
in the minority at the time.  My preference would be two separate BEEP
profiles, and this was in fact the case in an earlier version of the
document, as I recall.

Eliot
ps: whatever tool you're using to generate this email is generating
illegal destination addresses in the "To" field.

Brian Carpenter wrote:
> Discuss:
> (Based on Gen-ART review by Elwyn Davies)
>
> The base NETCONF protocol spec talks about 'client/server' instead of 'manager/agent'. This document uses 'manager/agent' but needs to be
> consistent with the base spec.
>
> The base NETCONF protocol spec requires (in section 2):
>
>   
>>    The transport protocol MUST provide a mechanism to indicate the
>>    session type (client or server) to the NETCONF protocol layer.
>>     
>
> So where does the BEEP mapping do this? If that isn't defined,
> it's a bug.
>
>   

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Eliot Lear <[email-masked]>
Date: Thu, 02 Mar 2006 12:12:54 +0100

Brian E Carpenter wrote:
> Yes but, there remains an inconsistency with a solid
> requirement of the protocol spec. I don't see how you
> can expect the IESG to approve in the same meeting a draft
> that says you MUST do something and another draft that
> says you don't need to. Would you rather I put a DISCUSS
> on the protocol spec?
>
> (I assume the terminology issue will get fixed and isn't
> contentious.)

No, my personal preference is to go with two capabilities.  Barring
objections from WG I will send proposed text later today.

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Mar 2006 11:17:41 +0100

Brian

---

From: Eliot Lear <[email-masked]>
Date: Thu, 02 Mar 2006 19:12:54 +0100

> objections from WG I will send proposed text later today.
I'm sorry.  I needed a boot to the head.  Here is a method that does not
require two capabilities.

New text after 2.1p2:

    After all BEEP greeting messages are exchanged in order for roles to
    be clear,  the agent MUST advertise the NETCONF profile.  The
    manager MUST NOT advertise the NETCONF profile.   If the agent side
    of the communication (either initiator or listener) receives a BEEP
    <greeting> element that contains the NETCONF profile, it MUST close
    the connection.  Similarly, if neither side issues a NETCONF profile
    it is equally an error, and the listener MUST close the connection.

Discussion

No new profiles are needed using this scheme.

Eliot