Subject: get-config and :url

From: Martin Bjorklund <[email-masked]>
Date: Thu, 30 Mar 2006 15:12:40 +0200 (CEST)

Hi,

I don't think this has been up before.  It's another schema/text
mismatch.

In the XSD, get-config's source is defined as:

     <xs:complexType name="getConfigSourceType">
       <xs:choice>
         <xs:element ref="config-name"/>
         <xs:element name="url" type="configURIType"/>
       </xs:choice>
     </xs:complexType>

I.e. an <url> is acceptable.  However, the text doesn't mention this,
neither in 7.1 nor 8.8.

I suspect the text is correct?

/martin

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Thu, 30 Mar 2006 12:10:00 -0500

Yup, looks like the schema's in error.  You can copy-config
an url, but not get-config it.

Thanks,
 Phil