Subject: RE: Second Example in section 7.2 of netconf-proto

From: "Sharon Chisholm" <[email-masked]>
Date: Thu, 9 Mar 2006 10:24:19 -0500

hi

Well, as a minimum, it appears to be an ambiguity in the specification
that different implementations have interpreted differently. After we
agree which we agree(d) with, can I suggest we update the description of
replace to be explicit?

Thanks,

Sharon

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: Thursday, March 09, 2006 9:57 AM
To: [email-masked]
Cc: Chisholm, Sharon [CAR:ZZ00:EXCH]; [email-masked]
Subject: Re: Second Example in section 7.2 of netconf-proto

Andy Bierman <[email-masked]> wrote:
> This error text is wrong.
> Replace does not cause an error if the data does not exist.

That was quite some change to the current draft!

/martin

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 30 Mar 2006 15:37:20 +0200

The note that was sent to the RFC editor reads like this:

Page 39, bottom:

OLD:

   Example:

       Set the MTU to 1500 on an interface named "Ethernet0/0" in the
       running configuration:

NEW:

   Example:

       The <edit-config> examples in this section utilize a simple
       data model, in which multiple instances of the 'interface'
       element may be present, and an instance is distinguished
       by the 'name' element within each 'interface' element.

       Set the MTU to 1500 on an interface named "Ethernet0/0" in the
       running configuration:

I believe that it passes the message, although it is placed differently
than initially discussed (the first example in 7.2 rather than the
second)

Dan

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Sharon Chisholm
> Sent: Thursday, March 30, 2006 3:14 PM
> To: Netconf (E-mail)
> Subject: RE: Second Example in section 7.2 of netconf-proto
> 
> hi
> 
> Did we agree we were adding this clarifying text as a note to 
> the RFC editor?
> 
> Also, another clarifying question. If I have a record with a 
> key and I send it a replace command, are the non-key fields 
> not included in the replace snippet deleted or just not 
> modified? I've seen one implementations that does the latter, 
> and I think based on the following excerpt it is what is 
> expected, but I wanted to confirm.
> 
> "Unlike a <copy-config> operation, which replaces the entire 
> target configuration, only the configuration actually present 
> in the config parameter is affected."
> 
> <bowler>
> <name>Fred</name>
> <location>Bedrock</location>
> <status>single</status>
> </bowler>
> 
> +
> 
> <bowler operation="replace">
> <name>Fred</name>
> <status>married</status>
> </bowler>
> 
> =
> 
> <bowler>
> <name>Fred</name>
> <location>Bedrock</location>
> <status>married</status>
> </bowler>
> 
> Sharon
> 
> From: Andy Bierman [mailto:[email-masked]]
> Sent: Thursday, March 09, 2006 9:50 AM
> To: Chisholm, Sharon [CAR:ZZ00:EXCH]
> Cc: Netconf (E-mail)
> Sharon Chisholm wrote:
> > In section 7.2, the second example indicates it will add an 
> interface,
> 
> > but uses the operator of replace. The definition of replace 
> does not 
> > actually say that if the entry does not exist, it is 
> created. Should 
> > it, or should the operator of create be used instead in 
> this example?
> >
> > I also wonder with these examples if there is an implicit 
> assumption 
> > that the key is name and this somehow defines whether 
> something exists
> 
> > or not?
> >
> >   
> 
> How about some text that says:
> 
> "The manager must understand the data model being used.
> In these examples, the manager knows a priori that the 'name' 
> element is
> used for instance identification to distinguish multiple instances of
> the 'interface' element.
> 
> 
> <clip>
> 
> --