Subject: NETCONF over TLS?

From: Andy Bierman <[email-masked]>
Date: Thu, 30 Mar 2006 08:55:58 -0800

Hi,

Somebody sent me an email and asked if the WG was
interested in NETCONF over TLS.  I said probably
not.  This morning I saw this I-D in Last Call
to supply a user name to TLS, an obvious missing
component is you want to support a user-based
access-control model (and I do).

http://www.ietf.org/internet-drafts/draft-santesson-tls-ume-04.txt

So now I am curious (but not enough to standardize
anything) if the secure syslog integration with netconf
over TLS makes security and operational sense.

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Eliot Lear <[email-masked]>
Date: Thu, 30 Mar 2006 18:57:58 +0200

There's no reason you couldn't do this with TLS/BEEP, right?

Eliot

---

From: Andy Bierman <[email-masked]>
Date: Thu, 30 Mar 2006 09:01:28 -0800

> There's no reason you couldn't do this with TLS/BEEP, right?

Right.
So we already have this covered, except you
have to implement BEEP.  I think that was
the point of the original question.  Like I said,
just curious -- not trying to create new work at all.

Andy