Subject: RE: Interim attendance survey [data model first]

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 27 Mar 2006 11:22:58 -0800

Tom Petch wrote on 26 March at 2:34 PM:
> 
> 2) but could become a 3) if the meeting was somewhere 
> convenient like London,
> UK.
> 
> I think it matters but not as much as getting the current XML 
> straight, which
> seems to be taking an inordinate amount of effort, after 
> which I would give
> higher priority to the data model.
> 
> Tom Petch

I agree with David Perkins - notifications, subscriptions,
event aggregation, and event filtering are fascinating
topics.

However, I fail to see any compelling reason for NetConf
to reinvent the wheel once again and create yet another
notification protocol.

Standard data model is _far_ more important, IMHO.

I still maintain that "merge this blob with that blob" is
a wildly underspecified operation - so far, NetConf seems
to have provided the substrate for a number of entirely
vendor proprietary implementations that do not _by_design_
interoperate in any meaningful way - I'm astounded that
the IESG thought it was OK to invent yet another darned
configuration protocol with no standard data model(s).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.385 / Virus Database: 268.3.2/294 - Release Date: 3/27/2006

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 27 Mar 2006 12:24:47 -0800

> Standard data model is _far_ more important, IMHO.

yeah!!
me too!!

Especially diving into notification content.

Data models for network configuration would seem appropriate,
given this is the NET-CONF WG.

> configuration protocol with no standard data model(s).

You are right Ira. It is data-model dependent and
also a bad practice not to define a data model in such
a way that there is no native order or naming of any kind
for multiple instances of a "row".  If you do a merge on
a multi-instanced element that has a naming scheme and
a natural order, then "merge" is not an problem at all.
(If it hurts when you define bad data models, then just
don't do that.)

The IESG insisted we do the protocol first and not include
data models, in order to phase the work.  It took almost
6 years as it is.

> - Ira

Andy