Subject: RE: NETCONF Port Decision

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 20 Mar 2006 09:44:07 -0800

Hi Andy,

No objection, but clear WG concensus is NOT sufficient.
Bert Wijnen specifically asked for a technical justification
of the working group's decision - NOT just a decision.

[Also - small process thing - decisions in IETF WG's and on
their concensus happen _only_ on mailing lists, not in any
face-to-face meetings, per IETF Standards Process.]

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Andy Bierman
> Sent: Monday, March 20, 2006 12:07 PM
> To: netconf
> Subject: NETCONF Port Decision
> 
> 
> Hi,
> 
> The WG met this morning and discussed the port assignments 
> for the protocol.
> The clear consensus in the room was that the WG should ask 
> for well known
> ports instead of registered ports.
> 
> If anyone wishes to strongly object to this decision,
> then please send an email to the WG  mailing list by 12:00AM 
> EST 3/22/06
> demonstrating a "fatal flaw" in this decision.  (E.g.., why assigning
> a well-known port instead of a registered port will harm the 
> Internet).
> 
> The WG will ask for 4 ports:
>    - NETCONF over SSH
>    - NETCONF over BEEP
>    - NETCONF over SOAP over BEEP
>    - NETCONF over SOAP over HTTPS
> 
> 
> Andy
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> -- 
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.385 / Virus Database: 268.2.5/284 - Release 
> Date: 3/17/2006
>  
> 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.385 / Virus Database: 268.2.5/284 - Release Date: 3/17/2006

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 20 Mar 2006 12:53:43 -0800

> of the working group's decision - NOT just a decision.

I didn't list the factors in this mail.
The main justification is that NETCONF is designed
to replace CLI over SSH, which is run on a system port,
and considered to be a task that is only performed by privileged users.

Andy