Subject: RE: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed Standar d [I06-051127-0011]

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 15 Mar 2006 21:57:51 -0800

No, as Phil Shafer just said, there's no justification for
Netconf consuming the scarce resource of a well-known port
less than 1024.  

And just asking is NOT a sufficient justification, Andy.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Andy Bierman
> Sent: Wednesday, March 15, 2006 6:31 PM
> To: Wijnen, Bert (Bert)
> Cc: Phil Shafer; 'Margaret Wasserman (E-mail)'; 'Netconf (E-mail)';
> [email-masked]; IANA
> Subject: Re: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed
> Standar d [I06-051127-0011]
> 
> 
> Wijnen, Bert (Bert) wrote:
> > But am amswer of "it doies not matter" does not help the IANA
> > to make an assignment. We as a WG must choose. If it does not
> > matter, then I guess we're saying >1024.
> >   
> 
> Eliot did answer this -- we want a port number < 1024
> 
> > Bert
> >   
> 
> Andy
> 
> >   
> >> -----Original Message-----
> >> From: Phil Shafer [mailto:[email-masked]]
> >> Sent: Thursday, March 16, 2006 00:15
> >> To: Wijnen, Bert (Bert)
> >> Cc: 'Margaret Wasserman (E-mail)'; Andy Bierman (E-mail); 'Netconf
> >> (E-mail)'; [email-masked]; IANA
> >> Subject: Re: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed
> >> Standar d [I06-051127-0011] 
> >>
> >>
> >> The only reason to have it <1024 is to keep unix users from running
> >> it as non-root.  While this is fairly weak security, it 
> does prevent
> >> untrusted users on trusted hosts (whose host-key your client likes)
> >> from starting a process that mimics the real ssh-based 
> netconf daemon
> >> and skims whatever information it can.  Then again, I guess you'd
> >> need to be root to have the private version of the host key, so
> >> it's not really an issue.
> >>
> >> So IMHO it doesn't matter.
> >>
> >> Thanks,
> >>  Phil
> >>
> >>
> >>
> >> "Wijnen, Bert (Bert)" writes:
> >>     
> >>> I was trying to find the answer to this IANA quesion,
> >>> and I cannot find it. Did we (WG) decide what we want?
> >>>
> >>> I need to know BEFORE the IESG telechat (11:30 EST) tomorrow 
> >>>       
> >> (thursday)
> >>     
> >>> if possible.
> >>>
> >>> Bert
> >>>
> >>>       
> >>>> -----Original Message-----
> >>>> From: [email-masked] 
> >>>>         
> > [mailto:[email-masked]]On
> >   
> >>> Behalf Of IANA
> >>> Sent: Tuesday, February 28, 2006 18:44
> >>> To: 'Wijnen, Bert (Bert)'
> >>> Cc: 'Margaret Wasserman (E-mail)'; 'Netconf (E-mail)';
> >>> [email-masked]
> >>> Subject: RE: Evaluation: draft-ietf-netconf-ssh-05.txt to Proposed
> >>> Standard [I06-051127-0011]
> >>>
> >>>
> >>> Bert,
> >>>
> >>> I still don't see what range the port needs to go in...
> >>> User (0-1023) or system (1024-49151) range?
> >>>
> >>> Am I missing a note somewhere that give this information?
> >>>
> >>> Thanks,
> >>>
> >>> Michelle
> >>> IANA
> >>>       
> >> --
> >> to unsubscribe send a message to [email-masked] with
> >> the word 'unsubscribe' in a single line as the message text body.
> >> archive: <http://ops.ietf.org/lists/netconf/>
> >>     
> >
> >
> >   
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 19 Mar 2006 06:43:56 +0100

> 
> Netconf is at best a 'niche' protocol at present, because:
> 
> (a) Netconf currently has no standard data models
> 
> (b) Netconf currently is intended for use only with routers and
>     other intermediate network elements
> 
> (c) Netconf operations have fuzzy semantics, due to the lack of any
>     standard data models (e.g., "merge this blob with that blob")
> 
> Therefore, Netconf in not plausibly a critical system service.
> 
> An IANA-assigned "Registered Port" (greater than 1024) is appropriate.
> 
> The argument that user processes may pre-bind the Netconf port applies
> equally to an IANA-assigned "Well Known Port" (less than 1024).
> 
> I encourage the IETF ADs to intervene here and provide direction.
> 

The direction is that:

- The IESG is OK if the WG wants system ports if they have some 
  reasonable argument to request so. The stronger the argument,
  the better.  But a reasonable argument is OK.
- I think the arguments I have seen pro and against sofar make me
  tend to agree with selecting <1024. They seem at least reasonable.
  (I am in the air right now, so I can only comment as to what I have seen
  up till now).
- I have seen arguments for using ports above 1024 too. 
  they are OK but I do not find them as convincing (yet) as the ones
  in favor fo <1024.
- I have not seen arguments that point out a fatal problem if we
  assign below 1024.
- I find it important that people who have implented (or are implementing)
  or those who plan to deploy now or within a year are speaking up. Their
  view counts heavily as far as I am concerned.

Hope this helps,
Bert (speaking as AD)