Subject: RE: Interim attendance survey

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 28 Mar 2006 12:18:56 -0500

hi

We have historically not had much luck with requirements documents
(unless killing a working group can be considered success) or
requirements sections which is why they were not included in the draft.
If we wanted to start documenting requirements in parallel with
developing the notifications draft, that could potentially be
productive.

I believe that the list of requirements and a realistic assessment of
the likelihood of successfully updating legacy solutions (documents and
deployments) to meet those requirements (including alignment with
Netconf content) will support the general direction we are taking. If
people need to do the math on that and it helps get us more on the same
page, then that would be good.

Note though that I know of at least three different vendors that now
have non-interoperable solutions for doing notifications in Netconf. I'm
not sure how that serves the industry.

I'm not sure who's pushing standardizing notification content as our
next priority, but when I look at what to do after standardizing on the
messaging format (the goal of the current draft), access control and
*how* to specify content are pretty high up there for me.

Sharon

-----Original Message-----
From: Andy Bierman [mailto:[email-masked]] 
Sent: Tuesday, March 28, 2006 10:16 AM
To: Chisholm, Sharon [CAR:ZZ00:EXCH]
Cc: Netconf (E-mail)
Subject: Re: Interim attendance survey

Sharon Chisholm wrote:
> hi
> 
> There were a number of people who said they could attend depending on 
> location and dates. Let's try some other dates
> 
> 3. Week of May 8th
> 4. Week of May 15th
> 5. Week of June 5th
> 

I want to make sure there is time to publish
an updated draft before the I-D cutoff for Montreal.

I think the most realistic choices would be in
Montreal, either before (Th, July 6 - Sat, July 8)
or after (Fri July 14 - Sun July 16) IETF #66.

> where 1 was week of May 22nd and 2 was week of May 29th.
> 
> Of course, we could also consider a series of teleconference, but it 
> is difficult to get a timeslot that works for everyone.

I am considering another approach.
Putting your document on the shelf and forcing
the WG to write a Requirements specification first.
The current draft doesn't even have a Requirements section.

We have no agreement on why we need notifications
in NETCONF and what specific roles they serve.
We don't event agree on whether notification content
is part of the problem space or not.

I could argue that the SYSLOG WG should standardize the protocol and
contents for system logging messages, not NETCONF. There are some people
(including myself) who think that if we are going to work on data
models, we should work on configuration data models, not notification
content.

> Sharon

Andy

> 
> -----Original Message-----
> From: Andy Bierman [mailto:[email-masked]]
> Sent: Tuesday, March 28, 2006 9:14 AM
> To: Romascanu, Dan (Dan)
> Cc: Chisholm, Sharon [CAR:ZZ00:EXCH]; Netconf (E-mail)
> Subject: Re: Interim attendance survey
> 
> 
> Romascanu, Dan (Dan) wrote:
>> I am not sure either about what week we are talking.
>>
>> If this is about the week of May 22, I cannot make it at all.
>>
>> If it's the week of May 29, I could possibly make May 29-31, but need
>> to be back to Israel in the morning of June 1st.
>>
>> The first week of June would be much better.
> 
> I am just trying to get an idea of who would show up.
> So far (besides the authors and 1 co-chair, which doesn't even count) 
> there are about 2 people who can attend an interim at the end of May 
> in London.
> 
> I don't think there is enough interest to hold an interim.
> 
> If the interim is too late, then there won't
> enough time afterwards to get a new draft out
> before the I-D cutoff for Montreal.
> 
> 
>> Dan
> 
> Andy
> 
>>
>>  
>>  
>>
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]]

>>> On Behalf Of Sharon Chisholm
>>> Sent: Tuesday, March 28, 2006 2:21 PM
>>> To: Netconf (E-mail)
>>> Subject: RE: Interim attendance survey
>>>
>>> hi
>>>
>>> I take it this date is based on availability of a venue or 
>>> something?
>>>
>>> I have a personal commitment in Ottawa the morning of May 27th. If 
>>> we do that week, if we can do it earlier in the week to ensure I'm 
>>> back (not jet lagged might be too much to ask for), I'd really 
>>> appreciate it.
>>>
>>> Sharon
>>>
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]]

>>> On Behalf Of Andy Bierman
>>> Sent: Monday, March 27, 2006 7:54 PM
>>> To: Orly Nicklass
>>> Cc: Netconf (E-mail)
>>> Subject: Re: Interim attendance survey
>>>
>>>
>>> Orly Nicklass wrote:
>>>> Option 2 that  might turn to 3 if it takes place 1st or 2nd
>>> weekend of
>>>
>>>> June in the US.
>>> Nope.  Last week in May in London, UK
>>>
>>> Andy
>>>
>>> --
>>> to unsubscribe send a message to [email-masked] with 
>>> the word 'unsubscribe' in a single line as the message text
> body.
>>> archive: <http://ops.ietf.org/lists/netconf/>
>>>
>>>
>>> --
>>> to unsubscribe send a message to [email-masked] with 
>>> the word 'unsubscribe' in a single line as the message text
> body.
>>> archive: <http://ops.ietf.org/lists/netconf/>
>>>
>> --
>> to unsubscribe send a message to [email-masked] with 
>> the
> 
>> word 'unsubscribe' in a single line as the message text body.
>> archive: <http://ops.ietf.org/lists/netconf/>
>>
>>
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with the

> word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Tue, 28 Mar 2006 09:42:09 -0800

> *how* to specify content are pretty high up there for me.

We do requirements documents when we deadlock on the solution.
Like now.  IMO, the WG opinions are all over the map.  I cannot
declare WG consensus for or against anything so far.
If we can't agree on the requirements, then the work should
be shut down.

As Dan just pointed out, there needs to be many more reviews
of the draft, work on requirements, and even people willing to do
implementations in order for us to make progress.

We were able to make NETCONF happen because it started as
XMLCONF, which started as Junoscript.  Without operators
saying they liked Junoscript and wanted us to standardize
it, we wouldn't be talking about notifications for netconf today.

This time we seem to be deep in the sandbox instead.

Andy