Subject: RE: use of netconf to configure Unix systems

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 17 Mar 2006 17:56:30 -0800

Hi,

Specious arguments, Andy.

The "Well Known Port" range has 1,024 slots and 70% consumed.

The "Registered Port" range has over 48,000 slots and 12% consumed.

Most new IETF protocols have NOT been given "Well Known Port"
assignments in recent years.  The only justification for Netconf 
would be that it will be a critical system service for MOST
end and intermediate systems, intended to entirely supplant the
alternatives - such a usage profile is ludicrous in any possible
future.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Andy Bierman
> Sent: Friday, March 17, 2006 8:45 PM
> To: Joel M. Halpern
> Cc: Eliot Lear; netconf
> Subject: Re: use of netconf to configure Unix systems
> 
> 
> Joel M. Halpern wrote:
> > I believe that the correct, current, answer to your question is 
> > "nothing."
> > Netconf is clearly not a better use of those ports than a 
> large number 
> > of things that have been assigned higher numbered ports.
> > Hence, I think Netconf should live in the same space as 
> everyone else.
> > The 1024 port space was reserved based on a certain model of the 
> > world.  That model no longer obtains.
> >
> > There is arguably even a good reason that Netconf should 
> not be using, 
> > by default, a reserved port.  I can easily imagine 
> experimental router 
> > implementations where the control logic (and even the router and 
> > router config logic) are living in user space.  They are 
> not running 
> > as priviledged processes.  They could support Netconf, and the 
> > standard port, if that port were not in the kernel set.  
> But could not 
> > use the normal Netconf port if it was in the system space.
> >
> > Using a <1024 port buys us nothing.
> 
> Your previous paragraph clearly contradicts this statement.
> I am interested in current practice for operational systems,
> not experimental systems that might exist in the future.
> Current practice is to make it harder for users to attach processes
> to system port numbers that higher port numbers.
> 
> 
> > Not using one is more appropriate, and may even be useful.
> 
> I disagree -- current practice by network operators is contrary
> to this conclusion. 
> 
> The logic that no protocol should ever use the <1024 range again
> instantly makes the "Registered Port" range a more scarce resource
> for no apparent reason.
> 
> 
> >
> > Yours,
> > Joel M. Halpern
> 
> Andy
> 
> >
> > At 07:53 PM 3/17/2006, Eliot Lear wrote:
> >> Finally I do wish you would answer the question that was 
> asked several
> >> times: if NETCONF is not a good use of well known ports, what is?
> >
> >
> > -- 
> > to unsubscribe send a message to [email-masked] with
> > the word 'unsubscribe' in a single line as the message text body.
> > archive: <http://ops.ietf.org/lists/netconf/>
> >
> >
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 19 Mar 2006 22:56:59 +0100

w.r.t.

> Behalf Of McDonald, Ira
> Sent: Saturday, March 18, 2006 10:35
> To: 'Joel M. Halpern'; Andy Bierman
> Cc: Eliot Lear; netconf
> Subject: RE: use of netconf to configure Unix systems
> 
> 
> Hi Joel,
> 
> +1
> 
> If Netconf really wants a "Well Known Port", then OK, let's
> move on.
> 
> But it really is distressing that the IESG takes no active
> part (apparently) in setting and enforcing policies for the
> use of the remainder of this scarce resource.
> 

The IESG does take part in that we have stated that we want some
plausable arguments if you want a port <1024. 
So the answer: we trew a coin is not acceptable.

Bert